[gelöst] NFS Automount geht bei manchen Dreamboxen nicht mehr

  • Da kann der hacken liegen.

    Die DM920 z.B. kann mit höhere Samba version umgehen (cifs,vers=3.0). Alle andere boxen nicht höher als version 1 (cifs,vers=1.0)

    Ob jetzt auch durch Sicherheitsmaßnahmen an deine NAS durch update bei NFS auch solche Einschränkungen gesetzt hat?


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Jup mit der Option -o nfsvers=3 klappt es zu mindestens jetzt von Hand. Ich probiere jetzt mal das im Automount mit einzupflegen


    root@dm520:/media# mount -v -o nfsvers=3 -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22

    mount.nfs: timeout set for Mon Jan 4 18:36:06 2021

    mount.nfs: trying text-based options 'nfsvers=3,addr=192.168.1.21'

    mount.nfs: prog 100003, trying vers=3, prot=6

    mount.nfs: trying 192.168.1.21 prog 100003 vers 3 prot TCP port 2049

    mount.nfs: prog 100005, trying vers=3, prot=17

    mount.nfs: trying 192.168.1.21 prog 100005 vers 3 prot UDP port 30000

    NasS1b2:/FilmeS22 on /media/TryMount/FilmeS22 type nfs (rw,nfsvers=3)

    root@dm520:/media#

  • Da kann der hacken liegen.

    Die DM920 z.B. kann mit höhere Samba version umgehen (cifs,vers=3.0). Alle andere boxen nicht höher als version 1 (cifs,vers=1.0)

    Ob jetzt auch durch Sicherheitsmaßnahmen an deine NAS durch update bei NFS auch solche Einschränkungen gesetzt hat?

    Ich verwende aber nfs und nicht cifs. Bei der Dreambox 8000 geht es aber auch. Die hat kein 0e25, glaube ich, sondern OE1.6


  • E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • :thumbup:


    Optionen kannst du ja in der Datei /etc/auto.gemini4 anpassen händisch, denke nicht dass du das in der gui findest...

  • JuuuuHuuuu


    Scheint jetzt wieder zu gehen. Habe folgenden Eintrag im auto.gemini4 gemacht

    # automatically generated by gemini

    # do NOT change manually!

    #FilmeS22 -fstype=cifs,rw,file_mode=0777,dir_mode=0777,user=Lucas,password=userLucas ://NasS1b2/FilmeS22

    #FilmeS1a -fstype=cifs,ro,file_mode=0444,dir_mode=0444,user=Lucas,password=userLucas ://NasS1b2/FilmeS1a

    FilmeS22 -o nfsvers=3 -fstype=nfs,rw ://NasS1b2/FilmeS22

    FilmeS1a -o nfsvers=3 -fstype=nfs,ro NasS1b2:/FilmeS1a

    DB8000@S22 -fstype=nfs,rw,nolock,soft,tcp,rsize=131072,wsize=131072,retry=0 192.168.1.20:/hdd/movie


    Ergebnis:

    pasted-from-clipboard.png

  • Buh. War eine langer Weg. Danke an alle die mich unterstützt bzw. mir geholfen haben.


    Nochmal. Problem tritt bei mir nur bei den 52x'er Boxen mit OE2.5 auf. Auf der 920'er Box und der DB8000 geht es auch. Auf der 7080 hab ich noch nicht überprüft. Falls da auch diese Probleme auftreten melde ich das noch hier.


    Komisch nur das die 525'Er auf version 4.2, 4.1 .4.0 (NFS) prüfen und dann abbricht und die 920'er aber am Ende auf nfs 3.0 (nach 4.2 und 4.1) geht. Siehe Beitrag

  • Testweise kannst mal bei der DM920 mit nfsvers=4 schauen ob geht :)


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • forumCluberer

    Changed the title of the thread from “NFS Automount geht bei manchen Dreamboxen nicht mehr” to “NFS Automount geht bei manchen Dreamboxen nicht mehr [gelößt]”.
  • Testweise kannst mal bei der DM920 mit nfsvers=4 schauen ob geht :)

    Im ersten Schnelltest ging es nicht so auf der 920'er mit nfsvers=4. Jetzt habe ich keine Verbindung mehr von der 920'er zum FilemS22 Share. Das krieg ich aber wieder hin. Die Box ist nur gerade belegt und ich werde schon angemahnt nicht dort rumzuspielen. 8o8)

  • Noch eine Abschlussbemerkung:


    Das Problem tritt bei mir bei einer NFS-Verbindung zu Qnap-Server TVS 671 auf. Die NFS-Verbindung zur alten DM8000 ging problemlos. Ab es jetzt an meinem speziellen Qnap-Server(Version) oder generell an Qnap liegt kann ich nicht sagen. Ebenso wenig weiß ich ob das auch bei anderen NAS-Server auftreten kann.

  • Testweise kannst mal bei der DM920 mit nfsvers=4 schauen ob geht :)

    Hi cephues, noch ein kleiner Nachtrag


    das setzen von nfsvers=4 geht doch auf der 920'er Box.

    Es funktioniert sowohl mit und ohne das Setzen der Version. Auch auf den 52x'er Boxen funktioniert es jetzt ohne das Setzen der Version.

    Grund (roter Pfeil im Bild):

    Meine Dusseligkeit. Auf den Qnap-Servere TVS 671 gibt es eine Konfigurationsmöglichkeit zum Setzen der Versionen von nfs 2/3 und 4. Ich hatte den Reiter hierfür übersehen. Dort war die Version 4 nicht angehakt. Nach dem Setzen des Hakens auch bei Version 4 ging es auf allen Boxen auch wie vorher (älter Firmwareversion als 4.5.1).

    Es liegt doch meistens das Problem vor dem Computer (einen selbst) und nicht am Computer.

    pasted-from-clipboard.png

  • Danke, geil, mit

    Code
    ,nfsvers=3

    kann ich von der dm920 endlich wieder auf die dm8000 zugreifen ohne dass die 920 abschmiert. :thumbup:

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Danke, geil, mit

    Code
    ,nfsvers=3

    kann ich von der dm920 endlich wieder auf die dm8000 zugreifen ohne dass die 920 abschmiert. :thumbup:

    Das geht bei mir auch ohne den Parameter ,nfsvers=3 ohne Probleme von der DB920 auf die DB8000. Hatte da bisher nie Probleme. Auch von den 52x'er und der 7080 aus auf die DB8000. Die haben alle OE2.5 (außer der DB8000 hat oe2.0 !?). Kann die (DB8000) überhaupt nfs 4?