[gelöst] NFS Automount geht bei manchen Dreamboxen nicht mehr

  • wie soll man dir weiter helfen, wenn du die Dinge nicht versuchst, die man dir schreibt?

    Na ja, ich mach ja fas alles was man mir sagt. Will es halt auch verstehen was ich dann da mache. Dann lösche ich halt mal den Eintrag in der Fritzbox. Muß ihn dann aber wieder anlegen, da ja meine Struktur im Netz darauf aufbaut.

    Aber was soll den die Fritzbox als DNS-Server da falsch machen?. Wenn ich es ausprobiert habe melde ich mich wieder

  • löschen in der Fritzbox, den Boxen feste IPs vergeben, die auto.gemini löschen und durch netscan neu erstellen lassen.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Habe es so gemacht wie beschrieben. Hat aber nichts gebracht. NFS-Verbindung geht weiterhin nicht.

    Festgestellt habe ich jedoch, das das Problem mit den falschen Angaben im Header von Netzwerksuche nicht existent ist. Beim weitergehen auf das nächste Icon dauert es verzögert bis der HGeader uptudate ist. Der Screenshot wird aber schon vorher erstellt. Ich hatte den Zugriff über Den Computer und der Web-Control gemacht. Aktualisiert man den Skreenshot etwas später so sieht man das die Angaben im Header korrekt sind. Ist mir aufgefallen, als ich die IP-Adresse der Dreambox direkt über die Fernbedienung am Gerät selber gemacht habe.

    Damit war dieses Problem als nur "Heiße Luft".

    Letzt endlich kann ich aber immer noch nicht von den 52x'er Boxen über den NFS-Server auf meinen NAS zugreifen. Wie gesagt von der 920'er und der 8000'er geht alles.

    Irgendwelche Ideen was ich noch machen kann?

  • Wird mir wohl nichts anderes übrig bleiben. Eigentlich wollte ich den Grund herausfinden warum auf den 52x'er der NFS-Zugriff auf den NAS plötzlich nicht mehr funktioniert.

    Protokolldateien für den NFS-Zugriff konnte mir leider keiner nennen.

    Mach mich jetzt erst mal über fstab schlau. Kenne ich noch nicht.

  • /var/log/messages existiert nicht es gibt nur ein :/var/volatile/log/

    Dort gibt es nur das Verzeichnis samba

    und die Dateien btmp und wtmp

  • Auf den Boxen 52x und 920 ist ja das gleiche OE drauf: laut telenet opendreambox 2.5.0

    Dann muß es doch auch mit allen Boxen gehen. Brauche unbedingt noch Tips;(

  • Bevor Du Dich an die "Kür" (automagisches Mounten) machst, solltest Du einfach mal die Pflicht (manuelles Mounten) erledigen. Dort erhält man auch eine sicht- und lesbare Fehlermeldung:


    $ mount -t nfs NasS1b2:/FilmeS22 /mnt

  • Gut Idee. werde ich wohl als nächstes probieren.

    Zuvor hatte ich die Datei auto.gemini4 von Hand geändert (rumgespielt), obwohl darin steht nicht ändern, wird automatisch generier. Plötzlich ging es. Doch nach einem Reboot der Dreambox ging es wieder nicht mehr, obwohl der Inhalt der Datei unverändert ist.

    Bin irgendwie am Verzweifeln.


    # automatically generated by gemini

    # do NOT change manually!

    DB8000@S22 -fstype=nfs,rw,nolock,soft,tcp,rsize=131072,wsize=131072,retry=0 192.168.1.20:/hdd/movie

    FilmeS22 -fstype=nfs,rw,nolock,soft,tcp,rsize=131072,wsize=131072,retry=0 ://NasS1b2/FilmeS22

    FilmeS1a -fstype=nfs,ro,nolock,soft,tcp,rsize=131072,wsize=131072,retry=0 ://NasS1b2/FilmeS1a

  • Ich weiß nicht ob ich gegen ne wand rede weil ich hab auf meine info keine Antwort bekommen und wenn du die Datei per hand änderst dann musst du nach dem einspielen einmal das automount aufrufen und beenden ,dann wird die Datei erst gespeichert.

    Und hast du mal getestet ob es ohne das retry geht ? Du schreibst ja das es mal ging und da hattest dann schon das richtig es wurde nur nicht gespeichert weil du das automount nicht einmal geöffnet hast damit die neuen Daten eingelesen und gespeichert werden.

  • Also ich probiere schon was Ihr mir sagt.

    Das mit dem retry=0 entfernen hatte ich auch ausprobiert. Hatte aber nicht geholfen. Das mit dem Aufrufen des Automount mach ich in der Regel. BluePanel Automount auswählen schließen.

    Das es funktioniert hatte, war nachdem ich einen Zugriff über cifs angelegt hatte mit User und Passwort. Dann hatte plötzlich auch nfs mit einem anderem oder dem gleichen Pfad funktioniert. Dann cifs wieder entfernt und es hatte immer noch funktioniert. Nach Reboot ging es dann wieder nicht.

    Ich probiere es jetzt noch mal genau wie Du es geschrieben hast. Ich kann jetzt nicht mehr genau nachvollziehen, was ich bei meinen ganzen Versuchen in welcher Reihenfolge gemacht habe.

    Es wundert mich nur, das es bis jetzt über Jahre hinweg funktioniert hatte und bei den anderen Boxen 8000'Er und 920'er immer noch geht, so wie ich es eingerichtet hatte.

  • nolock,soft,tcp,rsize=131072,wsize=131072

    Das würde ich auch entfernen (OE2.5).


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Bevor Du Dich an die "Kür" (automagisches Mounten) machst, solltest Du einfach mal die Pflicht (manuelles Mounten) erledigen. Dort erhält man auch eine sicht- und lesbare Fehlermeldung:


    $ mount -t nfs NasS1b2:/FilmeS22 /mnt

    # automatically generated by gemini

    # do NOT change manually!

    DB8000@S22 -fstype=nfs,rw,nolock,soft,tcp,rsize=131072,wsize=131072,retry=0 192.168.1.20:/hdd/movie

    FilmeS1aO -fstype=nfs,ro ://NasS1b2/FilmeS1a

    FilmeS22O -fstype=nfs,rw ://NasS1b2/FilmeS22


    Hat nicht funktioniert. Bin total gefrustet. Muß morgen mal erst händisch wie von "__QT__" beschrieben probieren, damit ich wenigstens mal ne Fehlermeldung bekomme um der Sache auf den Grund gehen zu können

  • Bevor Du Dich an die "Kür" (automagisches Mounten) machst, solltest Du einfach mal die Pflicht (manuelles Mounten) erledigen. Dort erhält man auch eine sicht- und lesbare Fehlermeldung:


    $ mount -t nfs NasS1b2:/FilmeS22 /mnt

    So jetzt hab ich es auch mal von Gand Probiert


    root@dm520:/media/gp4share# mount -t nfs NasS1b2:/FilmeS22 /media/gp4share/FilmeByHand

    Fehlermeldung: mount.nfs: mount point /media/gp4share/FilmeByHand does not exist


    root@dm520:/media/gp4share# mkdir /media/gp4share/FilmeByHand

    Fehlermeldung mkdir: can't create directory '/media/gp4share/FilmeByHand': Permission denied


    Jetzt habe ich es mit einem existierendem Verzeichnis probiert (wurde über Automount-Versuche angelegt):

    root@dm520:/media/gp4share# mount -t nfs NasS1b2:/FilmeS22 /media/gp4share/FilmeS22O

    Fehlermeldung: mount.nfs: mount system call failed


    Wieso kann ich in gp4share keine Verzeichnis anlegen? Habe mich über telnet als root angemeldet.


    (Nochmal die Frage: Was ist den am OE2.5 auf der 920'er anders als auf der 52x'er, das dort das Automount funktioniert?)

  • Hier mal ein Auszug des mount Aufrufs auf der 920'er (funktioniert):


    root@dm920:~# mount

    /dev/mmcblk0p2 on / type ext4 (rw,relatime,data=ordered)

    devtmpfs on /dev type devtmpfs (rw,relatime,size=503456k,nr_inodes=55121,mode=755)

    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)

    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)

    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)

    tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)

    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)

    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)

    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)

    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)

    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)

    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)

    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)

    mqueue on /dev/mqueue type mqueue (rw,relatime)

    systemd-1 on /data type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)

    tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)

    tmpfs on /tmp type tmpfs (rw,relatime)

    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

    /etc/auto.misc on /misc type autofs (rw,relatime,fd=6,pgrp=370,timeout=300,minproto=5,maxproto=5,indirect)

    -hosts on /net type autofs (rw,relatime,fd=12,pgrp=370,timeout=300,minproto=5,maxproto=5,indirect)

    /etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=18,pgrp=370,timeout=300,minproto=5,maxproto=5,indirect)

    /etc/auto.network on /media/net type autofs (rw,relatime,fd=24,pgrp=370,timeout=300,minproto=5,maxproto=5,indirect)

    /etc/auto.gemini4 on /media/gp4share type autofs (rw,relatime,fd=30,pgrp=370,timeout=300,minproto=5,maxproto=5,indirect)/dev/mmcblk0p3 on /data type ext4 (rw,relatime,data=ordered)

    root@dm920:~#


    Hier der Auszug des mount Aufrufs auf der 520'er (funktioniert nicht):

    Hier ist auch zusätzlich eine funktionierende cifs drinnen. Fehler kommen aber auch ohne die cifs-Verbindungen. Die will ich eigentlich nicht verwenden, da ich keine im Passwörter im allgemenen und im Klartext überhaupt nicht in Dateien hinterlegen will (auto.gemini4)


    root@dm520:/media/gp4share# mount

    ubi0:dreambox-rootfs on / type ubifs (rw,relatime)

    devtmpfs on /dev type devtmpfs (rw,relatime,mode=755)

    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)

    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)

    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)

    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)

    tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)

    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)

    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)

    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)

    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)

    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)

    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)

    mqueue on /dev/mqueue type mqueue (rw,relatime)

    tmpfs on /tmp type tmpfs (rw,relatime)

    tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)

    /etc/auto.gemini4 on /media/gp4share type autofs (rw,relatime,fd=30,pgrp=31211,timeout=300,minproto=5,maxproto=5,indirect)

    192.168.1.20:/hdd/movie on /media/gp4share/DB8000@S22 type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,soft,nolock,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.20,mountvers=3,mountport=59902,mountproto=tcp,local_lock=all,addr=192.168.1.20)

    //NasS1b2/FilmeS22 on /media/gp4share/FilmeS22 type cifs (rw,relatime,sec=ntlm,unc=\\NasS1b2\FilmeS22,username=XXXX,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.21,file_mode=0777,dir_mode=0777,nounix,serverino,rsize=61440,wsize=65536,actimeo=1,user=XXXX)

    //NasS1b2/FilmeS1a on /media/gp4share/FilmeS1a type cifs (ro,relatime,sec=ntlm,unc=\\NasS1b2\FilmeS1a,username=XXXX,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.21,file_mode=0444,dir_mode=0444,nounix,serverino,rsize=61440,wsize=65536,actimeo=1,user=XXXX)

    /etc/auto.misc on /misc type autofs (rw,relatime,fd=6,pgrp=31211,timeout=300,minproto=5,maxproto=5,indirect)

    -hosts on /net type autofs (rw,relatime,fd=12,pgrp=31211,timeout=300,minproto=5,maxproto=5,indirect)

    /etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=18,pgrp=31211,timeout=300,minproto=5,maxproto=5,indirect)

    /etc/auto.network on /media/net type autofs (rw,relatime,fd=24,pgrp=31211,timeout=300,minproto=5,maxproto=5,indirect)

    root@dm520:/media/gp4share#


    XXXX ersetzt den Namen Zwecks Anonymisierung

  • Du solltest nie in das automount Verzeichnis mouten, weil es von aufomount verwaltet wird.

    Deswegen hast du keine Permission.


    Zum testen mounte in ein anderes existierendes Verzeichnis.

  • Bevor Du Dich an die "Kür" (automagisches Mounten) machst, solltest Du einfach mal die Pflicht (manuelles Mounten) erledigen. Dort erhält man auch eine sicht- und lesbare Fehlermeldung:


    $ mount -t nfs NasS1b2:/FilmeS22 /mnt

    So habe jetzt mal die Pflicht gemacht.

    Sowohl auf der 920'er als auch auf der 525'er habe ich ein Verzeichnis Namens /media/TryMount/FilmeS22 angelegt

    Auf beiden Boxen habe ich dann den Befehl

    mount -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22

    ausgeführt


    Ergebnis 525 - Fehler:

    root@dm520:/media# mount -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22

    mount.nfs: mount system call failed

    root@dm520:/media#


    Ergebnis 920 - Erfolgreich:

    root@dm920:/media# mount -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22

    root@dm920:/media#


    Kann mir da vielleicht jetzt jemand weiterhelfen?

  • Was wenn du die Option

    Code
    -o nfsvers=3

    angibst beim manuellen

    mounten mit der 525?


    List man manchmal im Zusammenhang mit dem Fehler.

    Obs aber hilft :)

  • Probiere ich gleich mal. Habe auf den Boxen folgenden Befehl ausgeführt, den ich im Internet gefunden habe. -v <-- Parameter

    mount -v -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22


    525 bricht nach Version 4.0 ab. 920 probiert version 3. Warum machen die Boxen einen unterschied?!


    Ergebnis 920:

    root@dm920:/media# mount -v -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22

    mount.nfs: timeout set for Mon Jan 4 18:30:00 2021

    mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.21,clientaddr=192.168.1.13'

    mount.nfs: mount(2): Protocol not supported

    mount.nfs: trying text-based options 'vers=4.1,addr=192.168.1.21,clientaddr=192.168.1.13'

    mount.nfs: mount(2): No such file or directory

    mount.nfs: trying text-based options 'addr=192.168.1.21'

    mount.nfs: prog 100003, trying vers=3, prot=6

    mount.nfs: trying 192.168.1.21 prog 100003 vers 3 prot TCP port 2049

    mount.nfs: prog 100005, trying vers=3, prot=17

    mount.nfs: trying 192.168.1.21 prog 100005 vers 3 prot UDP port 30000

    mount.nfs: mount(2): Device or resource busy

    mount.nfs: /media/TryMount/FilmeS22 is busy or already mounted

    root@dm920:/media#


    Ergebnis 525:

    root@dm520:/media# mount -v -t nfs NasS1b2:/FilmeS22 /media/TryMount/FilmeS22

    mount.nfs: timeout set for Mon Jan 4 18:33:44 2021

    mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.21,clientaddr=192.168.1.14'

    mount.nfs: mount(2): Invalid argument

    mount.nfs: trying text-based options 'vers=4.1,addr=192.168.1.21,clientaddr=192.168.1.14'

    mount.nfs: mount(2): Invalid argument

    mount.nfs: trying text-based options 'vers=4.0,addr=192.168.1.21,clientaddr=192.168.1.14'

    mount.nfs: mount(2): Input/output error

    mount.nfs: mount system call failed

    root@dm520:/media#