Streaming via VLC Player ruckelt stark

  • Ich bin jetzt schonmal soweit, dass wenn ich einen Ordner freigebe, ihn auf der Dreambox sehe und dann aktivieren kann. Soweit so gut.

    nun sehe ich im Mediaplayer auch den Namen, jedoch immer noch keinen inhalt...

    kann man den Mediaplayer irgendwie aktualisieren oder ähnliches? Neustart der Dreambox hilft auch nichts.

  • Aktualisiert muss da nix werden im Mediaplayer der geht schon und hat sich seit Jahren nicht geändert.

    Wenn du also im Mediaplayer in der dateiliste auf den freigabeordner ( Mount Punkt )klickst und dann siehst du nix ,dann sind da entweder in dem Ordner keine anzeigbaren Medien drin oder es ist eben nicht richtig freigegeben .

  • Also ich bin fast soweit die box aus dem Fenster zu werfen , nein spass ;)


    Ich bin mir schon bewusst, dass nicht alles automatisch geht, aber das es so kompliziert ist, habe ich nicht gedacht.

    Ist denn nfs bzw. cifs bei Windows 10 standardmäßig installiert?


    Ich denke ich habe noch ein Problem beim mounten, soweit ich das überblicke.

  • Es ist schon etwas kompliziert, wenn man es noch nie gemacht hat. Und wenn andere sagen, dass sei einfach und mach das doch mal so...

    Es wird leichter - später - viel später - aber es wird leichter. Und am Ende steht der Lohn, dass es funktioniert ;)<


    Also nicht verzagen, morgen ist auch noch ein Tag. Es wird schon. Und wenn du noch Fragen hast - immer her damit.

  • Das ist überhaupt nicht kompliziert. Aber Du könntest auch mal die Fragen beantworten, um Dir weiterhelfen zu können:


    Was siehst Du im Ordner /media/test?


    Code
    cd /media/test
    ls -la


    Wie zombi schon fragte:


    Wie sieht die Windows Freigabe aus?


    Mach mal Screenshots!



    Des weiteren:

    Quote


    Ist denn nfs bzw. cifs bei Windows 10 standardmäßig installiert?


    Die Windows Netzwerkfreigabe (CIFS bzw. SMB Protokoll) ist immer vorhanden. Da muss nichts installiert werden. NFS ist was anderes: https://docs.microsoft.com/de-…er/storage/nfs/deploy-nfs



    Ein wenig musst Du schon mithelfen, wenn man Dir helfen soll. Nur "geht nicht" oder "ich seh nichts" hilft da nicht.

  • root@dreambox:~# cd /media/test

    -bash: cd: /media/test: No such device

    root@dreambox:~# ls -la

    total 16

    drwx------ 3 root root 4096 Dec 30 16:00 .

    drwxr-xr-x 25 root root 4096 Dec 29 20:20 ..

    -rw------- 1 root root 2617 Dec 30 17:30 .bash_history

    drwxr-xr-x 3 root root 4096 Jan 1 1970 .cache

    root@dreambox:~# systemctl status /media/test

    ● media-test.mount - /media/test

    Loaded: loaded (/etc/fstab; generated; vendor preset: enabled)

    Active: failed (Result: exit-code) since Wed 2020-12-30 23:38:11 CET; 1min 8s ago

    Where: /media/test

    What: //192.168.178.55/Film1

    Docs: man:fstab(5)

    man:systemd-fstab-generator(8)

    Process: 6312 ExecMount=/bin/mount //192.168.178.55/Film1 /media/test -t cifs -o rw,rsize=8192,username=,x-systemd.automount,wsize=8192,password=,x-systemd.idle-timeout=60,soft (code=exited, status=32)


    Dec 30 23:38:11 dreambox systemd[1]: Mounting /media/test...

    Dec 30 23:38:11 dreambox systemd[1]: media-test.mount: Mount process exited…s=32

    Dec 30 23:38:11 dreambox systemd[1]: Failed to mount /media/test.

    Dec 30 23:38:11 dreambox systemd[1]: media-test.mount: Unit entered failed …ate.

    Hint: Some lines were ellipsized, use -l to show in full.


    Entschuldig bitte.

    Leider bekomme ich es immer noch nicht hin es im code anzeigen zu lassen.

    Ich sehe nun hier, dass der freigegebene ordner welcher "Film1" heisst, aufgeführt ist.

  • Quote

    Entschuldig bitte. Leider bekomme ich es immer noch nicht hin es im code anzeigen zu lassen.


    Einfach den Text markieren und dann in der blauen Zeile vom Post den Schalter </> anwenden. "Mouse over" zeigt auch den Hinweis "Code".

    Lege mal manuell ein Verzeichnis auf den Box an:


    Code
    mkdir /media/test

    Dann wieder probieren. Box neu starten zur Sicherheit.



    PS: Der Name der Windows Freigabe muss nicht zwangsläufig der Ordername (Mountpunkt) auf der Box sein - aber es hilft ungemein den selben Namen zu verwenden. Der Übersicht halber...;)

  • Also, das Verzeichnis /media/test konnte er nicht anlegen, ist auch klar, er sagt mir das es bereits existiert.

    Habe daraufhin mal ein Verzeichnis test1 angelegt, das erscheint auch auf der Dreambox im Mediaplayer unter internal Flash/media/test1

  • OK - letzte Tips für heute:


    a) In deiner Ausgabe User und Passwort in einem öffentlichen Forum lieber ausschwärzen. ;)


    b) Versuche das mal manuell via putty Session zu mounten:


    Code
    mount -vvv //192.168.178.55/Film1 /mnt -o user=<dein-user>,password=<dein-passwort>

    Klappt das ohne Fehlermeldung? Sonst Ausgabe posten.


    Dann guckst Du:


    Code
    ls -la /mnt


    Dann ist die Windows Freigabe OK und es passt was mit der Box Konfiguration nicht.


    Morgen dann mehr. ;)

  • zu a) Danke!


    zu b)

    Das hier kommt als Ausgabe:


    Code
    mount.cifs kernel mount options: ip=192.168.178.55,unc=\\192.168.178.55\Film1,user=,pass=********
    mount error(112): Host is down
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


    also da stimmt schonmal etwas nicht, denke ich.


    Danke dir schonmal für deine Hilfe, ich hoffe ich werde so einiges lernen und das ganze dadurch besser verstehen können. ;)


    Ich gehe jetzt erstmal arbeiten, gute nacht und bis morgen.

  • Habs doch noch eben gelesen. Versuche mal:


    Code
    mount -vvv //192.168.178.55/Film1 /mnt -o user=<dein-user>,password=<dein-passwort>,vers=2.0

    Ich denke mal, das wird klappen. Die Box versucht wohl SMB Version 1.0 und das wurde bei W10 seit einiger Zeit deaktiviert.


    Jetzt aber auch GN8.

  • Guten Morgen!


    Das hier kommt als Ausgabe:


    Code
    mount.cifs kernel mount options: ip=192.168.178.55,unc=\\192.168.178.55\Film1,vers=2.0,user=Bastian,pass=********
    mount error(22): Invalid argument
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
  • Das war es. Vielen vielen Dank!


    Also von Windows funktioniert es jetzt. ;)

    Bin schonmal ziemlich erleichtert.


    Jetzt wäre noch die Frage wie es von Mac aus geht. Denn dort habe ich fast alle meine Filme auf externen Festplatten gespeichert.

    Wenn das noch klappen würde, wäre ich erstmal vollauf zufrieden.

  • Sollte ein Mac auch können: https://www.macwelt.de/ratgebe…r-einrichten-9784306.html


    Zu Kaiser Wilhelm : Deshalb hatte ich ja den Tipp mit "vers=2.0" gegeben. Ja, SMBv1 ist seit einiger Zeit deaktiviert. Aber nicht generell das SMB Protokoll. Bei mir klappt das einwandfrei:


    Code
    root@dm900:~# mount //192.168.188.1/fritzbox/Dokumente /mnt -o user=*****,password=****
    mount error(112): Host is down
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    oot@dm900:~# mount -v //192.168.188.1/fritzbox/Dokumente /mnt -o user=****,password=***,vers=2.0
    mount.cifs kernel mount options: ip=192.168.188.1,unc=\\192.168.188.1\fritzbox,vers=2.0,user=****,prefixpath=Dokumente,pass=********

    Komisch, warum da bei Dir "invalid argument" kommt. Aber egal, nu geht ja. Mit dem MAC wirst es auch hinbekommen.

    Aber bei mehr als einer externen Festplatte solltest Du mal über ein NAS nachdenken. Da kann dann ein jeder (PC/MAC,Box) mit dem jeweils für sich "besten" Protokoll (NFS/SMB) drauf zu greifen. Nur mal so als Tipp.


    In diesem Sinne: Guten Rutsch.

  • Erstmal ein frohes neues Jahr!


    Mit dem Mac bekomme ich es aus irgendeinem Grund noch nicht hin...


    Aber bitte nochmal kurz zum Streaming mit dem VLC player:

    Dort sehe ich meine komplette Ordnerstruktur vom Mac und ich habe im VLC player plugin lediglich die IP-Adresse des Macs angeben. Wie kann das sein, dass dort alles angezeigt wird, aber ich nichts mounten kann wie ich es mit Win 10 geschafft habe?


    Und noch etwas, das VLC Streaming lief mit meiner DM800 relativ gut, nun bei der Dreambox one läuft die Zeit zwar aber das Bild bleibt schwarz und ich höre keinen Ton. Woran könnte das denn liegen?


    Bitte nicht falsch verstehen, ich kann auch einfach alles vom Mac aufs NAS ziehen, das dauert aber immer etwas und ist eher umständlich.

    Ich möchte einfach nur die Dinge verstehen, falls das möglich ist. ;)

  • Quote

    Aber bitte nochmal kurz zum Streaming mit dem VLC player:

    Dort sehe ich meine komplette Ordnerstruktur vom Mac und ich habe im VLC player plugin lediglich die IP-Adresse des Macs angeben. Wie kann das sein, dass dort alles angezeigt wird,

    Weil VLC mal rein gar nichts mit einer Netzwerkfreigabe (egal ob SMB oder NFS) zu tun hat. Das ist alles VLC "internes" Protokoll.


    Quote

    Mit dem Mac bekomme ich es aus irgendeinem Grund noch nicht hin...

    Da kann man nicht wirklich helfen. Keiner was, was Du machst: keine Fehlermeldungen, keine Screenshots, keine Infos.


    Quote

    ich kann auch einfach alles vom Mac aufs NAS ziehen, das dauert aber immer etwas und ist eher umständlich.


    Hä? Hast Du ein NAS oder nicht? Und was ist daran dann umständlich?


    Du solltest mal genau beschreiben, was Du an Hardware hast und wie Du das alles verwendest. Meinst Du mit "alles vom Mac" eine interne Platte?

    Das ist alles sehr nebulös beschrieben und für Hilfswillige schwer nachvollziehbar.

  • Ich habe noch einmal eine Frage die jetzt nicht mehr das eigentliche Thema zum Kontext hat, aber ich möchte keinen eigenen Thread aufmachen.


    Ich hab die dream box one imminent per plan mit meiner FritzBox 7490 verbunden. Dort hängt über Usb eine SSD als NAS dran, wo meine Filme drauf sind.


    Mit dem mounten hat alles geklappt, ich kann die Filme auch abspielen.


    Ab und zu ruckelt es jedoch stark, wie heute zum Beispiel, die letzten 2 Wochen lief aber alles reibungslos.


    Die dreambox verbindet sich über das 2,4 GHz Band zur FritzBox. Gehe ich recht in der Annahme, dass die Dreambox nur das 2,4 GHz Band kann? weil wenn ich das 2,4 GHz band an der FritzBox ausstelle bekomme ich keine Verbindung mehr.


    Sobald hier das Netzwerk geht, ist geplant die Dreambox über LAN ans Netz zu bringen, jedoch ist es seltsam das es übers plan mal geht und mal nicht, ich habe bisher noch keine Lösung dafür, weil ich nicht weiss woran es liegt.


    Kann das einfach nur die Netzauslastung sein, oder könnte etwas anderes dahinter stecken?


    Ich weiss, ihr könnt alle nicht hellsehen, aber eventuell hat ja der ein oder andere das gleiche Problem und eine Lösung gefunden.


    Ich werde die Dreambox heute Abend mal mit einem LAN Kabel ans Netz hängen und mal schauen ob es dann gut läuft.


    Grüße


    Bastian