DM920 lässt sich flashen geht aber trotzdem in Rescue Mode

  • Hallo Zusammen,


    leider bootet meine DM920 seit heute in den Rescue Mode. Es hat sich bereits abgezeichnet weil z.B. EPG nicht mehr gespeichert wurde, etc.


    Laut Log wird sie auch geflashed, meine Erachtens auch alles sauber auf die richtigen Partitionen, aber sie geht trotzdem wieder in den Rescue Mode. Habe auch verschiedene Images und normales Recovery versucht:




    Das sieht eigentlich alles gut aus, dies irritiert ein wenig, habe ich so unter Linux noch nicht wahrgenommen "Discarding device blocks: 4096/253952"


    Dass kein /var/log/alternatives.log vorhanden ist, sollte eigentlich auch kein Problem sein, habe es aber auch mal angelegt ohne Unterschied.


    Code
    root@dm920:~# blkid
    /dev/mmcblk0: PTUUID="88250523-0901-4fe5-96ea-e2a7b9cc409c" PTTYPE="gpt"
    /dev/mmcblk0p1: PARTLABEL="kernel" PARTUUID="ed288b57-3a2a-48ac-9fd8-af839664b4cf"
    /dev/mmcblk0p2: LABEL="dreambox-rootfs" UUID="5fd2e976-36ba-4934-8b48-054a4032dd65" TYPE="ext4" PARTLABEL="rootfs" PARTUUID="7e4551e2-1959-4d0d-8902-fd2e690e74c3"
    /dev/mmcblk0p3: LABEL="dreambox-data" UUID="4659a3e8-c50b-4660-9165-8704436cc5a6" TYPE="ext4" PARTLABEL="data" PARTUUID="6b06369f-e834-4cd1-a83c-a54e821c3e86"


    Ich werde mich aber auch mal seriel verbinden um mir die Ausgabe mal auf die Konsole zu holen.


    Hat jemand gerade einen Ansatzpunkt bevor ich an ein USB recovery gehe?
    https://board.newnigma2.to/wbb…M920-DM7080-USB-Recovery/


    Besten Dank


    Grüße
    Oli_K76

  • Also Images zu flashen versucht habe ich oZZooN, Gemini und Original.


    bootlog ist leider leer:

    Code
    root@dm920:~# ls -laF /var/log/
    drwxr-xr-x 2 root root 100 Jan 1 1970 ./
    drwxr-xr-x 5 root root 100 Jan 1 1970 ../
    -rw-r--r-- 1 root root 0 Jan 1 1970 boot
    -rw-r--r-- 1 root root 20963 Jan 1 1970 dmesg
    -rw-rw-r-- 1 root root 3072 Nov 7 20:12 wtmp


    Aber in dmesg habe ich was gefunden:


    So wie es aussieht ist das Boot Device dahin.





    Ich denke, dass der bootloader das boot Device nicht mounten kann. Wahrscheinlich muss ich doch mit der Console ran um zu sehen was passiert.
    Das Rescue System schreibt ja nur in die Datenpartitionen, Partitionstabellen erstellt er dabei nicht. Gibt es hierzu ein Workaround oder kann mir jemand sagen wie die Bootpartitionen aussehen müssen?


    Vielleicht liege ich auch falsch und es gibt noch einen anderen Ansatz?


    Danke

  • Ohne Bootlog ist das echt schwierig.


    Hast Du mal geschaut, ob zufällig eine Taste am Frontpanel festhängt?


    Sowas ist auch schon passiert. Dann wurde halt laufend wieder ins recovery gebootet.


    cu

  • Hallo nokia2,


    die Box hat keine tasten mehr, nur touch.
    Anbei der Output der Konsole:



    So wie ich vermutet habe:
    Normal bootup
    Default boot device not found!
    Booting failed. Running recovery


    Kann jemand helfen?


    Besten Dank


    Grüße
    Olli