Zombi-FHD - Kanalliste/ChannelSelection - mehr Zeilen

  • Ich habe von GP3.3 zum GP4.1 aktualisiert, wo es nicht mehr möglich ist in Blue Panel die "Height of entries in the channel list" zu ändern.
    Und weil meine Frau wollte wieder 25 kanäle in der Liste haben, habe ich mich Heute den ganzen Tag damit beschäftigt mehr Kanälen in der liste zu bringen. :)
    Am Ende habe ich es auch geschaft, aber ich bin Einbisschen verzweifellt ob es der richtige weg ist.


    Erst hab ich gedacht das Modifikazion der ChannelSelection screen, wie ich es mit EMCselection gemacht hatte, wurde genug.
    Konkret die itemHeight=36 anstatt 45 ins das Widget mit name=list
    Aber wen ich das hier unten ins user_skin.xml reinkopierte hat nichts geschehen.



    Dan habe ich rausgefunden dass Man heute viel mit styles_user.xml machen kann, aber mein user style (sehe unten) hat auch nicht viel gebracht.
    Ich konnte es zwar im Styles plugin aussuchen und auch speichern aber es hatte kein Einfluss.
    Jemand eine idee was habe ich hier falsch gemacht?


    Am Ende habe ich in Styles grössere Font versucht zu setzen und dan skin.xml verglichen und da habe ich rausgefunden, dass es component des type=ServiceList geändert hat, konkret serviceItemHeight Eigenschaft.
    Also habe ich das hier unten in user_skin.xml eingepackt und es funzt.

    Code
    <components>
    <component beginMargin="2" endMargin="8" piconOffset="10" piconWidth="70" piconWidthBig="110" progressBarHeight="14" progressBarMargin="10" progressBarWidth="90" serviceInfoHeightAdd="10" serviceItemHeight="36" serviceItemHeightLarge="75" serviceNumberWidth="80" textOffset="10" type="ServiceList" />
    </components>


    Aber verstehe ich nicht warum my user_styles.xml, kann es nicht ändern.


    So ich werde dankbar wenn Jemand mehr erfahren mehr Licht in die Sache für mich bringt.


    Danke

  • Der Eintrag hätte so aussehen müssen in der User ,dann ist es richtig und würde auch gehen ;)



    Allerdings hoffe ich das du da nicht den GP3 Skin nutzt und versuchst das in GP4 zu nutzen ,das geht nämlich nicht der passt da garnicht und auch die Einträge nicht .


    Wenn dann musst du auch einen Skin nutzen der wenigstens GP4 tauglich ist ,der geht dann auch im GP4.1 nur nicht im vollem Umfang ,die neuen GP4.1 Screens sind dann un geskinnt aber laufen tut der Skin genauso wie die Sensorfelder usw. in der GP Infobar. Aber der GP3 Skin wird nicht im GP4 oder 4.1 laufen das wird knallen.

    Files

    Edited 2 times, last by zombi ().

  • Quote

    Original von PiGeonCZ
    Konkret die itemHeight=36 anstatt 45 ins das Widget mit name=list
    Aber wen ich das hier unten ins user_skin.xml reinkopierte hat nichts geschehen.


    Das zauberwort heiß hier ...


    serviceItemHeight="36"

  • Quote

    Originally posted by *Jerry*


    Das zauberwort heiß hier ...


    serviceItemHeight="36"


    dass hat nicht gefunzt

    Code
    Jul 06 14:12:08 dm7080 enigma2[2333]: WARNING!!!!: unsupported skin attribute serviceitemHeight=36
  • Hi Zombi,
    ich benutze der enigma2-skin-gp4-zombi-fhd_all.deb von diese thread Zombi-FHD Skin
    Und alles funzt wunderbahr, danke das du diese Skin noch nicht wirklich störben lassen gehabt.


    OK, also es heisst ich hatte alle Werte falsch und das usable construct soll da auch nicht sein?
    Was ist die Bedautung der value und expected parameters?


    danke

  • Ja die Werte waren falsch und doch das andere muss da schon sein damit das nur für diesen Skin genommen und angezeigt wird.
    Ich hab dir nur mal die schaltbare Option richtig hingeschrieben


    <usable>
    was da steht für diesen Skin gibst das frei ,also das wird dann ur in diesem Skin bei Styles als Option angezeigt.



    <set name="serviceItemHeight" value="36" expect="45"/>


    value
    bedeutet so soll der Wert werden


    expect
    das ist der default Wert ,der sollte nicht geändert werden sonst wird auch nicht geschalten.

  • It worked great, but in the end I have used these values



    thanks again!