MyTube / YTrailer DM7080

  • Quote

    Original von harper73
    /usr/lib/enigma2/python/Plugins/SystemPlugins/TubeLib/youtube/Base.py


    Danke.
    Funktioniert

    Fritz!Box 7490 + Syno DS214play
    DM920 FBC-S2X+Triple + DM One BT combo <-- 28E;23E;19E;13E;KD

  • Schade funktioniert jetzt aus einem anderen Grund plötzlich nicht mehr.
    Der API Key ist es definitiv nicht, wenn ich versuche einen Trailer via yTrailer aus der angebotenen Liste abzuspielen passiert nichts und im Log sehe ich:


    Jul 04 21:36:53 dm7080 enigma2[241]: reused converter! (3 times)
    Jul 04 21:36:53 dm7080 enigma2[241]: allocating new converter!
    Jul 04 21:36:53 dm7080 enigma2[241]: create buffer for widget 1920 x 230
    Jul 04 21:36:53 dm7080 enigma2[241]: [eUriResolver::tryResolveUri] schema is yt
    Jul 04 21:36:53 dm7080 enigma2[241]: I/ [YoutubeUriResolver.resolve] :: yt://wQpWydz7J1Y
    Jul 04 21:36:53 dm7080 enigma2[241]: I/ [YoutubeUriResolver.resolve] :: https://youtube.com/watch?v=XXXX
    Jul 04 21:36:54 dm7080 enigma2[241]: W/ [YoutubeDL.__init__] :: Assuming --restrict-filenames since file system encoding cannot encode all characters. Set the LC_ALL environment variable to fix this.
    Jul 04 21:36:54 dm7080 enigma2[241]: I/ [YoutubeDL.to_screen] :: [youtube] wQpWydz7J1Y: Downloading webpage
    Jul 04 21:36:54 dm7080 enigma2[241]: W/ [VideoUrlRequest._request] :: __init__() got an unexpected keyword argument 'check_hostname'
    Jul 04 21:36:54 dm7080 enigma2[241]: [eServiceUri::failedToResolve] Failed to resolve yt://wQpWydz7J1Y!
    Jul 04 21:36:54 dm7080 enigma2[241]: I/ [InfoBar.setPlaybackState] :: connecting... Kanal nicht gefunden! 1593891414.15



    Jemand vielleicht eine Idee was jetzt nicht stimmt??

  • Hallo zusammen,


    habe mir letztens eine Youtube API erstellt und alles hat wieder gut funktioniert.
    Jetzt ... heute probiert läuft Ytrailer wieder nicht.


    Bei Euch?


    VG
    Robert

  • hier bleibt leider auch auf der 920iger das bild dunkel und keine trailer werden angezeigt oder abgespielt....

  • war bei mir auch so.
    Durch ein Update wurde bei mir die Datei Base.py überschrieben,
    somit war auch mein key verschwunden.


    Habe dann den Key neu reingesetzt … und jetzt funktioniert es wieder :)

  • Doch das geht :D ;) ,ihr habt denke die aktuelle tubelib nicht und daher wird es bei euch nicht gehen ,wenn ihr MP nutzt dann hat dhwz meist immer die aktuelle auf seinem Feed und die wird dann upgedatet ,Dream hinkt da leider immer ein wenig hinterher da sie halt nicht ständig ihren Feed aktuallisieren.
    Und ja die Base.py wird auch bei einem Imageupdate überschrieben ,da muss man die immer wieder neu einspielen mit seinem API Key (ist da einfach bescheiden gemacht so wie das jetzt ist ) ;(

  • hm, entweder hat sich an der base.py was geändert gehabt, weil als ich die alte eingespielt hatte ging es nicht.
    ich habe das yttrailer und YouTube nochmals neue installiert und es ging dann alles wieder.