Kopieren per FTP - Dateidatum wird überschrieben (Timestamp)

  • Dies funktioniert schon mal:


    Dateien lassen zwischen Windows-PC (ntfs) und Dreambox DM 920
    per FTP hin und her kopieren (LAN, Router).


    Beim Kopieren von Dreambox zu PC bleibt das Datum erhalten.


    Einstellungen FTP-Programm (WinSCP):
    - Übertragung Binär
    - Dateizeit erhalten


    Das Problem:
    Beim Kopieren von PC zu Dreambox wird das Datum durch's aktuelle Datum ersetzt.


    Das passiert leider auch beim Kopierern von PC
    zur zusätzlichen USB-Festplatte an der Dreambox.


    Hat jemand eine Idee oder Lösung?

  • Um zu testen, ob es ein Problem des Dateisystems ist,
    hab ich mal die USB-Festplatte, die an der Dreambox angeschlossen ist,
    mit unterschiedlichen Dateisystemen partitioniert und formatiert:


    ext2
    ext3
    ext4
    Fat32
    ntfs
    exFAT


    Ein datumserhaltendes Kopieren funktioniert auch damit nicht,
    das Ergebnis ist leider das gleiche:


    Beim Kopieren vom PC zur USB-Festplatte an der Dreambox
    wird das Datei-Datum immer durch das aktuelle Datum ersetzt.

  • Ich meine, dass Filezilla eine Option hat, die da lautet "Änderungszeitpunkt der übertragenen Datei beibehalten".


    Der "dumme" FTP-Client von Windows kann das imho nicht.


    PS: Oder mal hier schauen, wenn Du öfters Kopier/Backup Aktionen durchführst: https://www.windowspro.de/tool…ell-sichern-mit-deltacopy

  • Filezilla hab ich nun auf dem Laptop (Debian-Linux, ext2) installiert.
    Damit sollte ein Windowsfehler als Ursache ausgeschlossen sein.


    Die Option "Änderungszeitpunkt der übertragenen Datei beibehalten"
    hab ich eingeschaltet (und bin natürlich auch alle anderen Optionen durchgegangen).


    Auch hier dasselbe Problem:


    Beim Kopieren von Dreambox zu Laptop (Linux) bleibt das Datum zwar erhalten.


    Aber beim Kopieren vom Laptop zur Dreambox
    wird das Datei-Datum immer durch das aktuelle Datum ersetzt.


    Kann es sein, dass irgendeine Dreamboxeinstellung die Ursache ist?

  • Hat mich zwar nie gestört der Umstand, aber scheinbar kann der FTP-Server auf der Dreambox
    nicht richtig mit MDTM umgehen und damit wird das Datum überschrieben. Bei Samba Freigabe
    habe ich übrigdends die gleiche Problematik. Nur via NFS-Share tut es richtig.


    Angeblich soll vsftp als Server es können.

  • Es gibt doch genug Alternativen zu FTP. Da wären NFS und Samba, aber auch SFTP oder SCP.
    Auch in der /etc/vsftpd.conf könntest du mal nachsehen.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Danke für Eure Tips :-)


    Ich werd' mir das alles mal die Tage ansehen und mich einlesen.


    netman
    Wenn ich Dich richtig verstanden hab, ist der vsftp also nicht
    der aktive Standard-FTP-Server auf der Dreambox ?
    In dem Fall müsste ihn irgendwie aktivieren, um zu sehen, ob es dann funktioniert.


    m0rphU
    Die /etc/vsftpd.conf hab ich mir angesehen,
    aber außer der GMT-Einstellung, die damit wohl nichts zu tun hat,
    scheint da nichts drin zu sein,
    was das Datumsüberschreiben abstellen könnte.

  • Hast Du es mal damit versucht?
    In der Menuleiste bei Transfer den Haken setzen bei: Änderungszeitpunk der übertragenden Punkte beibehalten.


    Mit VU klappt das, mit meiner Dream nicht.
    Unterstützt die Dream wohl kein MDTM?

    Files

    • ftp.png

      (15.23 kB, downloaded 152 times, last: )

    Nicht jeder Käse kommt aus Holland...
    „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.

    Edited 3 times, last by phelbes ().

  • Ich habe das jetzt auch mal getestet und sehr unterschiedliche Ergebnisse erhalten:
    - Filezilla per FTP: mtime und ctime werden überschrieben, atime wird nicht geänder.
    - Filezilla per FTP mit Option "Änderungszeitpunkt der übertragenen Datei beibehalten": mtime und ctime werden überschrieben, atime wird nicht geändert.
    - WinSCP per FTP: atime und mtime werden auf Zeit der Ursprungsdatei gesetzt, ctime wird auf aktuelle Zeit gesetzt


    Der FTP Server kann also schon das richtige Verhalten. Warum es mit Filezilla nicht klappt? Keine Ahnung.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Hab es mal mit WS_FTP Pro getestet.
    Hier funktioniert es ohne Probleme auch mit Dreambox.


    Das Problem scheint also File Zilla zu sein... ;(

    Nicht jeder Käse kommt aus Holland...
    „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.

    Edited once, last by phelbes ().

  • Spanned waren übrigens auch die Ergebnisse mit MobaXterm und WinSCP per SCP (Secure Copy) :D Da wurde dann teilweise das Datum auf 0:00 Uhr gesetzt -.-
    SFTP (FTP over SSH) scheint nach wie vor nicht standardmäßig installiert zu sein :(


    Verschiebungen um 2h (wegen UTC vs MEST) hat man übrigens in den meisten Clients.


    phelbes: Welchen ftp Server in welcher Version nutzt denn deine VU?

    Code
    root@dm920:~# apt list *vsftp*
    Listing... Done
    vsftpd/unknown,now 3.0.3-r0.10 armhf [installed]
    root@dm920:~#

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • root@vuultimo4k02:~# opkg list-installed *vsftp*
    vsftpd - 3.0.2-r1
    root@vuultimo4k02:~#


    Auf der Dream:
    wie bei Dir...

    Nicht jeder Käse kommt aus Holland...
    „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.

    Edited 3 times, last by phelbes ().

  • Quote

    Original von phelbes
    Hast Du es mal damit versucht?
    In der Menuleiste bei Transfer den Haken setzen bei: Änderungszeitpunk der übertragenden Punkte beibehalten. ...


    Ja, hatte ich. Das konnte das FTP-Datumsproblem leider nicht beseitigen.


    Quote

    Original von phelbes
    Hab es mal mit WS_FTP Pro getestet.
    Hier funktioniert es ohne Probleme auch mit Dreambox. ...


    Klingt gut, werd' das auch probieren (muss aber erstmal etwas Platz zum Installieren auf dem Windowsrechner schaffen).


    Quote

    Original von m0rphU
    ... Alternativen zu FTP. Da wären NFS und Samba, aber auch SFTP oder SCP. ...


    Samba hab ich jetzt installiert, funktioniert super. :-)

  • So bin ich vorgegangen:
    Zuerst musste ich ca. 20-30 MB Platz auf dem internen Flashspeicher freimachen.


    Dann in die Addons (von Gemini):
    -> Menü -> Pakete nach Namen suchen -> Samba -> samba-testsuite
    -> installieren -> Neustart


    Dann in den Einstellungen von Multi-Quickbutton:
    Einstellungen -> Blue-Panel-Komponente hinzufügen -> Samba-Einstellungen


    Nachdem man dann die Samba-Einstellungen aufruft,
    kommt evt. noch die Frage, ob man Samba installieren will -> ja -> Neustart.


    Dann wieder in die Samba-Einstellungen, die Voreinstellungen hab ich
    erstmal so gelassen (muss man sich evt. noch mal genauer ansehen).


    Dann Rot drücken (Freigaben):
    Falls noch nichts drin ist, kann man hier die Festplatte, den Data-Bereich,
    externe USB-Laufwerke hinzufügen, zB so:


    Festplatte: /media/hdd
    Data-Bereich: /media/data
    USB-Festplatte: /media/laufwerksname
    USB -Stick: /media/stickname


    In Windows öffnet man den Dateiexplorer und gibt als Dateipfad
    die IP der eigenen Dreambox ein, zB.: \\192.168.100.15


    Das funktioniert super, das Datum bleibt beim Kopieren erhalten.


    Danke für Eure Hilfe :-)