Festplatte standby

  • Hallo!
    Kann man im Gemini Gerätemanager die Festplatten standby Zeit wo einstellen? Ich finde den Punkt nicht...

  • Nein gibt es nicht mehr im gp4 (nur Manuel auf stby kannst es im gp4 Geräte manager setzen).
    Wenn du ne Zeit einstellen möchtest dann musst das im dream eigenen manager machen laut Mechatron wird es das im gp4manager nicht mehr geben.
    Heute haben auch viele ne SSD da ist sowas e nicht nötig :D

  • oder eine rc.local erstellen und eintragen und mit hdparm -S <value> <device> die Zeit setzen


    die /etc/rc.local wird bei jedem boot ausgeführt und sendet dann über hdparm den standby command an die gewünschte Platte



    Werte von 1 bis 240 geben Vielfache von 5 Sekunden an, was Zeitüberschreitungen von 5 Sekunden bis 20 Minuten ergibt. Die Werte von 241 bis 251 geben 1 bis 11 Einheiten von 30 Minuten an, was Zeitüberschreitungen von 30 Minuten bis 5,5 Stunden ergibt. Ein Wert von 252 bedeutet eine Zeitüberschreitung von 21 Minuten.


    z..B 24 schickt die Platte nach 2 Minuten in Standby (24x5 Sekunden = 120 Sekunden = 2 Minuten)


    Annahme das die Plate als /dev/sda erkannt wird


    /etc/rc.local (rechte 755)

    Bash
    #!/bin/bash
    hdparm -S 24 /dev/sda
    exit 0


    funktioniert auch über die Festplatten ID

  • Danke Fred!


    Die Platten werden doch nicht im Dauerlauf sein... Wann schalten sie ab wenn man nix manuell macht?

  • gar nicht


    die standby Zeit wird nicht auf der Platte gespeichert sondern der Befehl kommt nach jedem boot aus dem Betriebsystem. Wenn man den hdparm Befehl absendet, geht die Platte nach Ablauf der Eingestellten Zeit in Standby. Wenn sie anläuft geht sie dann wieder nach X Minuten in standby.


    Der Gemini Festplatten Manger machte vermutlich auch nichts anderes


    der Umweg über die /etc/rc.local ist nichts neues, das gibt es schon lange unter Linux -
    alles was in dieser Datei steht, wird einmalig bei jedem boot ausgeführt - sofern die syntax passt :D



    Die Datei /etc/rc.local ist default nicht im Image enthalen, die muss man selbst erstellen (Rechte 755) - warum auch immer.


    Der Dienst, der für die Ausführung verantwortlich ist, läuft aber im DreamOs bereits ohne etwas einstellen zu müssen


    Code
    root@dm7080:~# systemctl status rc-local.service
    ● rc-local.service - /etc/rc.local Compatibility
    Loaded: loaded (/lib/systemd/system/rc-local.service; static; vendor preset: enabled)
    Active: active (running) since So 2020-02-02 22:06:59 CET; 2 days ago
    Process: 270 ExecStart=/etc/rc.local start (code=exited, status=0/SUCCESS)
    CGroup:
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
    root@dm7080:~#
  • Hallo Fred


    Scheint nicht zu funktionieren.


    Habe das in rc.local eingetragen:

    Quote

    #!/bin/bash


    hdparm -S 72 /dev/sdb


    exit 0


    72 dürften 6 Minuten sein


    mit hdparm -C /dev/sdb
    kommt status unknown


    hdparm -y /dev/sdb geht sie in standby
    ansonsten scheinbar nicht...

  • Hast du auch die 6 Minuten nach Absenden des Befehls gewartet?


    Nach Erstellen der rc.local mit dem Inhalt wird diese nach reboot ausgeführt



    ob die rc.local funktioniert kannst du einfach per Aufruf testen


    sh -x /etc/rc.local


    die Ausgabe ist dann recht gesprächig und man sieht eventuelle Fehler

  • ja klar warte ich 6 Minuten.


    mit Deinem Befehl:


      root@dm920:~# sh -x /etc/rc.local
      + hdparm -S 72 /dev/sdb


      /dev/sdb:
      setting standby to 72 (6 minutes)
      + exit 0
      root@dm920:~#

  • Ok, ich habe jetzt das Ohr an die Box gehalten und sie anlaufen hören als ich die Filmliste geöffnet habe. Scheint also doch zu funktionieren.


    Danke und Grüße
    fixnix

  • Wenn man es per Festplatten ID machen will, ist es so richtig?


    Quote

    hdparm -S 72 /dev/disk/by-id/ata-ST4000LM024-2AN17V_WFF111BS

  • ja, einfach die ATA devices nach ID ohne Partitonen listen, dann sieht man auch auf welches /dev/sdx verwiesen wird - falls HDD und SSD verbaut sind (dm7080hd)


    Code
    root@dm900:~# ls -l /dev/disk/by-id/*|grep ata|grep -v part
    lrwxrwxrwx 1 root root 9 Feb 2 21:03 /dev/disk/by-id/ata-ST2000LM015-2E8174_ZDZ4ML4V -> ../../sda
    root@dm900:~# ls /dev/disk/by-id/*|grep ata|grep -v part
    /dev/disk/by-id/ata-ST2000LM015-2E8174_ZDZ4ML4V
    root@dm900:~#
  • Hallo!


    Ich muss noch mal nerven bevor ich aufgebe...
    Standby funktioniert nicht mehr. Ich habe seit dem letzten funktionieren nur eine SD hinzugefügt, glaube aber nicht, dass das was damit zu tun hat.


    sh -x /etc/rc.local bringt folgende Ausgabe:


    root@dm920:~# sh -x /etc/rc.local
    + hdparm -S 144 /dev/disk/by-id/ata-ST4000LM024-2AN17V_WFF111BS


    /dev/disk/by-id/ata-ST4000LM024-2AN17V_WFF111BS:
    setting standby to 144 (12 minutes)
    + exit 0



    Standby per console mit
    hdparm -y /dev/disk/by-id/ata-ST4000LM024-2AN17V_WFF111BS


    funktioniert auch aber automatisches Standby mit rc.local nicht :rolleyes:


    Edit: Jetzt hat es doch funktioniert (warum auch immer).

  • Hallo Fred!


    Ja zickig.


    Die Sache ist jetzt so:


    Wenn ich den Befehl

    Quote

    hdparm -S 144 /dev/disk/by-id/ata-ST4000LM024-2AN17V_WFF111BS


    auf der Konsole eingebe, geht sie Brav nach vorgegebener Zeit in Standby, wenn ich neustarte wird der Befehl NICHT ausgeführt d.h die Festplatte läuft ewig weiter also wird es über rc.local nicht gestartet. Kann man die rc.local ev. verzögert ausführen oder an was kann es liegen?

  • Im Akt der Verzeiflung, habe ich es mal so versucht:



      #!/bin/bash


      sleep 35


      hdparm -S 36 /dev/disk/by-id/ata-ST4000LM024-2AN17V_WFF111BS


      exit 0


    Das hat jetzt mal funktioniert...

  • besser als subprozess im Hintergrund ausführen - wenn es daran liegt


    wenn du einen weiteren command in der rc.local danach ausführst, wieder dieser auch um sleep x verzögert, was im worst case den Box/Enigm2 Start um x Sekunden verzögert


  • Danke.
    Soll ich es genau so (copy and paste) eintragen?


    Was bedeuten diese Zeichen { } ?

  • ja, die syntax müsste passen


    die Kommenarzeilen beginnend mit # kannst du weglassen, das war nur zu Veranschaulichung.


    die shebang (1 Zeile: #!/bin/bash) muss natürlich bleiben


    hdparm wartet so im Hintergrund die eingestellte Zeit bis zur Ausführung ohne weitere commands in der rc.local oder den systemstart zu beeinflussen

  • Bei meinen Dreamboxen mit GP4 brauche ich nichts verändern und die gehen brav in Standby wie
    es sich gehört.