Bitte um Hilfe bei DM 7080 Update

  • Hallo zusammen!


    Ich möchte mal meine Dreambox 7080 auf aktuellen Stand bringen.
    Hab mich schon durch gelesen, jedoch sind das zuviele Inforamtionen auf einen Schlag, die ich leider nicht verarbeiten kann, bzw. ich nun nicht mehr weiß, wo ich anfangen soll.. <- ja, solche Personen gibt es, sorry :(


    Also, ich habe hier jetzt meine Dreambox mit folgenden Daten:


    Dreambox OS: 4.3.0r22-2016-11-22
    Image: Experimental 2016-07-12
    Gemini 3.3


    Die Box kann komplett neu mit aktuellen FW und Programmen aufgesetzt werden.
    Würdet ihr mir bitte dabei helfen?
    Mit was fange ich an, bzw. was soll der erste Schritt sein?


    Vielen vielen Dank

  • Im allerersten Schritt solltest du ein Backup des aktuellen Setups machen. Auch, wenn du glaubst nichts mehr aus dem aktuellen Setup, zu brauchen: Sicher ist sicher ;)
    Ein Voll-Backup kannst du mit dem passenden Gemini-Plugin, dem Plugin dBackup oder im Rescue-Loader machen.


    Dann musst du dich für ein Image entscheiden. Im Wesentlichen hast du die Wahl zwischen dem Original-Image von Dream (in Version stable oder experimental) und den darauf basierenden Images Merlin, NN2, Dream-Elite, OoZooN (aktuell leider offline). Alternativ gibt es auch Images, die auf dem alternativen Open-Alliance Zweig aufbauen und nur wenig mit dem Original-Image gemeinsam haben. Hier im IHAD gibt es im Wesentlichen Support für das Original-Image und GP.
    Beschreibungen der Image-Funktionen und Download-Links gibt es überall hier im Board, im Dreambox-Blog oder den jeweiligen Support-Boards ;)


    Willst du dann wieder das GP (inzwischen in Version GP4) installieren, solltest du beachten, dass Merlin und NN2 diese Kombination nicht offiziell unterstützen. Bei Dream-Elite weiß ich den Stand dazu nicht.


    Das Image wird dann über den Rescue-Loader geflasht (http://wiki.blue-panel.com/ind…pielen_-_Dreambox_7080_HD). Dabei solltest du darauf achten, dass neuere Versionen des Rescue-Loaders dir anbieten, alle Einstellungen zu übernehmen (siehe die zwei Häckchen in http://wiki.blue-panel.com/ind…tei:Rl_firmwareupload.png). Da du das nicht wünschst, musst du die entsprechenden Checkboxen selbst deaktivieren.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • fritz freudich, hol Dir bitte einen Kaffe, wenn Du einen brauchst, aber lass mich bitte in Ruhe.


    Wie gesagt, es gibt Leute, die sind mit zu vielen Informationen überfordert und wissen nicht mehr, was vorn und hinten ist, tut mir leid dass ich ein solcher bin ..



    m0rpU, vielen Dank für Deine ausführliche Hilfe!


    Ja, ich will wieder das neue GP4 installieren.
    Ob ich nun ein stabiles Image oder ein instabilies nehme.. da ist es doch sinnvoller ein stabiles von Dream zu verwenden, oder?
    Hat das instabilie irgendwelche Vorteile?


    Vielen Dank!

  • Halma
    Da du auch Plugins vom GP4 nutzen möchtest schlage ich dir vor hier http://www.dreamboxupdate.com/…e/images/dm7080/index.php das aktuelle unstable Dreambox image zu laden ( das vom 18.11.19)
    hast du dieses Image geladen und installiert kannst du die Grundeinstellungen machen und kannst schonmal Fernsehen ,das geht alles recht fix.
    Wenn du dann auch auf GP4 Plugins zugriff haben möchtest dann musst du dir noch das geminilocale installieren ,das gibt es hier http://wiki.blue-panel.com/index.php/GP4_Installation mit infos wie man was macht (bedenke du hast dann ein OE2.5 Image und musst es so installieren wie für OE2.5 dort steht).
    Das wars dann eigentlich schon ,weil Plugins nachladen geht dann mit der Dreamsoftwareverwaltung (dort findest du dann auch in der GP4 Section die GP4 Plugins) und dann kannst weiter loslegen mit was auch immer du dir nachinstallierst und damit arbeitest.
    Denke bitte daran wenn du etwas manuell installierst das es auch für deine Box und dein genutztes System sein muss ,nicht einfach was von wo dir laden oder von deinem PC installieren und denken es passt schon.


    PS. GP Plugins und einiges andere auch setzt auf unstable da ein unstable öfters als ein stable update bekommt und somit immer das aktuellere von beiden ist.
    Man kann zwar auch ein stable Image nutzen ,nur wird es dann auch mal vorkommen das du etwas nicht installieren kannst weil es aktuelle Sachen brauch das halt zuerst immer das unstable bekommt.



    PPS. und noch etwas ,du darfst außer max. deiner Kanalliste nix von dem alten auf der Box mit nehmen ,keine settings oder Datein die du mal gespeichert hast .
    Zum einen ist es ein neues OE was du installierst (also ein neueres System) und zum anderen sind die GP4 Plugins (alle ,wirklich alle) anderst als die vorherigen GP Sachen ,das bedeutet da passt nix mehr zusammen und daher nix altes übernehmen sonderen alles neu einrichten.

  • Nur zur Rektifikation vom Thread Titel:
    Ein Update von GP3.3 auf GP4 ist nicht möglich. Neuflashen ist schon zwingend nötig.
    Bevorzugte image zur GP4 installation ist immer das aktuelle unstable Dreambox image, bzw. im aktuell gebrachte stand durch online update.


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Und seid nett zueinenader ;)

  • Okay, vielen Dank!


    Dreambox das aktuelle habe ich mal installiert, eingerichtet.
    Anschließend den Befehl..


    Code
    wget -O /tmp/geminilocale_all.deb http://download.blue-panel.com/geminilocale_gp4.php && dpkg -i /tmp/geminilocale_all.deb


    ausgeführt, Box neugestartet.
    Mit drücken der blauen Taste passierte aber gar nichts, es kam das Standart Dreambox Fenster.


    Bei der INstallation war das zu sehen:

    Code
    root@dm7080:/# wget -O /tmp/geminilocale_all.deb http://download.blue-panel.com/geminilocale_gp4.php && dpkg -i /tmp/geminilocale_all.deb Connecting to download.blue-panel.com (31.47.234.114:80) geminilocale_all.deb 100% |*******************************| 71028 0:00:00 ETA (Reading database ... 13192 files and directories currently installed.) Preparing to unpack /tmp/geminilocale_all.deb ... Unpacking geminilocale (3.0-r8.0) over (3.0-r8.0) ... Setting up geminilocale (3.0-r8.0) ...


    Von einer direkten Installation sehe ich da nichts?

  • Alles IO ;)
    Nochmal GP4 ist komplett anderst ,bitte lies dich dann auch ein ,GP4 ist nicht wie die Vorgänger ein Plugin was mit fertig vorinstalliertem zeug kommt sondern GP4 besteht aus zZ. glaube so 50 einzel Plugins die dann noch mehrere in einem mit bringen.
    Diese Plugins kannst du dir dann einzeln installieren oder auch wieder deinstallieren bei nicht gefallen.
    Dazu gehst du in die Softwareverwaltung/Erweiterungen verwalten und dort haste dann auch ne Sektion mit GP4 (das wurde dir mit dem locale mit installiert) .
    Und dann kanst du dir halt auch GP4 Plugins installieren (die beim GP3 zb. schon fest drin und nicht deinstalliebar waren) ,das kann jetzt einfach einzeln installiert werden jenachdem was der User möchte.
    Da gibt es auch das BP ,die GP Browser oder auch den GP Addonmanager usw. das hast du jetzt nicht gleich mit installiert sondern du hast mit dem locale ,den GP4 feed sowie Übersetzungen und paar andere iDinge nstalliert was zum Gp gehört.

  • Uff, okay... vielen Dank :)


    Und was davon brauche ich jetzt unbedingt?
    Gibt es da etwas, was man unbedingt braucht für das System?


    Ich habe eine Festplatte verbaut in meiner Dreambox, ich hab ein CI Plus Modul, das ich verwenden möchte...

  • :D du bist gut :D einige würden sagen vom GP brauchst du garnix :D ,andere wie ich zb. würde sagen es gibt viele gute Plugins ,sei es vom GP ,vom Merlin oder von anderen ,was du wie für dich benötigst das musst du schon selbst wissen oder durch installieren /ausprobieren und die support Threads der Plugins lesen herrausfinden.
    Das was ich mag musst du ja nicht mögen und daher was soll man dir da sagen?

  • Stimmt :)
    Ich hab sie eigentlich auch nur zum normalen Fernseh schauen..
    Aber ich weiß ja nicht mal, wonach ich da suchen muss, gibt ja über 6.000 AddOns..
    Weiß nicht mal einen Namen oder Suchkreterien ...


    Damit die CI+ Module erkannt werden, da hatte ich letztens ein AddOn installiert.
    Jedoch weiß ich nicht mehr wie das heißt...

  • Das minimum wo du installieren müsste um das BluePanel zur haben und dadurch auch ein Auswahl der online plugins zur laden, ist das BluePanel und Addon-Manager.
    Diese findest du zur erst unter Erweiterungsverwaltung => GP4.
    Danach kannst du mit dem Blaue Taste / Addon-Manager erwünschte (Gemini) Plugins installieren.


    dreamciplus und autopin werden im Board und im Feed nicht angeboten.


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Bei CI+ Zeugs bin ich raus da ich sowas zb. überhaupt nicht benötige oder je benötigt habe ,da brauch man erstens etwas damit die erkannt werden (das gibt es hier nicht wird hier auch nicht besprochen da sich das mit unseren Boardregeln nicht vereinbart) und dann benötigt man für CI am besten noch gutemine sein Autopin (gibt es dort wo gutemine seine Sachen supportet ,im Oozoon Board das ist aber zZ. nicht erreichbar) bzw. auch im NN2 Board oder ... .
    Wie gesagt da bin ich aber kein guter Ratgeber weil ichs nicht im Einsatz hab.

  • Okay, vielen Dank..


    Mal eine andere Frage...
    Wenn ich das Image mittels dem Rescue Loader installieren, da wird ja alles andere überschrieben oder?
    Es ist nur... weil nach dem flashen sind die manuellen Netzwerkeinstellungen nach wie vor unberührt..
    Alles andere ist neu.

  • "Settings restore" und "Settings backup" sind stardardmäßig im Web Interface aktiviert - das muss man deaktivieren, wenn man es nicht will.


    D.h. vor Flashen werder dann die settings nach /data/.recovery gesichert und nach dem Flashen gleich wieder restored.


    Gesichert werden u.a. die Netzwerkeinstellungen, das root passwort, Senderlisten usw.

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Diese Option, soweit ich gelesen habe, gibt es nur bei den neueren RL.
    Diese beiden Punkte waren bei mir nicht vorhanden.

  • Okay.
    Ist der für sonst auch noch etwas zuständig?
    Dachte ist ein reines Rettungsmenü..


    Nehme dann mal an, das ist dieser hier: vmlinux.gz-rescue-3.4-r1-dm7080-20191118.bin


    Wie installiere ich den?
    Über das RL Menü oder über die Erweiterungen mit der Dreambox?


    Vielen Dank!

  • Quote

    Originally posted by Halma
    Wie installiere ich den?


    Im laufenden System per Telnet:


    # update-rescue