SSD hängt beim Abspielen / Aufnahmen brechen ab

  • Hey Leute!


    Muss mich jetzt doch mal hilfesuchend an euch wenden.
    Folgendes Problem:


    Heute z.B. hab ich einen Film auf ARD HD aufgenommen und ihn etwas zeitversetzt angesehen. Dieses mal hat die Box mir 6 oder 7 mal spinner gezeigt, Bild und Ton haben zwischen 10 und 20 Sekunden gestoppt und dann lief es weiter. Mal lief der Film dann an der richtigen Stelle weiter, mal fehlte ein Stück. Mal waren 2 Minuten zwischen den Aussetzern, mal 10 Minuten.
    Ein anderes mal brechen mir die Aufnahmen ab, mit der Meldung die Festplatte sei voll. Sekunden später startet dann eine neue Aufnahme bis zum Ende.
    Ich frag mich noch, von welcher Seite ich den Fall aufrollen soll. Liegt es an der SSD oder doch an der DM920?
    Wie könnte ich hier denn mal logisch vorgehen?
    In den Situationen läuft maximal 1 Aufnahme und / oder es wird Tv dabei geguckt.
    Gibt es logs die mir da Aufschluss geben können?


    Danke für's lesen schonmal....

  • Hmm - welches Dateisystem ist auf der Platte ?
    Vielleicht mal in ext4 formatieren , die platte als hdd labeln - vom Gemini mounten lassen ind nochmal versuchen ?


    Wie gesagt - ich schwimme auch bei deinem Problem und kann nur eine Alternative geben - wenn ueberhaupt.


    Aber einen Versuch ist es wert.


    Jake

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

  • Welches Dateisystem auf der SSD Partition?
    Wie voll ist die Partition?
    Hast Du TRIM/discard für die Partition im Einsatz?
    Welche Mountoptionen setzt Du für die Partition?
    Wie alt ist diese SSD und war die Partition schon mal voll bzw. nahe dran?

  • 1. Dateisystem:
    Gute Frage....wo kann ich das ersehen? Hab die SSD damals eingebaut und mehr oder weniger nur das getan, was die Box mir gesagt hat.


    2. Wie voll:
    Aktuell sind von 500 Gb ca. 100 belegt. Massig Platz also noch.


    3. TRIM/discard:
    Was ist das?


    4. Mountoptionen
    Siehe 1.


    5. Alter
    Platte ist etwa 6 Monate alt


    6. Füllstand Partition
    Platte war noch nie voller als die aktuellen 100 Gb


    Entschuldigt meine laienhaften Aussagen. Hab schon etliche Boxen gehabt und nie groß Probleme. Zudem war ich nie der Crack. Konnte mir meist mit Lesen weiterhelfen. Aber hier weiß ich nicht weitet

  • 1.


    Code
    root@dm920:~# blkid|grep dev/sd
    /dev/sda1: LABEL="dreambox-storage" UUID="6d774fc5-6a5e-48cf-9570-da603d0604da" TYPE="ext4" PARTLABEL="dreambox-storage" PARTUUID="5577bf13-8119-4bf6-9df5-91b4a29ae9e0"
    /dev/sda2: UUID="737e071b-6e57-4959-854e-4dcbc40fcddb" TYPE="swap" PARTLABEL="dreambox-swap" PARTUUID="c2e5ebab-4a5d-4aa5-b848-82e9c90f1f71"


    Code
    root@dm920:~# fdisk -lu dev/sd?
    fdisk: can't open 'dev/sd?': No such file or directory



    4.


    Code
    root@dm920:~# grep /media /etc/fstab|grep -v systemd
    /dev/disk/by-uuid/6d774fc5-6a5e-48cf-9570-da603d0604da /media/hdd auto auto,nofail 0 0


    6.


  • Ich würde mal das Dateisystem überprüfen lassen. Natürlich nur, wenn gerade keine Aufnahme läuft bzw. eine Aufnahme abgespielt wird!


    1) Festplatte aushängen:


    # umount /media/hdd


    2) SWAP Partition mal einhängen


    # swapon /dev/sda2


    3) Dateisystemprüfung starten (kann etwas länger laufen)


    # fsck.ext4 -f -v -p -y /dev/sda1


    Die Ausgabe vom letzten Befehl wäre interessant.


    Wenn das durch ist, kannst Du die SSD wieder einhängen und den SWAP abschalten:


    # mount /media/hdd
    # swapoff /dev/sda2


    Generell solltest Du SSDs mit anderen Optionen in fstab mounten. Hier mal meine SSD (siehe discard und noatime Option):


    Code
    /dev/disk/by-uuid/c2e0d2b6-ac58-4198-ac5a-a2a4f7b7a0ca /media/ssd auto auto,nofail,discard,noatime 0 0
  • Sorry für die späte Rückmeldung. Hatte einfach keine Zeit hierfür.
    Folgendes kommt da raus:


    Connected ***************************** * * * The Gemini Project 4.0 * * * ***************************** opendreambox 2.5.0 dm920 dm920 login: root
    root@dm920:~# umount /media/hdd
    root@dm920:~# swapon /dev/sda2
    root@dm920:~# fsck.ext4 -f -v -p -y /dev/sda1
    e2fsck: Only one of the options -p/-a, -n or -y may be specified.
    root@dm920:~#

  • sieht eigentlich gut aus


    Quote

    Original von Roaddog

    Code
    root@dm920:~# fdisk -lu dev/sd?
    fdisk: can't open 'dev/sd?': No such file or directory


    Bei dem command hast du den "/" am Anfang vergessen, da wollte ich rausfinden ob das disk alignment stimmt. Wenn die Sektoren nicht korrekt ausgerichtet sind, kann es zu Performance Einbußen kommen



    versuch's noch mal


    fdisk -lu /dev/sda


    oder mit parted (die commands nacheinander eingeben):


    parted
    select /dev/sda
    align-check optimal 1
    q


    sollte dann so aussehen:


    Code
    root@dm900:~# parted
    GNU Parted 3.2
    Using /dev/sda
    Welcome to GNU Parted! Type 'help' to view a list of commands.
    (parted) select /dev/sda
    Using /dev/sda
    (parted) align-check optimal 1
    1 aligned
    (parted) q
    root@dm900:~#



    Hast du die SSD schon getrimt? Nachdem du die SSD ohne autotrim (discard) gemountet hast, könntest du mal manuell trimen, ssd bzw. /dev/sda1 muss gemounted sein


    fstrim -v /media/hdd

  • Danke für deine Hilfe....
    Ohne zu wissen was das ist, hab ich die SSD jetzt mal nach deiner Empfehlung getrimmt.


    Was mir bei meinem Aufnahmeproblem ungefallen ist: nehme ich ne SD Serie auf, hab ich keine Probleme. Nehme ich nen Film in HD auf, dann passiert es immer. In meinem Fall ist das immer der Tatort im Ersten. Merkwürdig....

  • z.B. SSD Trim


    interessant wäre das partition alignment, wenn die sektoren nicht korrekt ausgerichtet sind, kannst du trimen wie du willst


    aber wenn die SSD mit einem halbwegs aktuellen Enigma2 (late OE2.0 oder OE2.2/OE2.5) initialisiert wurde sollte das alignment passen


    oder die SSD ist Schrott oder am sterben


    welche SSD verbaut ist hast du uns ja nicht verraten ...



    hdparm -I /dev/sda|grep -i model
    smartctl -a /dev/sda

  • Modell ist: Samsung SSD 860 EVO 500GB


    Platte ist ca. 1/2 Jahr alt....

  • An der Samsung SSD sollte es eigentlich nicht liegen, sofern die vom Smartctl als OK gemeldet wird.


    Ich verwende hier die Samsung SSD 840 EVO 500GB, die vorher jahrelang in einem Notebook lief und damit gibt es keine Probleme. Allerdings habe ich die Platte auch während der E2-Einrichtung gleich mit partitioniert, wodurch dann das Alignment stimmt.


    poste bitte mal die Ausgabe von "fdisk -l /dev/sda"


    Gruß
    Ryker

  • das aligment sollte passen




    mach mal einen einfachen Permormancetest, die Ausgaben posten (den mountpoint der ssd anpassen, wenn erforderlich)


    dd if=/dev/zero of=/media/hdd/performancetest bs=1M count=200
    dd if=/dev/zero of=/media/hdd/performancetest bs=1M count=1000
    rm /media/hdd/performancetest
    fstrim -v /media/hdd
    hdparm -tT /dev/sda

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Nur für's Protokoll:


    SSD erneuert und alle Probleme sind gelöst.
    Hätte nie gedacht, dass ne neue SSD defekt sein könnte....

  • Nennt sich denglisch „dead on arrival“ oder kurz DOA.


    Kann immer wieder mal vorkommen.