Retro Game Station beim Verlassen DBnicht mehr bedienbar

  • Habe mich riesig gefreut, dass ich die Retro Game Station entdeckt habe :hurra:


    Ich habe zwar auch das Problem, dass der Ton nicht immer funktioniert, aber wenn ich die Dream runter fahre und starte, ist der Ton da.


    Aber wenn ich den Vice 64 mit Quit beende, dann ist zwar das TV Bild (und Ton) da, aber ich kann die Dreambox nicht mehr bedienen. Weder mit Fernbedienung, noch mit Smartphone.

  • Ja, das ist in nullkommanix gefixt.
    Du musst nur 2 Zeilen auskommentieren...
    Das findest du irgendwo in einem Thread hier...


    Hab jetzt aber kein Bock zu suchen, deswegen hänge ich die Datei einfach an. Einfach überschreiben und neu starten.
    Hebe dir die Datei aber gut auf, weil die beim nächsten Update leider überschrieben wird.
    Das sollte einer mal im dreamboard melden, sonst bleibt das leider so.
    Auf jedenfall kommt man so nach beenden der emus wieder normal in das retrogamestation Menü und kann mit Exit beenden und die dream ist ganz normal bedienbar...
    Auch ein danke an den User der es gepostet hat dessen Name ich nicht mehr weiß...
    Oder dessen Name nicht genannt werden darf... Hehe
    Greetz from H. Potter...

    Files

    • Emulator.py

      (3.91 kB, downloaded 18 times, last: )

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY

    Edited once, last by FoLeY ().

  • /usr/lib/enigma2/phyton/plugins/extensions/retrogamestation/

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY

  • Super. Funktioniert einwandfrei. Glaub das ständige Ein- und Ausschalten tut der Box nicht gut. Hiermit wirste offiziell Zwangsknuddelt.

  • Hehe... Der war gut...


    Du hättest ja nicht den Kippschalter nehmen müssen.
    Telnet Befehl Reboot hätte auch funktioniert.
    Geht auch mit Handy und conectbot aus dem playstore...
    Dann brauchst nichtmal aufstehen... Faul ist der Mensch...

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY

  • Jetzt wo Du es sagst ...
    Auf die Idee mit Telnet oder Web-If bin ich zu meiner Schande nicht gekommen
    Notiz an mich selbst .. "merke Dir das"

  • Wird Zeit, dass DP das mal repariert in enigma2.
    Das ist ja schon Eeeewig hin: "eDBoxLCD.getInstance().lock(True)"

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Das Problem, dass ich keinen Sound habe, hab ich leider immer noch. Hab grad eben mal ein frisches Image (was schon gp4 beihaltet) geflasht. Retro Game Station gestartet, kein Ton :-(


    Es ging nur 1x, danach nicht mehr. Egal ob Neustart oder Shutdown. Das scheint reiner Zufall zu sein, wenn der Ton mal zu hören ist.

  • Der Ton geht weg wenn du retrogamestation startest ohne was anzuklicken? Oder wenn du ein emu startest und das Game hat kein Ton? Hier bei mir mit aktuellem dreamOS und gp4 auf ner 900er hab ich Null Probleme mit Ton. Weder der Spiele Sound noch beim verlassen...

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY

  • Wie hast du deine dream angeschlossen? Hdmi? Av Receiver? Kommt der Ton vom TV? Was falsches im Audio menü ? Downmix oder irgendwas?
    Wie gesagt, hier gehts.
    Per hdmi an Pioneer SC-LX-88 und dann zum TV, downmix natürlich aus.

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY

  • Sorry, dass ich jetzt erst antworte.


    Mit "der Ton ist weg" meine ich, dass der Emulator keinen Ton bringt. Ich höre keine Spiele Sounds.


    Ab und zu, aber nur selten, starte ich den Emulator (C64) und danach das Spiel und dann habe ich Ton. Starte ich dann ein anderes Spiel, ist kein Ton mehr zu hören. Auch Box Neustart bringt keine Abhilfe.


    Ich habe auch schon ein neues Image geflasht und NUR die retro-game-Station über GP4 installiert. Ging auch nicht.


    Angeschlossen direkt am TV per HDMI mit AC3 Downmix an.
    Müsste es mal mit AC3 Downmix aus probieren.


    Möglicherweise liegt es daran.

  • Problem besteht auch nach "Downmix aus" immer noch sporadisch.


    Dieses Mal sehe ich aber zum ersten Mal eine Fehlermeldung.


    Ich nutze einen PS4 Controller über USB und da ist ein Lautsprecher mit drin. Möglicherweise liegt es auch daran?


    Habe dann mal nur die Game-Station gestartet und anschließend erst den Controller verbunden...dann ging der Sound.


    Ob es jetzt aber am Controller definitv liegt, kann ich noch nicht bestätigen. Dazu müsste ich mehr testen.

  • Interessant... Also bei mir werkelt ein Xbox Controller vom PC... Also Empfänger an USB Der dream und der Controller ist dann ja kabellos...
    Und ich hab auch bei vice immer Sound.
    Spiele waren : pitfall, gyrus, demon attack, hero, dig dug und rtype... Eben nochmal getestet.
    Keine Hänger und kein Sound Problem...


    Aber nochmal... Das Zeugs auf der dream ist Furz...
    Ein vernünftiges frontend auf PC, shield oder raspi ist schon was anderes... Dann macht das retro zocken auch Spaß...

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY