[gelöst] NFS Poblem

  • Hallo zusammen, vielleicht kann mir ja einer helfen.


    Hab auf meinem Rechner Ubuntu 18.10. Wollte meinen PC mit der Dreambox 8000 per nfs verbinden.


    Der mount von der Dreambox zum PC funktioniert sehr gut. Nur bekomme ich keinen mount vom PC zur Dreambox hin.


    Wenn ich mir im Terminal die Freigabe auf der Dreambox anzeigen lassen will kommt folgende Fehlermeldung.


    Quote

    philian@Laptop:~$ showmount -e 192.168.2.10
    clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)


    Was ist der Fehler?

    Gruß Philian

    Edited once, last by Philian ().

  • Quote

    Original von mfgeg
    Wie ist die Fehlermeldung wenn du die Freigabe mountetst?


    Wenn ich die Freigabe mounten will dann stoppt sofort der nsf-Server der Dreambox.


  • philian@Laptop:~$ rpcinfo -p 192.168.2.10
    192.168.2.10: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)


    Nein hab keine Firewall installiert. Mit SELinux kann ich jetzt nicht anfangen.

  • ich kann mich dunkel an einen bug mit dem portmapper im OE2.0 im Zusammenhang mit dem kernel-module-ipv6 erinnern


    Hast du das kernel-module-ipv6 auf der 8K installiert?
    Wenn ja, deinstalliere es mal, wenn nicht dann installiere es


    in jedem Fall den nfsserver auf der box neu starten oder rebooten




    \\edit


    ach ja, noch etwas
    mit den standard NFS Freigabeoptionen auf der Box wirst du auch Probleme beim mounten mt Ubuntu bekommen


    mit den Optionen in der /etc/exports sollte es klappen, dann wird der user immer auf root gemappt


    /etc/exports

    Code
    /media/hdd/ 192.168.2.0/24(rw,insecure,no_subtree_check,all_squash,async,anonuid=0,anongid=0


    nach der Änderung den nfsserver auf der Box reloaden


    exportfs -r


    bzw. nfsserver neu starten oder rebooten



    beim mounten wirst du auch die NFS Version auf v3 in den Optionen festlegen müssen: vers=3

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

    Edited 6 times, last by Fred Bogus Trumper ().

  • Hallo,


    habe zwar nicht wirklich Ahnung, aber würde erstmal auch fast glauben das der NFS-Server gar nicht installiert ist und somit auch nicht läuft.....



    Und solange du selbst auf deinen angeblich installierten NFS-Server diese Meldung bekommst:


    Quote

    philian@Laptop:~$ showmount -e 192.168.2.10
    clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)


    Brauchst du auch nicht versuchen dich mit dem Rechner auf die Box zu verbinden, diese Zeit ist vergeudet...


    Du musst erstmal schauen das der NFS-Server läuft.


    Habe zwar selbst mal eine Anleitung gemacht, aber die ist nur für OE2.2 und OE2.5
    https://dreambox.de/board/inde…ng-server-einrichten-faq/


    Aber dein OE2.0 hat kein systemd und läuft ja glaube ich noch mit den init-scripten,
    Naja und wirklich gute Anleitunegn für Anfänger sind ja bekanntlich rar in der Scene, will ja jeder mit der Mouse auf irgendwelche Netzwerkscanner klicken, egal was der dann macht ;)



    Ansatzweise habe ich ja mal 2007 für das alte OE einen Wikibeirag gemachtt, der geht aber davon aus das der NFS-Server schon läuft...


    http://wiki.blue-panel.com/ind…inander_per_NFS_Verbinden



    Ich weiß nur noch das für den NFS-Server folgende Pakete installiert sein müssen..


    Pakete sind wie folgt, für den NFS Server.


    - kernel-module-nfsd
    - portmap
    - nfs-utils


    Und natürlich noch die Datei /etc/exports für die Freigaben.

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

    Edited 5 times, last by EgLe ().

  • Quote

    Original von Fred Bogus Trumper
    ich kann mich dunkel an einen bug mit dem portmapper im OE2.0 im Zusammenhang mit dem kernel-module-ipv6 erinnern


    Hast du das kernel-module-ipv6 auf der 8K installiert?
    Wenn ja, deinstalliere es mal, wenn nicht dann installiere es


    in jedem Fall den nfsserver auf der box neu starten oder rebooten



    Genau das war der Fehler. Bei mir hat das kernel-module-ipv6 gefehlt. Hab es installiert und nfs-server neu gestartet.
    Freigaben gemountet und es läuft. :hurra:


    Vielen Dank :top: