kodi 19.0 ALPHA (armhf) /kodi 18.2 RC1(mipsel)

  • Achtung, kodi-18/19 benutzt viel neuere libs als enigma2 (aus dem nächsten OE).


    zu kodi-19: ist auf dem kodi-18 feed armhf


    Darum ist das auf einem eigener feed.


    Man muss damit rechnen, dass viele addons nicht gehen. kodi-19 ist alpha!


    Mache ein Backup von deinem Image, damit es keine Tränen gibt. Ich hab's nicht gemacht *duck* :D.


    MIPSEL ist an der absoluten Speichergrenze in derzeitigen Stadium, es geht eigentlich ohne Abstürze und Speicherüberschwemmung nur im "Standalone" Modus.


    Install (dm9X0):

    Code
    root@dm920:~# tar -xzf kodi-18-feed-armhf-unstable.tar.gz -C /
    root@dm920:~# wget -O - http://download.blue-panel.com/info@ihad.tv.key | apt-key add -
    root@dm920:~# apt-get update
    root@dm920:~# apt-get install enigma2-plugin-extensions-kodimediacenter


    Install (dm820, dm7080):

    Code
    root@dm7080:~# tar -xzf kodi-18-feed-mipsel-unstable.tar.gz -C /
    ...


    Notaus:

    Code
    root@dm7080:~# killall -9 kodi-dreambox


    UHD issues Auflösung.


    HOME=/data/.kodi

  • Ist soweit schon mal durchgelaufen und starten geht auch ;)


    Beim installieren über telnet aber folgendes Problem:


    Code
    Errors were encountered while processing:
    /var/cache/apt/archives/libcec_4.0.2+git1+d54093a548-r0.0_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    So wie es aussieht braucht es eine neuere Verison von inputstream.adpative ? Die 2.0.18 scheint nicht zu reichen, TVNow meckert z.b. das es erst gar nicht installiert wäre.
    Aber einfachere Addons wie z.b. Sporttotal.tv gehen schon.

  • inputstream.adpative ist keines dabei. Nutzt mein Player auch so nicht. Ich hab das nur in Einzelteilen, weil es das oe nicht baut. Ich kann ja mal testen.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Ja z.B. TVNow und DAZN Addon nutzen beide inputstream.adaptive mit dem VideoPlayer, und bei Kodi 17.6 funzt zumindest TVNow noch, während bei DAZN keine chance, braucht eine höherere Version.


    Hier ist das git:


    https://github.com/peak3d/inputstream.adaptive


    Keine Ahnung ob jemand damit was anfangen kann, um es umzubauen.

  • top openGLES geht ja schon mal


    laden der Covers und KODI ist tot hat sich also nicht geändert zur 17.6


    oder gab es da irgend ein trick ?

  • kodi-addon-inputstream-adaptive_2.3.6+gitr0+51c94a7c8d-r0.0_armhf.deb
    kodi-addon-pvr-hts_5.10.2+gitr0+f4ea60f944-r0.0_armhf.deb
    kodi-addon-pvr-iptvsimple_3.9.4+gitr0+2134467d96-r0.0_armhf.deb
    kodi-addon-pvr-vuplus_3.12.2+gitr0+ac72704ddc-r0.0_armhf.deb
    kodi_18.0+gitr15+0307cadaf5-r0.2_armhf.deb


    auf dem feed

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Quote

    Original von babsy98
    top openGLES geht ja schon mal


    laden der Covers und KODI ist tot hat sich also nicht geändert zur 17.6


    oder gab es da irgend ein trick ?


    Beschreib mal, wie/wo (menu, welche Box) ich das auslösen kann

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • DM900


    einbinden externes NAS Laufwerk


    bei mir um 50 mkv files


    scaper video standard alles gelassen nichts verändert


    dann sucht er noch den Daten was ohne fehler auch klappt


    wenn er fertig ist mit exit zurück auf den main screen


    kodi crash und lässt sich nicht mehr öffnen


    man muss nun den kodi daten Ordner löschen damit kodi wieder geht

  • da wär mal ein log gut. Ich kann das nicht nachstellen.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • habt dir pn gesendet mit allen infos

  • kodi_18.0+gitr15+0307cadaf5-r0.2_armhf.deb


    auf dem feed[/quote]


    I can not find please?

  • Maybe emanuel updated the feed already. Try

    Code
    apt-get update && apt-cache search kodi_18
  • Sollte Dazn nun damit auf der 920 gehen?


    Inputstream und libwidevine installiert, aber kommt weiterhin kein Bild.

    Ich bin nicht faul sondern im Energiesparmodus!

  • Mit Dazn bin ich auch noch nicht weiter gekommen. Nochmal eben alles frisch aufgesetzt aber weder GstPlayer noch Kodi-Videoplayer lassen sich zum Abspielen überreden.


    Aber TVNow flutscht jetzt gut, mit Kodi 17.6 war es bisher nur per Kodi-Videoplayer abspielbar, aber nun geht das auch mit dem GstPlayer.

  • Ich habe bei meiner die liburl2.py wie im 17.6 Post angepasst für SSL.
    Eventuell hilft das. Komischerweise gehen manche streams nur auf der 7080 auf. SRF Play z.b. die armhf hängen sich da weg. Kann aber nur dmm was machen.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Quote

    Ich habe bei meiner die liburl2.py wie im 17.6 Post angepasst für SSL.


    Welche meinst du genau, nicht etwa die urllib2.py, die nach /usr/lib/python2.7 kommt ?

  • Also laut Log


    Code
    ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/data/.kodi/cdm/libwidevinecdm.so)
    ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed

    ldd libwidevinecdm.so ergibt



    Die Libs mal draufkopiert und läuft über den Videoplayer,.. ;)

    Ich bin nicht faul sondern im Energiesparmodus!

    Edited once, last by LazyT ().

  • https://help.vivaldi.com/article/raspberry-pi/#drm-and-flash


    drm ist aber im Moment nicht mitgebaut, weil ich das nicht im EGL/gstreamer so einfach einbauen kann.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594