kodi 19.0 ALPHA (armhf) /kodi 18.2 RC1(mipsel)

  • das ist ein Problem aus dem oe libs.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Kann man bzw. du da nix machen? ,jemanden fragen der an den libs arbeitet oder so?
    Wie gesagt Kodi schmiert jedes mal ab wegen dem und ohne eine schöne Datenbank mit den Filminfos usw. da fehlt dem Kodi auch etwas und das sollte nach der Zeit die man jetzt Kodi schon auf der Dream nutzen kann auch denke funktionieren bzw. nach dem Bug geforscht werden und ihn beseitigen.

  • Es gibt das im OE gar nicht, wenn müsste ich mich mal opfern...
    Kein Ahnung ob das überhaupt so geht...


    Auf dem rpi bzw auf der aml Box nutze ich mariadb-connector-c
    gibt's aber so im OE nicht.


    mal sehen...

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Wie gesagt wäre schön wenn das dann auch geht und man sich mal eine schöne Bibliothek anlegen könnte.
    Hab das letztens erst an meinem Android TV gemacht und da läuft auch die aktuelle Kodi Version ;)

  • emanuel, so do You have 2GB of ram indicated for ex. in Kodi system info? Do You know about some instructions how to update bootloader/img? I was flashing it via web browser from OpenATV 6.1 to OE2.5.


    About this refresh rate, this option doesn't work, but opening kodi via standalone version - there is an option to switch refresh rate to 50hz, then save it, and switch back to fullscreen version of kodi - it will be saved as 50Hz there then.


    Is there an option to start the kodi as systemd service, in the way that enigma2 will be started correctly, and then systemd will start kodi automatically? I'm not interested to switch off enigma 2 service and enable kodi service, this way channels will definitely does not work.

  • I do not use ext 2GB. It does depend on the newer kernel only. See dreambox forum for instuctions.


    System deamon is for kodi standalone only without enigma2 tv.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • So this would work with tvheadend then, enigma2 service disabled, tvheadend & kodi sevices enabled, then I'll have kodi mediacenter+dvb channels from tvheadend.. Ok I guess I have the basic knowledge now.

  • Therefore are Lots of ways.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • zum Movie database crash, wenn kodi nicht mehr startet:
    in /data/.kodi/userdata/Database/ die letzte angelegte Videodatenbank löschen. Dann startet kodi wieder.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Update 18.2:
    Fix: Movie database MyVideos116.db crash

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • I have a dreambox dm900 and trying to install kodi. but my box does not know the command apt-get how to fix this?

  • how do i install this on an dm900 with openpli the command apt-get is not known

  • You are seriously asking here for Open... images?
    We are using DreamOS. You should ask in Open... forums.


    Why the hell do you use this ancient OS? There is no apt package manager in pli!

  • Quote

    Original von emanuel
    Update 18.2:
    Fix: Movie database MyVideos116.db crash


    Das wär ja cool, wenn das nun endllich funktioniert. Muss mir mal Zeit für's testen nehmen. ;-)
    Sollte das dann auch mit einer zentralen Datenbank via "advancedsettings.xml" funktionieren?


    Danke und Gruß

  • Ich antworte mir mal selber:


    Toll! Das mit der Datenbank scheint prima zu funktionieren. Auch mit meiner "advancedsettings.xml" ist sofort die Verbindung zu meiner Datenbank auf dem NAS vorhanden und alles wird angezeigt.


    Aber: Abspielen von Filmen will nicht (Musik klappt).
    Entweder bei drücken auf "OK" passiert nichts, wenn ich die "Play" Taste drücke, dann flieg ich ins Hauptmenü der Box zurück.


    Hier der Auszug aus einem Abspielversuch:



    Woran kann das liegen?


    Sorry, wenn das schon mal gefragt wurde. Konnte aber mit der Suche nichts finden.


    Danke und Gruß

  • keine Ahnung, schaut eigentlich gut aus.


    Was ist wenn du vorher im enigma2 das Verzeichnis mountest unter nfs und über kodi nur abspielst?

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Direkt abspielen geht:



    Scheint also an der NFS-URL zu liegen.
    Aber die kann ich in der Datenbank (auf dem NAS) ja schlecht ändern, da der Sinn der NFS-URL natürlich ist, dass alle Kodi's im Netzwerk (Windows, Fire-TV) den gleichen originalen Pfad ansprechen sollen.


    Ich bin jetzt nichtg wirklich firm mit dem gstreamer via CLI. Hast Du da mal ne Syntax, mit der ich mit den Pfaden/URL's in der Shell rumspielen kann?


    Und nochmal: Mit Musik vom NAS via zentraler Kodi-Datenbank klappt das ohne Probleme (siehe Screenshot). Warum dort aber nicht bei Filmen?


    Danke und Gruß

    Files

    • musik.png

      (47.78 kB, downloaded 647 times, last: )
  • Ich habe nun mal auf blauen Dunst das Pakte "gstreamer1.0-plugins-base" installiert. Sieht ein wenig anders aus - ändert aber nix.


    Was ich rausgefunden habe:


    Ich versuche einen Film zu starten:


    Es erscheint oben rechts das blaue Play-Symbol (>), dann passiert nichts mehr. Symbol verschwindet einfach wieder nach kurzer Zeit und es bleibt die Filmliste stehen.
    Starte ich einen 2. Versuch auf den gleichen Film dann fliegt Kodi weg und ich lande im Hauptmenü der Box.


    Log sieht dann so aus:



    Wenn jemand einen Tip hat - her damit. ;)


    Danke und Gruß