Gemini-Openvpn

  • grauadler: Deine conf wird so mit den Gemini-Openvpn plugin unter GP4 nicht funktionieren.
    Alternativ probier mal zum Test den Befehl :
    openvpn --config /etc/openvpn/client/XXX.conf (XXX=Name deiner .conf)
    in ein script zu packen und dieses dann zBsp. mit dem userscipts-plugin von oozoon zu Starten.

  • Danke für die antworten.
    Dachte mir schon dass ich ein script benötige um es zu starten.
    Wenn ich den Telnet Befehl eingebe kommt error.
    Hatte da mal was probiert. Die Datei wird auch in Erweiterungen angezeigt und kann auch gestartet werden. Leider fehlen in der Plugin.py die weiteren Zeilen um es zu starten. Bin kein Programierer.
    Vielleicht gibt es hier ja jemanden der es bauen könnte. Die nötigen Dateien kann ich zur Verfügung stellen.


    Danke und eine schöne Woche

  • Guten Morgen,
    hat jemand einen tipp, wie ich weiter komme,
    Funktioniert alles... aber im Client Plugin sehe ich nichts?


    Client:
    /etc/openvpn# openvpn --config /etc/openvpn/clients/client.conf


    Wed Apr 24 07:33:28 2019 OpenVPN 2.3.8 mipsel-oe-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Jul 25 2017
    Wed Apr 24 07:33:28 2019 library versions: OpenSSL 1.0.2h 3 May 2016, LZO 2.09
    Wed Apr 24 07:33:28 2019 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
    Wed Apr 24 07:33:28 2019 WARNING: file '/etc/openvpn/clients/dm500hd85.key' is group or others accessible
    Wed Apr 24 07:33:28 2019 Socket Buffers: R=[196608->131072] S=[196608->131072]
    Wed Apr 24 07:33:28 2019 UDPv4 link local: [undef]
    Wed Apr 24 07:33:28 2019 UDPv4 link remote: [AF_INET]X.X.X.X:3504
    Wed Apr 24 07:33:28 2019 TLS: Initial packet from [AF_INET]62.210.113.106:3504, sid=35bb61d6 ef6b3401
    Wed Apr 24 07:33:28 2019 VERIFY OK: depth=1, C=AM, ST=DM, L=DeMirOvo, O=OpenVpn-Server, CN=OpenVpn-Server CA, emailAddress=vk_lisica@hotmail.com
    Wed Apr 24 07:33:28 2019 VERIFY OK: depth=0, C=AM, ST=DM, L=DeMirOvo, O=OpenVpn-Server, CN=server, emailAddress=vk_lisica@hotmail.com
    Wed Apr 24 07:33:32 2019 Data Channel Encrypt: Cipher 'DES-EDE3-CBC' initialized with 192 bit key
    Wed Apr 24 07:33:32 2019 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr 24 07:33:32 2019 Data Channel Decrypt: Cipher 'DES-EDE3-CBC' initialized with 192 bit key
    Wed Apr 24 07:33:32 2019 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed Apr 24 07:33:32 2019 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
    Wed Apr 24 07:33:32 2019 [server] Peer Connection Initiated with [AF_INET]62.210.113.106:3504
    Wed Apr 24 07:33:34 2019 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
    Wed Apr 24 07:33:34 2019 PUSH: Received control message: 'PUSH_REPLY,route 172.16.0.0 255.255.0.0,dhcp-option DNS 8.8.8.8,dhcp-option DNS 8.8.4.4,route 172.16.0.0 255.255.0.0,topology net30,ping 10,ping-restart 120,ifconfig 172.16.8.86 172.16.8.85'
    Wed Apr 24 07:33:34 2019 OPTIONS IMPORT: timers and/or timeouts modified
    Wed Apr 24 07:33:34 2019 OPTIONS IMPORT: --ifconfig/up options modified
    Wed Apr 24 07:33:34 2019 OPTIONS IMPORT: route options modified
    Wed Apr 24 07:33:34 2019 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
    Wed Apr 24 07:33:34 2019 ROUTE_GATEWAY 192.168.178.1/255.255.255.0 IFACE=eth0 HWADDR=00:09:34:2f:6d:5a
    Wed Apr 24 07:33:34 2019 TUN/TAP device tun0 opened
    Wed Apr 24 07:33:34 2019 TUN/TAP TX queue length set to 100
    Wed Apr 24 07:33:34 2019 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Wed Apr 24 07:33:34 2019 /sbin/ip link set dev tun0 up mtu 1500
    Wed Apr 24 07:33:34 2019 /sbin/ip addr add dev tun0 local 172.16.8.86 peer 172.16.8.85
    Wed Apr 24 07:33:34 2019 /sbin/ip route add 172.16.0.0/16 via 172.16.8.85
    Wed Apr 24 07:33:34 2019 /sbin/ip route add 172.16.0.0/16 via 172.16.8.85
    ip: RTNETLINK answers: File exists
    Wed Apr 24 07:33:34 2019 ERROR: Linux route add command failed: external program exited with error status: 2
    Wed Apr 24 07:33:34 2019 Initialization Sequence Completed
    ^CWed Apr 24 07:43:49 2019 event_wait : Interrupted system call (code=4)
    Wed Apr 24 07:43:49 2019 /sbin/ip route del 172.16.0.0/16
    Wed Apr 24 07:43:49 2019 Closing TUN/TAP interface
    Wed Apr 24 07:43:49 2019 /sbin/ip addr del dev tun0 local 172.16.8.86 peer 172.16.8.85
    Wed Apr 24 07:43:49 2019 SIGINT[hard,] received, process exiting

  • Hallo,


    abbei die client.conf:



    root@dm7080:/etc/openvpn/clients# ll
    drwxr-xr-x 2 root root 4.0K Apr 24 07:29 .
    drwxr-xr-x 4 root root 4.0K Apr 23 23:08 ..
    -rwxr-xr-x 1 root root 1.6K Dec 10 12:45 ca.crt
    -rw------- 1 root root 276 Apr 24 07:30 client.conf
    -rwxr-xr-x 1 root root 5.1K Feb 15 2012 dm500hd85.crt
    -rwxr-xr-x 1 root root 1.6K Feb 15 2012 dm500hd85.key


    root@dm7080:/etc/openvpn/clients# cat client.conf


    client
    dev tun
    proto udp
    remote X.X:X.X.net 3504
    resolv-retry infinite
    nobind
    persist-key
    persist-tun
    ca /etc/openvpn/clients/ca.crt
    cert /etc/openvpn/clients/dm500hd85.crt
    key /etc/openvpn/clients/dm500hd85.key
    cipher DES-EDE3-CBC
    keepalive 3 10
    ping-timer-rem

  • Vielleicht liegt da doch nicht der Fehler.


    Das Problem wird sein, dass die Route in das Netz 172.16.0.0/16 bereits existiert und daher nicht erstellt werden kann.
    Was gibt denn ip route aus?

  • anbei ip route Ausgabe


    default via 192.168.178.1 dev eth0
    192.168.178.0/24 dev eth0 src 192.168.178.31
    192.168.178.1 dev eth0

  • Die Route existiert ja nicht. Dann weiß ich auch nicht weiter. Sorry.


    Dein problem liegt jedenfalls hier:

    Code
    Wed Apr 24 07:33:34 2019 /sbin/ip route add 172.16.0.0/16 via 172.16.8.85
    Wed Apr 24 07:33:34 2019 /sbin/ip route add 172.16.0.0/16 via 172.16.8.85
    ip: RTNETLINK answers: File exists
    Wed Apr 24 07:33:34 2019 ERROR: Linux route add command failed: external program exited with error status: 2
  • Kann mir hier jemand anderes helfen?

  • Evtl. wird

    Code
    /sbin/ip route add 172.16.0.0/16 via 172.16.8.85


    tatsächlich zweimal ausgeführt - so wie es im Log steht. Das würde dann auch den Fehler erklären. Wieso das aber so ist.... schwer zu sagen. Hast du die Config mal auf einem vollwertigen Linux getestet?

  • Mit Image oenATV funktioniert es ....aber ich möchte openATV nicht benutzen.

  • Hallo,


    wenn ich mit "openvpn --config /etc/openvpn/client.conf" die Abfrage mache, bleibt die Abfrage stehen bei "Initialization Sequence Completed"


    und eine Tunnel-IP-Adresse wird aufgebaut und ich kann mich auf den Server verbinden.


    Wenn ich die Abfrage mit Steuerung C abbreche, dann ist die IP-Adresse nicht mehr verfügbar.


    Gibt es eine Möglichkeit, dass ich das alles über Gui aufbaue?



    root@dm7080:/etc/openvpn/clients# openvpn --config /etc/openvpn/client.conf


    Wed Apr 24 18:34:33 2019 /sbin/ip addr add dev tun0 local 172.16.8.86 peer 172.16.8.85
    Wed Apr 24 18:34:33 2019 /sbin/ip route add 172.16.0.0/16 via 172.16.8.85
    Wed Apr 24 18:34:33 2019 /sbin/ip route add 172.16.0.0/16 via 172.16.8.85
    ip: RTNETLINK answers: File exists
    Wed Apr 24 18:34:33 2019 ERROR: Linux route add command failed: external program exited with error status: 2
    Wed Apr 24 18:34:33 2019 Initialization Sequence Completed


    root@dm7080:/etc/tuxbox/config# ifconfig


    tun0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:172.16.8.86 P-t-P:172.16.8.85 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:20 errors:0 dropped:0 overruns:0 frame:0
    TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:1318 (1.2 KiB) TX bytes:4500 (4.3 KiB)

  • Das verstehe ich jetzt nicht. Wie bist du denn zu dem Logfile in deinem Eingangspost gekommen? Da sieht es so aus, als hättest du den Client über die Kommandozeile ausgeführt...

    Quote

    /etc/openvpn# openvpn --config /etc/openvpn/clients/client.conf


    ...und der Error wurde daraufhin geloggt.


    Wenn es nur über die GUI, aus einem Plugin heraus nicht funktioniert, dann ist es ja erstmal kein OpenVPN Problem. OpenATV hast du ja schon getestet. Im Grunde haben doch alle Images ein VPN Plugin an Board (Merlin, NN2, usw.). Wenn es jetzt mit dem GP4 Plugin nicht funktioniert, müsste der Pluginersteller mal drüberschauen.
    Hast du überhautp GP4 im Einsatz? Für die Boxen aus deinem Profil gibt es das nämlich gar nicht...

  • Hallo Basti756,


    nachdem ich Gemini-Openvpn deinstalliert habe ist alles in bester Ordnung.


    Danke für deine Hilfe!!!

  • Habe mir einen GoldenFrog,service und GoldenFrog.sh erstellt und lasse alles über die systemd/system laufen. VPN Dateien unter etc/openvpn gespeichert. Script erstellt weches dann unter Erweiterungen gestartet werden kann.
    Startet nach dem neubooten selbsständig und eine neue ip ist hinterlegt. Kann über FB geatartet und gestoppt werden.
    Aus meiner Sicht der sogar besser Weg.

  • Neuestes stable Image auf DM900 geflashed (dreambox-image-deb-dm900-20190628.tar.xz). GP4 installiert und über den Addon-Manager geminiopenvpn installiert - ohne Fehler.


    Bei Start des Clients über's BluePanel -> Greenscreen (s.Anhang).


    Kann jemand helfen?

  • Ist glaub ein Fehler im Plugin, ich schau mir das an. Das passiert wenn man den GeminiDateiBrowser nicht installiert hat. Ich fix das.

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • Update ist oben. ;)

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • Super danke! Lässt sich nun starten.


    Allerdings läuft nun im Client ständig ein Countdown "lese Status in 9 Sekunden" und das Menü geht nicht auf. Beim Server komme ich ins Menü. Habe ein OVPN.zip import probiert - entpackt wird korrekt nach /etc/openvpn/clients. Kann aber sonst nichts weiter machen, wird auch keine Config angezeigt.


    Habe komplett deinstalliert und anschließend neuinstalliert.


    EDIT: Nach Installation von geminibrowser geht das Menü nun auf.
    Config wird zwar noch nicht eingelesen, wird aber wohl an der Conf selbst liegen.