Gemini 3.2 wird nicht gezogen, weil nameserver falsch ist "dns lookup failed"

  • Moin,


    ich habe eine DM 8000 neu geflashed mit diesem Image:
    https://www.dreamboxupdate.com…mbox/2.0.0/images/dm8000/


    und dann:
    dreambox-image-dm8000-20170216.nfi



    installiert ist dann laut den informationen die mir die box anzeigt
    eingma2: 2016-06-16-tarball
    image: experimental 2017-02-16
    ip adresse ist auch korrekt (sonst käme ich ja a uch nicht via ftp drauf)
    also alles schick.



    ich habe dann das HD skin ausgewählt und das Passwort für den root geändert, wie irgendwo beschrieben. ich habe das mit telnet gegengetestet und musste dann für root-zugriff auch das passwort eingeben.
    interessanterweise war der zugriff via ftp trotzdem noch möglich ohne passwort...


    den flash expander habe ich auf der compact flash installiert.


    dann habe ich den gp3 wizard installiert g3wizard_0.28-r0_all.ipk um gp3.2 zu verwenden (hoffe das war richtig und das ist kompatibel?).


    zwischendurch immer wieder fleissige neustarts - windows user ;)


    nun muss ich den ja über das menü aufrufen und finde ihn auch. ich wähle ihn aus und starte und er fragt, ob er installieren soll. ich bestätige und er fängt an den netzwerkstatus "bitte warten check network status" zu prüfen. und dann kommt eine meldung


    "dns lookup failed. http://download.blue-panel.com kann nicht gefunden werden"


    die netzwerkeinstellungen habe ich auch schon geändert. der nameserver war auf 192.178.x.x eingestellt. das habe ich auf 192.168.1.1 (mein rooter) und alternativ 8.8.8.8 geändert.
    aber die tests der netzwerkeinstellunegn sagen: "nameserver nicht bestätigt"


    habe dann das netzwerk der dm8000 neugestartet und festgestellt: die einstellungen im netzwerk frisst er nicht. deswegen meine vermutung:
    ip adresse passt. nameserver ist der falsche und deswegen kommt er nicht aus dem netz raus. nur:
    wie kann ich der box sagen, dass sie bitte meinen router als nameserver verwenden soll?



    danke für euren input.

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

  • bitte in /var/volatile/run/ die Datei resolv.conf von Hand auf die IP des Routers ändern und Box neu starten.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • moin jürgen,


    das bringt leider nichts. der inhalt ist:


    # Generated by resolvconf
    domain multi.box
    nameserver 192.168.1.1
    nameserver 8.8.8.8


    also ist der nameserver korrekt. oder fehlen da doppelpunkte o. ä.?


    habe auch mal in /var/volatile/run/resolvconf/interfaces


    geschaut in die dateien
    eth0.udhcpc

    domain multi.box
    nameserver 192.168.1.1


    eth0.inet


    # Generated by ifup for eth0.inet
    nameserver 192.168.1.1
    nameserver 8.8.8.8


    habe unter /etc auch die volatile.cache gefunden. kann man damit irgendwie den cache löschen?


    macht es sinn die dateien zu löschen und neuzustarten oder so?


    was mir auch aufgefallen ist: die uhrzeit stimmt nicht, die die box anzeigt und in den logfiles steht auch merkwürdiges


    grüße jens

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

    Edited 2 times, last by Jensmitbenz ().

  • Wie ist denn dein Gateway eingestellt?
    Ansonsten mal auf dhcp umstellen und freuen :)


    DHCP läuft sicher auf deinem heimischen Router...

  • Moin,


    DHCP hab ich an.


    Was mir aber aufgefallen ist:
    Der Router hat mir die DM8000 als WLAN Gerät angezeigt (ist aber über Kabel angeschlossen mittels Repeater). Und die Box kriegt ja uauch eine IP zugewiesen. Nur der DNS/Name-Server geht nicht... oder soll ich die 8.8.8.8. wieder rausnehmen als alternatnvien namesever?


    Ich versuche mal eine andere Dose des Routers, aber dsa nervt mich ja alles schon wieder ... grrrrrrrrrrrrrrrrrrrrrrrr.


    Danke aber für den Tipp.

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

    Edited once, last by Jensmitbenz ().

  • Die IP-Adresse deine Routers ist die normal auch die Nameserver-Adresse. Also ist die 8.8.8.8
    (google DNS-Server) falsch.

  • wenn du über CMD einfach nur nslookup
    eingibst wird dir dein derzeitig eingestellter DNS angezeigt


    Der DNS Eintrag sollte aber auf die IP des Routers zeigen.


    Die 8.8.8.8 , oder eine andere, wird gerne als 2te DNS genommen.

  • guten morgen leute,


    ich hatte als primären dns den router eingetragen.
    als sekundören den von google.


    habe den sekundären auf 192.168.1.1 geändert


    die fritzbox ist als dhcp server weiterhin aktiv und die dm8000 hat auch in den netzwerktest den dhcp erkannt usw.
    nur im letzten punkt "test nameserver" dauert es eeeewig bis ein ergebnis kommt. und das ergebnis ist dann rot "nicht bestätigt".


    soll ich sonst mal neu flashen? oder kann da was kapuut sein (habe die box gebraucht erworben, machte aber einen sehr guten eindruck).


    grüße jens

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

  • Dann würde ich zuerst die FritzBox in den Originalzustand versetzen.
    Danach die aktuellste Firmware aufspielen.


    Wie das für deine Box geht findest du auf der AVM Seite.


    Kann durchaus sein, dass dein Vorgänger in der Firmware rumgespielt hat
    und dort Einträge sind, die du nicht per GUI erreichen kannst.


    Oder du machst ein Backup deiner Box und flashst neu.

  • ah sorry....


    die FRITZBOX ist schon immer MEINE gewesen.



    meinte die dreambox. diese habe ich gebraucht erworben. habe dort jetzt mal den w-lan adapter (weiß gar nicht ob der im standardlieferumfang dabei ist?) aktiviert. jedenfalls ist da dann auch der name-server 192.178.1.1 eingetragen statt 192.168.1.1 und obwohl DHCP eingschaltet ist.


    insofern gleicht sich das: egal ob wlan oder kabnel: nameserver ist falsch und lässt sich nicht ändern :(


    hilfe :/


    edit: also wenn ich in der dm8000 nach den netzwerken suche findet er wlans. auch das der nachbarn... insofern: wlan ist eingebaut. aber ich komm damit auch nicht in mein netzwerk rein, obwohl wpa2 schlüssel korrekt usw.
    würde mich aber lieber erstmal auf kabel konzentrieren. schalte wlan daher jetzt wieder aus.

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

    Edited 2 times, last by Jensmitbenz ().

  • Dann einfach mal das letzte original DMM flashen, die Box per LAN anbinden
    und schauen was dann passiert.

  • so, habe nun ein paar mal geflashed und bin dann über enien punkt gestolpert:


    wenn man die box neugestartet hat, direkt nach dem flashen, wird man über einen menüpunkt geführt, der "einstellungen zurücksetzen" heisst.
    das habe ich dieses mal NICHT gemacht und voila.... bei beiden images hat es jetzt funktioneirt und ich habe einen NAMESERVER..


    PEBMAC..... problem exists between monitor and chair



    danke für eure unterstützung. ich mache mal weiter und versuche den rest auch zum fliegen zu bringen.

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

  • so... gp3 wizard lief auch durch. danke nochmal allen beteiligten.

    dreambox-image-dm800-20151205.nfi
    g3wizard_0.30-r0.3_all.deb

  • :hurra:
    denke das Problem wird dir künftig nicht mehr passieren.


    Fein wenn jetzt alles soweit wieder läuft