Aufnahme mit DM920 nicht vorhanden

  • Hallo,
    Aufnahmen mit meiner DM920 werden auf das NAS geschrieben.
    Hab öfters das Problem, dass Aufnahmen zwar ausgeführt werden, dann aber nicht vorhanden sind.
    Im Timer wird die Aufnahme auch angezeigt.


    Am NAS finde ich 3 files der Sendung.
    ts.ap + eit + ts.meta + .nfs0000000000600a3f00000004.


    Kann mir nicht erklären wieso das passiert.
    Hatte mit meiner alten DM7020HD keine Probleme.


    Vielen Dank

  • Dateien mit ".nfs" am Namensanfang sind in der Regel Dateien, die von einem Prozess A ueber NFS geoeffnet wurden und, bevor sie geschlossen wurden, von einem Prozess B ueber NFS geloescht wurden.
    "orphaned" heisst das im Fachslang.
    K.A. warum das bei Dir mit den TS-Dateien passiert, denn die fehlen in der Auflistung der Dateiendungen.
    Da koennte die NFS-Verbindung wackelig sein oder irgendein Tool will Dateien ueber NFS verschieben, waehrend die noch geoeffnet sind. Aber das ist Kaffeesatzlesen. Da muss man im Detail suchen.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • Kenne jemand mit einer dm900 (aktuelles Merlin Image) und nem Syno NAS, der vom gleichen Problem berichtet. Manche Aufnahmen gehen, manche haben das beschriebene Problem, dass die TS Datei fehlt. Dieses unzuverlässige Verhalten ist natürlich keine schöne Sache.

  • peter.b


    Versuche mal die NFS Version mit "vers=3" fest zu verdrahten. Das soll, so liest man, im Allgemeinen das Problem lösen. Die dm900, und ich vermute auch die dm920, wollen sich wohl standardmäßig mit NFS Version 4 verbinden. Leider unterstützen die Synology NAS das nicht (alle).


    Hier mein Fall:


    root@dm900:~# cat /proc/fs/nfsd/versions
    -2 +3 +4 +4.1 -4.2


    operator@DS215J:~# cat /proc/fs/nfsd/versions
    +2 +3 -4 -4.1


    Schnittmenge nur bei Version 3...

  • Quote

    Originally posted by __QT__
    Kenne jemand mit einer dm900 (aktuelles Merlin Image) und nem Syno NAS, der vom gleichen Problem berichtet. Manche Aufnahmen gehen, manche haben das beschriebene Problem, dass die TS Datei fehlt. Dieses unzuverlässige Verhalten ist natürlich keine schöne Sache.



    habe das gleiche: DM920 mit Merlin und GP3, Synology DS413. Manchmal fehlt auch bei Aufnahmen die .ts Datei.

  • Noch ein Problem, das mich langsam verzweifeln lässt:


    Bei Timer-Aufnahmen von meiner DM920 kommt "Schreibfehler bei der Aufnahme, Festplatte Voll?" wenn meine Synology im Standby ist. Bei Sofortaufnahmen und Timeraufnhamen wenn mein Nas im Wachzustand ist funktioniert alles.

    Wenn ich eine Timeraufnahme in meiner DM500HD programiere und das Nas ist zum Startzeitpunkt im Standby funktionierts auch tadellos, nur mit der DM920 nicht.


    Merlin4, Nas via Netzwerkbrowser gemounted, Aufnahmepfade in Kanäle und Aufnahmen angepasst.


    Habe auch diverse Images ausprobiert mit und ohne GP3.3. kein Erfolg!


    Kennt jemand das Problem und kann helfen?

  • Ich kann mich erinnern, dass ich mit einer DS413 und einer DM8000 auch ein Problem mit dem Standby der DS413 hatte.
    Es dauerte einfach zu lang, bis die vier Platten hochgefahren waren und die DM8000 "dachte", das NAS sei nicht vorhanden bzw. nicht bereit Daten zu empfangen.
    Meine Loesung wird Dir allerdings nicht gefallen. Die DS413 laeuft jetzt ohne Standby durch. Der Aerger war mir das gesparte Geld fuer den Strom nicht Wert.


    Eine Bastelloesung hatte ich kurzfristig auch mal versucht. Da die meisten Aufnahmen aus dem Deep-Standby der DM8000 gemacht werden, hatte ich ein Skript in den Startup der DM eingefuegt (direkt vor den Start von Enigma), der einen Zugriff auf die DS413 versuchte, bis diese antwortete. Damit war die DS413 immer schon am Laufen, wenn 5 Minuten spaeter die Aufnahme starten sollte. Der Standby der DS413 war auf 30 Minuten eingestellt.
    Hat aber auch nicht zuverlaessig getan, denn die DS413 ist trotzdem ab und an im Standby bei einer Aufnahme gewesen, wenn die DM8000 zum Streamen genutzt wurde und dadurch nicht im Deep-Standby war.
    Wenn Synology eine Box im Angebot haette, die eine SSD als "Eingangsspeicher" (aka. Cache) nutzt und dann intern bei Bedarf die Daten transparent fuer den Benutzer auf eine Platte verschiebt, waere das eine Loesung, die den Standby der Platten komplett aus der Gleichung nehmen wuerde. SSDs haben ja keine merkbare Verzoegerung beim Aufwachen.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • kenatonline
    vielen Dank für Deine Antwort. Das Interessante ist ja, dass das vorher mit der DM8000 kein Problem war und auch jetzt noch mit Aufnahmen der Dm500HD kein Problem ist. Da funtktionieren die Aufnahmen noch, wenn die die DS413 im Standby ist.
    Nur mit der DM920 hab ich dieses Problem.
    Bin aber zuwenig Profi, um herauszufinden, ob das mit DreamOS zu tun hat oder mit etwas anderem.

  • Die DM9x0 ist halt ein tick schneller beim booten :tongue:


    Geht es wenn die Box aus dem Standby hochfährt?


    E2 Box: ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM920 ~ DM900 ~ DM820 ~ DM800SEv2 ~ DM800se ~ DM800 ~ DM52x ~ DM500HDv2 ~ DM500HD ~ DM7025+ ~ DM7025
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7490 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Werde das gleich testen, sobald NAS wieder im Standby ist.


    Vorher ein Test: Timeraufnahme wenn DM920 schon an ist (normalerweise hab ich sie im idle mode). Aufnahme auf NAS (im Standby) geht.

  • OK,
    Timer programmiert auf 18:45. Dann Box in den Stanby geschickt. NAS ist auch im Standby.
    18:41 Dm920 booted und weckt dabei NAS auf und geht in den idle:)
    18:45 Blaue LED beginnt zu blinken:)
    Box mit PowerTaste eingeschalted und mit PVR ins EMC gewechselt > Aufnahme ist da :hurra:


    Somit muss ich feststellen, dass falls die Dm920 im idle ist bei anstehender Aufnahme kein Befehl geschickt wird, dass das NAS aufwachen soll.


    Irgendwie muss das aber bei OE2.0 noch funktioniert haben, denn bei der DM500HD geht das.


    Hoffe, ich habe mich verständlich ausgedrückt.

  • Hallo,
    habe heute festgestellt, dass bei einer Timeraufnahme folgende Fehlermeldung angezeigt wurde:
    Schreibfehler bei der Aufnahme. Festplatte voll?


    Kann es sein dass das NAS nicht schnell genug reagiert? Beim NAS gehen die Festpatten in Standby...
    Gibt es eine Einstellung für ein Timeout?


    Vielen
    Dank