Anleitung NAS einbinden

  • nee das kommt nur beim ersten mal wenn ich auf das NAS zugreife

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03


  • hab gerade mal versucht aus den FileBrowser heraus ein Verzeichnis zu erstellen .Ergebnis -->Greenscreen. Aber wenn die DM wieder an ist ist das Verzeichnis da.

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

  • Quote

    Original von RikerW.T.


    hab gerade mal versucht aus den FileBrowser heraus ein Verzeichnis zu erstellen .Ergebnis -->Greenscreen. Aber wenn die DM wieder an ist ist das Verzeichnis da.


    sorry Falsch ist doch kein Verzeichnis da

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

  • Um einen NFS Share zu verbinden, braucht es kein User & Passwort.
    K.a. was das bei dir soll, oder was du gemacht hast. Der NFS Share ist ja explizit für eine bestimmte IP freigegeben, da gibt es kein User dazu.
    Naja wenn der FileBrowser abkackt ist natürlich doof, deshalb mache ich solche Versuche immer direkt in der Konsole der Dreambox.
    Da sieht man dann auch was das Problem ist wenn es nicht geht.
    Ich würde aber nochmal den Mount unter die Lupe nehmen. Ich wüsste sonst gerade nicht wieso das nicht sauber geht.
    Dein Mount auf die int. Platten des NAS funktioniert aber problemlos oder ?

  • Das mit dem User & Passwort ist ja nur beim ersten mal wenn ich über den Netzwerkbrowser auf das NAS zugreife. Ich denke das hat einfach nur was mit der Benutzerverwaltung zu tun.Wenn ich unter Benutzerverwaltung die Benutzer lösche und dann wieder auf das NAS zugreife werde ich nach User & Passwort gefragt wenn ich das nicht mache ist das scheinbar auch egal ich hab das gerade mal probiert.Ich dachte immer das sich die Dreambox gegenüber dem NAS als User authentifizieren muss.
    Wenn ich einen NFS Mount mache benötige ich kein User & Passwort.
    Nein ,die Internen Platten funktionieren ebenfalls nicht.


    Swiss-MAD könntest du mir dabei behilflich sein .Das über Telnet an der Dream zu prüfen?Ich brauche nur die Telnet Befehle.

    Files

    • 5.png

      (88.01 kB, downloaded 304 times, last: )

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

    Edited once, last by RikerW.T. ().

  • @ RikerW.T


    um welche Dreambox (en) geht es denn bei dir überhaupt und welches Image hast du installiert? Im Profil steht Dm8000, unten aber DM7080 und DM900.


    Sollte es sich um die "alte" DM8000 handeln, dann kommst du besser wenn du mit der auto.network mountest.


    Wenn es aber um die "neueren" DM7080 und DM900 handelt und du bei beiden ein OE 2.5 Image hast, so würde ich über die fstab mounten. Den Netzwerkbrowser mal außen vor lassen.


    Um Änderungen an der fstab (in .etc) vorzunehmen bzw. die Einträge aus .etc > enigma2 > automounts.xml zu bearbeiten, musst du aber vorher enigma2 stoppen


    im Telnet dazu systemctl stop enigma2 eingeben. Nun kannst du die Einträge bearbeiten. In der automount.xml Datei sollte der Eintrag etwa so aussehen


    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.0.124</ip>
    <sharename>DS414usb4</sharename>
    <sharedir>/volumeUSB1/usbshare</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>


    und in der fstab in etc dann etwa so


    192.168.0.124:/volumeUSB1/usbshare /media/DS414usb4 nfs udp,x-systemd.automount,retrans=1,noauto,wsize=8192,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=2,rsize=8192,soft,nofail 0 0


    Wenn du diese an deine Gegebenheiten angepasst hast, startest du in Telnet wieder enigma2 mit systemctl start enigma2


    PS: natürlich musst du diese Angaben (IP und Freigabenamen) an deine noch anpassen.

    Edited once, last by magnum1795 ().

  • Ich trage bei mir die Mounts meines Synology DS415+ einfach in die /etc/auto.gemini ein und gut is. Sowohl auf DM525, als auch auf DM900. Auf älteren Geräten einfach in die /etc/auto.network.


    Mountmethode seit vielen Jahren die Gleiche (ich nutze CIFS):


    <Name des Mounts> -fstype=cifs,rw,soft,user=<Benutzername>,pass=<Passwort> ://<Synology IP>/<Pfad zum freigegebenen Verzeichnis>


    läuft 1A auch mit zig Unterverzeichnissen im Einsprungspunkt.


    Ansonsten steht alles im Wiki: http://wiki.blue-panel.com/index.php/Auto_Mounter

  • DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

    Edited once, last by RikerW.T. ().

  • Na dann frisch ans Werk.
    ich poste erstmal die Dateien von DM 900UHD bevor ich da was ändere.

    Files

    • 6.jpg

      (82.61 kB, downloaded 249 times, last: )
    • 7.jpg

      (150.14 kB, downloaded 233 times, last: )

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

    Edited once, last by RikerW.T. ().

  • @ RikerW.T


    auf deinen ersten Bild in der automount.xml würde ich den zweiten Eintrag komplett rausnehmen. Steht zwar auf "False", dennoch kann dieser raus. Auf deinen NAS (laut Bild) hast du volumeUSB1/usbshare drinnen stehen. Also gehört auch nur dieser Eintrag in die automount.xml. (du hast ja in der automount.xml zwei verschiedene Label vergeben, einmal usbshare und einmal USBNAS).Für einen von beiden solltest du dich entscheiden. Würde bei USBNAS bleiben und den kompletten unteren Eintrag raus nehmen. Ab <nsf> bis </nsf<


    Dein Eintrag in der fstab sieht dagegen gut aus und sollte so auch funktionieren. Bitte also die automount bearbeiten (vorher aber eben enigma2 stoppen wie oben schon angegeben. Dann eventuell die ganze Box neu starten. Dies kannst du auch über Telnet machen. einfach reboot eingeben und Enter drücken.

    Edited 3 times, last by magnum1795 ().

  • Okay hab ich jetzt so gemacht wie du das beschrieben hast.
    Leider kein Erfolg.

    Files

    • 8.jpg

      (53.35 kB, downloaded 208 times, last: )

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

  • enigma2 vorher tatsächlich beendet? Box komplett neugestartet?


    Was ist denn wenn du mit einen Dateibrowser (Dreamexplorer oder Geminidateibrowser etc.) nach media und hier dann USBNAS anklickst? Kommst du denn dann auf dein NAS? wenn nicht dann stimmen irgendwelche Freigaben auf deinen Synology NAS noch nicht oder du solltest dein NAS mal neu starten.

  • ich werde mal die Diskstation Neustarten .Alles andere habe ich gemacht -->Enigma Stopp usw.

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

  • Nur so nebenbei: Ich hatte die letzten Tage massiv Probleme mit meiner DM7080 auf meine beiden Synologies zu mounten. Das ging am Ende erst, als ich vers=3 in den Mount- Optionen eingestellt habe.


    An der Synology ist zwar NFSv4 aktiviert, aber die Dreamboxen (mit aktuellstem OE 2.5) mounten trotzdem nur mit Version 3, die dm900 hat das automatisch "runterverhandelt", bei der DM7080 musste ich es explizit hinzufügen.


    Ich habe das direkt in der xml gemacht und dann die Box neugestartet.


    So sehen die Einträge in meiner automounts.xml jetzt aus:

    Code
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.192.213</ip>
    <sharename>nasmovie</sharename>
    <sharedir>/volume2/movie</sharedir>
    <options>rw,nolock,udp,vers=3</options>
    </mount>
    </nfs>
  • Der Neustart meines NAS hat auch nix gebracht.


    Merkwürdig!Nachdem ich die Dream neugestartet habe ist auf einmal mein Netzwerkbrowser verschwunden.

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

  • ich glaube ich werd mal GP3 flashen

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

  • Ich glaube nicht, daß du damit auf Anhieb Erfolg haben wirst. Bei dir ist ein grundsätzliches
    Problem

  • Quote

    Original von netman
    Ich glaube nicht, daß du damit auf Anhieb Erfolg haben wirst. Bei dir ist ein grundsätzliches
    Problem


    Da hast du wohl recht ich habe gerade GP3 geflasht und komme überhaupt nicht klar.
    Unter Erweiterungsverwaltung werden mir lediglich zwei Sachen angezeigt in denen jeweils nur der StalkerClient enthalten ist.
    Hat sich erledigt habe die Addons gefunden

    Files

    • 9.jpg

      (60.92 kB, downloaded 128 times, last: )

    DM 7080
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03
    DM 900
    OS Version:4.3.1r28-115-g20699-2018-10-02
    Image:Newnigma2-daily 2018-11-03

    Edited once, last by RikerW.T. ().

  • Bei Gemini gibt es dafür das BluePanel. Unter Addons wirst du fündig. Und lies ruhig mal,
    was andere User dir schon zum GP3 empfohlen haben zu lesen.