Kodi-17 - mipsel/armhf - ab OE2.5

  • Kodi-17.6-RC1 - mipsel/armhf - ab OE2.5 - DM820, DM7080 (mipsel), DM900, DM920 (armhf)


    kodi für aktuellen Softwarestand unstable geeignet.


    Tastatur/Maus ist gut (empfehlens Wert), es geht aber auch ohne. Default keyboard controls


    Jetzt mit TV über enigma2, und Wiedergabe über gstreamer mit Steuerfunktionen.


    Im GP3 ist fast 'alles' auf den feeds und kann mit apt installiert werden!


    Downloads für kodi gibt es hier


    Banned_add-ons#Repository_blacklist
    Bitte beachtet auch das es vieles für kodi gibt das nicht Offiziell/legal ist!
    Eine Liste gibt es HIER
    Was gelistet ist wird auch hier nicht weiter besprochen.
    Leider ist mir das in der Vergangenheit nicht so bewusst gewesen,!
    Deshalb findet man leider ein paar Sachen davon in den Threads.


    Pakete für die jeweilige Box downloaden (kodi, libkodiplatform), nach /tmp auf die Box per FTP kopieren.
    Per Remote CLI verbinden (telnet oder ssh)


    Alles von emanuel:
    mit HW Videoplayer (gstreamer), playercorefactory.xml und keymap) - kodi mipsel/armhf
    tvheadend-4.0.9 - mipsel/armhf


    pclin
    Nightly Builds


    tvheadend:
    1.) Seite 4/5
    2.) Fertige Konfiguration und Kanal Liste für Astra19.2 - DM820


    tvheadend wiki


    ------
    Link zu fertigen Images mit kodi vorinstalliert, Support zu den Images nur am jeweiligen Board
    mit GP3
    und
    Dream-Elite
    Bitte melden wenn ihr andere fertige Images mit kodi kennt, die Links kommen dann auch hier rein.
    Kodi Support gibt es aber auch hier...


    ------
    Forum:
    IHAD also hier ;)
    Dreamboard Forum
    Dream-Elite
    kodi
    tvheadend


    ------

    Code
    apt install gstreamer1.0-plugins-base-apps

    bringt gst-play-1.0 auf die Box, ich installiere alle gstreamer-plugins mit

    Code
    apt install gstreamer1.0-plugins-good-meta gstreamer1.0-plugins-base-meta gstreamer1.0-plugins-bad-meta gstreamer1.0-plugins-ugly-meta


    ------
    Zum Starten von kodi benötigt man enigma2-plugin-extensions-kodimediacenter
    Alternative:
    Startet man kodi über plugin systemboot wird automatisch e2 beendet, tvheadend und kodi geladen. Bei 'Verlassen' von kodi oder crash wird tvheadend und kodi beendet und enigma2 wieder gestartet.
    kodi-startup wird nur für den Xserver benötigt!


    ------
    Bugs:
    Es funktionieren keine Bibliotheken!
    'In Bibliothek aufnehmen' nicht verwenden. Es geht nur über die Ordner Struktur.
    Macht man das doch stürzt kodi ab und lässt sich nicht mehr starten.
    Man muss dann die entsprechende .db (MyMusic.../MyVideo...) in /data/.kodi/userdata/Database löschen.


    ------
    Mein Dank geht an: :thx:
    Alle beteiligten, im speziellen an:
    DP, emanuel, IHAD, makaveli, satinfo (Dream-Elite), babsy98 (openATV), gutemine, alle Kodi Programmierer und alle Open Source Programmierer. :danke:


    ------
    LICENSE:
    kodi - GNU GPL
    tvheadend - GPLv3+


    gruß pclin

  • Ich habe es instaliert aber es ist nirgens zufinden???? :evil:


    mfg

    Files

    • log putty.txt

      (15.55 kB, downloaded 21 times, last: )
    • log putty.txt

      (15.55 kB, downloaded 95 times, last: )

    :hurra: :hurra: :hurra: :hurra: :hurra:

    Edited once, last by tysontaps ().

  • Es ist kein Plugin, das musst du erstmal von Hand starten.


    systemctl stop enigma2
    kodi -fs


    Wie gesagt noch alles BETA.


    Kodi-17.1
    noch ungetestet und BETA


    gruß pclin

  • Hey


    die neue version lässt sich schon mal ohne probs instalieren ,kommt das noch das man es auch aus den erweiterungen starten kann???.ich finde das super das es kodi nun doch endlich für die dreambox gibt .


    mfg tyson

  • Erstmal geht es darum ob es überhaupt funktioniert.
    Wir sind ja noch am Anfang...


    Dann muss nur ein enigma2-plugin-extensions-kodi erstellt werden, das sollte dann auch gehen.


    gruß pclin

  • hey


    Ja ich weiss aber nach dem befehlen systemctl stop enigma2
    kodi -fs passiert nix, er sagt nicht gefunden ;(


    mfg

  • Bei mir im alten Image vor 20170324 gibt es einen Crash beim starten.
    Da kann es aber auch noch nicht funktionieren.
    Ich muss erstmal meine ganzen Images updaten, das dauert noch ein wenig...


    Kodi-17.1 habe ich noch gar nicht getestet.


    Was bekommst du bei

    Code
    kodi --help


    Hier im dreambox forum wird auch einiges Berichtet.



    gruß pclin

    Edited 2 times, last by pclin ().

  • das hier


    root@dm7080:~# systemctl stop enigma2
    root@dm7080:~# kodi -fs
    -bash: kodi: command not found
    root@dm7080:~# kodi --help
    -bash: kodi: command not found
    root@dm7080:~#



    mfg

  • sieht nicht so aus als wäre kodi installiert.

    Gruß MaXAt0M


    1 x DreamBox 900UHD
    1 x DreamBox 7080HDSS
    3 x DreamB0X 520

  • Bei mir findet er kodi (auch bei kodi-17.1)


    Also mal deinstallieren und dann nochmal versuchen. Und auf die Ausgaben achten, bei dir fehlt was!


    apt remove kodi



    gruß pclin

    Edited 2 times, last by pclin ().

  • noch nicht mal das geht


    opendreambox 2.5.0 dm7080



    dm7080 login: root
    Password:
    root@dm7080:~# apt remove kodi
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package kodi



    mfg

  • Dann das Paket nach /tmp kopieren


    dpkg -i /tmp/*.deb


    Ausgabe hier posten.


    gruß pclin

  • hier bitte


    root@dm7080:~# dpkg -i /tmp/*.deb
    Selecting previously unselected package kodi.
    (Reading database ... 15676 files and directories currently installed.)
    Preparing to unpack .../kodi_17.1_gitr0_fc1619b118-r0.0_mipsel.deb ...
    Unpacking kodi (17.1+gitr0+fc1619b118-r0.0) ...
    dpkg: dependency problems prevent configuration of kodi:
    kodi depends on libyajl2 (>= 2.1.0); however:
    Package libyajl2 is not installed.
    kodi depends on libssh (>= 0.7.3); however:
    Package libssh is not installed.
    kodi depends on libtinyxml2.6.2 (>= 2.6.2); however:
    Package libtinyxml2.6.2 is not installed.
    kodi depends on libmicrohttpd10 (>= 0.9.34); however:
    Package libmicrohttpd10 is not installed.


    dpkg: error processing package kodi (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    kodi
    root@dm7080:~#



    mfg

  • so wie es aussieht gibt es die Pakete nicht auf dem dmm feed die benötigt werden.

    Gruß MaXAt0M


    1 x DreamBox 900UHD
    1 x DreamBox 7080HDSS
    3 x DreamB0X 520

  • Work internal player kodi or this from e2 ?
    Is posible run he on other resolution no only in HD ready ?

  • hier bitte

    Code
    opendreambox 2.5.0 dm7080 dm7080 login: root Password: root@dm7080:~# apt-get update Ign http://dreamboxupdate.com ./ InRelease Ign http://dreamboxupdate.com ./ InRelease Ign http://dreamboxupdate.com ./ InRelease Hit http://dreamboxupdate.com ./ Release.gpg Hit http://dreamboxupdate.com ./ Release.gpg Hit http://dreamboxupdate.com ./ Release.gpg Hit http://dreamboxupdate.com ./ Release Hit http://dreamboxupdate.com ./ Release Hit http://dreamboxupdate.com ./ Release Hit http://dreamboxupdate.com ./ Packages Hit http://dreamboxupdate.com ./ Packages Hit http://dreamboxupdate.com ./ Packages Ign http://dreamboxupdate.com ./ Translation-en Ign http://dreamboxupdate.com ./ Translation-en Ign http://dreamboxupdate.com ./ Translation-en Reading package lists... Done root@dm7080:~# apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. root@dm7080:~# dpkg -i /tmp/*.deb Selecting previously unselected package kodi. (Reading database ... 15657 files and directories currently installed.) Preparing to unpack .../kodi_17.1_gitr0_fc1619b118-r0.0_mipsel.deb ... Unpacking kodi (17.1+gitr0+fc1619b118-r0.0) ... dpkg: dependency problems prevent configuration of kodi: kodi depends on libpcrecpp0 (>= 8.38); however: Package libpcrecpp0 is not installed. kodi depends on libtag1 (>= 1.9.1); however: Package libtag1 is not installed. kodi depends on libyajl2 (>= 2.1.0); however: Package libyajl2 is not installed. kodi depends on libssh (>= 0.7.3); however: Package libssh is not installed. kodi depends on libgpg-error0 (>= 1.21); however: Package libgpg-error0 is not installed. kodi depends on libswscale4 (>= 3.0); however: Package libswscale4 is not installed. kodi depends on libpostproc54 (>= 3.0); however: Package libpostproc54 is not installed. kodi depends on libtinyxml2.6.2 (>= 2.6.2); however: Package libtinyxml2.6.2 is not installed. kodi depends on libsmbclient0 (>= 4.4.5); however: Package libsmbclient0 is not installed. kodi depends on libavfilter6 (>= 3.0); however: Package libavfilter6 is not installed. kodi depends on libgcrypt (>= 1.6.5); however: Package libgcrypt is not install dpkg: error processing package kodi (--install): dependency problems - leaving unconfigured Errors were encountered while processing: kodi root@dm7080:~# apt-get update Ign http://dreamboxupdate.com ./ InRelease Ign http://dreamboxupdate.com ./ InRelease Ign http://dreamboxupdate.com ./ InRelease Hit http://dreamboxupdate.com ./ Release.gpg Hit http://dreamboxupdate.com ./ Release.gpg Hit http://dreamboxupdate.com ./ Release.gpg Hit http://dreamboxupdate.com ./ Release Hit http://dreamboxupdate.com ./ Release Hit http://dreamboxupdate.com ./ Release Hit http://dreamboxupdate.com ./ Packages Hit http://dreamboxupdate.com ./ Packages Hit http://dreamboxupdate.com ./ Packages Ign http://dreamboxupdate.com ./ Translation-en Ign http://dreamboxupdate.com ./ Translation-en Ign http://dreamboxupdate.com ./ Translation-en Reading package lists... Done root@dm7080:~# apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: libavfilter6 libgcrypt libgpg-error0 liblzo2-2 libpcrecpp0 libpostproc54 libsmbclient0 libswscale4 libtag1 Use 'apt-get autoremove' to remove them. The following extra packages will be installed: libavfilter6 libgcrypt libgpg-error0 liblzo2-2 libpcrecpp0 libpostproc54 libsmbclient0 libswscale4 libtag1 The following packages will be REMOVED: kodi The following NEW packages will be installed: libavfilter6 libgcrypt libgpg-error0 liblzo2-2 libpcrecpp0 libpostproc54 libsmbclient0 libswscale4 libtag1 0 upgraded, 9 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. Need to get 1206 kB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Get:1 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libswscale4 3.0-r0.4 [106 kB] Get:2 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libavfilter6 3.0-r0.4 [424 kB] Get:3 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libgpg-error0 1.21-r0.2 [27.3 kB] Get:4 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libgcrypt 1.6.5-r0.2 [333 kB] Get:5 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ liblzo2-2 2.09-r0.2 [33.6 kB] Get:6 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libpcrecpp0 8.38-r0.2 [12.3 kB] Get:7 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libpostproc54 3.0-r0.4 [20.1 kB] Get:8 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libsmbclient0 4.4.5-r0.8 [39.7 kB] Get:9 http://dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm7080/deb/mips32el/ ./ libtag1 1.9.1-r0.2 [210 kB] Fetched 1206 kB in 0s (1569 kB/s) (Reading database ... 18848 files and directories currently installed.) Removing kodi (17.1+gitr0+fc1619b118-r0.0) ... Selecting previously unselected package libswscale4. (Reading database ... 15657 files and directories currently installed.) Preparing to unpack .../libswscale4_3.0-r0.4_mipsel.deb ... Unpacking libswscale4 (3.0-r0.4) ... Selecting previously unselected package libavfilter6. Preparing to unpack .../libavfilter6_3.0-r0.4_mipsel.deb ... Unpacking libavfilter6 (3.0-r0.4) ... Selecting previously unselected package libgpg-error0. Preparing to unpack .../libgpg-error0_1.21-r0.2_mipsel.deb ... Unpacking libgpg-error0 (1.21-r0.2) ... Selecting previously unselected package libgcrypt. Preparing to unpack .../libgcrypt_1.6.5-r0.2_mipsel.deb ... Unpacking libgcrypt (1.6.5-r0.2) ... Selecting previously unselected package liblzo2-2. Preparing to unpack .../liblzo2-2_2.09-r0.2_mipsel.deb ... Unpacking liblzo2-2 (2.09-r0.2) ... Selecting previously unselected package libpcrecpp0. Preparing to unpack .../libpcrecpp0_8.38-r0.2_mipsel.deb ... Unpacking libpcrecpp0 (8.38-r0.2) ... Selecting previously unselected package libpostproc54. Preparing to unpack .../libpostproc54_3.0-r0.4_mipsel.deb ... Unpacking libpostproc54 (3.0-r0.4) ... Selecting previously unselected package libsmbclient0. Preparing to unpack .../libsmbclient0_4.4.5-r0.8_mipsel.deb ... Unpacking libsmbclient0 (4.4.5-r0.8) ... Selecting previously unselected package libtag1. Preparing to unpack .../libtag1_1.9.1-r0.2_mipsel.deb ... Unpacking libtag1 (1.9.1-r0.2) ... Setting up libswscale4 (3.0-r0.4) ... Setting up libavfilter6 (3.0-r0.4) ... Setting up libgpg-error0 (1.21-r0.2) ... Setting up libgcrypt (1.6.5-r0.2) ... Setting up liblzo2-2 (2.09-r0.2) ... Setting up libpcrecpp0 (8.38-r0.2) ... Setting up libpostproc54 (3.0-r0.4) ... Setting up libsmbclient0 (4.4.5-r0.8) ... Setting up libtag1 (1.9.1-r0.2) ... root@dm7080:~#


    mfg

    Files

    • log.txt

      (7.25 kB, downloaded 26 times, last: )

    :hurra: :hurra: :hurra: :hurra: :hurra:

    Edited once, last by tysontaps ().

  • nochmal alles zusammen ,mir scheint er installiert es aber dann bringt er mir immer wieder fehler .

    Files

    • log.txt

      (20.94 kB, downloaded 25 times, last: )

    :hurra: :hurra: :hurra: :hurra: :hurra:

  • Hier die fehlenden pakete.


    Alles nach /tmp kopieren, und dpkg -i /tmp/*.deb


    Ausgabe posten


    gruß pclin