[gelöst] NFS mit OE2.5 auf beiden Dreamboxen

  • Hallo Jungs,


    will heute meine Boxen nochmal komplett neu einrichten und hab eine Frage wegen dem NFS Server mit dem OE2.5 unstable.


    Muss ich "vers=3" in die auto.network Datei einfügen? Auf beiden Boxen läuft OE2.5 unstable mit GP3.3.


    So war es unter OE2.2 unstable:


    auto.network

    Code
    Dreambox1 -fstype=nfs,rw,soft,udp,nolock 192.168.1.90:/media/hdd


    enigma2.autofs

    Code
    /autofs /etc/auto.hotplug
    /media/net /etc/auto.network --ghost


    Kann ich es auch für OE2.5 so übernehmen oder muss ich nochwas beachten?

    DM900UHD ~ DreamOS Unstable ~ GP3.3

    Edited 2 times, last by stern-stern ().

  • Versuche es ohne vers=3 und ohne upd. Es kommt halt aufs NAS drauf an, ob es mit vers=4 läuft.

  • Weder im OE 2.2, noch im OE 2.5 ist es ratsam die auto.network zu nutzen. Da sollte man entweder eine eigene autofs Config nutzen (etwa die auto.gemini, die das GP3 erstellt) oder direkt auf den Netzwerkbrowser umsteigen. Da der Netzwerkbrowser ja jetzt systemd nutzt, was hier deutlich stabiler und zuverlässiger läuft, würde ich empfehlen einfach umzusteigen ;)


    Zu NFS-Versionen: Ich glaube im OE 2.5 ist auch ein Server mit NFSv4 drin. Getestet habe ich das aber noch nicht. Wenn irgendwo noch OE 2.0 oder OE 2.2 im Spiel ist, brauchst du aber auf jeden Fall das vers=3.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Wie sieht es aus wenn ich von der DM820 (OE2.5) auf die DM900 (OE2.5) zugreife? Brauche ich hier auch "vers=3" oder brauche ich es überhaupt nicht?


    Was ist der Unterschied zwischen auto.gemini und dem Netzwerkbrowser und warum läuft es über den Netzwerkbrowser stabiler?

    DM900UHD ~ DreamOS Unstable ~ GP3.3

  • Normal brauchst du den Parameter nicht, schaden tut er aber auch nicht.


    Der Networkbrowser von DMM geht über systemd, der Automounter läuft als "normaler"
    Prozess. Von stabiler zu reden ist übertrieben. Wenn man die richtigen Parameter benutzt
    funktionieren beide tadellos. Der Automounter vom Gemini arbeitet logischer und ist somit
    meine erste Wahl.

  • Danke Jungs, ich werde es mit auto.gemini versuchen ;)


    Gibt es irgendo eine kleine Anleitung wie es mit auto.gemini funktioniert oder kannst du mir kurz es eklären wie du das benutzt bzw. eingerichtet hast?

    DM900UHD ~ DreamOS Unstable ~ GP3.3

  • Installiere dir das plugin Gemini-Netscan. Das findest du im BluePanel. Von dort kannst du nach
    Freigaben im Netzwerk suchen und diese direkt an den Automounter weitergeben lassen. Das
    funktioniert sicher und gut.

  • Brauche ich jetzt auch noch den Gemininfs oder macht es der Netscan automatisch mit?

    DM900UHD ~ DreamOS Unstable ~ GP3.3

  • Quote

    Originally posted by stern-stern
    Danke Jungs, ich werde es mit auto.gemini versuchen ;)


    Gibt es irgendo eine kleine Anleitung wie es mit auto.gemini funktioniert oder kannst du mir kurz es eklären wie du das benutzt bzw. eingerichtet hast?


    Bitte kuck auch im wiki. Steht da beschrieben :)

  • Danke Jungs ;)


    Ich werde es heute ausprobieren.

    DM900UHD ~ DreamOS Unstable ~ GP3.3

  • Jungs warum finde ich die Datei auto.gemini unter etc/ nicht? Muss man sie manuell erstellen?

    DM900UHD ~ DreamOS Unstable ~ GP3.3

  • Heute habe ich mit meiner zweiten Box ein wenig getestet, dabei habe ich die auto.gemini Datei passend geändert aber leider will sich die Box nicht verbinden über PVR.


    Automaunt passt auch und der Test funktioniert auch, warum kann ich die Festplatte von der andere Box nicht sehen? Der NFS Server läuft.


    auto.gemini

    Code
    Dreambox1 -fstype=nfs,rw,soft,nolock,retry=0 192.168.1.90:/media/hdd/movie


    auto.master

    Code
    /media/network /etc/auto.gemini --ghost


    Wie gesagt die Box sehe ich über Network Mount nicht, wo ist da der Fehler?

    DM900UHD ~ DreamOS Unstable ~ GP3.3

    Edited 3 times, last by stern-stern ().

  • Ja der läuft. Hab beiden Boxen auch mehrmals neu gestartet leider ohne Erfolg.


    Hab es auch ohne movie probiert aber das will auch nicht.


    auto.gemini

    Code
    Dreambox1 -fstype=nfs,rw,soft,nolock,retry=0 192.168.1.90:/media/hdd/

    DM900UHD ~ DreamOS Unstable ~ GP3.3

    Edited once, last by stern-stern ().

  • Auf der Server Box steht Freigabe: /media/hdd/movie

    DM900UHD ~ DreamOS Unstable ~ GP3.3

  • Ich habe die Box jetzt neu geflasht und jetzt geht es :hurra:


    d.H irgendwo hat irgendetwas nicht gestimmt bzw. nicht gepasst, die auto.gemini Datei ist die gleiche, da habe ich nichts geändert.

    DM900UHD ~ DreamOS Unstable ~ GP3.3