Tools für OE2.5 - Console - mipsel/armhf

  • Mit bitbake im OE2.5 erstellt.


    Damit die Tools Richtig Funktionieren sollte


    Code
    export TERM=xterm


    Code
    export SHELL=/bin/bash


    gesetzt sein.


    Am besten in /etc/profile editieren.


    Und bash installiert sein.


    gruß pclin


    ps.
    Das gilt natürlich auch für mc


    es werden noch weitere Pakete installiert. Diese Pakete sind über http://dreamboxupdate.com/opendreambox/2.5/unstable zu laden.

    Edited 8 times, last by pclin ().

  • curl OE2.5
    Das 'normale' curl im OE2.5 wird mit diesen Optionen gebaut.


    Wenn ich bei mir im OE2.5 cross-compiliere kommt diese Version dabei raus.


    Es geht auch c-ares als 'resolver'


    Bei Bedarf kann ich das hier hochladen, hat aber dann einige Abhängigkeiten.


    gruß pclin

    Edited 4 times, last by pclin ().

  • Sollten euch pakete fehlen, hier posten.


    gruß pclin

    Edited 2 times, last by pclin ().

  • Hallo pclin,


    ich suche eine curl Version für meine Dreambox 8000 mit HTTPS und IPv6 support.
    Wichtig ist, dass curl nicht zu aktuell und mit folgenden Versionen zufrieden ist:

    libz1 - 1.2.6-r1-opt1 - Zlib Compression Library
    libgmp10 - 5.0.4-r0 - gmp version 5.0.4-r0
    libc6 - 2.13-r26+svnr15508 - Embedded GLIBC (GNU C Library)
    libcurl4 - 7.24.0-r0 - curl version 7.24.0-r0


    Hintergrund: ich habe mir ein kleines dyn DNS update Skript geschrieben und möchte die IPv4 und IPv6 Adressen per HTTPS aktualisieren.


    wget unterstützt ja bekanntlich kein SSL.
    Die curl Version, die ich zur Zeit habe, unterstützt zwar SSL, aber kein IPv6:
    > curl -V
    curl 7.24.0 (mipsel-oe-linux-gnu) libcurl/7.24.0 GnuTLS/2.12.17 zlib/1.2.6
    Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s rtsp smtp smtps telnet tftp
    Features: Largefile NTLM NTLM_WB SSL libz TLS-SRP


    Quelle:
    http://dreamboxupdate.com/open…rl_7.24.0-r0_mips32el.ipk


    Danke !

  • hoo-ray
    Tut mir leid da kann ich dir nicht helfen.


    Ich baue nur noch für OE2.2/OE2.5 .
    in meinen alten builds ist nichts passendes dabei.


    wget im OE2.5 (Orginal) kann auch SSL und IPv6



    gruß pclin

  • @pclin


    könntest du vielleicht falls es deine Zeit erlaubt von der neuen openvpn Version 2.4.0 eine Version für mipsel und armhf erstellen?


    Danke

    Gruß MaXAt0M


    1 x DreamBox 900UHD
    1 x DreamBox 7080HDSS
    3 x DreamB0X 520

  • openvpn Version 2.4.0 ist für mipsel/armhf durch!

    Code
    oe_runconf --enable-systemd --enable-iproute2 IPROUTE=/sbin/ip


    Wenn du nur die compilierte bin brauchst lade ich hoch.
    Pakete dauern etwas länger.


    EDIT
    Sehe gerade das noch mehr Abhängigkeiten drin sind. Ist aber alles verfügbar.

    Code
    root@dm820:/hdd/comp/OE2.5/openvpn-2.4.0/src/openvpn# ./openvpn --version
    OpenVPN 2.4.0 mipsel-oe-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Dec 29 2016
    library versions: OpenSSL 1.0.2h 3 May 2016, LZO 2.09
    Originally developed by James Yonan
    Copyright (C) 2002-2017 OpenVPN Technologies, Inc. <sales@openvpn.net>
    Compile time defines: enable_async_push=no enable_comp_stub=no enable_crypto=yes enable_crypto_ofb_cfb=yes enable_debug=yes enable_def_auth=yes enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_fast_install=yes enable_fragment=yes enable_iproute2=yes enable_libtool_lock=yes enable_lz4=yes enable_lzo=yes enable_management=yes enable_multi=yes enable_multihome=yes enable_pam_dlopen=no enable_pedantic=no enable_pf=yes enable_pkcs11=no enable_plugin_auth_pam=no enable_plugin_down_root=yes enable_plugins=yes enable_port_share=yes enable_selinux=no enable_server=yes enable_shared=yes enable_shared_with_static_runtimes=no enable_small=no enable_static=yes enable_strict=no enable_strict_options=no enable_systemd=yes enable_werror=no enable_win32_dll=yes enable_x509_alt_username=no with_crypto_library=openssl with_gnu_ld=yes with_mem_check=no with_pic=yes with_plugindir='$(libdir)/openvpn/plugins' with_sysroot=no


    gruß pclin

    Edited 3 times, last by pclin ().

  • openvpn-2.4.0
    Erstmal die mipsel Version. Bitte testen!
    Die mipsel Version ist auf der DM820 compilert, die armhf Version im sysroot OE2.5 cross-compiiert.


    lz4

    Code
    Extremely Fast Compression algorithm
    LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems.


    gruß pclin

    Edited 6 times, last by pclin ().

  • Die armhf Version.


    Bitte testen!


    gruß pclin

    Edited 2 times, last by pclin ().

  • Zuweisen mehrere virtuelle Ethernet-Schnittstellen mit tunctl



    https://linux.die.net/man/8/tunctl
    http://www.packetcoreit.com/tag/ubuntu-tunctl/?lang=de


    gruß pclin

    Edited once, last by pclin ().

  • bridge-utils
    Eine praktische Anwendung für eine Bridge ist der Zusammenschluss verschiedener Netze, die unterschiedliche Transportmedien nutzen, z.B. LAN und WLAN.


    gruß pclin

    Edited once, last by pclin ().

  • Zu fast jedem paket gehört ja auch eine Dokumentation.


    z.b. bash-doc


    um diese lesen zu können benötigt man entweder man oder info.



    nach Installation

    Code
    [23:50 root@dm820 ~] > info bash


    Im 1 Screenshot ist jeder Eintrag der mit * beginnt ein Untermenu.
    2 Screenshot ein teil eines Untermenus.


    gruß pclin

  • openvpn-2.4.1

    Code
    [22:10 root@dm820 openvpn-2.4.1] > openvpn --help
    OpenVPN 2.4.1 mipsel-oe-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Mar 25 2017


    Compiliert auf der DM820.

    Code
    ====================
    All 2 tests passed
    (1 test was not run)
    ====================


    Was benötigst du?
    Paket kann etwas dauern.


    gruß pclin

    Edited 2 times, last by pclin ().