[gelöst] Festplatte "gelöscht"

  • Hallo Zusammen,


    folgendes ist passiert: Die Box hat eine Fehlermeldung gebracht, dass kein Platz mehr zum Schreiben auf der Festplatte ist. Meldung quittiert und nach ner Weile mal gecheckt was da los ist.
    Nach ich also auf PVR gedrückt und gecheckt warum da kein Platz mehr frei sein sollte (es hätten noch einige GB übrig sein müssen, also so Richtung 40 GB) Auf der Platte waren exakt 0 MB frei und er zeigt mir nur eine Filmaufnahme an. Also meine kompletten Aufnahmen der 1,8 TB Platte sind wohl irgendwo im NIrvana verschwunden. Ich wollte die Box dann Neustarten und es geht nichts mehr. Er produziert Greenscreen nach Greenscrenn mit dem Hinweis auf die Enigma Komponenten. Wobei der erste Greenscreen sich auf das VPS Plugin bezog. Nach dem dritten rundgang hab ich die Box vom Srom genommen und dann wieder eingeschalten. Danach hat jetzt enigma ein Problem. WArum auch immer.


    Ist es Euch schonmal passiert dass einfach die Platte gelöscht wurde? Es sieht irgendwie aus als hätte Sie die Partitionstabelle verloren. Ich werde Sie mal noch ausbauen und am PC überprüfen ob noch irgendwas zu retten ist, ich vermute aber mal, dass tatsächlcih die Partitionstabelle überschreiben wurde.. Also das ist der echte Super Gau...

  • Glaub nicht das die Platte gelöscht wurde, vermutlich ist das Dateisystem der Platte defekt oder die Platte wird nicht mehr erkannt (Kabel checken). Jedenfalls sieht das für für mich so aus, dass die Platte nicht mehr korrekt korrekt gemountet wurde und die letze Aufnahme in den Flash ging und der Flash nun proppenvoll ist und deswegen Enigma2 crasht.


    verbinde dich mal per telnet und poste die Ausgabe von
    df -h

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Mal ein kurzes Update.


    Also die Partition ist noch vorhanden, allerdings ist es nicht möglich die Platte einzuhängen. Dies habe ich bisher aber ausschliesslich auf diversen Live Linux varianten (gebootet per CD/DVD Laufwerk oder USB STick) versucht. Interessanterweise können viele erst gar nicht gestartet werden. z.b. eine 1-2 Jahre alte Ubuntu variante, Ct Desinfect, Slax. Diese alle booten nichtmal, solange die Festplatte angeschlossen ist. Ich hab sie dann mal über einen USB Adapter drangehängt (nach die Live Varianten gestartet waren). Festplatte wurde erkannt, aber konnte nicht eingehängt werden. Er scheint sich beim einhängen aufzuhängen.


    Erst ein Knoppix von 2013 hat dann auch mit dem booten funktioniert. Auf dem werde ich jetz tmal ein xfs_check ausführen, vielleicht fördert der was zu Tage. GParted hat nichts ausgeweöhnliches gefunden. Auch mit testdisk bin ich nicht weitergekommen (aber da fehlt auch noch ein wenig das Verständnis).
    Naja vielleicht sollte ich Die Platte einfach wieder in das neu aufgesetzt Dreambox einbauen und dort einhängen. Vielleicht kommt die Dreambox ja damit klar... Alles sehr sehr sehr strange...

  • Sieht so aus als hätte die platte ein problem. Klickt sie verdächtig nach dem sie strom bekommt?
    Hast du auch mal eine aktuelle distribution (z.B. ein xubuntu 16.04) versucht zu starten?
    Wenn dann mal eine distribution startet, setz den befehl "dmesg" in der konsole ab, dann siehst du die fehlermeldungen.
    Falls die platte überhaupt noch erkannt wird würde ich mal die smart-werte (mit smartmontools) auslesen und studieren.

  • dmesg Output:
    xfs failed to recover efi


    und die andere Meldung weis ich nich tmehr. Auf jedenfall hatte das was mit dem Mounten zu tun. Wenn ich die Platte manuell mounten möchte, dann hängt sich das Konsolenfenster auf. Sprich es passiert gar nichts mehr.


    Gibt es irgendwo eine detailliertere Beschreibung von testdisk? Der findet zwar alle Partition aber vielleicht lohnt es sich dort mal den bootsector neu zu schreiben.



    Ist es müglich mit ddrescue die Partition zu kopieren, auch wenn die platte nicht eingehängt ist?
    Ich würde anschliessend mal einen XFS repair -l durchlaufen lassen (falls dieser überhaupts funktinoiert)


    PS: habe den Mount auch mal mit no recovery und read only versucht, aber auch dann hängt er sich auf.
    PPS: mit einer Knoppix live cd vom 25.11 konnte ich auch mit GParted nichts anfangen, mit der Version von 2013 kam Gparted noch klar. Dieses hängt sich beim versuche die Platte einzulesen bei der neuesten Version nämlich einfach auf.

  • Hast du meinen kommentar oben gelesen?
    Scheint irgendwie nicht so.... :face_with_rolling_eyes:
    Wenn die platte hinüber ist kannst du da noch lange fummeln, einfach so ist das dateisystem meist nicht defekt.

  • Die Platte ist mechanisch vollkommen in Ordnung. Ich hätte schon geschrieben wenn da ein irgendwas komisches klackern oder sonst was tun würde.


    Mit dem Befehl dmesg bin ich doch vorwärts gekommen, daher verstehe ich nicht warum ich deinen Beitrag nicht gelesen haben sollte.


    Ich hab mit ddrescue jetzt mal eine sicherungskopie der Platte erstellt.


    Der Befehl smart irgendwas geht nicht. Er hat das gleiche Symptom wie xfs_repair oder xfs_check. Die hängen sich praktsich auf und das Terminal kann man nur noch abschiessen.


    Den meisten Leuten hat geholfen xfs_repair -l zu machen. Das überleg ich mir mal. Andernfalls könnte man mit testdisk ggf. noch was retten, aber mit dem Programm kenn ich mich zu wenig aus. Zumindest findet er die Partition, aber auch keine wirklichen Fehler.


    Was genau passiert ist weis ich immer noch nicht, aber aus irgendwelchen Gründen ggf. Stromausfall hat sich wohl was zerschossen. GGf. war auch das VPS Plugin schuld.

  • Nach einer oberflächenanalyse mit smartmontools wirst du feststellen das die platte sehr wohl einen mechanischen defekt hat, und zwar jede menge defekte blöcke. Mit etwas glück kann man noch einige daten retten.
    Smart auslesen: smartctl -a /dev/sdX
    Smart Test starten: smartctl -t long /dev/sdX
    Sobald sie in den bereich mit den defekten blöcken fährt wird sie vermutlich anfangen zu klicken. Neue platten klicken aber meist so leise das man es praktisch nicht mehr hört.

  • Wie hätte dann die Kopie funktionieren sollen? Diese musste ja auch über die "kaputten Blöcke" und hätte da nicths mehr gemacht (zumindest war das früher so bei einem Hardware defekt). Das war aber nicht der Fall. Daher bin ich noch guter Hoffnung dass von der platte auch noch was zu retten ist.


    Ich kann es auch gerne für dich nochmals wiederholen, der befehl lässt sich nicht ausführen ohne dass sich das terminal aufhängt. Das kann jetzt verschiedenste Gründe haben...

  • Sorry, aber du hast keine ahnung. Wir haben nicht mehr das jahr 1988 und die festplatten heissen auch nicht mehr "winchester" :winking_face:
    Viel spass.

  • Also lieber Märchenerzähler TheRaven,


    ein Grossteil der Daten ist gerettet (was relativ wenig mit Glueck zu tun hatte), der Rest ist in zwei Stunden durch. Die von mir getesteten Files funktionieren auch ohne Probleme, das war aber logischerweise nur ein Bruchteil. Mal schauen wie kritisch die letzten Files noch werden.


    Ich gehe weiterhin davon aus, dass die Platte in Ordnung ist und nach einer Formatierung wieder funktioniert. Mal schauen was ein Smart Test hier noch zu Tage fördert... vielleicht doch schlimmeres... Ich glaube aber nicht daran...


    Grüße

  • Märchenerzähler? Soso...
    Weisst du überhaupt was SMART ist? Hattest du schon mal damit zu tun? Du gehst davon aus das die platte "in ordnung" ist. Anhand von was gehst du davon aus? Einfach mal drauf los geraten? Oder hast du eine glaskugel? :tongue:
    Denke eher du bist hier der märchenerzähler. :winking_face:
    Poste mal einen SMART-Statusbericht.

    • Official Post

    easy easy ---


    :winking_face:

    | 2 x 920 ULTRA HD | 2 x TWO | 7080 HD| 8000 HD | 7020 HD V2 | 800 HD SE V2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB :tired_face: 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy :winking_face:


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

    • Official Post

    scheint ja alles gelöscht äähhh gelöst zu sein.


    ich mach das dann mal auf gelöst

  • Lieber Raven, deine Behauptungen, dass die Platte defekt ist basieren auf noch weniger Grundlagen als meine, aber deine sollen richtig sein und meine nicht?? Alles klar.
    Es sind einfach nur Behauptungen die bisher, weder von Dir noch von mir belegt werden können. Wir beide machen schlichtweg nur Annahmen. Im vergleich zu Dir beharre ich aber nicht, dass dies ein Fakt ist und sagt dem anderen, dass er einfach zu blöd ist... Sorry das ist einfach schlechter Stil.


    Thema: Märchenerzähler:
    Zitat:
    Nach einer Oberflächenanalyse mit smartmontools wirst du feststellen das die platte sehr wohl einen mechanischen defekt hat, und zwar jede menge defekte blöcke. Mit etwas glück kann man noch einige daten retten


    Realität: Alle Daten sind gerettet!



    Dazu kommt noch, dass ich Dir schon gesagt hatte, dass smartctl nicht ausführbar war, aber du hast weiterhin darauf beharrt dass ich es ausführen soll.


    Meine Prio war die Datenrettung, welche ich dann mit verschiedensten Tools auf dem erstellten Image versucht habe. Die Datenrettung ist schlussendlich dann geglückt, aber leider nicht ganz kostenlos, weil nur der UFS Explorer es ohne Probs konnte.
    Versucht hatte ich es mit Testdisk, gparted, xfs_ncheck (ging gar nicht), xfs_repair, xfs_repair -l und photorec. Letzters hat mir zwar Daten gerettet, aber für die TS Files nur müll generiert. Vermutlich kommt jetzt einer her und sagt, dass es noch ein anders Tool gekonnt hätte :) (ich glaub es waren noch andere Tools im Spiel, aber die habe ich jetzt nicht mehr im Kopf)


    Am Ende habe ich die Platte neu partitioniert und formatiert. Danach hat auch der smartctl befehl funktioniert. Inzwischen laufen auch wieder Aufnahmen, darauf.


    Anbei ein Screenshot vom Smartctl Resultat: Bild dir darauf deine eigene Meinung.


    Imho sieht das in Ordnung aus, trotzdem ist es komisch warum der Extended test erst beim zweiten mal geklappt hat. Den ersten hatte ich bewusst abgebrochen. GGf. ist doch irgendwas an der Platte faul. Du wirst mir das aber sicherlich direkt sagen können.

  • Danke Bunny,


    hab noch oben kurz beschrieben was ich am Ende gemacht habe. Falls nochmals jemand das gleiche Problem hat.


    Die Platte hab ich jetzt aber auf ext4 formatiert.

  • So, endlich haben wir fakten auf dem tisch! :winking_face:
    Warum basieren meine behauptungen auf "noch weniger grundlagen" als deine? Was das angeht sind wir mindestens gleich auf! :tongue:
    Der smart-status sieht gut aus. Sie ist etwas warm, aber sonst ok.
    Trotzdem bleibt die frage warum das dateisystem "einfach so" defekt ging. Bis jetzt hatte ich noch nie probleme damit (ausser die platte hatte einen schuss), habe aber auch ausschliesslich ext in verwendung und kein xfs.
    Was mich auch mal interessieren würde ist warum der smart-befehl nicht funktioniert hat. Dieser geht direkt auf die hardware und nicht auf das dateisystem.
    Hast du das mit einem ubuntu versucht? Falls ja ist klar warum es nicht geklappt hat, da ist smartmontools nicht von werk aus installiert. Man muss es zuerst installieren.

  • die Software war installiert/habe ich nachinstalliert.:face_with_rolling_eyes:


    bei xfs_repair hat er einfach gar nichts gemacht. Befehl ausgeführt und dann "hing" das Terminal, das gleiche müsste auch beim smart Befehl gewesen sein. Genau sagen kann ich das aber tatsaechlich nimmer...