[gelöst] Dateien in NAS-Verzeichnis werden nicht alle angezeigt

  • Hallo Leute,
    ich habe seit kurzem das Problem, dass nicht mehr alle Dateien und Unterordner in einem gemounteten NAS-Verzeichnissen angezeigt werden. Egal ob im Standard Media Player, in der AMS oder im Datei Browser. Gibt es eine Verzeichnisgröße oder Anzahl von Dateien wo es da zu Problemen kommen kann?
    Hab noch drei andere Verzeichnisse gemountet da gibt es keinerlei Probleme, ist aber auch nicht so viel Zeug drin. :)
    Problem besteht übrigens auf meiner 8000er sowie auf einer 500HD V2 mit "aktuellem" Merlin3 und GP3.2
    Aufgefallen ist mir das Ganze erst nach dem letzten Update, weiß nicht ob es da evtl. einen Zusammenhang gibt!?


    Vielleicht hat einer einen Rat?

    DM 8000HD PVR / ;(† DM 7025+SS † ;(
    DMMExp OE 2.0
    mit GP3.2
    Synology
    DS416play
    Teufel
    Concept S

    Edited once, last by hNt` ().

  • Überprüf mal, ob / wie die Dateien überhaupt vom Linux-System gesehen werden. Dafür kannst du mit ls -lah /pfad/des/mounts den betreffenden Verzeichnis-Inhalt sehen.


    Du könntest auch mal im NAS nachsehen, welche Berechtigungen die betroffenen Dateien haben.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Hi m0rphU,
    danke für die Antwort.


    Das Problem ist, wenn ich per telnet auf die Box gehe und den Befehl eingebe, gibt mir die Box auch nur die Dateien aus, die ich in der AMS oder dem Datei Browser sehen kann. In dem Fall sind es die Dateien von A bis S im gemounteten Ordner "Filme"


    -rw-r--r-- 1 root 42949672 178.8K Nov 11 2014 12 Years a Slave.backdrop.jpg
    -rw-r--r-- 1 root 42949672 2.0K Nov 11 2014 12 Years a Slave.eit
    -rw-r--r-- 1 root 42949672 173.9K Nov 11 2014 12 Years a Slave.jpg
    -rwx------ 1 42949672 42949672 3.8G May 13 2014 12 Years a Slave.mkv
    -rw-r--r-- 1 root 42949672 24 Jun 20 2014 12 Years a Slave.mkv.cuts
    -rw-r--r-- 1 root 42949672 74 Nov 11 2014 12 Years a Slave.mkv.ts.meta


    Die Rechte sehen bei allen Dateien über Telnet gleich aus, auch in dem gemounteten Ordner "Serien" mit dem ich keinerlei Probleme habe.


    Hier ein Beispiel aus dem Ordner wo meine Aufnahmen hin gehen.


    -rwxr-xr-x 1 root 42949672 623 Dec 14 22:29 20151214 2230 - Fox HD - Ray Donovan - S03E12 - Bilder im Kopf.eit
    -rw-r--r-- 1 root 42949672 3.4G Dec 14 23:30 20151214 2230 - Fox HD - Ray Donovan - S03E12 - Bilder im Kopf.ts
    -rw-r--r-- 1 root 42949672 48.9K Dec 14 23:30 20151214 2230 - Fox HD - Ray Donovan - S03E12 - Bilder im Kopf.ts.ap
    -rw-r--r-- 1 root 42949672 36 Jan 1 16:01 20151214 2230 - Fox HD - Ray Donovan - S03E12 - Bilder im Kopf.ts.cuts
    -rw-r--r-- 1 root 42949672 196 Jan 1 16:01 20151214 2230 - Fox HD - Ray Donovan - S03E12 - Bilder im Kopf.ts.meta
    -rw-r--r-- 1 root 42949672 2.7M Dec 14 23:30 20151214 2230 - Fox HD - Ray Donovan - S03E12 - Bilder im Kopf.ts.sc


    Gestern wurden mir bei einem Versuch kurz mal wieder alle Dateien im Ordner Filme angezeigt, nach Verzeichniswechsel oder nach dem Abspielen eines Films, sind die Dateien wieder Weg und es werden nur wieder die Dateien von A-S oder manchmal auch nur von A-O angezeigt.


    Auf dem NAS sieht auch alles gut aus, für den Ordner sowie die Dateien ist Vollzugriff über NFS-Sharing freigegeben.


    Kann es evtl. sein, dass es zu viele Objekte in dem einen Ordner sind? Hab mal geschaut, mit den ganzen Dateien die AMS anlegt für Filmbeschreibung, Cover und Backdrop, sind es 2296 Dateien bei ca. 2,5TB Gesamtgröße. Geht beim Aufrufen des Ordners evtl. der RAM in die Knie? Würde es da helfen, die Dateien nochmal in einen Unterordner zu packen?

    DM 8000HD PVR / ;(† DM 7025+SS † ;(
    DMMExp OE 2.0
    mit GP3.2
    Synology
    DS416play
    Teufel
    Concept S

  • Quote

    Original von hNt`
    Kann es evtl. sein, dass es zu viele Objekte in dem einen Ordner sind? Hab mal geschaut, mit den ganzen Dateien die AMS anlegt für Filmbeschreibung, Cover und Backdrop, sind es 2296 Dateien bei ca. 2,5TB Gesamtgröße. Geht beim Aufrufen des Ordners evtl. der RAM in die Knie? Würde es da helfen, die Dateien nochmal in einen Unterordner zu packen?


    Das kann kein gernerelles Problem im Zusammenhang des AMS auf der Dreambox und einem NAS sein.
    In meinem Ordner für Movies liegen derzeit über 7000 Dateien mit einer Gesamtgrösse von knapp 5 TB und die werden alle vom AMS gefunden.

  • OK, danke für die Info swell.
    Auch wenn es nicht ausschließlich um die Anzeige in der AMS sondern generell im System geht, also auch im Datei Browser.
    Aber nach deiner Info weiß ich schon mal, dass das Problem woanders zu suchen ist.


    Ich werde den Fehler mal eher beim NAS suchen. Ich vermute da was.

    DM 8000HD PVR / ;(† DM 7025+SS † ;(
    DMMExp OE 2.0
    mit GP3.2
    Synology
    DS416play
    Teufel
    Concept S

  • Ok, also ich hab den Übeltäter wohl gefunden.
    Hatte auf dem NAS noch den Universal Media Player laufen. Der hat wohl ein paar Mätzchen gemacht. Warum und was genau, keine Ahnung! Nach dem Deinstallieren von dem Ding werden mir jedenfalls wieder alle Dateien angezeigt.
    War nur eben komisch, weil das Problem erst seit dem letzten E2 Update auftrat. Aber meine geliebte Box war nicht schuld. :)

    DM 8000HD PVR / ;(† DM 7025+SS † ;(
    DMMExp OE 2.0
    mit GP3.2
    Synology
    DS416play
    Teufel
    Concept S