[gelöst] Nach update wird Nas mi NSF Server nicht mehr gemountet

  • Was meinst du mit Festplattentest?


    Kann mit noch zwei guten alten dboxen meiner Töchter auf die Nas-Festplatte zugreifen. Ebenso mit einem Win7 PC. Reicht das bzw.was meinst du mit der Zeile:


    showmount -e 192.168.178.25


  • Das sieht so aus, als haettest Du da eine Platte an USB angeschlossen. Zumindestens ist auf /media/usb etwas eingehaengt, was mit ext3 (das ist ein Linux Dateisystem) formatiert wurde.


    Ausserdem kann man sehen, dass es zwei mount-Punkte fuer den automounter gibt.
    Einmal unter /media/net und einmal unter /autofs.
    Das habe ich bei mir so noch nie beobachten koennen. Bei mir gibt es nur /autofs.
    Sind da zwei Instanzen des Automounters aktiv?
    Das kannst Du mit "ps -ef" kontrollieren. In der Ausgabe sollte es nur eine Zeile mit automounter geben.


    Btw. Hast Du ueberhaupt ein interne Platte in der Box? Wenn nicht, kann das Pruefen von /dev/sda nicht klappen, denn das prueft die erste Platte im System.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • Quote

    showmount -e 192.168.178.25


    Dies zeigt Dir die Freigaben des NFS-Servers, also ob der Server läuft und welche Verzeichnisse (exports) per NFS freigegeben wurden.


    Versuche mal manuell zu mounten. Dann kann man sehen, warum der Mount nicht funktioniert. Auf der Konsole folgendes eingeben:


    mkdir /media/filme
    mount -t nfs 192.168.178.25:/tmp/harddisk /media/filme


  • Ich habe einen USB-Stick mit diversen Dateien (Picons, backup, Telefonbook) an USB angeschlossen und in ext3 formatiert (hatte ich aber unter oe1.6 schon).


    Und NEIN, in der Box ist keine Platte.


  • dann kommt das:


    root@dm800:~# mkdir /media/filme
    root@dm800:~# mount -t nfs 192.168.178.25:/tmp/harddisk/media/filme
    mount: can't find 192.168.178.25:/tmp/harddisk/media/filme in /etc/fstab


    und hier die Rückmeldung Teil2 (mit Leerzeichen nach harddisk)


    root@dm800:~# mount -t nfs 192.168.178.25:tmp/harddisk /media/filme
    mount: 192.168.178.25:tmp/harddisk failed, reason given by server: Permission de
    nied
    mount: mounting 192.168.178.25:tmp/harddisk on /media/filme failed: Bad file des
    criptor


    Noch ne Frage: fehlt da zwischen media und filme nicht das "net" beim Pfad?

  • Der Pfad /media/filme ist schon ok. Da scheint aber noch ein Rechteproblem mit deinem NFS-Server zu sein, oder es fehlt noch eine Mount-Option.


    Poste bitte mal die Ausgabe von:



    showmount -e 192.168.178.25

  • OK, showmount ist bei dir nicht verfügbar.


    Versuche noch ein:


    mount -t nfs -o soft,nolock 192.168.178.25:/tmp/harddisk /media/filme

  • mount: mounting 192.168.178.25:/tmp/harddisk on /media/filme failed: No such file or Directory


    Mit media/net/filme kam das:


    root@dm800:~# mount -t nfs -o soft,nolock 192.168.178.25:/tmp/harddisk /media/ne
    t/filme
    mount: mounting 192.168.178.25:/tmp/harddisk on /media/net/filme failed: Input/o
    utput error

  • Existiert /media/filme ?
    Falls nicht, bitte Verzeichnis filme unter /media erstellen nochmal probieren.

  • root@dm800:~# mkdir /media/filme
    root@dm800:~# mount -t nfs 192.168.178.25:/tmp/harddisk /media/filme
    mount: mounting 192.168.178.25:/tmp/harddisk on /media/filme failed:Input/output error

  • Mach noch ein:


    ls -l /media


    dann


    mount -t nfs -o soft,nolock 192.168.178.25:/tmp/harddisk /media/filme

  • root@dm800:~# ls -l /media
    drwxr-xr-x 2 root root 0 May 31 2014 card
    drwxr-xr-x 3 root root 0 Jan 1 2000 cf
    drwxr-xr-x 2 root root 0 Jan 7 13:12 filme
    drwxr-xr-x 3 root root 0 Jan 6 14:58 hdd
    drwxr-xr-x 2 root root 0 May 31 2014 mmc1
    drwxr-xr-x 3 root root 0 Jan 7 11:17 net
    drwxr-xr-x 3 root root 0 Jan 1 2000 ram
    drwxr-xr-x 2 root root 0 May 31 2014 realroot
    drwxr-xr-x 2 root root 0 May 31 2014 ssd
    drwxr-xr-x 2 root root 0 May 31 2014 union
    drwxr-xr-x 7 root root 4096 Jan 6 14:58 usb
    root@dm800:~# mount -t nfs -o soft,nolock 192.168.178.25:/tmp/harddisk /media/fi
    lme
    mount: mounting 192.168.178.25:/tmp/harddisk on /media/filme failed: Input/outpu
    t error

  • Ich vermute mal, dass dein NFS-Server nicht läuft oder die Freigabe 192.168.178.25:/tmp/harddisk nicht korrekt ist.


    Kommst Du denn von anderen Geräten per NFS auf den NAS-Server?

  • Habe gerade noch einmal bei den dboxen geschaut:
    Nfs Server läuft auf dem Nas. Kann unter der o.g. Freigabe auch darauf zugreifen. Filme aufnehmen und abspielen.

  • Also wenn schon das manuelle mounten nicht funktioniert, wird das mit dem Automount auch nichts werden. Ich werde heute abend auf meiner Box den mount-Befehl mal ausprobieren - ansonsten hab ich leider auch keine Idee mehr.

  • Trotzdem vorab danke für deine Unterstützung.


    Vielleicht hat ja noch jemand anderes eine Idee.


    Ich habs geschafft:
    In dem ****2 Board habe ich den entscheidenden Hinweis gefunden:


    "udp brauchst du nur für e1-boxen wie es aussieht - ausser du hast ein NAS mit nfs server ..." von Fred Bogus Trumper


    Jetzt läuft es!!!!


    Danke allen, die geholfen haben.

  • Prima, dass es jetzt funktioniert.
    Wie hast Du es denn zum Laufen bekommen?

  • Quote

    Original von 11Denon22
    In dem ****2 Board habe ich den entscheidenden Hinweis gefunden:


    "udp brauchst du nur für e1-boxen wie es aussieht - ausser du hast ein NAS mit nfs server ..." von Fred Bogus Trumper


    Ich habe bei den Mount-Attributen "udp" eingestellt. Das war's.


    Einfach...wenn man(n)s weiß.

  • Ok, dann hast Du doch mehr als ein Update gemacht ;)


    PS: NFS sollte aber auch per TCP funktionieren!