Sundtek Controlcenter // 2015-07-23

  • Da Giro77 das Controlcenter eingestellt hat haben wir die aktuelle Version auf unseren Server gezogen.




    Contributors:
    Giro77 (I-have-a-dreambox-forum)
    initial author

    DIMON73 (I-have-a-dreambox-forum)
    bugfix: green button('Save setup') if not install sundtek driver(if use v1.4.0_r3)
    added option(yes/no):check the status of the internet to update driver/plugin
    added support for third sundtek stick

    Sundtek: 2015-07-17
    bugfix: Updatecheck
    bugfix: Netzwerksupport (eintragen der Seriennummer in /etc/sundtek.conf)


    Sundtek: 2015-07-20
    bugfix: updated ipk Struktur für Newnigma 3.3.2 (User Feedback)


    Sundtek: 2015-07-22
    - completely reworked multiple device support
    - reworked DVB Streaming support
    - fixed debian package (DM820 / DM7080 Support)


    Sundtek: 2015-07-23
    - bugfix OE 2.2 (DM7080/DM820)


    Sollte es weitere Probleme oder Wünsche geben einfach melden wir arbeiten das dann in's Controlcenter ein.


    Release: 20150723-3
    http://sundtek.de/media/enigma…trolcenter-20150723-3.deb
    http://sundtek.de/media/enigma…trolcenter-20150723-3.ipk


    Als zusätzliche Information:
    DM7080 unterstützt 6 zusätzliche Tuner
    DM800SE unterstützt aktuell 2 zusätzliche Tuner
    Das Plugin Menü passt sich automatisch an je nachdem wie viele zusätzliche Tuner vom System unterstützt werden.

    Files

    • scc_dm_01.jpg

      (148.21 kB, downloaded 470 times, last: )
    • scc_dm_02.jpg

      (148.16 kB, downloaded 443 times, last: )
    • scc_dm_03.jpg

      (155.83 kB, downloaded 394 times, last: )
    • scc_dm_04.jpg

      (147.18 kB, downloaded 392 times, last: )

    Edited 9 times, last by sundtek ().

  • Updated 2015-07-20
    bugfix: updated ipk Struktur für Newnigma 3.3.2 (User Feedback)

  • Status: DM820, ControlCenter 20150717-9


    Im SCC über Menu Neue Version suchen wird mir angezeigt, dass es ein Update gibt. Wenn ich dann aktualisieren will, erhalte ich einen BlueScreen.
    Wenn ich die Update-Datei -plugin-e...-20150720-3.deb auf die Box nach /tmp kopiere und dann installieren will erhalte ich eine Fehlermeldung (siehe Angang).
    Daraufhin habe ich die DEB-Datei auf den PC entpackt. Auf der DM820 das Plugin-Verzeichnis geleert, die entpackten Dateien auf die Dream transferiert, Rechte gesetzt, Neustart durchgeführt und das Plugin ist installiert.


    So war es übrigens auch schon bei der Installation der 20150717-9-Version.


    Auf meiner DM8000 mit OE2.0 funktioniert alles ohne Probleme.

  • Hi,


    wir überarbeiten das Controlcenter derzeit komplett.


    Wäre gut wenn du morgen eventuell mal im Chat vorbeischauen könntest dann können wir die DM820 auch nochmal gesondert überprüfen.


    http://chat.sundtek.de

  • hab zwar so nen Stick nicht, hab es aber auch mal versucht auf ner 7080 mit aktuellstem Image von DMM zu installieren, sieht genauso aus wie bei der 820


    Code
    dpkg -i enigma2-plugin-extensions-20150720-3.deb
    dpkg-deb: error: file `enigma2-plugin-extensions-20150720-3.deb' is not a debian binary archive (try dpkg-split?)
    dpkg: error processing archive enigma2-plugin-extensions-20150720-3.deb (--install):
    subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
    enigma2-plugin-extensions-20150720-3.deb

    Gruß MaXAt0M


    1 x DreamBox 900UHD
    1 x DreamBox 7080HDSS
    3 x DreamB0X 520

  • Anbei überarbeitete ipk und deb packet, das auch auf die Dream installiert werden kann.


    Im BP/Addons auch erhältlich.

    Files


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • cepheus, was hast du da noch alles geändert?



    Die aktuelle Version:
    http://www.sundtek.de/media/en…extensions-20150722-4.ipk
    http://www.sundtek.de/media/en…extensions-20150722-4.deb


    - Die Einträge wurden komplett überarbeitet, man kann nun so viele zusätzliche Tuner registrieren wie die Settopbox tatsächlich unterstützt (die alten Dreamboxen aktuell 2, die neueren 4?)
    - das .deb Paket wurde erneut etwas überarbeitet (da keine DM820 / DM7080 vorhanden ist bitte testen und Feedback geben)
    - Wenn man bei der Netzwerksuche OK drückt werden aktuell die IP Adressen der TV Servers angezeigt
    - Wenn man bei der Geräteauswahl auf OK drückt werden die verfügbaren Geräte aufgelistet (mit OK kann man diese übernehmen)


    Wenn man einen Netzwerk TV server einbinden möchte muss man den Server zuerst via dem Sundtek Controlcenter (entweder Scan and connect to a TV Server oder Connect to a TV Server IP) verbinden, anschließend kann man ihn wie einen lokalen Tuner im Controlcenter und der Dreambox konfigurieren.

  • Code
    dpkg -i enigma2-plugin-extensions-20150722-4.deb
    dpkg-deb: error: file `enigma2-plugin-extensions-20150722-4.deb' is not a debian binary archive (try dpkg-split?)
    dpkg: error processing archive enigma2-plugin-extensions-20150722-4.deb (--install):
    subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
    enigma2-plugin-extensions-20150722-4.deb


    geht auf der 7080 nicht zu installieren

    Gruß MaXAt0M


    1 x DreamBox 900UHD
    1 x DreamBox 7080HDSS
    3 x DreamB0X 520

  • Quote

    Originally posted by MaXAt0M

    Code
    dpkg -i enigma2-plugin-extensions-20150722-4.deb
    dpkg-deb: error: file `enigma2-plugin-extensions-20150722-4.deb' is not a debian binary archive (try dpkg-split?)
    dpkg: error processing archive enigma2-plugin-extensions-20150722-4.deb (--install):
    subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
    enigma2-plugin-extensions-20150722-4.deb


    geht auf der 7080 nicht zu installieren


    Kannst du dich via Chat melden?


    http://chat.sundtek.de


    Wir haben hier leider keine 7080/820er nur die DM800HD SE


    Hab das Debian Paket nocheinmal aktualisiert:
    http://www.sundtek.de/media/en…extensions-20150722-4.deb


    Ich sehe nicht so richtig wo der Unterschied ist, aber ein ähnliches Problem hatten wir auch schon mit dem IPK Paket und älteren ipkg tools.

  • Quote

    Original von sundtek
    cepheus, was hast du da noch alles geändert?


    Das Ordner Struktur ist bei euch noch falsch am letzte versuch eine .deb zur bauen.



    In control datei sollen kein Leerzeilen zwischen die Feldern liegen.
    Leere Felder sollen auch nicht vorhanden sein.


    Der Name des deb Packet, soll so aufgebaut werden:
    <Package>_<Version>_<PackageArch>.deb


    Und bei ipk packet soll auch ähnlich aussehen:
    <Package>_<Version>_<Architecture>.ipk

    Files


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Quote


    Das Ordner Struktur ist bei euch noch falsch am letzte versuch eine .deb zur bauen.



    Wenn ich Dein Paket oder unser altes funktionierendes Paket entpacke bekomme ich diese Verzeichnisstruktur jedoch auch nicht. Irgendetwas läuft hier komplett verkehrt mit dem ".deb" Paket.


    Code
    tar xvzf control.tar.gz
    ./
    ./postrm
    ./control
    ./postinst


    unsere vorgehensweise:

    Code
    cd control
    tar cvzf ../control.tar.gz .
    cd ..
    ar -q package.deb control.tar.gz data.tar.xz debian-binary


    bei IPKG funktioniert das ja auch.

  • Code
    dpkg-deb -R <PAKETNAME> <ZIELVERZEICHNIS>


    Code
    dpkg-deb -R enigma2-plugin-extensions-sundtekcontrolcenter_20150722-4_all.deb ./tmp


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Es klappt jetzt.
    ar -q package.deb control.tar.gz data.tar.xz debian-binary
    sollte natürlich so sein:
    ar -q package.deb debian-binary control.tar.gz data.tar.xz

  • Nach dem neusten Update bekomme ich einen GreenScreen.


    DM 800se OE2.0 mit GP 3.2

  • Quote

    Original von sossenprinz
    Nach dem neusten Update bekomme ich einen GreenScreen.


    DM 800se OE2.0 mit GP 3.2



    Ich leider auch!
    DM 800seV2, Merlin 3/GP 3.2


    LG Lobbie