Media Player - Network Mount dauert ewig

  • Dreambox


    Typ : DM8000PC


    Betriebssystem : W7 Pro
    Firewall : aktiv


    Verbindung PC zur Dream : Switch/Router


    Router Fritz



    Im Prinzip funzt die Kommunikation, daher habe ich oben etwas gekürzt.


    Bschaar hat bei anderer Gelegenheit empfohlen, mich mit meinem Problem hier zu melden. Erstmal die Fakten:


    1x 8000er mit Gemini 5.1, 2x 8000 mit Gemini 3.2, 1 PC, 2 Synology NAS.
    "Gemountet" sind jeweils:
    Syn1: die Verzeichnisse "Music" und "Bilder"
    Syn2: "TV", "DVD", "BluRay" & "Andere"
    8000er: jeweils gegenseitig (alle haben Festplatten)
    PC: 2 weitere Verzeichnisse
    Die beiden 3.2er laufen mit Experimental 2014-02-19, Enigma2 2014-03-14-Tarball


    Das Problem:
    Bei der 5.1 Box erscheint, unabhängig davon, ob alle Devices gerade eingeschaltet sind oder nicht, beim Suchen nach Filmen auf "gemounteten Devices" (Media Player - Network Mount) eine Liste mit im "auto.network" eingetragenen Devices sofort. Ich klicke dann auf die gerade gewünschte Device, es erscheint die Filmauswahl längstens bis ihre Festplatte aufgewacht ist.


    Anders bei 3.2. Der o.a. Mechanismus dauert Ewigkeiten. Anscheinend scannt die Software jede eingetragene Device, wartet auf Timeout falls das Gerät nicht eingeschaltet oder im Standby ist, und zeigt erst dann die Liste aller eingetragenen Devices, aus der man dann die gewünschte Device mit der dann erscheinenden Filmliste aussucht.

    Im Thread Auto.Network finde ich "loui", der im Wiki eine Einstellung für die Verlängerung des Timeouts gefunden hat: auto.master: /media/net /etc/auto.network --timeout=60

    Das habe ich gemacht, aber wirklich geholfen hat das nicht:
    Syn1 & Syn2 aus, 8000 Neuboot, danach Media Player - Network Mount.
    Rädchen kommen nach 2 Sekunden, nach 1'30" erscheint neues Verzeichnis ohne Inhalte. Man kann aber von hier zum "übergeordneten Verzeichnis" gehen. Das dauert bis 2'43" und es erscheinen nun die gemouteten Devices (aus der Auto.network). Scheinbar sind die 8000er aufgeweckt worden, die Filmauswahlliste erscheint sofort, wenn ich auf eine der 8000er Device klicke.

    Ich will nun einen gespeicherten Film einer anderen 8000 anschauen. Dafür muß ich eine Ebene zurück. Wieder die Verzögerung, es dauert bis 3'40" bis ich wieder in der falschen Ebene lande. Wieder "übergeordnetes Verzeichnis" anklicken, nach 5'03" erscheint die Gesamtauswahl und ich kann wieder sofort einen Film auswählen.

    Viel besser ist es, wenn alles eingeschaltet ist: die Auswahlliste erscheint nach 50", was tolerierbar ist. Leider sind meine Synologies aber meistens aus und werden nur bei Bedarf eingeschaltet. Oft reicht ja, was gerade auf den lokalen HDs gespeichert ist.

    Aber: wehe das System hat schon mal die eingeschalteten Synologies "gesehen" und man schaltet sie ab. Falls man dann entweder eine andere Device aufsucht, oder, weil es so lange dauert, denkt, daß ein Neuboot fällig ist, landet man bei der 15 Minuten Restart-Zeit von loui.

    Bitte als Lösung nur vorschlagen, das aktuellere Image zu laden, wenn damit sicher ist, daß das Problem damit beseitigt ist und die Kistchen sich wie unter 5.1 verhalten. Ich habe zwar ein älteres Image mit dem ich fast auf den jetzigen Stand zurückgehen könnte, aber ein aktuelleres Image, vorher angefertigt, wäre mir lieber. Da dFlash tot ist, geht das aber nur mit anderen Klimmzügen.

    enaigma09

  • jo, das sieht bei OE1.6 oder OE2.0 (Gemini3.2) so aus.


    mein Trick:
    man darf "nie" auf ein Verzeichnis gehen, wo direkt links/mounts auch auf andere Systeme drin sind, also:
    net
    |----> NAS1 (link zum NAS 1)
    |----> NAS2 (link zum NAS2)
    |----> PC (link zum PC)
    |----> DM8000-1 (link zur DM8000 Nr. 1)
    |----> DM8000-2 (link zur DM8000 Nr. 2)



    führt dazu, dass wenn man auf einen der links geht, offensichtlich auch die anderen gesucht werden, und Gute Nacht, wenn die nicht online sind. passiert schon, wenn man nur drüber weg navigieren will.


    Also, was mache ich (ich lege für jeden link ein eigenes Verzeichnis an):
    MediaNeu
    |----> NAS 1 (neues Verzeichnis) (und hierin den link ablegen zum NAS1) |-----> NAS1 (link zum NAS1)
    |----> NAS 2 (neues Verzeichnis) (und hierin den link ablegen zum NAS2) |-----> NAS2 (link zum NAS2)
    |----> PC (neues Verzeichnis) (und hierin den link ablegen zum PC) |-----> PC (link zum PC)
    |----> DM8000-1 (neues Verzeichnis) (und hierin den link ablegen zum DM8000-1) |-----> DM8000-1 (link zur DM8000 Nr.1)
    |----> DM8000-2 (neues Verzeichnis) (und hierin den link ablegen zum DM8000-2) |-----> DM8000-2 (link zur DM8000 Nr.2)


    Damit kann ich in MediaNeu schnell navigieren und auf das System gehen, wo ich weiss dass es an ist. Dann gehe ich in das Verzeichnis, wähle den Symlink und bin relativ schnell auf dem angeschlossenen Medium. (nicht angeschlossene andere medien werden dann nicht gelesen)



    Bei mir geht es so ganz gut.


    Charly2mal2

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

    Edited 7 times, last by Charly2mal2 ().

  • Perfekte Idee!!


    Das werd' ich heute Abend gleich dementsprechend umbauen.. :hurra:


    (Sorry, dass ich mich da in die Diskussion einmische, aber ich war da aufmerksam dabei beim mitlesen, da ich das gleiche Problem wie Enigma09 habe)


    LG Tina

  • Charly2mal2
    Da ich keine Links nutze (habe ich mal probiert, bin aber davon abgekommen - ich glaube das war deswegen, weil man nicht wußte, wo man gerade ist) bin ich verunsichert, wie Dein Tipp bei mir einzurichten wäre.
    Hier die ersten paar Zeilen meiner "auto.network":


    # Muster: Das Verzeichnis "music" der Synology wird "gemountet"
    # Nach dem "Mounten" findet sich die Musik der Synology unter dem Pfad /root/automount/Syn_Music
    Syn_Music -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.2:/volume1/music
    #
    #
    # Muster: Das Verzeichnis "photo" der Synology wird "gemountet"
    # Nach dem "Mounten" finden sich die Bilder der Synology unter dem Pfad /root/automount/Syn_Bilder
    Syn_Bilder -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.2:/volume1/photo
    #
    #
    # Muster: Das Verzeichnis \filme_DVB der DS1513 wird "gemountet"
    # Nach dem "Mounten" finden sich die DVB=TV Filme der SYN_DS1513 unter dem Pfad /root/automount/1_TV
    1_TV -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.4:/volume1/filme_DVB
    #
    #
    Wie soll das dann mit Deinem Trick aussehen?


    enigma09

  • was ist mit "Media Player" gemeint? Die standard filmliste?



    wie sind die einträge in die automount gemacht?



    bei mir sind die Syno-shares über den netscan/automounter eingebunden,
    und danach in die AMS mit bookmarks verlinkt

  • Hey enigma09
    Alle. Deine mounts finden sich unter root/automount/
    D.h, du gehst wahscheinlich mit Deinem Mediaplayer in das Verzeichnis root/aotomount. Und schon fängt die Box an, jeden mount zu testen und zu mounten und das dauert eben lange, insbesondere wenn die Sachen nicht online sind.
    Also:
    An deinen mounts änderst Du nichts.
    Dann legst Du für jeden mount ein verzechnis und darin einen symlink auf den mount an. Also:
    Gehe nach media/hdd/ ( oder lege dir ein neues verzeichnis unter media/ an)
    Lege Dir in dem verzeichnis je ein neues Verzeichnis für jeden mount an.
    Und erstelle in jedem verzeichnis einen symlink, der auf den passenden mount in root/automount zeigt.


    Und dann gehst Du mit dem mediaplayer nur noch auf Dein media verzeichnis und die unterverzeichnisse und nie mehr direkt ueber /root/automount/. Nachteil, du musst erst einmal in ein verzechnis, um den mount zu nutzen und wieder raus und in das nächste verzeichnis, um einen anderen mount zu nutzen( eine Ebene mehr) . Aber das von dir beschriebene Problem ist dafür weg.


    Wie Du Verzechnsse anlegst und symlinks, evtl googlen.


    Viel erfolg,
    Charly2mal2

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • Und die Lösung von Bschaar ist natürlich auch möglich ( und einfacher), wenn man AMS nutzt.
    men WAF wil aber auf EMC als MediaAdministration nicht verzichten, daher nutze ich meine Methode.

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • Bschaar
    Mit Media Player meine ich: Menu - Media Player - Network Shares
    SymLinks (Bookmarks) habe ich nicht eingerichtet, sondern ich gehe immer den "langen" Weg über das Menü.
    Keine Ahnung, was das mit dem "Automounter" auf sich hat, bei mir habe ich seit Jahren immer nur die "auto.network" (früher automount.conf) entsprechend editiert und gespeichert.
    Einträge in eine "Automount" habe ich also nicht angelegt. Ich habe einzig die oben beschriebenen Einträge in der"auto.network" angelegt.
    Also:
    Syn_Music -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.2:/volume1/music
    Syn_Bilder -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.2:/volume1/photo
    1_TV -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.4:/volume1/filme_DVB
    u.s.w.


    Damit funktionierte alles prima in der 5.1er Gemini, bei der 3.2er habe ich die beschriebenen Verzögerungen. Mit genügend Geduld kommen die Devices aber auch im 3.2er schließlich im Auswahlmenü zur Anzeige, ich kann anschließend die gewünschte Device auswählen und dann aus deren Auswahlverzeichnis die gewünschte Datei (Film, Bild, MP3) anklicken.
    Falls das nur durch Zufall funktioniert hat und ich zusätzliche Einträge machen sollte, bitte Info dazu.


    enigma09

  • warum selbst in dateien rumeditieren wenn das GP alles über das UI bieten:
    http://wiki.blue-panel.com/index.php/GP3_Netscan


    ein parameter falsch setzen und schon kann es probleme geben


    und symlinks ist nicht dasselbe als bookmarks



    warum nicht über die filmliste?


    EDIT
    überlesen, du willst nicht nur filme starten?

  • Wenn ich direkt über die mounts gehe, ist es bei mir gefühlt mit den parametern noperm, noserverino besser. Weiss aber gar nicht, ob die bei der nfs implementierung hier was bewirken.

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • Erst mal vielen Dank für die Tipps. Am ehesten scheint der Charly2mal2 Tipp zielführend zu sein. Wir werden sehen (mal abgesehen davon, daß beim "alten" 5.1 derartige Klimmzüge nicht nötig waren). Trotzdem noch die vermutlich doofe Frage: was ist AMS, WAF und EMC?


    Die Devices über das Plugin GP3Netscan finden und automatisch eintragen zu lassen ist als Experiment auch interessant, ich kannte das Plugin nicht. Andererseits: Ich ändere die Konfiguration ja nicht, muß also die Datei nur einmal erstellen und kann mit eigenen Kommentaren für Transparenz sorgen. GP3Netscan scheint dafür Overkill zu sein. Trotzdem....ausprobieren werde ich es, wenn es auch das eigentliche Problem nicht lösen wird.


    Enigma09

  • AMS = Advanced Movie Selection.
    EMC = Enhanced Movie Center
    Beides sind Plugins, um Aufnahmen zu verwalten und anzusehen.


    WAF = Woman acceptance factor , also, was die beste Ehefrau von allen akzeptiert. :gui:

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • Wenn ich schon mal beim Experimentieren bin, sollte ich wohl AMS und EMC auch gleich mit ausprobieren. Ich bin bisher davor zurückgeschreckt, weil ich eigentlich nicht immer mehr Aufgaben der 8000er aufpacken wollte und einfaches Filmeschauen ja funktioniert. Vieles wäre vermutlich bei einer Media-Center Kiste besser aufgehoben. Aber sei's drum. Erst mal möchte ich aber das Image-Backup Problem lösen. Das Schlimmste wäre, wenn ich die Kiste abschieße (was mit großer Wahrscheinlichkeit im ersten Anlauf passieren wird) und dann Stunden damit beschäftigt bin, wieder auf den Ausgangspunkt zurück zu kommen. Da droht nämlich nicht zuletzt der WAF im Hintergrund.


    enigma09

  • Habe eben wahrscheinlich das selbe "Zahnrad über 2min 37sek Problem" mit dem Symlink Workaround auf meinen beiden Boxen mit OE1.6 und OE2.0 gelöst

    Dreambox 920 UHD /// Newnigma2-daily 2019-09-25
    Dreambox 900 UHD /// 4.3.2r7-17-g32f8eb-2019-08-30
    Dreambox 7020HD /// Flash : 3.2.4

    Edited once, last by Paradream ().