[gelöst]Festplatte weg

  • Jetzt sieht es so aus.
    Die erste Zeile habe ich nicht eingegeben.


    root@dm8000:~# df -m > /tmp/meminfo.dcc; echo ">>> DONE <<<";
    >>> DONE <<<
    root@dm8000:~# ls -ld /media/hdd
    drwxr-xr-x 2 root root 160 Apr 7 15:56 /media/hdd
    root@dm8000:~#

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • root@dm8000:~# ls -ld /media/hdd
    drwxr-xr-x 2 root root 160 Apr 7 15:56 /media/hdd
    root@dm8000:~# umount /media/test
    umount: can't umount /media/test: Invalid argument
    root@dm8000:~# mount -t auto /dev/sda1 /media/hdd
    mount: mounting /dev/sda1 on /media/hdd failed: Invalid argument
    root@dm8000:~#

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • root@dm8000:~# xfs_check /dev/sda1
    ERROR: The filesystem has valuable metadata changes in a log which needs to
    be replayed. Mount the filesystem to replay the log, and unmount it before
    re-running xfs_check. If you are unable to mount the filesystem, then use
    the xfs_repair -L option to destroy the log and attempt a repair.
    Note that destroying the log may cause corruption -- please attempt a mount
    of the filesystem before doing this.
    root@dm8000:~#


    Ich hatte den EMC auf beiden Boxen aufgerufen, um zu sehen, ob ich über /net noch die jew. andere Festplatte sehen kann.


    Das hätte ich wohl lieber bleiben lassen sollen.

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Was Dir lieber ist.


    Mit dem anderen Board habe ich zur Zeit Verbindungsprobleme. Der Seitenaufbau dauert ewig.

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

    Edited once, last by Paulchen P. ().

  • Kann ein Dateisystemcheck oder neues Datenträgerverzeichnis vergeben


    über den Gerätemanager des Bp, Schaden verursachen?

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Da steht doch genau, was du machen sollst.


    Mounte die Festplatte und umounte sie wieder, dann führe noch einmal
    xfs_check aus.

  • Quote

    Original von Paulchen P.
    If you are unable to mount the filesystem, then use
    the xfs_repair -L option to destroy the log and attempt a repair.


    Bitte dieser Aufforderung nachkommen, da Du ja nicht mehr mounten kannst!


    Und bitte schaff Dir ein anderes Telnettool an. Die Mitschnitte von DCC sind das Schrecklichste, was man einem, der helfen will, vorsetzen kann. Das kann man ja nicht lesen. Einfach PuTTY installieren!

  • Habe ich nochmal gemacht. Es kommen immer nur Fehlermeldungen.


    root@dm8000:~# xfs_repair /dev/sda1
    Phase 1 - find and verify superblock...
    Not enough RAM available for repair to enable prefetching.
    This will be _slow_.
    You need at least 352MB RAM to run with prefetching enabled.
    Phase 2 - using internal log
    - zero log...
    ERROR: The filesystem has valuable metadata changes in a log which needs to
    be replayed. Mount the filesystem to replay the log, and unmount it before
    re-running xfs_repair. If you are unable to mount the filesystem, then use
    the -L option to destroy the log and attempt a repair.
    Note that destroying the log may cause corruption -- please attempt a mount
    of the filesystem before doing this.


    Hier ist jetzt das Problem mit dem Ram, was vorher schon angesprochen wurde.


    Mein Swap auf die SD-Karte nützt da wohl nichts?

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Du sollst mit der -L Option das repair starten!


    Und Dein SWAP ist halt zu klein. Du benötigst einfach mehr davon. Kannst Du nicht einfach mal ein halbes GB Swapfile anlegen? Kannst Du ja nachher nochmal löschen...

  • Bevor man repariert sollte man es mal mit mounten probieren. Denn aus den obigen Logs geht hervor, dass Du das noch nicht gemacht hat. Du hast nur versucht von /media/test zu unmounten und auf /media/hdd zu mounten. Der eine Ordner existiert vermutlich nicht und der andere ist ein Symlink. Mounten kann da natürlich nicht gehen.


    also zum mounten:
    mkdir -p /media/test
    mount -t xfs /dev/sda1 /media/test
    ls -al /media/test


    zum unmounten:
    umount /media/test

  • OK.


    root@dm8000:~# -L
    -sh: -L: not found
    root@dm8000:~# mkdir /media/test
    root@dm8000:~# mount -t xfs /dev/sda1 /media/test
    mount: mounting /dev/sda1 on /media/test failed: Structure needs cleaning
    root@dm8000:~# ls -al /media/test
    drwxr-xr-x 2 root root 160 Apr 7 17:56 .
    drwxr-xr-x 14 root root 976 Apr 7 17:56 ..
    root@dm8000:~#


    Was muss ich nochmal bei der -L Option genau eingeben?
    Ich habe doch bereits geschrieben, dass ich eine Swap von 1GB auf der SD-Karte habe.
    Auf der FP wirds ja zur Zeit nicht gehen.?
    Auf die Schnelle habe ich keinen seriösen Putty Download Link gefunden.
    Der von Chip online geht nicht.

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Nach der obigen Fehlermeldung brauchst Du nicht mehr RAM, wenn zuwenig vorhanden ist, dann ist das xfs repair einfach langsamer. Abgebrochen ist das repair nur wegen dem noch existierenden Log.
    Da mounten nicht möglich repair also mit der -L option starten wie oben angegeben.


    vorher Enigma beenden mit "init 4", dann ist mehr RAM vorhanden.


    xfs_repair -L /dev/sda1

  • Vielen Dank für Eure Geduld. Mir platzt gleich der Schädel bei soviel Neuem.
    ptha


    Habe ich alles gemacht. Jetzt läuft es vor sich hin.
    Ich bin zZt. bei Phase 4.


    Hoffentlich gehen die Aufnahmen nicht kaputt.


    :Bibber:


    Phase 7...

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Jetzt ist es fertig.


    Was muss ich nun tun?

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Wenn repair ohne Fehlermeldung beendet, versuch es nach /media/test zu mounten


    also zum mounten (der Ordner /media/test existiert ja noch von vorher):
    mount -t xfs /dev/sda1 /media/test
    zum anschauen was im Ordner ist, falls mounten erfolgreich (ohne Fehlermeldung):
    ls -al /media/test


    zum unmounten:
    umount /media/test

  • Muss ich E2 vorher wieder starten?

    Gruß PP
    ---------------------------------------------------------------------------OE 2.0/2.5 immer die aktuellste

  • Nein Enigma muss vorher nicht gestartet werden. Wenn Du es möchtest kannst Du es mit "init 3" starten. Enigma ist nur ein Anwenderprogramm, das mit dem Betriebssystem Linux nichts zu tun hat.