dreambox friert ein nach dem anschauen von I-Net Videos

  • Hallo Zusammen!


    Hat noch jemand das Problem, das die Box nach einiger Zeit einfriert, wenn man zuvor ein Video aus dem Internet gesehen hat?


    Das wirkt auf mich wie ein memory leak und passiert nach dem Video betrachten mit mytube und mediaportal. Vielleicht eins der gst-plugins????


    Stunden nach dem Videosehen wird die Box immer träger und reagiert dann irgendwann garnicht mehr. Auch eine Telnet-Session lässt sich nicht mehr öffnen. Da hilft nur noch der Hauptschalter zum resetten.


    Werde es bei Gelegenheit mal mit einem Konsolen-Log versuchen. Vielleicht komm ich der Sache dann auf die Spur.


    [EDIT] Alternativ werde ich mal ein neues, sauberes Image einspielen. Vielleicht ist über die Jahre ja irgendwas "hängen geblieben" was nicht mehr da sein sollte.


    Die Box ist eine DM8000 und das Image ist das neuste von DMM.


    Gruß
    deathrattle

  • Nein, kein swap aktiviert.


    Code
    root@dm8000:~# cat /proc/swaps
    Filename Type Size Used Priority
    root@dm8000:~#


    Hab auch zwischendurch mal mit top nach einem "speicherfressenden Monster" gesucht. Leider ist mir keines aufgefallen. Vielleicht hab ich auch nur zum falschen Zeitpunkt geguckt...

  • Alles klar. Probier es direkt mal aus. Schon mal Danke für den Support!


    Code
    root@dm8000:~# cat /proc/swaps
    Filename Type Size Used Priority
    /media/hdd/swap0 file 524284 0 -1
    root@dm8000:~#
  • Welchen Image-Stand hast du? Der gstreamer hatte immer wieder viele Memleaks. Der aktuelle Stand im OE 2.0 experimental sollte aber relativ stabil sein.
    Viel RAM bzw. Swap braucht man aber leider trotzdem.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Natürlich den neusten SW-Stand aus dem offiziellen repository (OE2.0).


    Ob swapfile oder swap-device wird ganz bestimmt schnuppe sein. Laß es jetzt mal so laufen und berichte später.

  • Ob Swapfile oder Swapdevice das ist so eine Glaubensfrage und der unterschied ist minimal bis gar nicht spürbar. Sprich es ist piepegal.

    DM8000SSSS 4TB RGB-Display Lüfter BR-RW OE2.0 2GB DeLock Modul
    DM7080SSSST 6TB RGB-Display OE2.2/GP3.3

  • So, jetzt hat er zum ersten Mal auch den Swap benutzt...


    Folgende Fehlermedlung im Log:



    Werd das jetzt beobachten, ob der Fehler häufiger auftritt oder ob das eine Ausnahme ist. Ansonsten kann ich am network scheduler selber nicht viel tun. Außer es bei DMM zu melden.

  • Unsere Brüder mit dem verwandten Receiver habe das Problem ebenfalls mit dem Netzwerk-Treiber für den Broadcom-Chip.


    Habe dort eine Anleitung gefunden, wie die TCP/IP Stacks in /etc/sysctl.conf anzupassen sind. Werde es testen und berichten.


    Vielleicht ist es aber auch die falsche Fährte zu meinem Problem... mal abwarten.

  • 17,5 Std. uptime und noch kein freeze.
    Das sieht gut aus.


    Allerdings weiss ich jetzt natürlich nicht, ob es am swap oder an den geänderten TCP/IP Stacks liegt.


    Ich denke aber mal, das der swap die Lösung ist.


    Code
    root@dm8000:/# uptime
    10:56:14 up 17:31, 1 user, load average: 0.13, 0.11, 0.21
    root@dm8000:/# free -m
    total used free shared buffers cached
    Mem: 146 130 15 0 0 35
    -/+ buffers/cache: 94 51
    Swap: 511 27 484
    root@dm8000:/#


    Swappt das System den jetzt permament auf meine Festplatte? Oder gibt er irgendwann auch wieder den verwendeten Bereich frei? Bis jetzt wächst der Wert des benutzen Swap immer nur und wird nicht wieder kleiner.

  • Hab noch ne "alte" CF-Karte. Nehm ich halt die...
    Danke für die Info und frohe Weihnacht!