[Enigmalight Update-Thread] v0.2rc1 22-01-2015 (IPK and DEB)

  • OT fortstetzen :D

    Quote

    Original von willwaswissen
    Was mir bei diesem Link aber aufgrund des dort geschilderten Zeitplanes nicht klar wird, einerseits sind einige Sachen SOLD und zum anderen ob es überhaupt gescheit fertig entwickelt ist!? :rolleyes:


    So läuft das beim Crowdfunding. Du leistest deinen Teil, dass das Produkt entwickelt werden kann und erhälst dafür eine Gegenleistung. Diese ist i.d.R. abhängig von der Höhe deiner Unterstützung geht oft von symbolischen Leistungen (Danksagung auf der Homepage, Sticker, Werbematerialien, in diesem Fall ein Newsletter für 1$) über die Zusage der Lieferung des finalen Produkts bis hin zu ganzen Bundles inkl. Zubehör usw....
    Das alles aber unter der Vorraussetzung, dass eine Grundschwelle der Finanzierung erreicht wird. Das ist ja meist nötig um überhaupt entwickeln zu können oder die Produktion zu starten. Würde die Schwelle nicht erreicht, bekommst du dein Geld garantiert zurück. Die Schwelle ist beim verlinkten Projekt aber längst überschritten.


    Siehe auch: http://de.wikipedia.org/wiki/Crowdfunding

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

    Edited once, last by m0rphU ().

  • Hi speedy. Thanks for the plugin but I've got the same problem.



    What can I do? How is it working in another boxes without python-cheetah?
    I don't understand nothing at all.
    Regards.
    ;)

  • What to do with this deb-File on my DM8000 with 2.0.0?
    I have not dpkg or ipkg!?

  • Quote

    Original von speedyisfast
    Try this deb file :)


    Hi Speedy,


    this deb package is not compatible with dm7080.


    see errorlog during install:


    dpkg -i python-cheetah_2.4.4-3_mipsel.de
    Selecting previously unselected package python-cheetah.
    (Reading database ... 15550 files and directories currently installed.)
    Preparing to unpack python-cheetah_2.4.4-3_mipsel.deb ...
    Unpacking python-cheetah (2.4.4-3) ...
    dpkg: dependency problems prevent configuration of python-cheetah:
    python-cheetah depends on python2.6; however:
    Package python2.6 is not installed.
    python-cheetah depends on python (>= 2.6.6-7~); however:
    Package python is not installed.
    python-cheetah depends on python (<< 2.8 ); however:
    Package python is not installed.



    In my point of view python-cheetah is to old for dm7080.


    The DM7080 has the following python installed:


    Python 2.7.3


    Regards

  • Wenn ich die neue Version installieren möchte, kommt folgende Meldung:


    Cannot satisfy dependencies

  • Quote

    Original von chris76
    Wenn ich die neue Version installieren möchte, kommt folgende Meldung:


    Cannot satisfy dependencies


    Das wurde doch schon 4 Posts vor deinem gemeldet. Und Speedy hat auch schon das entsprechende fehlende Package 3 Posts vorher zum Download angeboten.


    Und 2 Posts vorher habe ich gemeldet das das vor 3 Posts zum Download angebotene deb File nicht mit der DM kompatibel ist obwohl ein python 2.7 auf der DM vorhanden ist.


    Aber:


    Ich glaube du hast das ipk installiert da du bestimmt eine dm800 hast.. und auch da wird sicher etwas fehlen.


    Das wirst du aber nur sehen wenn du das ipk mal von hand installierst und hier das Log postest.

  • Habe aber kein 7080 sondern ne 800SE, da kann man man mir deb files nichts anfangen

  • hab meinen Post schon korriegiert da ich das dann gleich in deinem Profil gesehen hatte.


    Aber wie schon gesagt. Bitte mal über die Konsole installieren und die Meldung dann hier posten. Dann kann dir auch geholfen werden.

  • Das ist die Meldung die ich bekomme:



    root@dm800se:/# cd /tmp
    root@dm800se:/var/volatile/tmp# opkg install *.ipk
    Installing enigma2-plugin-extensions-enigmalight (0.2-rc1) to flash...
    Collected errors:
    * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigm
    a2-plugin-extensions-enigmalight:
    * python-cheetah *
    * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-enigmaligh
    t.
    root@dm800se:/var/volatile/tmp#

  • Hi all.
    I've done a trick (better several) to make work enigmalight.
    First, I've installed via FTP the "evil" cheetah, then I cheated enigma2 editing the file /var/lib/dpkg/status





    Then I can install enigmalight.


    It works with some problems, the worst...when I'm going to save "settings" the box crashes







    Finally the plugin works but how I said, with some bugs.
    Dirty work (the mine)
    Regards;)

  • Hi


    Python cheetah is for the new webremote.
    So we will need it in future releases.
    It will parse html files to python, so it can be running.


    Try this attachment.
    Or try to find another python-cheetah for mipsel on the Internet.


    Gr Speedy

  • Quote

    Original von speedyisfast


    Or try to find another python-cheetah for mipsel on the Internet.


    Gr Speedy


    Hi Speedy,


    sorry to jump in here but i think this is not the way how it will work.


    You are the programer of the software and if you use parts that not in the repository of the DreamOS than you need to provide the packages which are mandetory needed for the installation.


    Otherwise nobody can install your software and it will end up in more questions or frustrated users.


    At this point we cant use your new release bceause of the python_cheeta which is not available and which can't be installed depending your files are not compatible with the DreamOS.


    I Don't know how it is for the ipk files on OE 2.0 but i think it is the same situation.


    Be sure we will support you in testing or installation of provided packages from you but don't go the way to say search by your own and try it..


    Best Regards
    DreamKK

  • You right !! ;)


    I will fix this.
    I will make a new solution to make the html templates.
    So i will upload a new package end this weekend.


    First i need to fix my receiver, it's dead :( (Replacing Some Capacitors)


    Best regards Speedy


    /Edit by LN
    Don't use fullquotes by direkt answer.

  • Hey Speedy,


    many thanks for the quick response. This shows again you're a really good guy.
    Love your work and hope you get your receiver working again.


    If you need someone to test let me know.


    Regards
    DreamKK

  • Lässt sich auf meiner 7080 nicht Installieren wegen fehlendem cheetah,
    installiere ich cheetah(beide deb probiert) sagt er es fehlt python obwohl ich die
    python-core2.7 drauf habe.

  • Guten Morgen... :-)


    Das Problem ist schon bekannt.

  • speedy: No, you don't need to change anything ;)


    As python-cheetah was already available for OE 2.0, I've asked our image builder to create a package for OE 2.2 as well and now everyone can get it at least from the Merlin feed:
    http://debfeed4.merlin.xyz/mip…tah_2.4.4-r3.0_mipsel.deb
    Thanks weazle again! :)


    I'm sure other image teams or DMM can make it available on their feeds as well. But it's also not a problem if folks can get it from our feed...

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Also bei der 7080 geht die Installation voll in die Hose,
    Er erstellt nicht ein ordner, wenn ich sie von hand erstelle sind sie nach der Installation alle weg.
    Im Plugin menu ist auch nichts zu sehen.


    Habe es mal manuell Installiert, ich kann weder eine Config einspielen, die nimmt er nicht an.
    Wenn ich Config editor irgendwo OK drücke kommt ein greenscreen