MediaPortal Support

  • Hallo... Ich habe eben paar Updates installiert vom blupannel und Mediaportal war auch dabei. Lief alles durch bis auf mediaportal. Der sagte mir das er was nicht überschreiben kann weil es schon in dem mpgz plugin vorhanden ist. Und hat es daher nicht geupt.
    Nach gui Neustart bin ich in mediaportal mal rein und da steht
    Oben links noch die alte Version und bietet mir ein Update an.
    Das hab ich gemacht, aber wie von mir schon erwartet kommt die gleiche Fehlermeldung.
    Ist das bekannt?
    Soll ich das update-log hier anhängen?
    Ein Ausschnitt:
    Unpacking enigma2-plugin-extensions-mediaportal (2020051502) over (2020041901) ...


    dpkg: error processing archive /run/apt/archives/enigma2-plugin-extensions-mediaportal_2020051502_all.deb (--unpack):
    trying to overwrite '/usr/lib/enigma2/python/Plugins/Extensions/MediaPortal/additions/porn/porntrex.py', which is also in package enigma2-plugin-extensions-mpgz 2020033101


    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)


    Errors were encountered while processing:
    /run/apt/archives/enigma2-plugin-extensions-mediaportal_2020051502_all.deb


    Ein Update vom mpgz kam nach Neustart nicht.
    Das war sonst fast so üblich ...

    Das Licht das doppelt so hell brennt , brennt eben nur halb so lang ....


    CU , FoLeY

    Edited once, last by FoLeY ().

  • Nach dem Update vom MediaPortal kommt bei Youtube jetzt diese Meldung:


    Fehlender API-Key; bitte befüllen Sie die Datei 'mp_yt-apikey' zuerst und starten Sie dann das Plugin neu



    Habs jetzt hinbekommen, aber für den normalen User ist es zu kompliziert.

  • Hallo Zusammen


    Ich bekomme hier einen Fehler wenn ich den YT Token anfordere.
    Gerätecode kann nicht angefordert werden.
    Im Log steht folgendes
    _cb_requestDevCode Fehler


    Die Youtube API ist konfiguriert und die entsprechenden Daten sind in folgenden files eingetragen.
    mp_yt-oauth2
    mp_yt-apikey


    Irgendjemand eine Idee?


    Schnuepfli

  • Ich hatte gestern auch 2 MP Updates, die Meldung mit dem fehlenen api Key hab ich jetzt auch, wenn ich z.B. die YT Videosuche starte oder meine Favoriten aufrufen will.


    Getestet mit DM900 und aktuellem DreamOS und MP :)


    Edit: Mit der One kommt die gleiche Meldung.


  • E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Habs gerade erfahren, Danke ;)

  • Nutzt man im MP eine andere Mediathek und geht danach in Youtube kommt trotz das der api key vorhanden ist die Meldung das er fehlt.
    Erst mit mehrfach im Menu YT aus und ein und Neustarts dann geht es.

  • Keine Ahnung habs nach dem Video im newnigma Board gemacht und in die Datei in etc/enigma2/mp_yt-apikey eingetragen.
    Muss ich noch Schreib/Lese Rechte ändern?

  • Gibt es eine Möglichkeit youtube so einzustellen, das man auch ohne API-key und YT-Konto einfach z.b. live Inhalte abrufen kann ?

  • Reideen
    Nö, aber die Keys werden bei jedem Aufruf eingelesen, daher kann das nicht sein (außer du hättest irgendwas falsch eingetragen?)
    Und die anderen Plugins haben darauf gar keinen Einfluss.


    Purgy
    Was meinst du mit Live-Inhalte abrufen?!?

    https://mediaportal.info/

    Ein kleines Dankeschön, durch eine Spende, nehme ich gerne an, PayPal oder Amazon-Gutschein an dhwz(at)gmx.net

    Edited 2 times, last by dhwz ().

  • dhwz:


    na ich will z.b. einen live stream von "united we stream" anschauen, wie er fast jeden abend gesendet wird und will dann in die suche "united we stream" eingeben und dann wurde der stream auch immer gefunden und man konnte ihn gucken. nun komme ich erst aber gar nicht so weit, weil vorher die Meldung mit den api-key kommt. Das sollte man aber auch umgehen können, denn es gibt andere plugins, da brauche ich die api Geschichte gar nicht und alles läuft wie auch zuvor. Wohlgemerkt alles ohne YT-Konto und favouriten oder so.
    Deswegen meine Frage ob man das abschalten kann.

  • Ohne API-Key ist kein legaler Zugriff auf Youtube möglich (war er auch noch nie), auch andere Plugins verwenden einen API-Key (und auch die bekommen den früher oder später abgeschaltet).
    Das hat mit Youtube-Konto und Favoriten überhaupt nichts zu tun, das ist völlig unabhängig von der OAuth2-Geschichte.

    https://mediaportal.info/

    Ein kleines Dankeschön, durch eine Spende, nehme ich gerne an, PayPal oder Amazon-Gutschein an dhwz(at)gmx.net

    Edited 2 times, last by dhwz ().

  • Und wie läuft das dann ab, wenn ich am Rechner mit browser unangemeldet an ein google-account einen stream schaue ? Das geht ja auch. Oder kann ich einen API-Key auch ohne google konto erzeugen ?

  • Quote

    Original von Purgy
    Und wie läuft das dann ab, wenn ich am Rechner mit browser unangemeldet an ein google-account einen stream schaue ? Das geht ja auch. Oder kann ich einen API-Key auch ohne google konto erzeugen ?


    Was du über die offizielle Youtube Website tun kannst ist irrelevant.
    Um Daten von Youtube legal zu bekommen ist ein API-Zugang nötig und ohne einen API-Key bekommst du gar nichts. Und ohne einen Google Account bekommst du keinen API-Key weil du dann keinen Google Cloud Services nutzen kannst.


    https://www.googleapis.com/you…%20stream&type=video&key=


    Nochmal zum Verständnis es war schon immer ein API-Key in Verwendung, mein verwendeter Key ist aber nicht mehr gültig weil Google von mir eine nicht erfüllbare Auditierung forderte. Daher müsst ihr jetzt eure eigenen Keys verwenden.

  • Quote

    Nochmal zum Verständnis es war schon immer ein API-Key in Verwendung, mein verwendeter Key ist aber nicht mehr gültig weil Google von mir eine nicht erfüllbare Auditierung forderte. Daher müsst ihr jetzt eure eigenen Keys verwenden


    Ok danke verstanden und geklärt. Übrigens danke fürs fixen von ZDF, scheint ja wieder zu funzen.