MediaPortal Support

  • da du gp3 hast, ist unser feed egal. welche version von gp3 die aktuelle ist und ob es damit auf dem feed die packages gibt, kann ich dir nicht beantworten.

    Gruss Dre


    Developer Project Merlin

  • GP3.2 ist OE2.0


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • installier mal aus dem tmp heraus in folgender Reihenfolge die ipks aus post 1:


    python six; python requests; python js2py und python cfscrape


    dann reboot


    dann MP 7.5.8


    so hats bei mir geklappt



    Grüße goldsmith

    MAN LACHT NICHT WEIL MAN GUT DRAUF IST, SONDERN MAN IST GUT DRAUF WEIL MAN LACHT

    KEINE HILFE PER PM!

  • Unnötiges Zitat entfernt!
    Bitte keine Fullquotes bei direkten Antworten!


    danke !

    schöne grüße,
    sascha


    TVR - because loud is not enough

  • habe mit der 7080 und Merlin4 die 4 deb Dateien installiert und dann versucht ein Update des MediaPortal zu machen.


    Nun erhalte ich "MediaPortal no Modul named six".

  • Hier geht es die letzten 3 seiten nur um dieses Thema,könnt ihr nicht wenigstens das lesen und danach handeln?
    Es ist doch beschrieben was man machen muss und auch was dein Fehler bedeutet und wie du das ändern kannst.
    Seit doch bitte so nett und lest bzw. handelt danach und schreibt nicht 100x das selbe so das der thread unnötig mit dem selben voll geschrieben wird.

  • ich finde aber keine Lösung und habe es mir durchgelesen. Auch schon letzte Woche (nach der Ankündigung) vorab nach den notwendigen Abhängigkeiten gefragt.


    Die vier deb Dateien von Seite 1 hatte ich vorher installiert und die Reihenfolge beachtet.


    "MediaPortal no Modul named six" nach jedem Start.

  • Du hast gelesen?
    Ab hier geht es doch fast nur noch um die fehlenden Abhängigkeiten und da steht auch was man machen muss und das zig mal geschrieben.


    MediaPortal 7.5.8 [Diskussionsthread]
    MediaPortal 7.5.8 [Diskussionsthread]


    Euch fehlen Abhängigkeiten die eventuell nicht auf eurem feed sind oder ihr halt noch nicht auf der Box habt und genau diese müsst ihr erst installieren wenn sie nicht automatisch mit installiert wurden.


    Und gerade im Merlinimage fehlen halt diese im Image weil Merlin so einiges von Haus aus nicht installiert hat bzw. entfernt und daher fehlen sie Standardmässig im Image.

  • aus dreamboxupdate.com habe ich nun die python-six_1.7.3-r1.1_mipsel.deb installiert.


    Per Konsole hat dann das Update auf 7.5.8 funktioniert.


    Evtl. hilft es diese Datei noch auf Seite 1 zu verlinken?

  • zombi: sorry, aber jetzt muss mal eines klar stellen: bei uns sind (mit Ausnahme der 820) alle benötigten Packages auf dem Feed. Wenn sich dhwz entschieden hat, dass nicht alle Packages als dependency beim mediaportal drin sind (python-email wurde übrigens mittlerweile reingenommen), dann ist das nicht unser Problem. So muss sich nun halt jeder irgendwo erkundigen, wie er seinen Fehler wegbringt. Es ist sowas von egal, ob bei uns nun alles, was im DMM-Image drin ist, mitgeliefert wird oder nicht. Letztlich kann jeder z.B. autocrashlogsubmit deinstallieren und dann fehlt python-email genauso im DMM-Image.

    Gruss Dre


    Developer Project Merlin

  • Dre das war von mir aber kein Angriff an euch ,es sollte nur zur Info für die User dienen also nicht angegriffen fühlen ;)
    dhwz hatte einige vergessen weil sie normalerweise schon im Image drin sind ,wenn man daher ein schlankes Image installiert wo Sachen entfernt sind dann fehlen Sachen im Image ,was die User ja nicht wissen können und was halt gerade der Fall ist beim Merlin .
    Klar ist das alles auf eurem feed und klar ist auch das dhwz alle Abhängigkeiten besser mit rein machen sollte (oder glaube jetzt auch drin hat) und dann passiert sowas nicht.
    Es ist für die User gerade etwas schwierig und daher dann auch die Info hier im Thread.
    Nur wie man sieht geht das ganze hier und auch bei euch über mehrere Seiten (auch aus dem Grund weil viele das ganze halt nicht richtig lesen ) und daher schrieb ich auch das man sich das alles bitte durchlesen sollte und danach handeln .


    PS.python-email ist auch ne Abhängigkeit vom Browser der im Merlin ja zb. nicht mit drin ist .

  • zombi
    Das seh ich anders das ist eigentlich nicht mein Job dafür zu sorgen dass andere Pakete ihre Abhängigkeiten korrekt erfüllen, ja ich hab jetzt python-email bei uns reingenommen, dort hat es aber überhaupt nichts zu suchen, es ist eine Abhängigkeit von requests das ohne python-email gar nicht funktioniert. Genauso wie python-six eine Abhängigkeit von python-js2py ist und python-pprint eine von python-js2py.
    Ich kann und will nicht für jedes Pythonpaket die Abhängigkeiten prüfen und dann einfach bei uns reinballern.

    Ein kleines Dankeschön, durch eine Spende, nehme ich gerne an, PayPal oder Amazon-Gutschein an dhwz(at)gmx.net

    Edited 2 times, last by dhwz ().

  • gemäss dem recipe hat zumindest python-requests 2.8.1 keine Abhängigkeit zu python-email und ich kann auch im source nichts finden.

    Gruss Dre


    Developer Project Merlin

  • Dann schau mal in die fields.py im Ordner packages/urllib3 :tongue:


    import email.utils
    import mimetypes


    Sorry ich kann ja nix dafür wenn die recipes nicht korrekt gepflegt sind. :)

    Ein kleines Dankeschön, durch eine Spende, nehme ich gerne an, PayPal oder Amazon-Gutschein an dhwz(at)gmx.net

    Edited once, last by dhwz ().

  • dhwz ok da magst recht haben ,das Problem ist das normal die Sachen ja im Image schon drin sind und wenn Image Ersteller da jetzt schlankere Image anbieten und Sachen entfernen dann fehlen bestimmte Pakete im Image weil sie mit entfernt sind.
    Das können die User ja nicht wissen und daher gibt es da jetzt auch so einige Probleme bei diesen Image.
    Keine Ahnung was da wie alles zu welchem Paket gehört was dann auch vom MP genutzt wird ,das denke wisst ihr am besten und ist auch sicherlich auf allen feeds ,nur halt nicht immer in allen Image direkt drin weil die Image Ersteller da bestimmte Sachen raus machen.
    Ist halt alles nicht so schön für die User ,aber es ist auch kein Beinbruch das ganze nach zu installieren und das steht hier bzw. auch woanderst ja gefühlte 100x ,nur ist es halt so das viele User das ganze einfach überfliegen oder nicht lesen wollen und dann 100x das selbe fragen und das macht solche Hilfe Threads dann auch mal sehr schnell unübersichtlich und das vergessen da die meisten.

  • Ok, gesehen. Dann werde ich das wohl mal noch anpassen.


    Das müsste aber auch in den Sourcen als requirement aufgeführt werden vom Entwickler von requests.

    Gruss Dre


    Developer Project Merlin

    Edited once, last by Dre ().

  • Sag ich doch ist nicht euer Fehler, es ist aber trotzdem falsch :)
    Vermutlich wissen die das selbst nicht, weil die davon ausgehen (oder es so ist), auf dem System wo sie arbeiten, dass das immer im System vorhanden ist.

    Ein kleines Dankeschön, durch eine Spende, nehme ich gerne an, PayPal oder Amazon-Gutschein an dhwz(at)gmx.net

    Edited once, last by dhwz ().

  • date.
    Unknown package 'cfscrape'.
    Collected errors:
    * opkg_install_cmd: Cannot install package cfscrape.



    was soll ich machen