DM800SE + OpenVPN + HIDE.IO

  • das ist mir letztens aber auch aufgefallen, dass das kernel-module-tun nicht mitinstalliert wird und hab es nun noch mal getestet


  • In Zeile 25 steht:

    Code
    package openvpn recommend installing kernel-module-tun


    Ich würde das jetzt so deuten, dass das Paket also nicht dabei ist...

  • Ja ist auch so im Moment mit dem openvpn.
    Das Modul ist nur als Empfehlung im openvpn Paket vermerkt.


    Und muss manuell installiert werden.


    Z.B. via Konsole oder via den Kernelmodulen via BluePanel.

  • Quote

    Original von mfgeg
    Ja ist auch so im Moment mit dem openvpn.
    Das Modul ist nur als Empfehlung im openvpn Paket vermerkt.


    Und muss manuell installiert werden.


    Z.B. via Konsole oder via den Kernelmodulen via BluePanel.


    bin auch gerade darauf reingefallen...dass das Modul nicht aktiviert ist...
    kann man das Modul nicht standartmässig aktivieren bei der Installation von openvpn?

  • Vielleicht sollte man auf das "Fehlen" des Moduls im Wiki und/oder im ersten Beitrag erwähnen.

  • Quote

    Original von mfgeg
    Steht ja auch so im Wiki ;)


    Aber vielleicht wird es ja Zufünftig als Abhängigkeit mit dem
    Plugin mit angeboten :D


    Wer (mich einbegriffen) liest denn schon Wiki oder gar hier die Beiträge :D
    Abhängigkeit wäre angebracht ;)


    :350:

  • Quote

    Original von mfgeg
    Was ist nen Wuki :D


    nicht was, sondern wer: der Wuki (Chewbacca) fliegt doch mit Han Solo bei Star Wars rum!

  • Hallo,
    gibt es eignetlich dann auch ein eigenes Webinterface in dem man die Verbindungen einsehen kann oder geht das nur auf der Box? Das normale OpenVPn bietet ja anscheinend ein Webinterface.


    Danke

  • Ich hab es bis dato nur auf der Box gemacht.
    Ich mach mich mal schlau


    Jake

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

  • Bei mir kommt leider immer eine Fehlermeldung sobald ich den VPN starten will. Ich bin genau nach den Schritten im Wiki (http://wiki.blue-panel.com/index.php/GP3.2_OpenVPN) gegangen.
    Bei der Installation ist folgendes rausgekommen:



    kernel-module-tun wurde also installiert und ist aktiviert. Im Log-File von OpenVPN steht folgendes:


    Code
    Sun Apr 14 12:12:28 2013 OpenVPN 2.1.3 mipsel-oe-linux [SSL] [LZO2] [EPOLL] built on Apr 17 2012
    Sun Apr 14 12:12:28 2013 NOTE: when bridging your LAN adapter with the TAP adapter, note that the new bridge adapter will often take on its own IP address that is different from what the LAN adapter was previously set to
    Sun Apr 14 12:12:28 2013 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    Sun Apr 14 12:12:28 2013 NOTE: --script-security method='system' is deprecated due to the fact that passed parameters will be subject to shell expansion
    Sun Apr 14 12:12:29 2013 TUN/TAP device tap0 opened
    Sun Apr 14 12:12:29 2013 /etc/openvpn/up.sh br0 tap0 1500 1590 init route: SIOCDELRT: No such process add bridge failed: Package not installed
    bridge br0 does not exist!
    bridge br0 does not exist!
    ifconfig: SIOCSIFADDR: No such device route: SIOCADDRT: Network is unreachable
    Sun Apr 14 12:12:29 2013 script failed: external program exited with error status: 1 Sun Apr 14 12:12:29 2013 Exiting


    Was mach ich falsch? bridge-utils wurde auch installiert aber irgendwie hat er ein Problem damit.


    Danke

  • Hallo zusammen,


    Bis jetzt habe ich PPTPVPN benützt, da dies nun nicht mehr unterstützt wird und ich die Box neu geflasht habe und alle neu aufgesetzt habe, möchte ich nun das VPN mit openVPN einrichten.


    Beim Versuch das Root Zertifikat zu erstellen kommt jedoch immer die Fehlermeldung: "Can't create root certificate"


    Hier das Log-File:


    Code
    Sun Apr 28 21:56:32 2013 OpenVPN 2.1.3 mipsel-oe-linux [SSL] [LZO2] [EPOLL] built on Apr 25 2012
    Sun Apr 28 21:56:32 2013 NOTE: when bridging your LAN adapter with the TAP adapter, note that the new bridge adapter will often take on its own IP address that is different from what the LAN adapter was previously set to
    Sun Apr 28 21:56:32 2013 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    Sun Apr 28 21:56:32 2013 NOTE: --script-security method='system' is deprecated due to the fact that passed parameters will be subject to shell expansion
    Sun Apr 28 21:56:32 2013 Cannot open /etc/ssl/openvpn/dh1024.pem for DH parameters: error:02001002:system library:fopen:No such file or directory: error:2006D080:BIO routines:BIO_new_file:no such file
    Sun Apr 28 21:56:32 2013 Exiting


    Kann mir jemand helfen was ich falsch mache?
    Vielen Dank

  • geminipptpvpn geht übrigens immer noch.
    Also installieren und benutzen, wie auch via www zu verbinden.


    Das mit dem openvpn probiere ich einmal aus...

  • Würde es ja gerne mit geminipptpvpn einrichten, die installation klappt aber nicht bzw. Installiert wird es, finde es danach einfach nirgends, sollte doch weiterhin unter Daemon angezeigt werden?

  • Habe nun den ordner ssl und openvpn per ftp selbst erstellt, nun funktionierts :-) und das DH file wird gerade generiert. Trotzdem komisch.. Oder muss das Passwort eine minimallänge aufweisen? Habs ebenfalls grad verlängert.. Tja, hauptsache es geht weiter - trotzdem komisch..
    Aber wie das geminipptpvpn wieder zum laufen gebracht werden kann, wäre trotzdem interessant ;)

  • Habe es versucht so hinzuzufügen, konnte es in der Liste jedoch leider nirgends finden..?

  • Da wär vielleicht die Installationausgabe via telnet hilfreich.
    Auf der 8k hat es hier funktioniert.


    Aber das gehört in den geminipptpvpn Thread