(e2 plugin) Netatmo - Wetterstation

  • Bei mir passiert das Gleiche, habe auch schon im 7080 Image Bereich gepostet,
    da ich zuvor ein größeres "Update" (57) bekommen bzw. installiert hatte.
    Hier mein Crashlog:

  • es gibt Boxen die crashen und Boxen die weiterhin laufen, aber keine Daten mehr anzeigen.
    Also ein weig Geduld, bis cmikula online ist und sich das angeschaut hat.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Meine Box lief auch nach dem Update einwandfrei.
    Als ich dann gesehen hatte, dass das Netatmo Plugin keine Daten mehr anzeigt, bin ich
    in das Netatmo Plugin gegangen, und seitdem carshte meine Box.


    Ich habe das Plugin per Telnet deinstalliert und seitdem läuft die Box wieder.

  • crasht auch auf meiner 920hd. Habe erstmal per Edit in den "/etc/enigma2/settings" Netatmo-Enable auf false gesetzt.
    Auch die App auf dem Smartphone zeigt für das Außenmodul "Dieses Modul kann nicht mit der Station verbunden werden....." . Auf der Webseite ist alles OK. Da hat Netatmo wohl selber was verbastelt. Crash wird wohl überall der Gleiche sein.
    ....
    File "/usr/lib/enigma2/python/Screens/Screen.py", line 195, in show
    self.__onShow()
    File "/usr/lib/enigma2/python/Screens/Screen.py", line 202, in __onShow
    val.onShow()
    File "/usr/lib/enigma2/python/Components/Renderer/NetatmoPixmap.py", line 108, in onShow
    self.setSignalPixmap(self, module.rf_status)
    AttributeError: 'NoneType' object has no attribute 'rf_status'
    -------
    ]]>
    </enigma2crashlog>
    <pythonMD5sum>
    ....


    Die API-Server scheinen wohl ein Problem zu haben bei Netatmo, habe wohl Änderungen ungetestet ausgerollt und die "Hälfte vergessen" :( .

  • Hallo , Zur Info


    Heute ist bei mir das Außenmodul ausgefallen (leere Batterien )
    dadurch ist meine Box Dream 920 abgestürzt "Green"
    Auch nach Neustart ( verschiedene Image ) immer das gleiche
    erst nach wieder in Betriebnahme von dem Modul war wieder alles Ok



    mfg

    terra7


    Dream 920


    Draem One


    Dream 7080

    Edited once, last by terra7 ().

  • Das selbe heute bei mir


  • Darf man fragen, woran es lag, bzw. was Ihr von Euch aus machen konntet?

  • Hi,
    im Standby zeigt Netatmo (also mein LCD4Linux) wieder
    keine Daten an.
    Die App (Android) funktioniert einwandfrei.

  • Hier nach update gerade greenscreens.
    Habe netatmo-plugin vorerst mal deinstalliert.
    Kan jetzt wieder fern sehen !

    gr. aus die Niederlande, Mutxamel ;)

  • habt ihr auch Probleme, wenn ihr
    config.Netatmo.enabled=true
    durch
    config.Netatmo.enabled=false
    in der settings ersetzt? Dazu muss E2 natürlich gestoppt sein.


    Aber eigentlich sollte Netatmo jetzt wieder laufen.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

    Edited once, last by Jogi29 ().

  • Nein, damit funktioniert die Box, natürlich ohne netatmo

  • Ja, aber ich habe keine Lust das Plugin jeden Tag von 16:00 Uhr bis 19:00 Uhr zu deaktivieren.


    EDIT:
    es wäre halt schön, wenn sich cmikula vielleicht mal äußern könnte.
    Es ist für mich kein großes Problem, wenn das Netatmo Plugin mal ein zwei Stunden nicht funktioniert ... aber dass die Box dann permanent crasht ist
    halt schei... , denn meine Frau ist auch mal alleine Zuhause und eine Box die dann im Greenscreen hängt und permanent neu startet ist ungünstig.
    Vielleicht kann man das Plugin dahingehend umschreiben, dass bei so einem Ausfall, egal wo er jetzt genau herkommt, der Crash vermieden wird.


    Das wäre echt spitze, denn das Plugin ist wirklich der Hammer und ich nutze es permanent.