[update 0.4-r0] enigma2-plugin-extensions-mediaboot_0.4-r0_mips32el

  • Geschafft!!!!!!!!
    Endlich funktioniert es.
    Es gab nicht den einen Fehler, der beseitigt werden musste, sondern die Summe verschiedener Umstände verhinderte das Funktionieren.
    Danke an alle, die mir mit ihrem Rat zur Seite standen. Der größte Dank gebührt mfgeg. Dank seinem Tip machte ich ein Bios Reset wonach ich dann plötzlich im Bootlog die Sticks, die nicht funktionieren, eindeutig erkennen konnte und dann kam ich meinem Problem erst richtig auf die Spur. Vorher waren die Fehlermeldung bei jedem Stick gleich!
    Der eigentliche Fehler, warum es dann noch immer nicht gleich funktionierte war, dass der Boot vom Stick anscheinend nur dann reibungslos funktioniert, wenn der Stick alleine auf einem der ausgeführten USB Anschlüssen steckt. In meinem speziellen Fall hatte ich schon vor längerer Zeit, als ich das DVD Laufwerk ausgebaut hatte, den freigewordenen USB Anschluss auf der Hauptplatine mit einer USB Verlängerung nach aussen geführt. Hier steckte ich die Sticks für die mediaboot Tests an. Wahrscheinlich teilt sich dieser USB Anschluss aber den Kanal mit einemen anderen Gerät (HD, Tuner, ...) auf jeden Fall bootete kein Stick auf diesem Anschluss!
    Auf dem Frontanschluss und den beiden hinteren Anschlüssen funktioniert es nun schlussendlich (bis jetzt reibungslos)!


    Danke nochmals für die Hilfe


    LG Tina

  • Geanu 24h hat alles funktioniert. Dann hat der Stick einfach nicht mehr gebooted. Wahrscheinlich ist der Controller gestorben, denn auch am PC ist der Stick nur bei jedem zweiten mal anstecken sichtbar!
    Aber Gott sei Dank, hab' ich beim Experimentieren eine Reihe von Sticks getestet und musste nur den Stick wechseln und somit ging es gleich wieder weiter.
    Die Idee, die ich dabei geboren habe, ist, den Stick regelmäßig automatisch zu sichern.
    Die Fragen, die sich mir dabei aufdrängen, sind:


    1) Könnte man das mediaboot Plugin sohingehend erweitern, dass man die Backupfunktion automatisieren könnte?
    2) Würde es auch reichen, folgende Kommandozeile regelmäßig per crontab ausführen zu lassen:

    Code
    tar -cjpf /media/hdd/backup/my_mediabootstick_backup.tar.bz2 /


    oder müsste das Kommando anders lauten?


    LG Tina


    Edit (Ergänzung):
    Inzwischen weiss ich, dass die Idee der autom. Sicherung zwar gut ist, aber in der Praxis mit einfachen Mitteln nicht sinnvoll möglich ist. Beim Backup des Stick werden jetzt nämlich auch die in dem Moment unter /media/... verbundenen Geräte mitgesichert. Ich habe z.B. eine exterene USB HD only für Permanent Timeshift mitlaufen (die Interne 4TB HD ist mir dafür zu schade), welche beim Backup mitgesichert wird. Deshalb werde ich wohl das Backup wieder bei abgeschalteten/abgesteckten zusätzlichen HDs, Sticks, ... , also mediaboot Stick only, manuell starten.


    Edit2 (Berichtigung):
    Durch einen Fehler beim mounten hat Pernmanent Timeshift nicht auf die externe USB Festplatte geschrieben, sondern intern auf das Verzeichnis /media/extPTS auf den mediaboot Stick. Dadurch waren die Backup Sicherungen dementsprechend groß und dauerten ewig! Deshalb entstand auch meine nicht richtige Aussage oben (siehe Edit). Jetzt ist der Fehler behoben und jetzt sind meine Stick Backups wieder ca 80MB groß und somit steigt wieder mein Interesse, automatische Sicherungen durchzuführen. Hat keiner eine Idee, ob obiges Kommando reichen würde und da alles für eine Rücksicherung drinnen enthalten ist?

  • Hi,


    danke erstmal allen, die sich so lange mit dem Thema beschäftigt und die Resultate hier in Form von Code und Beiträgen publiziert haben, bis sich aus den drei Threads ein klares Bild zur generellen Vorgehensweise ergab. Ich habe mir damit einen Boot-Stick gebastelt (ohne das Plugin oder Script zu nutzen, ich wollte genau wissen wie es geht) und der hat zu meinem eigenen Erstaunen wirklich beim 1. Versuch gebootet ;)


    Mein ungutes Gefühl war damit aber nicht weg: Bei meiner 7020HD wechselten in der Vergangenheit der USB-Stick und die HDD mit schöner Regelmäßigkeit die Erkennungsreihenfolge, mal war der Stick sda und die HDD sdb und dann mal wieder umgekehrt. Dank UUID-Mount ist das an sich kein Problem, aber UUID-Boot funktioniert nur mit initrd und PARTUUID gibt's erst seit Kernel 3.8. Also muss die Erkennungsreihenfolge für die korrekte Funktion stabil sein, sonst habe ich eine 50-50-Chance dass es nicht bootet. Wie sind denn da die Erfahrungen in der Praxis bei Einsatz des Plugins? Ist ja nun eine Weile in der freien Wildbahn...


    Mein Vertrauen stieg jedenfalls deutlich, als ich diesen Kernel-Parameter entdeckte:

    Code
    usb-storage.delay_use=
    [UMS] The delay in seconds before a new device is
    scanned for Logical Units (default 1).


    Ich boote jetzt mit

    Code
    /boot/vmlinux-3.2-dm7020hd.gz rootfstype=ext4 root=/dev/sdb2 usb-storage.delay_use=3 rootdelay=8 rw console=ttyS0,115200

    was heißt, dass der USB-Stick erst ca. 3-4s nach seiner Entdeckung am Bus wirklich als Storage aktiviert wird. In der Zeit hat sich dann die HDD ziemlich sicher gemeldet und ein Race ist sehr unwahrscheinlich. Bis zum Ablauf von rootdelay ist der Stick dann mit Sicherheit da und wird gemountet (* markiert die interessantesten Zeilen):



    Bisher funktioniert das hier prächtig. In Fällen, wo also SATA HDD(s) gegen genau einen USB-Stick gewinnen müssen, damit der an einer stabilen Position landet, erscheint der Parameter daher sehr hilfreich. Ich wollte das nur an die Entwickler und Tester des Plugins zurückgeben, vielleicht hilft es dort ja auch jemandem.


    Thanks,
    An"no more UBIFS sudden death"dre.

  • Quote

    Originally posted by TiTitan

    Code
    tar -cjpf /media/hdd/backup/my_mediabootstick_backup.tar.bz2 /


    oder müsste das Kommando anders lauten?


    Ich würde kein bzip2 auf die arme CPU in der Dream loslassen. Selbst gzip mit Standard-Suchtiefe (6) schleppt sich schon ziemlich dahin. Da auf der HDD gewöhnlich endlos Platz im Vergleich zur Größe des Root-FS herrscht, kann man darauf auch verzichten. Oder man schickt den Compressor später mit nice hinterher.


    Gegen das Problem, weitere Mountpoints (wie die unter /media) vom tar auszuschließen, hilft am besten ein bind mount, der das Root-FS vereinzelt. Mal alles zusammen:

    Code
    D=`date +%Y%m%d%H%M`
    mkdir /tmp/backup-root
    mount --bind / /tmp/backup-root
    cd /tmp/backup-root
    tar cf /media/hdd/backup/root-${D}.tar .
    cd /media/hdd/backup
    umount /tmp/backup-root && rmdir /tmp/backup-root
    nice -n 19 gzip root-${D}.tar


    Das ist jetzt ad hoc hingeschrieben, in ein Script packen, testen und in Cron hängen sei dem Leser als Übung überlassen ;)


    Ob das reicht - nun, zumindest ist das Root-FS komplett drin und damit wiederherstellbar. Bequemer wäre es für das Zusammenflicken eines Ersatz-Sticks, auch noch ein tar vom /boot zu machen sowie eine Kopie vom MBR zu haben. Oder gleich ein dd-Image vom Anfang des Sticks bestehend aus MBR und der ersten Partition - die ist klein und man hat das FAT16 auch gleich mit abgefrühstückt. Da führen viele Wege zum Ziel...


    HTH,
    Andre.

  • Nabend
    Habe mediaboot erfolgreich am Laufen.
    Im flash ein DMM image auf Stick DMM und eins mit Merlin.
    Ich würde gerne mal das NN2 testen.
    Wie kann ich das NN2 auf einen Stick bekommen ohne das ich das image im Flash löchen muß.


    Gruß Uwe

  • da es keine newnigma2 tarballs gibt, entweder flashcopy oder das .nfi mit nfiextract.py entpacken und manuell auf den Stick kopieren/einrichten


    die .py findest du im OoZooN Board - aber kA ob das (noch) wunschgemäß funktioniert

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Hallo Zusammen,


    habe schon mehrere dreams 500 und 800 er mit NMediaboot gemacht...hat auch geklappt nur jetzt habe ich bei einer 500er hD das Prob nachdem ich das Mediaboot hier wieder von Seite 1 per telnet installiert habe nicht fuktioniert :-(


    wenn ich in den Erweiterungen auf das mediaboot klicke sollte normal erstmal die Zahnräder kommen und das zut es schon mal nicht!! :-( es kommt gleich der stick..ich installiere alles und neustart aber es funzt dann net mit Merlin. Autoexec.bat ist auch richtig


    /autoexec_500hd.bat


    Was mache ich falsch?


    Gruss

  • /autoexec_500hd_mb.bat


    und es kann auch vorkommen, dass bei der Installation der Stick gleich angezeigt wird, ohne Zahnräder ;)

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Hallo Marco,


    bei meiner anderen dream 500 hd habe ich spasseshalber mal das bios aufgerufen und da steht der Eintrag hier aus post 1 drinne und mediaboot funzt auch. komisch da...wenn ich über Erweiterungen das plugin starte dauerts es ewig bis ich im Plugin drin bin. jetzt nicht


    dann noch was..wenn ich das newnigma Image drauf habe langt es ja wenn ich unter Einstellungen speicher gehe da müsste ich es sehen dann..oder?


    Gruss

  • Schaut mal bitte....


    so muss also nun das Bios bei meiner 500HD aussehen und dann sollte es auch klappen mit dem booten oder? Also anstatt der 800se natürlich wie geändert die 500HD!

  • Ja was jetzt??????


    in deinem anderen Post hast das geschrieben:


    Zitat"


    /autoexec_500hd_mb.bat


    und es kann auch vorkommen, dass bei der Installation der Stick gleich angezeigt wird, ohne Zahnräder Augenzwinkern "


    und jetzt:


    /autoexec_dm500hd_mb.bat


    ?? Was stimmt jetzt?


    Gruss

  • ich hatte gestern nur deinen Eintrag um "_mb" ergänzt und nicht bemerkt, dass bei dir schon das "dm" vor "500hd" fehlt.


    Richtig ist /autoexec_dm500hd_mb.bat, das siehst du aber schon, wenn du im Bios der 500HD bist, du musst doch vor dem ".bat" nur "_mb" ergänzen, der Rest bleibt doch gleich.


    Auch bei deiner 800se steht ja dm davor, das ist bei allen Boxen so.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

    Edited once, last by Jogi29 ().

  • Zitat Entfernt! Bitte keine Fullquotes bei direkten Antworten!


    O.K. auf ein neues heute abend....;-)
    danke dir...


    Berichte..


    gell wenn ich das NN2 drauf habe sehe ich das unter Speicher dann richtig oder wie kann ich das wenn ich unter telent ls -h eingebe richtig deuten?

  • Quote

    Original von Jogi29
    ich hatte gestern nur deinen Eintrag um "_mb" ergänzt und nicht bemerkt, dass bei dir schon das "dm" vor "500hd" fehlt.


    Richtig ist /autoexec_dm500hd_mb.bat, das siehst du aber schon, wenn du im Bios der 500HD bist, du musst doch vor dem ".bat" nur "_mb" ergänzen, der Rest bleibt doch gleich.


    Auch bei deiner 800se steht ja dm davor, das ist bei allen Boxen so.


    So, jetzt hats endlich geklappt:-)


    Danke nochmal
    Gruss
    Kussel

  • Howdy,


    kurz eine Frage... Ich benutze mediaboot um das image auf einen USB-Stick laufen zu lassen. Jetzt wird der Usb-Stick, wenn von dem gestartet, ja entsprechend gemountet. Kann ich zusätzlich noch einen zweit mount auf /media/usb hinzufügen (der gleiche Stick) oder geht es nicht?
    Mein Ziel ist es, einen Swap auf dem Stick selber einzurichten.


    :em_greece::em_greece::em_greece::em_greece:
    Kein Support via PM und eMail!!

  • wieso nochmals Swap, wenn du MediaBoot richtig eingerichtet hast, wurde bereits bei der Installation eine Swappartition angelegt.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"