MEDIABOOT 0.8 mit Image von DMM Server

  • NEU: tar gezippte Images für OE2.0 dreamboxen vom DMM Server: http://dreamboxupdate.com/
    NEU: holt sich automatisch das brandneu image von DMM
    FIX OE2: swap disabled in der /etc/fstab (#) wegen Probleme beim Aufzeichnen (Ruckler)


    sonst ist alles beim Alten


    Wizard wird mitinstalliert


    Hilfe siehe wiki.


    viel Spass bei image auf USB/SD/CF/SSD installieren ;)

    Files

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Moin


    Heute ausprobiert mit eine 2GB Transcend CF Karte in der DM8000 und läuft wunderbar.

    Gruß Florian
    DM7080HD S2S2, HDD WDC WD10EARX Green 1 TB
    DMM experimental OE2.2 + GP3.3

  • Ich vermisse mein DVD-Laufwerk :evil:


    Seit dem Mediaboot habe ich heute meine erste DVD ausprobieren wollen. Leider wird das DVD-LW im Gerätemanager nicht angezeigt. Neustart der Box brachte leider auch keinen Erfolg. Beim Booten greift die Box auf die DVD zu. Hat da jemand eine Idee wo ich mit der Fehlersuche anfangen könnte??


    Gruß
    Kaiser

  • Nach etwas Recherche kam ich zu diesem Post und danach ging es. Allerdings musste ich die Box vorher nach dem Herunterfahren über den Stromschalter ausschalten. Wer weiß was da auf dem Board noch vor sich hin brummte....


    Zuerst hatte ich libdvdcss version 1.2.10-r1 vom GP-3.2 Feed genommen, damit ging es nicht. Komischerweise war dann das händische installieren gepaart mit dem Aus-Einschalten erfolgreich.


    Mal sehen ob es noch weitere Probleme damit gibt, aber zuerste einmal bin ich glücklich.



    Gruß
    Kaiser

  • Skript läuft hübsch durch, aber was ich gar nicht mag sind, Skripte, die ohne Nachfrage/Hinweis einen Reboot durchführen.


    Hast mir grad eine Aufnahme zerteilt. :-(


    Nix für ungut


    morks

  • Quote

    Original von Bschaar
    und im 1. post wird aufs wiki verwiesen



    http://wiki.blue-panel.com/index.php/Media-Boot


    Das ist schon klar. Aber es macht imho keinen Sinn.


    Wenn alles auf dem Stick installiert ist, muss ich doch noch das das Bios umstellen.
    Da hilft mir der Neustart zum Ende des Skripts nicht weiter.


    Und ja, natürlich könnte ich erst das Bios umstellen, dann bootet die Box ohne Stick aus dem Flash und nach dem Skriptdurchlauf würde die Box automatisch vom Stick booten.


    Wäre alles in allem einmal unnötigt neu gebootet.


    Wenn es denn unbedingt am Ende einen Reboot geben soll:


    Was spricht gegen eine kleine Nachfrage, ob _jetzt_ neugestartet werden soll?


    morks

  • kommt alles noch ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • "bald" :D



    und wenn du gelesen hättest wer das keine überraschung gewesen ;) (das automatische booten)

  • hallo zusammen


    ich habe nun schon stunden damit verbracht mich in die Materie media-boot einzulesen und auch zu probieren!


    mein System ist eine DM800se ohne Festplatte!
    für media-boot wird ein 4gb USB verwendet.


    ich kopiere mit dcc das Script in home/root. wenn ich es mit ./media-boot -d oder --help starte, komme immer ein Fehler bei wget.
    diesen hab ich mit dem konkreten link gefixed.


    wenn ich nun ./media.boot -i /dev/sda eingebe beginnt zwar die Routine, aber es kommen jede Menge Fehlermeldungen!
    Meiner Meinung nach geht das richtige Problem erst beim download von Mozilla im Script an, da da gar nichts geladen wird.


    die Internetverbindung steht aber!


    kann mir da jemand helfen?


    DANKE


    A.




    anbei noch das log:





    Creating journal (32768 blocks): done
    Writing superblocks and filesystem accounting information: done

    media-boot: downloading image...
    media-boot: unpacking image...
    bunzip2: root.tar.bz2: No such file or directory
    tar: can't open 'root.tar': No such file or directory
    sed: /media/usb-root/etc/fstab: No such file or directory
    ./media-boot: line 219: can't create /media/usb-root/etc/fstab: nonexistent dir
    ctory
    ./media-boot: line 220: can't create /media/usb-root/etc/fstab: nonexistent dir
    ctory
    media-boot: add some feeds...
    cp: can't create '/media/usb-root/etc/network/interfaces': No such file or dire
    tory
    cp: can't create '/media/usb-root/etc/resolv.conf': No such file or directory
    chroot: can't execute '/usr/bin/opkg': No such file or directory
    chroot: can't execute '/usr/bin/opkg': No such file or directory
    chroot: can't execute '/usr/bin/opkg': No such file or directory
    media-boot: rebooting box in 5 sec... (on boot issues: check bootlog via putty)

    Broadcast message from root@dm800se (pts/0) (Tue May 28 11:00:46 2013):

    The system is going down for reboot NOW!

  • danke für die rasche Antwort, leider...



    ... hab das script in /tmp verschoben und mit der Softwareverwaltung auf der Box installiert, ging auch schnell und hab nach gut 3 Minuten auf OK gedrückt.
    leider kann ich keine Erweiterung sehen und wenn ich bei Telnet df -h eingebe, ist auch nicht mehr Speicher ersichtlich?



    im BIOS hab ich auf autoexec_dm800se_mb.bat geändert.


    was mach ich falsch?

  • auch nach stromlos machen kann ich nichts erkennen.


    kann man ein log machen von der Installation?

  • Achte darauf das bei feste eingetragene ip, das primäre dns eingetragen ist. Sonst geht das Installation und wget Aufruf nicht. Am beste, erstmals die Box mit aktive DHCP mediaboot installieren.


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • danke, es lag an der fixen IP! DHCP ein und alles funktioniert!!


    danke an alle Helfer!!!

  • Hallo!


    Bei meiner Box im Bio unter Boot kann ich "autoexec_dm8000_mb.bat" nur 1x eintragen. Das Bild unter Wiki zeigt aber 2x an???


    LG

  • Nicht irritieren lassen ;)
    Du musst die Primary boot source: anpassen, Secondary boot source: auf flash einstellen und den USB support einschalten.