DM7025 Webinterface

  • Hallo, habe auf meiner DM7025 newnigma2 v.3.2.2 2011-07-07 mit
    Webinterface 1.6.8 und bootet von der CompactFlash Karte, alles ok.-


    So habe nun eine Frage an die Profis, gibt es eine Möglichkeit mein
    Web Interface auf die Version 1.7.1 zu modifizieren bzw. gibt es irgendwo
    eine gepatchte 1.7.1 für die DM 7025+
    Mit update und
    und über telnet
    opkg update
    opkg upgrade


    bekomme ich auch keine 1.7.1


    Danke :helpme:


    Furby

  • und welches image kannst Du mir empfehlen für die DM 7025+ OLDIE
    wo das webinterface 1.7.1 bereits enthalten ist bzw. durch update
    bekomme.


    DANKE

  • Quote

    Original von kodo
    Nö, einfach neu flashen


    Könnte er auch bei http://dreamboxupdate.com das aktuelle WebIF für seine Box laden und installieren? - Wenn Nein, warum nicht?


    Ich habe das leider auch noch nicht wirklich verstanden. :rolleyes:
    Ist das Web-Interface auch abhängig vom Image oder nur von der Box oder von beidem?

  • für die DM7025 gibt es kein Image mit aktuellerem Web-Interface, weil die Entwicklung für die DM7025 ca. 11/2011 eigestellt wurde. Das letzte experimental Web-IF ist vom 23.10.2011. Da wird neu flashen auch nicht helfen ...


    du kannst nur versuchen das Web-IF aus dem letzen stable OE1.6 Release vom Freed einer anderen Box einbauen. Ob auch das aktuelle OE2.0 Web-IF funktionert kann ich nicht sagen, musste man ausprobieren ....


    edit:

    Quote

    Original von relaht
    Könnte er auch bei http://dreamboxupdate.com das aktuelle WebIF für seine Box laden und installieren? - Wenn Nein, warum nicht?


    direkt installieren wird wohl nicht klappen, entweder manuell per ftp auf die box oder in der arch.conf z.b. temporär die dm8000 und mips32el "erlauben", dann kann man das web-if der dm8000 aus dem OE2.0 installieren.


    Aber ob das dann auch funktioniert, kann ich nicht sagen.

  • und damit ich das ganze wieder von der CF bootet
    dies hier


    mein armer flash Baustein.


    da muß ich zuerst von meiner zweiten DM 7025+ das Netzteil
    wieder auf Vordermann bringen, sonst lyncht mich meine
    bessere Hälfte, wenn da was daneben geht und Dame des Hauses
    Schnee schauen darf. ?(


    Danke voerst für die schnelle Info!


    Furby

  • war mit meiner Antwort zu langsam, da ein anderes image von der
    Webinterfaceversion nichts bringt.-


    ok brauche ich nicht neu flashen aber mit dem Beitrag von Meister
    Fred Bogus Trumper wird es auch eine Knochenarbeit , als Newbie
    mit grauen Haaren.-

  • Ich hab' dir mal zwei Pakete für die DM7025 gemacht, damit brauchst du nicht an der arch.conf rumpfuschen oder manuell installieren.


    die Version 20121104-r0 ist aus dem letzten DM8000 stable OE1.6 release
    die Version oe2.0-20130107 vom aktuellen DM8000 OE2.0 experimental Feed


    Aber keine Ahnung, ob das OE2.0 Web-IF im alten DM7025 Image läuft, da eine andere Pythonversion verwendet wird. Das für OE1.6 sollte eigenlich klappen


    Vor der manuellen Installation immer die installierte Version deinstallieren:


    opkg remove --force-depends enigma2-plugin-extensions-webinterface


    dann das .ipk nach /tmp per FTP schieben und manuell installieren, z.B.
    opkg install /tmp/enigma2-plugin-extensions-webinterface_20121104-r0_dm7025.ipk


    Hinweis: ungetestet! Benutzung auf eigene Gefahr ;)


    Edit:
    passende Webbouquet Editor Versionen hinzugefügt, falls das jemand braucht
    Vor der manuellen Installation immer die installierte Version deinstallieren:


    opkg remove enigma2-plugin-extensions-webbouqueteditor

  • würde ich nicht machen, weil dann ggfls. auch das BA, Dumbo Web-IF etc. nicht mehr funktioniert, weil die Sachen glaube ich auch in diesem Ordner sind. Bin mir jetzt aber nicht sicher, verwende das nicht (mehr).


    Falls es nicht klappt, kann man die gefrickelte Version auf gleichem Weg wieder deinstallieren und das Original wieder vom Imagefeed installieren, dann passt auch die opkg info immer.


    aber man kann auch eine "Sicherheitskopie" auf der HDD erstellen, die man dann wiederherstellen kann


    mkdir /media/hdd/Web-IF_BU
    cp -a /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/ /media/hdd/Web-IF_BU/


    Am besten wäre natürlich, wenn man die Versionsnummer des installierten Webinterfaces im Paketnamen "hochzählt", aber die Namen sind meist je nach Image unterschiedlich ...


    Aber man kann wie gesagt, auch die dm8000 ipk's mit 7-zip am pc entpacken und per ftp auf dich Box schieben, man muss dann eben auf die Dateirechte achten, wenn man den Original Ordner auf der Box umbennent ...


    ich hab' im obigen Post auch die passenden Versionen des Webbouqeut Editors hinzugefügt

  • Quote

    Original von Fred Bogus Trumper
    Hab' mal die DM7025 aus dem Keller geholt, auch das OE2.0 Web-IF funzt. Da könnte man auch gleich den Webbouqueteditor "aktuallisieren" ...


    Bitte, kannst Du mir sagen mit welchem image du arbeitest


    habe es mehrmals versucht mir platzt das image,
    CF habe vorher herausgenommen
    bootet zuerst normal, dann grün , dann geht es, dann neustart und finster


    und com schnittstelle wie geil :)


    bitte nicht falsch verstehen , meine box funzt wieder wie zuvor,
    aber es nervt wenn es bei Dir funzt und bei mir nicht.-


    Das sind die feinen Unterschiede Profi ---> niemand ;)


    Hi, und meine Freundin mußte sich noch mit der Fernbedienung der dbox2
    befreunden.-


    Aschenbecher geht über und Drogenkonsom von coffein war auch nicht ohne.-


    :jachef: :jachef: :jachef: :jachef: :jachef: :jachef: :jachef: und ich brauche eine :439: :439: :439:


    Furby

  • ok image ist wieder auf der cf, zuvor image update machen oder ist dies egal


    Danke

  • Danke Fred Bogus Trumper


    funzt jetzt 1A mit der letzten Version idreamx


    nur einen Schönheits fehler wenn ich von Pc auf das WI zugreife,
    hast Du dafür auch nocht etwas in Deiner Zauberkiste


    Danke


    Last login: Tue Jan 8 12:47:14 on console
    donalds-Mac-Pro:~ furby$ telnet 192.168.1.170
    Trying 192.168.1.170...
    Connected to 192.168.1.170.
    Escape character is '^]'.


    *****************************
    * http://www.newnigma2.to *
    *****************************
    * the next step is done *
    *****************************
    OpenDreambox
    dm7025 login: root
    root@dm7025:~# opkg remove enigma2-plugin-extensions-webbouqueteditor
    Removing package enigma2-plugin-extensions-webbouqueteditor from flash...
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebBouquetEditor/WebChilds/WebUploadResource.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebBouquetEditor/WebComponents/Sources/ProtectionSettings.pyo
    root@dm7025:~# opkg remove --force-depends enigma2-plugin-extensions-webinterfac
    e
    Removing package enigma2-plugin-extensions-webinterface from flash...
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/Toplevel.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/CurrentService.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Converter/SimpleResult.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Converter/VolumeInfo.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebIfConfig.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/__init__.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/Movie.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/LocationsAndTags.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Converter/HddInfo.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Converter/NetworkInterfaceInfo.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/ServiceListSave.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Converter/SleepTimer.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/Uploader.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/ServicePlayable.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/PowerState.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/AudioTracks.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/SubServices.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/Screengrab.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/Settings.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/RedirecToCurrentStream.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/__init__.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/Screenpage.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/AT.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/Hdd.pyo
    [Opendreambox] deleted: /usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebComponents/Sources/RemoteControl.pyo
    root@dm7025:~#
    root@dm7025:~#
    root@dm7025:~#
    Broadcast message from root (console) (Tue Jan 8 13:57:31 2013):


    The system is going down for reboot NOW!
    Connection closed by foreign host.
    donalds-Mac-Pro:~ furby$ telnet 192.168.1.170
    Trying 192.168.1.170...
    Connected to 192.168.1.170.
    Escape character is '^]'.


    *****************************
    * http://www.newnigma2.to *
    *****************************
    * the next step is done *
    *****************************
    OpenDreambox
    dm7025 login: root
    root@dm7025:~# opkg install /tmp/enigma2-plugin-extensions-webinterface_oe2.0-20
    130107_dm7025.ipk
    Installing enigma2-plugin-extensions-webinterface (oe2.0-20130107) to flash...
    Configuring enigma2-plugin-extensions-webinterface
    root@dm7025:~#
    Broadcast message from root (console) (Tue Jan 8 14:08:42 2013):


    The system is going down for reboot NOW!
    Connection closed by foreign host.
    donalds-Mac-Pro:~ furby$ telnet 192.168.1.170
    Trying 192.168.1.170...
    Connected to 192.168.1.170.
    Escape character is '^]'.


    *****************************
    * http://www.newnigma2.to *
    *****************************
    * the next step is done *
    *****************************
    OpenDreambox
    dm7025 login: root
    root@dm7025:~# opkg install /tmp/enigma2-plugin-extensions-webbouqueteditor_oe2.
    0-20130107_dm7025.ipk
    Installing enigma2-plugin-extensions-webbouqueteditor (oe2.0-20130107) to flash...
    Configuring enigma2-plugin-extensions-webbouqueteditor
    root@dm7025:~#
    Broadcast message from root (console) (Tue Jan 8 14:14:41 2013):


    The system is going down for reboot NOW!



    Nach Reboot kein crash :hurra: :hurra: :hurra:

  • glaube auch, dass die Version aus dem letzen stable OE1.6 release zu bevorzugen ist. Aber wie gesagt, wenn das OE2.0 Web-IF Probleme macht, einfach wieder deinstallieren ...


    auf meiner DM7025 funktioniert das OE2.0 Web-IF, also ich kann die Bouquets wählen, umschalten und streamen usw. Zugriff mit dreamdroid klappt auch einwandfrei


    Geräteinfo aus dem Web-IF

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Hi , jetzt funzt wirklich alles mit der oe2.0 für WI und WBE !!!!!!


    firefox , cookies und chronik löschen!!!


    und WebTV unter win864 auch!


    Quote

    Original von kodo
    Ich meine, dass das Webif zur Enigma Version passen muss.


    Bin froh das es ihad board gibt, wirklich 1A,


    jedoch kaufe ich mir bei einer neuen Android-Version kein neues Handy,
    wenn das Alte für mich seine Dienst erfüllt
    auch wenn die Industrie dies gerne hätte,
    und die ander Seite wären updates seitens der Hersteller.-


    dies ist meine persönliche Meinung und will niemanden damit auf den Slip
    treten


    :laola: