Bestellung Buntes Display Kit v2 für Dreambox DM7020/7080HD

Am Sonntag, den 2. Oktober ab ca. 9 Uhr geht das Board in den Wartungsmodus. Geschätzte Dauer: Irgendwas zwischen 12 und 24 Stunden.

Es geht hierbei um Vorbereitungen für das eigentliche Board-Update auf Version 5.5.x.

Euer IHAD Team
  • Quote

    Original von legolaender
    Juhu ; das Display funzt jetzt endlich mit NN2.
    Danke an Buck für die tolle Hardware. :335:
    Danke auch an Alle , die mir mit ihren Tipps zur Seite gestanden haben. :335:



    :408:


    Gruß -- Yoda1001

    • Official Post

    ich hatte dir doch schon den Link zu meinen Dateien gesendet


    Klick


    hier die 9. oder 10. Datei und bitte die Anleitung befolgen, nicht nur die skin_user.xml auf die Box kopieren, denn dann bekommst du mit Sicherheit wieder einen GS, weil dir Dateien fehlen.

  • Einbau hat soweit geklappt. Funktioniert in den Grundfunktionen.


    Ich hab NNOE2.0, aktuellste Version drauf, und will
    dreambox-usbtft-oe2-experimental_1.0-0-2 0130103-r4_mips32el.ipk
    installieren..


    Leider bekomm ich folgende Fehlermeldung:
    "Can not satify dependencies" ...die Installation wird dann abgebrochen.
    Wie krieg ich den nötigen Treiber nun auf die Box?


    EDIT:
    Hat sich erledigt. Hat ein Usb Treiber gefehlt. lies sich aus dem Feed nachinstallieren.

    .... Schöne Grüße ....
    ....:::: pinballl ::::....

    Edited once, last by pinballl ().

  • hallo Buck
    Danke für die dieses super TFT Display
    erstklassige Arbeit
    :groeste:
    Abteier

  • Auch ein herzliches Dankschön von mir! :hurra:
    Habe heute ein Ersatzdisplay erhalten und sofort montiert. Funzt wunderbar, nachdem beim ersten anscheinend der IR-Empfänger kaputt war.
    Umtausch war übrigens überhaupt kein Problem und sehr prompt!


    Vielen Dank Buck!

  • Nach viel querlesen, rumgefummel und unzähligen Neustarts funktioniert endlich (fast) alles wie es soll! :hurra:


    Nur bei zwei Kleinigkeiten würde ich mich über Hilfe freuen:


    1. Einige wenige Picons werden nicht angezeigt zB. SuperRTL HD, OrfHD1+2, keine Ahnunug warum.


    2. Beim abspielen einer Aufzeichnung /Film im EMC wird der Filmtitel und der Fortschritsbalken auf dem Display nur im Miniformat angezeigt. Würde mich sehr freuen, wenn mir jemand bei der Anpassung der skin_user.xml für das EMC helfen könnte. Bin sicher, auch andere User verwenden EMC. Ich nutze die skin_user.xml von Buck.


    Vielen Dank, und schöne Grüße,


    Wolfgang


    Edit: Ich hab mal versucht, einfach die ensprechenden Zeilen aus jogis skin_usr.xml zu kopieren. Die Filmauswahlwird dann schön bunt angezeigt, leider hängt sich die Box beim versuch einen Film abzuspielen sofort auf. :loudly_crying_face:

    .... Schöne Grüße ....
    ....:::: pinballl ::::....

    Edited 2 times, last by pinballl ().

  • Der Einbau war recht easy, aber die Installation ist recht knifflig.


    Bei mir wird auch nur oben links ganz klein etwas angezeigt, die Anzeige beim Videotext usw. passt aber.


    Ich habe den ganzen Thread durchgelesen, denke aber, dass ich nichts vergessen habe.


    Ich habe als Image das newnigma2 (OE 2.0) mit dem Vali.Flex HD Skin.




    Was ich bisher getan habe:


    1.)
    dreambox-usbtft-oe2-experimental_1.0-0-20130103-r4_mips32el.ipk ===> installiert


    2.)
    libusb-1.0-0_1.0.8-r4_mips32el.ipk ===> installier


    3.)
    farbige Picons ===> auf den USB Stick nach /mnt/USBDISKPart1/picon_oled


    4.)
    Skin_user-xml ===> kopiert nach etc/enigma2 (CVS_DM7020HD_Progressbar_blau von Jogi) (Rechte: 644)


    5.)
    Zombi_allConverterRotator.py und Zombi_allServiceName2.py ===> nach /usr/lib/enigma2/python/Components/Converter (Rechte: 644)


    6.)
    cb_off.png, cb_on.png, dummy.png, icon_dreamnetcast.png, icon_dvdplayer.png, icon_jukebox.png, icon_merlinmp3.png, progress-blue.png ===> nach /usr/share/enigma2/Skin_oled (Rechte: 644)


    7.)
    LCD Preferences: LCD Display ===> Customized



    Wie kann man den prüfen, ob die beiden Pakete unter 1.) und 2.) richtig installiert wurden?
    Weil bei der Installation von Paket 1.) gab es einen automatischen Neustart der Box. Anschließend beim Reboot kurz einen Grrenscreen. Der nächste Reboot war dann aber OK.


  • Hi Andy,


    Punkt 1 und 2 wurde richtig installiert.
    Wenn Dir der Displayinhalt oben links ganz klein angezeigt wird, dann hat das geklappt und der Deamon und enigma2 arbeitet auf 400x240 Pixel.
    Das liegt nun nur noch an der skin_user.xml


  • Hi,


    naja so ein paar mehr Infos wären schon hilfreich.
    welches Image, welcher Skin, und so weiter....


    Gruß Buck

    • Official Post

    Andy7411


    du verwendest eines meiner Pakete, aber die Anleitung dazu hast du nicht gelesen :winking_face: , denn darin steht der Hinweis, dass die skin_user.xml wohl nicht mit NN2 funktionieren wird, ich vermute, dass sich die Einstellungsmöglichkeiten im Image und die Converter/Renderer beißen, weil ich darin Einstellungen vornehme.


    pinballl
    du solltest zuerst überprüfen, ob überhaupt ein Picon mit der richtigen KR vorhanden ist, ich gehe davon aus, dass auch das Picon von Servus TV HD fehlt ;).


    Wegen EMC, wenn du die Screens z.B. aus meinem Paket entnommen hast, wundert es mich nicht, dass du einen GS bekommst, oder hast du auch die zusätzliche png-Datei auf die Box in den richtigen Pfad kopiert?

  • Quote

    Original von Jogi29
    ...denn darin steht der Hinweis, dass die skin_user.xml wohl nicht mit NN2 funktionieren wird, ich vermute, dass sich die Einstellungsmöglichkeiten im Image und die Converter/Renderer beißen, weil ich darin Einstellungen vornehme.


    Hi Jogi29


    Doch deine skin_user.xml funktioniert auch bestens im NN2. :winking_face: :winking_face:
    Mann muß nur in den OSD einstellungen das LCDisplay auf "Enigma2 default" stellen, daß scheinen viele zu vergessen.


    Gruß teejay

    Dreambox 900 UHD und Dreambox 920 UHD mit DMM + GP4.1 an LG-OLED65WX
    SAT: T90 mit 28,2 - 23,5 - 19,2 - 16,0 - 13,0 - 9,0 - 4,8 - 0,8 - 5,0W + (Zwangs)KabelBW/UM/VF

  • Quote

    Original von Jogi29


    pinballl
    du solltest zuerst überprüfen, ob überhaupt ein Picon mit der richtigen KR vorhanden ist, ich gehe davon aus, dass auch das Picon von Servus TV HD fehlt ;).


    Wegen EMC, wenn du die Screens z.B. aus meinem Paket entnommen hast, wundert es mich nicht, dass du einen GS bekommst, oder hast du auch die zusätzliche png-Datei auf die Box in den richtigen Pfad kopiert?



    Vielen Dank für die Hilfe!


    Ich hab die entsprechenden Picons umbenannt (die richtigen Bezeichnungen waren leicht per Google zu finden. Jetzt werden alle angezeigt.


    EMC funktioniert jetzt auch. Die .png Dateien.. ja na klar, hätt ich auch selber drauf kommen können. Vo allem, weil du ja wirklich praktische Pakete mit allem Nötigem geschürt hast).


    Soweit funktioniert jetzt alles, zumindest mit den Dateien von Buck (286x170 Picons und der emc-modifizierten skin_user.xml.


    teejay:
    Super Tipp mit "Enigma2 default" einstellung. Damit wird jogis in der richtigen Größe angezeigt. Bei Bucks Dateien muß man "Costumized" einstellen. Sehr verwirrend.
    Leider bekomme ich mitJogis skin_user.xml keine Picons zu sehen, egal wo ich die hinkopiere. Kann ich in der skin_usr.xml den Pfad definieren? Ich hab da leider keine große Ahnung..


    Ach so: ich nutze die aktuelle Newnigma2 unstable Version.


    Vielen Dank für die Unterstützung und schöne Grüße,


    Wolfgang

    .... Schöne Grüße ....
    ....:::: pinballl ::::....

  • Im Hauptverzeichnis gibt es die Verzeichnisse:
    "piconHD" und "piconlcd"


    Ich hab einen neuen ordner "picon_oled" erstellt mit den 400ern Picons. Auch ins Hauptverzeichnis. Also so:


    picon_oled
    piconHD
    piconlcd


    Geht nicht.


    Dann hab ich den Ordner "picon_oled" in den Ordner piconHD und ind den Ordner piconlcd reinkopiert. Picons werden nach wie vor nicht angezeigt.
    Ich hab den "picon_oled" an alle mehr oder weniger logischen Stellen kopiert, aber auf dem Display niemals ein Picon zu sehen bekommen. nur den normalen Text. :loudly_crying_face:


    Mit Bucks skin_user.xml bekomme ich die picons auf das Display, aber leider nur die 286x170. Die 400er werden falsch dargestellt. Außerdem gefällt mir die "JogiVersion" besser. So schön bunt und besser lesbar...



    Vieleicht bekomm ichs ja doch noch hin...mit eurer hilfe..


    Schönes Wochenende,


    Wolfgang

    .... Schöne Grüße ....
    ....:::: pinballl ::::....

  • Es bringt nichts, die picons irgendwohin zu kopieren.
    Du musst in der user_skin.xml einmal schauen, was dort für ein Pfad angegeben ist.

    • Official Post

    Andy7411
    in meiner skin_user.xml wirst du keinen Pfad finden, da dies im Renderer hinterlegt ist. :winking_face:


    in welchem Verzeichnis sind deine "normalen" Picons, also die für deinen Fernseher? In diesem Ordner musst du einen Unterordner "picon_oled" anlegen und die Picons 400x170 rein kopieren.


    Also Beispiel:
    deine normalen Picons liegen unter


    /media/usb/picon


    dann müssen die Picons 400x170 in den Ordner


    /media/usb/picon/picon_oled


    das ist schon alles.

  • Meine Antwort war auf den Beitrag von Pinball bezogen.


    Ich wollte ihm nur den Tipp geben, dass es darauf ankommt, welche skin_user.xml er verwendet, und was dort hinterlegt ist.


    Bei mir passt es mittlerweile.
    Ich habe eine andere skin_user.xml gefunden, mit der bei mir nun alles Funktioniert.



    PS:
    Grundsätzlich finde ich sollten hier auch ein paar Infos von Grautec zur Nutzung des Display kommen.
    In der Einbauanleitung wird mit keiner Silbe darauf eingegangen, wie das Display einzurichten ist. Sicher unterscheidet sich das etwas vom jeweiligen Image usw. Aber es wird finde ich etwas der Eindruck erweckt, mit dem einbau wäre es getan.
    Ohne die Hilfe der verschiedenen Foren, denke ich bekommen ein Großteil der User das Teil nicht ans laufen.