[gelöst] Keine FTP Verbindung mehr

  • Moin,


    ich kann plötzlich keine FTP Verbindung mehr zu meiner DM500 HD aufbauen.
    Im gleichen Netzwerk hängt noch eine 8000er, dort klappt es wunderbar.
    Bis gestern ging es auch noch mit der 500er, dann auf einmal nicht mehr.
    Telnet (DCC) läuft, Samba läuft, NFS läuft.


    Ich habe das DCC und FileZilla als client getestet.
    DCC: "Freambox login failed" -> Telnet funktionert aber
    Filezilla: "Unable to make a connection. Please try again."


    Wenn ich auf per telnet folgendes aufrufe:
    telnet 127.0.0.1 21
    oder
    telnet <wirklicheIP> 21
    kommt die Fehlermeldung "Connection refused"


    Ich habe dann heute noch ein update per BluePanel gemacht (man weiß ja nie), aber auch das hat nichts geändert.


    Zur Box:
    ICVS vom November 2011, logischerweise dann OE 1.6 mit Gemini Plugin. Kerni / Zombi HD1r3.


    Bevor der FTP Dienst weggesemmelt ist, habe ich versucht, von einer IP Kamera ein Bild zu speichern. Kann meiner Meinung damit nichts zu tun haben, aber der Vollständigkeit halber erwähne ich es mal...


    Bin für jede Hilfe dankbar.


    Homers

  • Keine Ideen?

  • je nach Größe des Fotos kannste dir dein image zerschossen haben.


    Mach mal im Telnet df -h

    LG
    Karl

    «Einen Menschen erkennt man daran wie er wird, wenn er was wird»


    __________________________________________________________
    Dreambox 8000HD SSCS HDD +CF 8 Gb, Merlin
    Dreambox 7020HD SC HDD
    Dreambox 500 HD S
    Dreambox 7025 SC HDD +CF 2 Gb
    Dreambox 600 S
    NAS = 2x Synology DS109 3 TByte
    TV= Samsung UE40ES6300
    SAT = 45° Ost - 30° West


    [SIZE=7]Dieser Beitrag wurde schon vor Veröffentlichung 8 mal editiert.[/SIZE]

  • Telnet geht, Samba und nfs auch.
    Habe das Foto (30 kb) versucht auf die Platte zu schreiben, also unterhalb von Media/HDD/


    Komischerweise bekomme ich auf Port 21 die Fehlermeldung, Wii oben beschrieben.
    Wie kann ich noch prüfen, ob der FTP Dienst überhaupt gestartet ist?


    Danke,


    Homers

  • Wenn FTP nicht aktiviert ist, dann kannst du auch nicht per FTP verbinden.
    Schau mal eher, ob der Daemon für FTP läuft...


    Das Programm dafür heißt "vsftpd" und liegt unter /usr/sbin...

  • Firewall denke ich nicht, da ich ja alles andere per Port 21 hier im Netzwerk ansprechen kann.
    Sorry, aber wie bekomme ich die Prozessliste angezeigt, m zu schauen ob der Daemon läuft?

  • hmm, nix mit vsftpd in der Prozessliste.
    Habe zur Kontrolle noch mal auf die 8000er geschaut, und da ist brav vsftpd aufgelistet.
    Bedeutet nun also, dass mein FTP Dienst nicht läuft...


    Wie bekomme ich den wieder ans rennen?
    Und was kann den zerlegt haben??

  • Code
    /dev/mtdblock3 60.0M 47.3M 12.8M 79% /
    udev 2.0M 324.0K 1.7M 16% /dev
    /dev/mtdblock2 3.8M 2.5M 1.3M 67% /boot
    tmpfs 67.0M 3.3M 63.7M 5% /var
    tmpfs 67.0M 24.0K 66.9M 0% /tmp
    /dev/sda1 458.4G 181.6G 253.6G 42% /media/hdd
    /dev/sdb1 14.8G 557.5M 13.5G 4% /media/BA
  • Kann man den FTP Dienst nicht via GP3 starten stoppen ??


    Wenn nicht mal per telnet versuchen mit /etc/init.d/inetd restart

  • Wüsste nicht, wo das im GP3 geht...


    Code
    root@dm500hd:~# /etc/init.d/inetd restart
    Restarting internet superserver: inetd Hangup


    Simsalabim, da isser iweder....
    Genial, aber warum zum Geier hat sich der Dienst weggehängt?
    Und ist nicht bei einem vollen Neustart dann mit gestartet?


    Wenn ich das irgendwo in der UI ein und abschalten kann, dann habe ich es nicht gefunden.


    Danke Ben!


    Ich prüfe jetzt noch mal, was bei einem Neustart passiert...

  • Echt merkwürdig...
    Ich kann das hier forcieren...


    Ich hatte den Passiv Mode bei den FTP settings der Kamera nicht eingeschaltet.
    Versuche ich dann ein Testbild hoch zu laden (aus der UI der Kamera settings heraus, Test Button), ist mein FTP Dienst weg.


    Einmal das magische /etc/init.d/inetd restart, alles wieder gut.
    Passiv mode an, kein Probleme.


    Falls jemand die Muße hat das zu erklären, ich würde es gerne verstehen.
    Wenn nicht, besten Dank noch mal für die Hilfe.

  • ich kann es dir nicht erklären ,sorry.


    Evtl übernimmt die Kamera mit den aktiv Einstellungen den FTP Part,was sie eben im passiv Mode nicht macht ,und dadurch die Box nicht beeinflusst.