DM800 + Synology DS110j kein NFS möglich

Wir haben aktuell ein Problem mit dem Board und arbeiten an der Lösung...


-> Aktuell bereiten wir das Upgrade auf die aktuelle Version 6 von Woltlab vor.
  • Hallo Gemeinde,
    zwei Tage Foren durchstöbern, installieren von plugins, Einstellungen auf Dream und NAS - kein Erfolg.


    Facts:


    DM800 IP 192.168.0.36
    NAS IP 192.168.0.35



    auf dem NAS ist das Verzeichnis /volume1/music per NFS freigegeben.


    die /etc/auto.network auf der DREAM hat folgenden Eintrag:


    cs_music -fstype=nfs,rw,nolock,soft,tcp,rsize=8192,wsize=8192 192.168.0.35:/volume1/music


    nach Neustart der Box, oder einem /etc/init.d/autofs restart ändert sich nichts, der Befehl mount zeigt nichts von einem Netzwerk-Mount an.


    Habe den Netzwerkbrowser gestartet und hier wurden alle Freigaben als CIFS gefunden, zusätzlich auch meine NFS Freigabe music


    Habe diese aktiviert und speichern lassen (in welche Datei speichert der networkbrowser die Daten?)


    Neustart brachte keinerlei Verbesserung. /media/net
    root@dm800:/media# ls -l
    drwxr-xr-x 2 root root 0 Jun 8 19:32 card
    drwxr-xr-x 3 root root 0 Jun 16 15:16 cf
    drwxr-xr-x 13 root root 4096 Jun 28 16:56 hdd
    drwxr-xr-x 2 root root 0 Jun 8 19:32 mmc1
    drwxr-xr-x 2 root root 0 Jan 1 2000 net
    drwxr-xr-x 3 root root 0 Jun 16 15:16 ram
    drwxr-xr-x 2 root root 0 Jun 8 19:32 realroot
    drwxr-xr-x 2 root root 0 Jun 8 19:32 union
    drwxr-xr-x 3 root root 0 Jun 16 15:16 usb


    root@dm800:/media# ls -l net
    root@dm800:/media#



    und glaubt mir, bevor ich das Forum nerve lese ich und versuche mein Bestes. Ich bin zu blöd, oder was weiß ich.


    Hat jemand eine Idee?

  • Hi,


    ich kenne aber nur die automount.xml unter /etc/enigma2



    Müsste so ungefähr ausschauen. Ganz wichtig auf die Klein- und Großschreibung achten.


    MfG Gerry

    Gruß Gerry

    Edited 3 times, last by gerry6n ().



  • Habs auch gerade gefunden.
    Da der Browser die Freigaben findet, und auch korrekt abgespeichert hat, wundert es mich um so mehr, dass die Verzeichnisse nicht gemounted werden?!

  • Dann schau mal unter /media/net/ :winking_face:


    Oder tippe mal "mount" ein unter Telnet


    MfG Gerry

    Gruß Gerry

    Edited once, last by gerry6n ().

  • root@dm800:/# ls -l /media/
    drwxr-xr-x 2 root root 0 Jun 8 19:32 card
    drwxr-xr-x 3 root root 0 Jun 16 15:16 cf
    drwxr-xr-x 13 root root 4096 Jun 28 16:56 hdd
    drwxr-xr-x 2 root root 0 Jun 8 19:32 mmc1
    drwxr-xr-x 2 root root 0 Jun 28 17:27 net
    drwxr-xr-x 3 root root 0 Jun 16 15:16 ram
    drwxr-xr-x 2 root root 0 Jun 8 19:32 realroot
    drwxr-xr-x 2 root root 0 Jun 8 19:32 union
    drwxr-xr-x 3 root root 0 Jun 16 15:16 usb
    root@dm800:/#


    root@dm800:/# ls -l /media/net/
    root@dm800:/#


    Genau wie oben schon beschrieben. Noch eine Idee?

  • was sagt denn die konsole wenn du's manuell von telnet mountest?


    Code
    mount -t nfs 192.168.0.35:/volume1/video /media/net/video -o rw,soft,tcp,nolock,rsize=32768,wsize=32768


    Und auch auf deiner DiskStation die Order per NFS freigegeben fuer alle?


    PS> Ich h'ng auch mal meine automounts datei an, damit mounted er erfolgreich meine diskstation auf der dreambox

  • Aah! Nun kommen wir der Sache schon näher. Verstehen tu ich es aber trotzdem nicht.


    root@dm800:/# mount -t nfs 192.168.0.35:/volume1/video /media/net/video -o rw,soft,tcp,nolock,rsize=32768,wsize=32768


    mount: 192.168.0.35:/volume1/video failed, reason given by server: Permission denied
    mount: mounting 192.168.0.35:/volume1/video on /media/net/video failed: Bad file descriptor


    root@dm800:/#


    Bei der Diskstation habe ich noch einmal überprüft. Die Freigaben sind korrekt. Sind alle 3 dem admin zugeordnet, lesen- sowie schreiben zugelassen.

  • Dann sind die Ordner vermutlich nicht richtig freigegeben auf der DiskStation, bei NFS muss immer explizit gesagt werden welche IP's zugriff haben dürfen, oder wie bei mir einfach nur ein * rein (siehe screenshot). Notfalls die Diskstaion auch mal neu starten oder NFS neu installieren. Ansonsten weiss ich auch nich wirklich, fehler scheint aber bei der diskstation zu liegen und nich an der dreambox

  • bin weiter!


    Muss ein BUG an der Enigma sein!



    root@dm800:~# mount -t nfs 192.168.0.35:/volume1/video /media/net/video -o rw,soft,tcp,nolock,rsize=32768,wsize=32768
    mount: mounting 192.168.0.35:/volume1/video on /media/net/video failed: No such
    file or directory


    aber!


    root@dm800:~# mount -t nfs 192.168.0.35:/volume1/video /media/net/ -o rw,soft,tcp,nolock,rsize=32768,wsize=32768
    root@dm800:~#


    hängt mir sofort den NAS ein, aber unter /media/net.


    Das heißt, das System oder auch root kann keinen Unterordner im ordner /media/net anlegen!


    root@dm800:~# mkdir /media/net/VIDEOTEST
    mkdir: can't create directory '/media/net/VIDEOTEST': Permission denied
    root@dm800:~#


    Oder wieder Denkfehler?


    Jedenfalls sind alle Filme in dem /media/net/ aufgelistet

    • Official Post

    Ist kein E2 Bug...


    Man mountet auch nicht manuell nach /media/net :winking_face:
    Das gehört dem autofs.


    Zum testen am besten einen Ordner in anlegen z.B. /media/test
    und dahin mounten


  • Hallo Homey, da ich daselbe Problem habe hänge ich mich mal hier dran. Ich habe mal eben per Konsole gemountet. Die Ausgabe lautet wiefolgt
    root@dm8000:~# mount -t nfs 192.168.0.140:/volume1/dreambox /media/net/video -o
    rw,soft,tcp,nolock,rsize=32768,wsize=32768
    mount: 192.168.0.140:/volume1/dreambox failed, reason given by server: Permissi
    n denied
    mount: mounting 192.168.0.140:/volume1/dreambox on /media/net/video failed: Bad
    file descriptor


    Meine auto.network sieht so aus
    NAS-Aufnahmen -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.0.110:/Dreambox


    Gemeinsamer ordner ist auf der DS 213+ erstellt Berechtigungen stehen auf lesen schreiben.
    NFS ist freigegeben auf dem NAS
    Ein entsprechender Benutzer (ich habe ihn dm 8000 ) genannt ist ebenfalls auf dem NAS erstellt und ihn Lese/Schreibrechte auf den Ordner Dreambox vergeben.
    Kannst du mir sagen, was ich noch versuchen könnte.
    Achja, nach einen reboot der Dream sehe ich die Freigabe unter Speichergeräteliste, wenn ich ihn anwähle liegen aber keine Dateien drin,obwohl ich ein Video eingefügt habe. Nachdem ich wieder zurück in die Speichergeräteliste wechsel, ist die Freigabe wieder verschwunden.... :face_with_rolling_eyes: :face_with_rolling_eyes: erst nach reboot wieder vorhanden
    Grüsse Mattys