138 updates im Addons Server???

  • Ich habe ein Problem mit dem Addonserver im Gemini 3.2 Blue Panel. Bei mir stehen immer 138 Updates dort drin stehen abwohl gar keine vorhanden sind. Und wenn doch welche da sind dann werden die oben drauf addiert. Sind keine Updates vorhanden und ich drücke "zeige Updates" bekomme ich einen green screen. (siehe dateianhang).
    Ich habe so`n ähnlich Post hier am Wochenende auch schon mal geschrieben, aber leider noch keine Antwort bekommen. :rolleyes:


    Deshalb habe ich ebend noch mal das Geminiplugin deinstalliert und noch mal neu installiert aber die 138 Updates waren gleich wieder da. ?(


    Hat nicht vielleicht doch mal jemand ne Idee woran das liegen könnte, oder weiss vielleicht jemand wo ich die 138 Updates manuell auf null setzen kann? :331:

  • Hi,


    Nur so eine Idee...


    Schau' mal nach dem Verzeichnis "opkg" unter /hdd/var/lib/opkg und lösche ihn.
    Wenn im BP (Einstekllungen/Allgemein) "nur Root bei OPKG nutzen" ein ist, dann befindet sich der Ordner nicht auf der Platte, sondern unter /var/lib/.


    Mach' dann - am besten per telnet - ein opkg update && opkg upgrade.


    Und berichte bitte, ob es geholfen hat.


    Grüße
    ...jp

    Grüße
    ...jp


    DM900 / OE2.5 Experimental ... und sehr glücklich damit :)

  • danke juanito_perez für deine schnelle Antwort. Leider hat das ganze nicht geholfen. Auf meine Festplatte war dieser OPKG Ordner und darunter war noch ein INFO Ordner der allerdings leer war und eine Statusdatei die auch leer ist.


    Allerdings befindet sich der OPKG Ordner auch im Flash unter /var/lib und da steht ganz schön viel drin obwohl die Einstellung unter BP (Einstekllungen/Allgemein) "nur Root bei OPKG nutzen" auf AUS steht. Habe die datei mal angehängt.

  • Quote

    Original von dr.hinkefuss
    danke juanito_perez für deine schnelle Antwort. Leider hat das ganze nicht geholfen. Auf meine Festplatte war dieser OPKG Ordner und darunter war noch ein INFO Ordner der allerdings leer war und eine Statusdatei die auch leer ist.


    Allerdings befindet sich der OPKG Ordner auch im Flash unter /var/lib und da steht ganz schön viel drin obwohl die Einstellung unter BP (Einstekllungen/Allgemein) "nur Root bei OPKG nutzen" auf AUS steht. Habe die datei mal angehängt.


    Hmm, da hatte wohl was nicht geklappt mit dem Dateianhang, deshalb noch mal ein Versuch. ;)

    Files

    • opkg.zip

      (961.11 kB, downloaded 16 times, last: )

  • so habe mal den OPKG Ordner im Flash unter /var/lib/ gelöscht. Danach deinen Befehl per Telnet ausgeführt, der funktionierte allerdings dann nicht mehr weil ihm jetzt der OPKG Ordner fehlte. Allerdings hatte ich jetzt nur noch 2 Updates im Addons.Server.
    Dauraufhin habe ich den OPKG Ordner wieder angelegt und wieder deinen Befehl ausgeführt und prombt stehen sie wieder drin die 138 Updates.


    Was sagt mir das jetzt? :rolleyes:

  • Quote

    Original von netman
    Und was macht der Befehl: opkg upgrade


    nabend netman


    also ich versuche es mal hier dazustellen was ich alles jetzt probiert habe. Wenn ich den OPKG Ordner im Flash lösche dann ist der Addons-Server sehr schnell und zeigt nur zwei Updates an. Allerdings darf ich dann nicht "Updates anzeigen" wählen sonst kommt GREEN SCREEN.
    Lege ich jetzt den OPKG Ordner wieder an und starte dann den Addons-Server dann ist dieser erstmal ziemlich langsam und es tauchen dann wieder die 138 Updates auf. Lösche ich dann den Inhalt des OPKG Ordners und starte dann die Box neu, ist danach der Ordner immer noch leer. Also für mich sieht das so aus also ob die Information die im OPKG Ordner stehen immer vom Addons-Server kommen und wenn ich den Ordner lösche kann er dort keine Daten mehr reinschreiben und deshalb stehen dann nur noch 2 Updates da, wobei ich mich Frage wie er das macht ohne Ordner? :rolleyes:
    Und dein Befehl den ich über Telnet eingeben sollte legt nur einen leeren Unterordner in den OPKG Ordner an der "Info" heisst. ;)

  • Hallo,


    Du brauchst jetzt nicht etliche Varianten mit Löschen des OPKG-Verzeichnisse zu testen. Die Idee war nur, dass darin etwas nicht überschrieben werden kann und deswegen Deine Updates stecken bleiben.


    Mach' bitte, was netman schreibt:


    Geh' mit Telnet auf die Box und gibt ein opkg upgrade und poste hier die Ausgabe.
    Solltest Du das opkg-Verzeichnis zwischenzeitlich wieder gelöscht oder manupuliert haben, dann gibt sicherheitshalber opkg update && opkg upgrade ein.


    Es deutet einiiges darauf hin, dass die Installation der Updates fehlschlägt, nur werden wir das ohne Ausgabe von opkg upgrade nicht erfahren ;)


    ...jp

    Grüße
    ...jp


    DM900 / OE2.5 Experimental ... und sehr glücklich damit :)

  • Das es crashed ist ganz normal. Ohne das Verzeichnis (was man halt nicht einfach löscht)
    geht es halt nicht.


    Ich denke deine Paketquellen werden nicht richtig eingelesen. Poste mal bitte den output
    von opkg update komplett hier.


  • Ok juanito_perez, ich habe die sicher Variante vorgezogen, grins ;)

  • Quote

    Original von netman
    Das es crashed ist ganz normal. Ohne das Verzeichnis (was man halt nicht einfach löscht)
    geht es halt nicht.


    Ich denke deine Paketquellen werden nicht richtig eingelesen. Poste mal bitte den output
    von opkg update komplett hier.


    Ok netman, habe dir hier die Daten angehängt. Bin mal gespannt was du da rauskriegst. 8)

  • Quote

    Original von netman
    Bei dir passen die updatefeeds nicht zum Image.


    Welche Image verwendest du?


    OE 2.O Experimental vom 02.06.2012 :rolleyes:

  • Quote

    Original von netman
    Dann hast du wohl per Backup die falschen feeds eingespielt. Am besten du flashed
    neu.


    hmm, per backup die falschen feeds eingespielt, wie geht das?


    Ich hatte das Problem als ich das neue Image reingespielt hatte, wollte ich gleich mit dem Wizard das Geminiplugin installieren. Das hatte der Wizard auch gemacht und einen Neustart ausgeführt nur war danach nichts vom Geminiplugin zu sehen. Daraufhin habe ich ein Softwareupdate über Einstellungen/Softwareverwaltung/Software aktualisieren gemacht und siehe da, nach dem Neustart war das Geminiplugin dann auch da. ;)
    Und von da an standen auch diese verfluchten 138 Updates im Addons-Server. :baby:

  • Hallo,


    möglcheweise kann dir


    opkg update && opkg upgrade -force-overwrite


    Befehl weiter helfen.


    Per Telnet oder SSH natürlich



    Gruß