[Boblight SupportThread] Update: 11-02-2014, Boblight 0.8R6

  • hm, geht...!


    kein plan - war gestern Nacht wohl doch schon etwas zu spät...


    ich weiß auch ehrlcih gesagt nicht warum es heute funzt... :rolleyes:


    naja... hauptsache geht! :hurra:


    nur so am rande:


    CPU-Last boblightd@AliX 72 Channel: ~40% bei SKY-HD und ~65% bei BluRay/XMBC HTPC


    funzt super...!


    meine 7020HD war doch manchmal ein wenig "überfordert", weil vorher:


    boblightd@DM7020HD: ~60% CPU SKY-HD + 30-50% CPU boblight-enigma2
    boblightd@XBMC HTPC: 90-100% CPU BluRay

  • kleiner Bericht:
    Nach neu flashen und langwieriges einrichten funktioniert das Seduboard nur mit Jumper
    Es verändert sich was passt aber nocht nicht zum Bild ud ist langsam.
    Da werde ich wohl noch Stunden mit verbringen.


    Was mir noch aufgefallen ist :
    die CPU Last steigt bei der aktivierung von Boblight von 5 % auf über 70 %

  • genau deshalb habe ich den boblightd ausgelagert auf einen AliX :)


    debian-for-alix auf eine 2GB CF-Card - alle unbenötigten vorinstallierten Dienste beendet und ab geht's


    boblightd config:



    gestern noch getestet - läuft super-smooth bei max. 40%CPU-Last AliX... bin begeistert :hurra:


    @ Dev's


    great Job!!! works like a charm...! Thank you!

  • So jetzt läufts.
    Ich bin auf die r09 zurück gegangen,
    Sedu Board funktioniert nur mir mit dem Jumper.


    Dann gab es das Problem, das die Farben nicht gepasst haben,
    obwohl ich am PC BGR eingestellt hatte,
    an der Config drehen hat auch nicht viel gebracht.


    Aber der Befehl Constante hat mich drauf gebracht :


    [device]
    name ambilight
    output /dev/ttyUSB0
    channels 378
    type momo
    interval 20000
    prefix 5A B0
    postfix A5
    rate 500000


    [color]
    name red
    rgb FF0000
    gamma 1.0
    adjust 1.0
    blacklevel 0.0


    [color]
    name green
    rgb FF00
    gamma 1.0
    adjust 1.0
    blacklevel 0.0


    [color]
    name blue
    rgb FF
    gamma 1.0
    adjust 1.0
    blacklevel 0.0



    und damit läuft es einwandfrei.




    Danke nochmahl für Eure bemühungen.

  • UPDATE


    Boblight 0.5r14.


    - Fixed sedu prefix (you can now set type to sedu in boblight.conf without prefix and postfix)


    - New video buffer
    - added support for brcm7358 and 7356
    - Better cpu performance
    - Buildin configcreator in gui
    - Network support, send values from xmbc or pc
    - Picture dump fixed.
    - Fixed some errors in install script.
    - A lot of little fixes
    - Clean up code


    Update 26-12-2012:


    - Fixed greenscreen (option in menu, Config creator, Type selection)
    - Fixed moodlamp and test over network
    - Fixed About screen
    - Set priority default to 20


    Boblight UpdateThread, Last update: Boblight Enigma2 v 0.5r14


    Kind regards Speedy1985

    if you like this project and want to support me, buy me a beer ;) Thanks!!

    Edited 8 times, last by speedyisfast ().

  • mit der R14 geht jetzt leider gar nichts mehr, sobald das Plugin gestartet wird, gibt es einen greenscreen. :-(


    in der R12 konnte man wenigstens das Plugin aufrufen und ein paar einstellungen machen und erst wenn man auf die netzwerkeinstellungen oder so gegangen ist, hat es sich verabschiedet.


    Habe auch die Skins getauscht, gleiches problem. Ein Crashlog wird auf /hdd erstellt, ist aber 0 KB groß.


    geht bei irgendeinem die R12 oder R14 ???


    Image ist NN2


    greetz
    Tomster

  • Works good!


    now Networksetup is available without greenscreen - but Moodlamp don't work for me


    Thx!!


    small Question: Interval - has it effect for boblight-enigma2 Client if boblightd is not running @ dream?


    I thought Interval is only for boblightd process...?


    greetings

    Merlin³ OE2.0|boblight-enigma2-0.8r3
    archlinux&boblightd2.1@raspberry[gpio]>72Chan.PIX


  • Hi.
    The interval is for the cliënt.
    So it has no effect with only deamon running... :)


    But moodlamp not working?
    Whats the problem. crash or something..


    Kind regards Speedy1985

    if you like this project and want to support me, buy me a beer ;) Thanks!!

  • no Crash. Moodlamp just don't work...


    it has no effect to enable or disable


    don't know but could it be a problem that my boblightd is running only on dedicated AliX?


    not running @ Dream anymore


    greetings

    Merlin³ OE2.0|boblight-enigma2-0.8r3
    archlinux&boblightd2.1@raspberry[gpio]>72Chan.PIX

  • more Tests:


    there's no connection to boblightd @ alix when enable Moodlamp


    the following process is running @ dream when choosing Moodlamp:


    Code
    26565 ? S 0:00 /usr/bin/boblight-chase 5 1c6ba0 -o speed=33 -o saturation=1.1 -o value=6 -o threshold=20 -o gamma=2.0


    it seems there's missing server-ip...


    if i start on Dream with:


    Code
    /usr/bin/boblight-chase 5 1c6ba0 -o speed=33 -o saturation=1.1 -o value=6 -o threshold=20 -o gamma=2.0 -s xxx.xxx.xxx.xxx


    it works a expected

    Merlin³ OE2.0|boblight-enigma2-0.8r3
    archlinux&boblightd2.1@raspberry[gpio]>72Chan.PIX


  • Ok. So i get it.
    I wil mke a update this evening.


    Kind Regards Martijn

    if you like this project and want to support me, buy me a beer ;) Thanks!!

  • found another Bug:


    Config -creator


    if choose "Device Output" --> greenscreen...


    Bugfix


    change Line 410 in plugin.py


    before:


    Code
    config.plugins.Boblight.type = ConfigSelection(default = "karate", choices = [("Karatelight", "Karatelight"), ("Oktolight", "Oktolight"), ("Atmolight", "Atmolight"), ("Sedulight", "Sedulight"), ("Adalight 25 Leds", "Adalight 25 Leds"), ("Adalight 50 Leds", "Adalight 50 Leds"), ("Adalight 100 Leds", "Adalight 100 Leds")])


    after


    Code
    config.plugins.Boblight.type = ConfigSelection(default = "Karatelight", choices = [("Karatelight", "Karatelight"), ("Oktolight", "Oktolight"), ("Atmolight", "Atmolight"), ("Sedulight", "Sedulight"), ("Adalight 25 Leds", "Adalight 25 Leds"), ("Adalight 50 Leds", "Adalight 50 Leds"), ("Adalight 100 Leds", "Adalight 100 Leds")])


    then it works... :)


    /edit


    Config-creator - yellow Button "Test config" don't work - no light's at all


    same behavoir as Moodlamp - no connect to dedicated AliX


    greetings


    Michael