[Boblight SupportThread] Update: 11-02-2014, Boblight 0.8R6

  • erstml danke.
    prefix und postfix hab ich geändert.
    Kanäle auf 16 geändert


    boblight-enigma2 funktioniert nicht, er kennt den Befehl nicht.
    wenn ich boblightd starte , wird boblight-enigma2 in den Systemprozessen ( TOP ) mit angezeigt.


    das ist die Ausgabe:


    Connecting to boblightd
    (CClientsHandler::Process) 127.0.0.1:55872 connected
    (CClientsHandler::ParseMessage) 127.0.0.1:55872 said hello
    Connection to boblightd opened
    (CClientsHandler::ParseSet) 127.0.0.1:55872 priority set to 128
    Gamma not set, using 2.2 since this is default for video
    [grabber] found STB-Type 2
    [grabber] Maximum intermediate-picture-size is 128px
    [grabber] Sync mode enabled
    [grabber] Blackbar mode enabled
    [grabber] Found 16 lights
    [grabber] Setting Resolution to 60x72 (Source 480x576)



    Aber am Licht ändert sich nichts


  • Hi, Try this new daemon. I have build in the prefix for sedu now.


    You have to set this in boblight.conf:


    type sedu
    rate 50000


    remove the prefix and postfix from the config.


    Let[ try :)

    Files

    if you like this project and want to support me, buy me a beer ;) Thanks!!

  • ok, dann graben wir erstmal ein wenig tiefer :-)


    generell rede ich davon, die befehle auf der konsole einzugeben und nicht mit fernbedienung das plugin starten. wenn du z.b. bobl eintippst und dann mittels der TAB taste (ein paar ma. drauf drücken) autovervollständigen benutzt, siehst du welche befehle vorhanden sind.


    du kannst auch erstmal

    Code
    boblight-chase 3 FF

    anstatt boblight-enigma2 benutzen (zum testen)


    ich sehe, du hast 500000 bps eingestellt, bist du sicher dass das so korrekt ist? (diesmal wäre eine antwort schön :)). ich glaube nciht dass das korrekt ist. hier die org config von boblight.

    Code
    [device]
    name device1
    output /dev/ttyACM0
    channels 12
    type momo
    interval 20000
    prefix FF
    rate 19200


    die reden von ttyACM0 (CDC device) du hast eingestellt ttyUSB0 (serial FTDI oder PL2303).
    um das thema korrekt in den griff zu bekommen am besten wie folgt vorgehen:


    1. Momo light von dreambox trennen
    2. dmesg eingeben
    3. dann nach ca 5 sek wieder einstecken
    4. dmesg eingeben und die zusätzlichen zeilen hier posten.


    dann wissen wir erstmal was da eingelötet ist :)



    mach mal:

    Code
    stty -F /dev/ttyUSB0


    und poste mal die Ausgabe.


    dann

    Code
    stty -F /dev/ttyUSB0 19200


    damit stellst du die Schnittstelle auf 19200bps manuel ein. ich vermute die wird standardmäßig auf 57600 / 115200 / oder 0 eingestellt sein.


    in der config die 500000 auf 19200 ändern


    nochmal testen. (daemon neu starten)


    wenn das nicht klappt, am besten wieder auf den original wert stellen


    wenn du sagst auf anderen systemen funktioniert dein modul, sind das linux systeme ? wenn ja, kannst du da die aktuelle schnittstellengeschwindigkeit rausfinden? (mit stty)


    Ich habe speedy auch mal angeschrieben, wie es mit der implementation von momo light aussieht. melde mich dann wenn er geantwortet hat.


    viel glück :)


    edit: ok, just saw, speedy is fast :-)

    [SIZE=6]
    Schaltet Bluetooth auf euren mobilen Geräten aus, wenn nicht benötigt. Dadurch halten die Akkus ca. 3x länger + Netzteil muss seltener an die Steckdose[/SIZE]

    Edited once, last by denim ().

  • Sedu muss man mit 500kbaud betreiben (/dev/ttyUSB0).

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • danke mamba :)
    weisst du ob "type momo" korrekt ist, muss da nicht sedu rein?
    ich kenne das protokoll zu wenig, sonst würde ich gerne mal nen test wie:
    echo -ne "\xFF\x00\x00\xFF\x00\x00\xFF\x00\x00-....." ausführen



    @ andy906090
    ok, dann kannst du dir die einstellerei mit der schnittstellen geschwindigkeit sparen.


    Versuch mal die version von speedy.

    [SIZE=6]
    Schaltet Bluetooth auf euren mobilen Geräten aus, wenn nicht benötigt. Dadurch halten die Akkus ca. 3x länger + Netzteil muss seltener an die Steckdose[/SIZE]

    Edited once, last by denim ().

  • momo geht. Habe das selbst ausprobiert. Prefix weiss ich nicht mehr, aber aber glaub so, wie angegeben. Kann mal suchen, falls du das sicher wissen musst.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Diese Config funktionierte damals bei mir:

    Code
    [device]
    name ambilight
    output /dev/ttyUSB0
    channels 768
    type momo
    interval 50000
    prefix 5A B0
    postfix A5
    rate 500000

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited 2 times, last by mamba0815 ().

  • ok, dann denke ich mal das ein

    Code
    stty -F /dev/ttyUSB0 500000


    helfen sollte :)


    nur 768 sollte man auf die tatsächliche anzhal der LEDs (LEDs*3) runterschrauben, da sonst die cpu last unnötig hochgeht

    [SIZE=6]
    Schaltet Bluetooth auf euren mobilen Geräten aus, wenn nicht benötigt. Dadurch halten die Akkus ca. 3x länger + Netzteil muss seltener an die Steckdose[/SIZE]

    Edited once, last by denim ().

  • Sind halt 256 Kanäle a 3 Byte plus Overhead. Die Anzahl Kanäle wird durch den Mode (z.B. "B0") vorgegeben. Les dir am besten mal Turis Manual zum Sedu durch.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • [23787.975000] usb 1-1.3: USB disconnect, device number 4
    [23787.976000] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
    [23787.976000] ftdi_sio 1-1.3:1.0: device disconnected
    [23792.749000] usb 1-1.3: new full-speed USB device number 5 using ehci-brcm
    [23792.835000] ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
    [23792.835000] usb 1-1.3: Detected FT232RL
    [23792.835000] usb 1-1.3: Number of endpoints 2
    [23792.835000] usb 1-1.3: Endpoint 1 MaxPacketSize 64
    [23792.835000] usb 1-1.3: Endpoint 2 MaxPacketSize 64
    [23792.835000] usb 1-1.3: Setting MaxPacketSize 64
    [23792.839000] usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB0




    root@dm8000:~# stty -F /dev/ttyUSB0
    speed 0 baud; line = 0;
    intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>;
    start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
    -brkint -icrnl -imaxbel
    -opost -onlcr
    -isig -icanon -echo -echoe -echok -echoctl -echoke



    Alles soweit abgearbeitet, die lichter wollen nicht hell werden.


    Scheinbar ist eine verbindung zum sedu da grabben tut er auch aber umsetzten macht er nicht.


    Die andere boblightd hab ich ausprobiert, keien änderung

  • hast du in deinem Sedu auch die richtige Firmware? Die muss 500kbaud können und im Sedu muss ein Jumper gezogen werden, damit es 500kbaud macht.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • ich hab es schon geöffnet, es ist kein jumper da.
    Ich habe als PC Betriebsystem Win 7

  • Äh .. wie? Win7? Haste das Sedu nicht an der Dreambox?

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Ich hab am PC probiert ob es überhaupt läuft,
    und hab dann mich an die Dreambox gemacht, nur die ist zickig.

  • Hallo Leute,


    kann mir jemand einen Tip geben wie ich das boblight-Addon manuell per Netzwerk konfiguriere?


    Ich kann im Plugin-Menu nicht Network-Setup anwählen --> greenscreen


    meine weitere Config:


    boblighd@AliX - weil auf der Dream zuviel CPU-Last ü60%
    boblight-constant auf dem AliX geht
    XBMC Plugin HTPC zum boblightd@AliX geht 1a
    boblight komplett über die Dream geht ebenfalls


    boblight-enigma2 connectet sich aber nicht zum boblightd@AliX


    wenn ich boblight-enigma2 über die shell starte:


    Code
    boblight-enigma2 -s 192.xxx.xxx.xxx


    dann geht's


    habe schon in den Enigma settings eingetragen:


    vorher init 4


    Code
    config.plugins.Boblight_grab.network_onoff=true
    config.plugins.Boblight_grab.address=192.168.xxx.xxx
    config.plugins.Boblight_grab.port=19333


    dann init 3


    nix - keine Verbindung und das boblight-plugin ist dann deaktiviert lt. Plugin-Menü?!?


    habe mir dann unter


    /usr/lib/enigma2/python/Plugins/Extensions/Boblight-enigma2


    die boblight.py angeschaut und darin den Localhost 127.0.0.1 in meine AliX IP geändert...


    nix... kann nicht übers Boblight-Plugin starten/connecten


    kann mir jemand einen Tip geben??? wäre nice...


    grüße

    Merlin³ OE2.0|boblight-enigma2-0.8r3
    archlinux&boblightd2.1@raspberry[gpio]>72Chan.PIX

  • auch ich benutze boblight-daemon vom xbmc...



    xbmc:


    in der /etc/rc.local


    Code
    sh -c 'su - xbmc -c "boblightd -f"'




    in der /etc/X11/Xsession.d/60x11-common_localhost


    Code
    boblight-X11 -p 130 -o value=5 -o saturation=1.1 -o threshold=30 -o speed=70 -o interpolation=true -f



    und boblight-plugin manuell installiert.



    VU+:


    /etc/enigma2/settings:

    Code
    config.plugins.Boblight_grab.saturation=1.2
    config.plugins.Boblight_grab.standby=true
    config.plugins.Boblight_grab.network_onoff=true
    config.plugins.Boblight_grab.value=10
    config.plugins.Boblight_grab.priority=20
    config.plugins.Boblight_grab.autostart=true
    config.plugins.Boblight_grab.address=192.168.0.100
    config.plugins.Boblight_grab.threshold=10
    config.plugins.Boblight_grab.speed=70
    config.plugins.Boblight_grab.port=19333



    das plugin für xbmc greift NUR bei video-wiedergabe ein, prio 128 lässt sich nicht ändern. Wenn video gestoppt wird, setzt das plugin auf prio 255, so übernimmt boblight-X11 mit prio 130 die kontrolle.


    vu+ hat prio 20, so dass wenn sie eingeschaltet wird auf jeden fall die kontrolle übernimmt.

  • Danke!


    aber eigtl. funktioniert das alles wenn ich mich per shell verbinde...


    ...will aber unbedingt das boblight-enigma2 plugin nutzen


    Farben, Speed etc. darüber einzustellen ist wesentlich komfortabler


    ich müsste doch nur die "default" Werte vom enigma2-plugin ändern in den Config's...


    so daß das enigma-plugin per "default" den boblightd@AliX per Netzwerk connected und den boblightd nicht auf der Dream startet


    ich kann das im Plugin-Menü nicht umstellen, weil - wenn ich die "2" drücke "Netzwerk-Setup" --> greenscreen :evil:

    Merlin³ OE2.0|boblight-enigma2-0.8r3
    archlinux&boblightd2.1@raspberry[gpio]>72Chan.PIX

  • den "greenscreen" hatte ich auch, und hab die settings per ftp geändert. so läuft's bei mir ziemlich stabil und muss nicht immer die settings ändern.



    bei meiner vu+ mit den settings wird auf der enigma2-seite boblightd NICHT gestartet, denn der eintrag "config.plugins.Boblight_grab.network_onoff=true" sorgt ja dafür.


    wie gesagt, schau die meine settings an. läuft alles automatisch, ohne dass ich per telnet irgendetwas starten muss ;)

  • Danke!


    ich schau mir das nachher nochmal an... evtl. habsch gestern was übersehen ;)

    Merlin³ OE2.0|boblight-enigma2-0.8r3
    archlinux&boblightd2.1@raspberry[gpio]>72Chan.PIX