LG Nas auf 7020 HD mounten - bin verzweifelt

  • Timeshift und Aufnahmen haben unterschiedliche Pfade (bzw. koennen unterschiedlich
    gesetzt werden).
    Nur weil Du den Pfad fuer Aufnahmen veraendert hast, heisst das ja nicht, dass auch
    Timeshift dahin geht.
    Setze mal einen Timer und gib als Aufnahmeziel den Bookmark auf das LGNAS an (Du
    hast doch einen Bookmark darauf gesetzt?).

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • gleiches problem - crash log, da angeblich nicht genügen freier Speicher ist.
    Wenn ich im bookmark auf den Netzwerkmount gehe, zeigt er mir dort auch 0 MB freien Speicher an?!

  • ich lese nur mit ;)


    aber:


    Quote


    Im Blue Panel gibt es den Netscan und der findet auch diese NFS Freigabe. In der automount habe ich es allerdings wie von Dir beschrieben selbst eingetragen und habe nicht die automount funktion vom Bluepannel genutzt.


    mach den eintrag den du da manuel eingetrgaen hast wieder raus,
    auch die bookmerks entfernen


    dan netscan benutzen um zu suchen
    dan mit GP3 automounter probieren


    mal manuel etwas auf den mount schreiben (über GP3 dateibrowser zum beispiel eine datei kopieren)


    dan bookmarks wieder setzen

  • Bevor Du weitere Aenderungen machst, gib mal auf der Konsole (Telnet) ein "mount"
    ein und poste das Ergebnis hier. Da sollte dann ja das LGNAS zu sehen sein.


    Irgendwie klingt das doch sehr seltsam. Das ist KEINE Raketenwissenschaft und sollte
    in den Griff zu bekommen sein. ;-)

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • das schreibt er, wenn ich nur mount eigebe:



    root@dm7020hd:~# mount
    rootfs on / type rootfs (rw)
    /dev/root on / type jffs2 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/mtdblock2 on /boot type jffs2 (ro)
    tmpfs on /var type tmpfs (rw)
    tmpfs on /tmp type tmpfs (rw)
    automount(pid839) on /autofs type autofs (rw,fd=4,pgrp=839,timeout=5,minproto=2
    maxproto=4,indirect)
    automount(pid886) on /media/net type autofs (rw,fd=4,pgrp=886,timeout=5,minprot
    =2,maxproto=4,indirect)
    /dev/disk/by-uuid/e28efc18-31bd-4d56-8f3d-dc59e7e582e3 on /media/MyPassport071A
    type ext3 (rw,data=ordered)
    root@dm7020hd:~#
    root@dm7020hd:~#

  • Du musst noch in das /media/net/xxx Verzeichnis gehen, bevor
    du den mount Befehl sendest.


    Ansonsten siehst du nichts, weil der automounter sehr schnell wieder unmountet ;)

  • Hi,


    Hattest Du eigentlich auf dem NAS root_squash in no_root_squash geändert und insbesondere das ro zu rw gemacht? Das sollte zwar beides nichts daran ändern, ob der NFS-Mount überhaupt zustande kommt, sehr wohl aber daran, ob er dann auch wie gewünscht funktioniert ;)


    Edit: Automounter übersehen

  • @kentaonline:


    wenn ich im bouquet auf das LGNAS gehe und dann den mount befehl im telnet eingebe kommt nun auch was zur LGNAS:


    root@dm7020hd:~# mount
    rootfs on / type rootfs (rw)
    /dev/root on / type jffs2 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/mtdblock2 on /boot type jffs2 (ro)
    tmpfs on /var type tmpfs (rw)
    tmpfs on /tmp type tmpfs (rw)
    automount(pid839) on /autofs type autofs (rw,fd=4,pgrp=839,timeout=5,minproto=2
    maxproto=4,indirect)
    automount(pid886) on /media/net type autofs (rw,fd=4,pgrp=886,timeout=5,minprot
    =2,maxproto=4,indirect)
    /dev/disk/by-uuid/e28efc18-31bd-4d56-8f3d-dc59e7e582e3 on /media/MyPassport071A
    type ext3 (rw,data=ordered)
    root@dm7020hd:~#
    root@dm7020hd:~#


    nur - wenn ich im dcc auf dieses mountverzeichnis zugreife, zeigt er es mir zwar an, kann aber da nix reinkopieren. es kommt immer "0 Bytes übertragen".
    Irgendwas liegt hier noch im argen.


    ABPSoft:


    Wie soll ich im NAS diese Einstellungen ändern? Am NAS selbst hab ich keine Möglichkeiten dazu höchstens über einen Telnet Befehl

  • Bei dir erscheint kein mount auf ein entsprechendes Gerät.
    Wenn dann müsstest du z.B. sowas hier finden:


    Quote

    192.168.1.36:/media/wasauchimmer on /media/net/800se type nfs (rw,vers=3,rsize=8192,wsize=8192,soft,nolock,proto=tcp,timeo=70,retrans=3,sec=sys,addr=192.168.1.36)


    Ich denke du mountest nicht korrekt und dein NFS Server ist nicht korrekt konfiguriert.


    Ich würde nochmals die NFS Server Einstellungen prüfen, auch dass du Pfade in
    die exports reinmachst die auch wirklich existieren.


    Und dann manuell mounten von der Dream. Ist viel effektiver und bringt einem vielleicht weiter,
    anhand der Fehlermeldungen die erscheinen.

  • Quote

    Originally posted by cooli81
    @kentaonline:


    wenn ich im bouquet auf das LGNAS gehe und dann den mount befehl im telnet eingebe kommt nun auch was zur LGNAS:


    Dann hast Du das falsche File pepasted - hier steht nix von einem NFS-Mount ;)


    Quote

    ABPSoft:


    Wie soll ich im NAS diese Einstellungen ändern? Am NAS selbst hab ich keine Möglichkeiten dazu höchstens über einen Telnet Befehl


    Du hast selbst geposted, im /etc/exports des NAS würde stehen:


    /mnt/disk/volume1/volume1/Dreambox/Movie *(ro,root_squash,sync,no_subtree_check)


    Das musst Du also irgendwie so eingerichtet haben (sei es über ein Web-UI oder Upload eines /etc/exports oder direktes Editieren oder oder oder - wir kennen Dein NAS nicht). Und dort wirst Du es auch ändern können. Es ist in diesesm Thread nun schon mehrfach gesagt worden, dass Deine /etc/exports schräg ist. Und Du hast ja selbst gesagt, dass sie primär über Stille Post von irgendwelchen Foren inspiriert wurde ;)


    HTH,
    Andre.

  • Die /etc/exports muss natuerlich korrekt eingerichtet sein.
    Nimm mal alles raus, was vor der letzten Freigabe mit ".../Movie" steht und passe
    das in der Klammer hinter ".../Movie" folgendermassen an:

    Code
    (rw,no_root_squash,async,no_subtree_check)


    Alternativ kannst Du auch die Konfigurationsmoeglichkeiten Deines NAS nutzen und
    dort konfigurieren, bis es so aussieht wie von mir angegeben.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • was soll ich groß drumherum reden:


    ES GEHT!!! :hurra: :hurra: :hurra:


    Nur bei Timeshift kommt die Fehlermeldung, dass nicht genügen Festplattenspeciher vorhanden sei (irgendwie dauert es 1-2 Sek. auch im Bouqet bis der mont angezeigt wird und dann sieht man auch erst den Inhalt und den freien FP-Speicher). Ich weiß nicht ob man da noch was machen kann?

  • Was soll ich sagen, bei mir funktioniert es bei der DM8000 und auch der 800se. Allerdings benutze ich das nur sehr selten.

  • Hallo zurück,


    alle Freude die ich hatte ist nun doch dahin, denn die Box nimmt zwar ohne Fehlermeldung auf, man findet auch den Film, ABER will man den wiedergeben kommt außer ein schwarzer Bildschirm und nach einigen Sekunden einer Fehlermeldung dass irgendeine Datei oder ein "Punkt" nicht gefunden wurde.


    Ich habe fast die Vermutung, dass die Netzwerkgeschwindigkeit nicht ausreicht (ist mit 150 MBit dlan verbunden) aber die generelle Geschw. des NAS ist allgem. bekannt nicht sooo berauchend (i.d.R. um die 5-10 MB/Sek. wenn man etwas überträgt z.B.).


    Das haben auch andere User bereits bestätigt, liegt also nicht an meinem Netzwerk.


    Würde die Speed grundsätzlich ausreichen?


    Wiedergabe von Filmen, die ich vorher auf einer direktan die Box angewschlossenen FP aufgenommen habe und dan via DCC auf die NAS übertragen habe funktionieren problemlos, auch MP3 gehen-.


    Was meint Ihr oder wie kann man das evtl. Testen?

  • so - ich melde mich nochmal zu Wort.


    Es hat sich an der Situation nichts geändert, aber ich habe noch einige Eingrenzungen gamcht, so dass evtl. das Ein oder Andere ausgeschlossen werden kann.


    Erst dachte ich das Netzwerk ist zu langsam, so habe ich nur die Fritz Box, die immer noch als Router dient und die NAS an die DB angeschlossen. Resultat war das gleiche, dann habe ich mit fester IP die NAS an die DB angeschlossen, somit war also nichts außer ein Netzwerkkabel zwischen beiden Geräten.


    Nach wie vor wird der Mount gefunden, die Bilder, MP3, Filme (nicht von der DB auf der NAS aufgenommen) werden alle super abgespielt. Wenn ich aufehme kommt auch keine Fehlermeldung, ebenso erscheint auch der Film dann in der Auswahl im PVR-Bouquet. Sobald man Ihn abspeilen will kommt entweder "diese Wiedergabe beenden" oder es passiert gar nichts um dann eine Fehlermeldung zu bringen dass ein "Punk" nicht gefunden wurde.


    Also irgendwas ist doch hier ganz komisch. Allein an der Netzwerkgeschwindigkeit kanns doch da nun nicht mehr liegen?


    Könnte es ein dass evtl. die Tantalus FW auf der NAS den NFS-Server Dienst nicht richtig betreibt?


    Würde es Sinn machen die ganze Sache mit CIFS auszuprobieren?


    Bin kurz davor die LG NAS zu verkaufen und in eine QNAP zu ersetzen, habe nur Angst davor, dass ich dann trotzdem nicht weiter komme, falls evtl. doch nur irgendwas Kleines an der DB noch nicht richtig eingestellt ist, was die Schreiber auf der NAS angeht.

  • Poste nochmal ALLE relevanten Konfigdateien, die Du aktuell verwendest.
    LG NAS:
    /etc/exports
    /etc/hosts.allow
    /etc/hosts.deny
    Dream:
    /etc/auto.*


    Spar Dir die Muehe, lokale Adressen (192.168.*.*) zu anonymisieren. Die bringen
    einem Hacker eh nichts, da die nur lokal ansprechbar sind.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • @ kentaonline:


    also hier die Inhalte der Dateien:


    auf der LG NAS:
    /mnt/disk/volume1/volume1/dreambox/movie *(rw,no_root_squash,async,no_subtree_check)


    eine hosts.allow oder hosts.deny gibt es nicht - hab hier mal den inhalt der hosts:
    127.0.0.1 LG-NAS
    127.0.0.1 localhost


    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts


    host.conf:
    multi on


    was ist genau gemeint mit der /etc/auto.* bei der Dream?
    alle mit auto. irgendwas? naja ich poste es einfach:


    auto.hotplug:
    sr0 -fstype=auto,ro :/dev/sr0
    sr1 -fstype=auto,ro :/dev/sr1


    auto.master:
    #
    # $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
    #
    # Sample auto.master file
    # This is an automounter map and it has the following format
    # key [ -mount-options-separated-by-comma ] location
    # For details of the format look at autofs(5).
    #/smb /etc/auto.smb
    #/net /etc/auto.net
    /autofs /etc/auto.hotplug
    /media/net /etc/auto.network


    auto.network:
    # generated by gemini
    movie -fstype=nfs,rw,nolock,soft,tcp,rsize=8192,wsize=8192 192.168.178.23:/mnt/disk/volume1/volume1/dreambox/movie