LG Nas auf 7020 HD mounten - bin verzweifelt

  • Hallo!


    Seit Tagen durchforste ich dieses und auch andere Foren, um als Linux Neuling meine neue 7020 HD auf mein LG Nas N2B1 zu mounten.


    Habe es bereits per DCC / Telnet probiert, ebenso per Blue Panel Automount.


    Bisher habe ich auf der NAS mit dem Tantalus FW 2450 NFS aktivieren können und habe die Pfade bis zum VErzeichnis "Dreambox" freigegeben. Was ich bisher nicht gefunden habe, wie ich auf der LG die Dreambox oder einen gewissen Nutzer oder ein gewisses Verzeichnis freigeben kann. Denke darin liegt das Grundproblem.


    Ev. mache ich auch auf der DM was falsch, doch die Eingaben sind eigentlich recht eindeutig.


    Vielleicht kann mir noichmal jemand par Tips zur NAS geben?

  • hallo
    wie sieht denn deine auto.network aus? bitte mal posten
    lg

    DM8000sssc interne 1,5 TB HDD, externe 1,0 TB und 2,0 TB HDDs,
    DM500S-HD externe eSATA 80GB HDD, 1,0 TB NAS, Sharp LC 37 XD 1 E

    Edited once, last by pwhasser01 ().

  • Ohne die auto.network (oder auto.hotplug) von der DM und der /etc/exports vom
    NAS, kann man nur versuchen sich als Hellseher zu betaetigen.
    Wenn Du dann gerade dabei bist, gib auch noch die IP Adressen Deines NAS und der
    DM mit an.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • wenn du GP3 installiert hast kanst du auch das "gemini netscan" plugin installieren



    Netscan (sucht Freigaben und scannt Ports)


    damit werden freigaben in dein netzwerk gefunden, und übergeben am automounter


    natürlich müssen die freigaben erst in ordnung sein

  • Oder unter BP gemini Plugins geminiftpfs

    Gruß
    banyba


    920 S2 FBC+Triple, 4tb WDblue
    900 S2 FBC
    525HD S+C
    520HD bei allen DMM, GP4 + notgedrungen HD+
    Nas Synology DS220+

  • Hi,


    also die auto.network der dm lautet
    "# generated by gemini
    LG-NAS -fstype=nfs,rw,nolock,soft,tcp,rsize=8192,wsize=8192 192.168.178.23:/volume1/Dreambox"


    und in der exports auf der NAS:


    /mnt/disk/ *(rw,root_squash,sync,no_subtree_check)
    /mnt/disk/volume1/ *(rw,root_squash,sync,no_subtree_check)
    /mnt/disk/volume1/volume1/Dreambox *(ro,root_squash,sync,no_subtree_check)
    /mnt/disk/volume1/volume1/Dreambox/Movie *(ro,root_squash,sync,no_subtree_check)


    So - ich denke man erkenntsicher an den mount-Daten, dass ich da nicht alles richtig eingegeben habe - aber vielleicht finden wir ja so den Fehler *g*

  • Das kann so nicht funktionieren.
    In der auto.* muss der Pfad stehen, der auch freigegeben wurde.
    Deshalb muss immer auch /mnt/disk/ davor.
    Packe mal folgendes in die auto.*:

    Code
    LGNAS -fstype=nfs,rw,nolock,soft,tcp 192.168.178.23:/mnt/disk/volume1/Dreambox


    Dein Verzeichnis "Dreambox" liegt doch in /mnt/disk/volume1 ?
    Deine /etc/exports zieht zumindestens ziemlich "kaputt" aus, oder Du hast da doch
    ziemlich Kraut und Rueben auf Deinem NAS angelegt. ;-)
    Du solltest Dich entscheiden, ob Du /mnt/disk oder die einzelnen Volumes freigeben
    willst.
    Es ist keine gute Idee, gleichzeitig ein Verzeichnis und seine Unterverzeichnisse fuer
    die gleiche Rechnergruppe (hier mit "*" = alle Rechner) freizugeben. Wer weiss, was
    die Programmierer der NFS-Anbindung da fuer einen Kram draus machen?

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • ok, hab ich gemacht.
    In den automount-Einstellungen ist jetzt auch LGNAS als Mountpunkt hinterlegt
    ABER davor steht noch /media/net/LGNAS


    ist das korrekt?


    Denn so kommt die Fehlermeldung "kann Ordener nicht erstellen"?


    Muss ich auf der NAS noch irgendwas anderes einstellen?
    Ordnerstruktur ist: Volume1 ist HDD1 und darauf ist das Verzeichnis "Dreambox" worin dann die Mediafiles bzw. Aufnahmen sollen.

  • Es ist WICHTIG, dass Du herausfindest, was genau vom LG NAS freigegeben wurde.
    Leider gibt es auf der Dream das "showmount" Kommando nicht, denn damit waere
    es ganz einfach.
    Kommst Du mit Telnet oder SSH auf das LG NAS?
    Wenn ja, gib da mal "showmount -e 127.0.0.1" ein; dann siehst Du die Freigaben mit
    ihrem EXAKTEN Pfad.
    GENAU dieser Pfad muss dann hinter den Doppelpunkt der auto.network Zeile.
    VOR dem LGNAS steht NICHTS in der Zeile der auto.network.
    Angenommen Deine Ausgabe von showmount saehe so aus:

    Code
    Exports list from 192.168.178.23:
    /mnt/volume1/ 192.168.178.0/255.255.255.0


    dann muesste die auto.network Zeile so aussehen:

    Code
    LGNAS -fstype=nfs,rw,nolock,soft,tcp 192.168.178.23:/mnt/volume1/

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • vielleicht überlesen:


  • Habe mit Netscan den mount gefunden und auch in die automount eingegeben. Wenn man dann dort auf den Button "Geschwindigkeit Testen" geht, kommt "Ordner kann nicht erstellt werden" - das ist doch ein Zeichen, dass wohl entweder der Mount nicht korrekt ist oder eine richtige Freigabe fehlt.



    Telnet hat die NAS leider nicht.
    Wie kann man denn sonst noch rausfinden, ob die Freigaben richtig sind? Muss man nicht irgendwo auf der Nas die Dreambox eintragen, damit die dann auch Zugansberechtigungen bekommt? Den bei der Dreambox muss ich ja nirgends Zugangsdaten der NAS eingeben.

  • Zugangsdaten brauchst du auch nicht bei nfs v3.


    Kontrolliere nochmals die Einstellungen am NAS und die Zugangsbeschränkungen für NFS.
    Sie dazu auch die Betriebsanleitung deines NAS.


    Oder mounte manuell von der Dreambox. Freigabe ermittelns kannst di wie
    kentaonline geschrieben hat. Oder schaue im Webif des NAS, das wird da sicher auch angegeben.

  • Quote

    Originally posted by cooli81
    Habe mit Netscan den mount gefunden und auch in die automount eingegeben. Wenn man dann dort auf den Button "Geschwindigkeit Testen" geht, kommt "Ordner kann nicht erstellt werden" - das ist doch ein Zeichen, dass wohl entweder der Mount nicht korrekt ist oder eine richtige Freigabe fehlt.


    Oder dass er ReadOnly ist...


    Quote

    Muss man nicht irgendwo auf der Nas die Dreambox eintragen, damit die dann auch Zugansberechtigungen bekommt? Den bei der Dreambox muss ich ja nirgends Zugangsdaten der NAS eingeben.


    NFS (<4) funktioniert etwas anders. Hier wird vorausgesetzt, dass der Zugang bereits anderswo geklärt wurde, das NFS selbst benutzt nur die resultierenden User-IDs, die auf Client und Server zusammenpassen müssen. Da die Dream aber eh alles als root macht und UID 0 universell gleich ist, klappt das hier - vorausgesetzt man schaltet den Sicherheitsmechanismus aus, der root normalerweise komplett aussperrt (aus gutem Grund, das zu erklären wird aber hier zuviel). Das macht die exports-Option no_root_squash. Also Dein:


    /mnt/disk/volume1/volume1/Dreambox/Movie *(ro,root_squash,sync,no_subtree_check)


    Heißt: Exportiere den Pfad (wieso ist da eigentlich volume1 doppelt drin?) an jede beliebige IP-Adresse, erlaube root dabei aber keinen Zugriff (da steht root_squash, d.h. der Sicherheitsmechanismus ist an!), und dieser Teilbaum bleibt außerdem ReadOnly. Glaube nicht, dass Du das so wolltest...


    HTH,
    Andre.


    Edit: Völlig übersehn, dass da bei cooli81 root_squash steht statt no_root_squash. Übrigens bei allen Exports, d.h. da wird nicht viel gehen, es sei denn der NAS hat ein sehr seltsames Handling von NFS-"nobody".

  • Bitte NICHT "root_squash" setzen, sondern beim "no_root_squash" bleiben.
    Mit "root_squash" werden alle Dateien von root auf nobody gemappt. Das gibt
    dann bei Zugriffen ueber SMB/CIFS Probleme.


    @Coli81:
    Welche Firmware ist auf Deinem NAS? Das Original kann es ja nicht sein, da das NAS
    sonst kein NFS haette. Die Alternativfirmwares haben aber entweder Telnet oder SSH
    Zugang freigeschaltet.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • Hi,


    ja - bei der LG Nas kann man durch die Tantalus FW Telnet aktivieren. Das habe ich auch getan. Dazu gibt es aber nur die Funktion Telnet aktivieren oder deaktivieren.


    Wie kann ich nun (nachdem ich es aktiviert habe) mit der NAS kommunizieren um die Freiigaben genannt zu bekommen?


    Hab davon nahezu 0 Ahnung!


    Bin über jede Hilfe dankbar.

  • Quote

    Originally posted by kenatonline
    Bitte NICHT "root_squash" setzen, sondern beim "no_root_squash" bleiben.
    Mit "root_squash" werden alle Dateien von root auf nobody gemappt. Das gibt
    dann bei Zugriffen ueber SMB/CIFS Probleme.


    Oh Gott, wie konnte ich das übersehen. Da steht root_squash statt no_root_squash, und ich zitier das auch noch, als wär's richtig. Ich konnte mir nicht vorstellen, dass jemand die Option, die hier garantiert nicht hilft (und außerdem default ist), explizit reinschreibt und habe das unterschwellig als no_root_squash gelesen. Mea culpa.


    Jetzt mal das Posting editieren, damit da kein Blödsinn verewigt bleibt...


    ISC,
    Andre.

  • Quote

    Original von cooli81
    ...
    Wie kann ich nun (nachdem ich es aktiviert habe) mit der NAS kommunizieren um die Freiigaben genannt zu bekommen?
    ...


    Dich per Telnet auf der Kommandozeile Deines Betriebssystems mit dem NAS verbinden?
    Und dann das machen, was ich bereits im vorletzten meiner Posts hier vorgeschlagen
    hatte (Stichwort: showmount)?

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • per telnet von meinem Betriebssystem ?


    ok - hab es tatsächlich hinbekommen - man kann ja unter Win7 Telnet und Telnet Client in den Funktionen aktivieren


    Habe mich also per Telnet mit der NAS verbunden und als admin eingeloggt.
    Dann habe ich den Befehl "showmount -e 127.0.0.1" eingegeben. Als Antwort kam "-sh: showmount: command not found"


    in der Eingabezeile steht "LG-NAS:~$" weiß nicht ob das so aussehen soll - wie gesagt bin Neuling in der Geschichte.

  • Versuche das mal als root.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • naja,
    aber wenn er das kommando gar nicht kennt, ists doch egal als was ich mich anmelde, oder?