SeriesPlugin for OE2.0 / OE2.2

  • Hi,
    du musst noch das difflib Modul installieren.
    Telnet:
    opkg update
    opkg install python-difflib


    Who kann ich das model finden
    Wie mach ich das mit filezilla
    und dann
    Kann jemand helfen

  • Quote

    Original von betonme
    Heiquito
    [...]
    Lösung für dich wäre evtl, im Setup von SeriesPlugin, den Title Pattern auf nur Org einzustellen, dann bleibt der Titel immer unberrührt und nut die Beschreibung in der Meta wird geändert.


    Hallo,


    habe dieses geniale Plugin erst kürzlich entdeckt und würde es gerne mit "Project Valerie" kombinieren. Aufgrund der Art und Weise wie Valerie versucht die Titel zu identifizieren, sollte der Dateiname nicht verändert werden, bzw. der Titel keine weiteren Infos wie Episodenname/Nummer enthalten (jedenfalls nicht bei TV-Aufnahmen mit meta-File).


    Wenn ich aber nun "Org" als Titel auswähle, werden ja alle Files einer Serie den gleichen Titel haben und somit alle bis auf eine gelöscht, da dann der Dateiname ja immer z. B. "Entourage.ts" lautet.


    Du schriebst in dem obigen Zitat, bei der Einstellung "Org" würde der Dateiname nicht verändert. Da diese Option aber in der Standard Cfg. nicht enthalten ist, habe ich diese abgeändert in " ["{org:s}", "Org"], ". Hierbei wird dann aber trotzdem der Dateiname umbenannt und nicht nur die Meta Info.


    Denkfehler?


    MfG,
    friendsfan

  • Hi,


    das Packet/Modul gibt es hier:
    http://www.dreamboxupdate.com/
    Box auswählen, Modul suchen, herunterladen, Per FTP auf die Box tmp und installieren,
    hier sind verschiedene Möglichkeiten erklärt:
    http://wiki.blue-panel.com/ind…nzeldateien_jeglicher_Art


    Oder
    Eine Telnet Verbindung aufbauen, dann reichen 2 Befehle:
    opkg update
    opkg install python-difflib


    Oder Webadmin, mit dem geht es bestimmt auch,


    Oder E2 DCC http://www.bernyr.de/dcce2/index.html


    So viele Möglichkeiten... :-)

  • Hi,


    ich vermute du hast die Aufnahmen im nachhinein umbenannt.


    Da ist Org = der Original Titel und nicht gleich dem Dateinamen.


    Wenn du die Aufnahmen vom AutoTimer umbenennen lässt, sollte bei Org auch der Original Name beibehalten werden, da dieser erst zum Zeitpunkt der Aufnahme von E2 erstellt wird.


    Ich werde das für die nächste Version berücksichtigen.


    PS: Die extra Org Zeile in der Cfg ist nicht notwendig, du kannst im Setup auch einfach "" (den leeren Eintrag) auswählen.


  • Korrekt, ich muss die Dateien im nachhinein umbenennen, da ich momentan keine Dreambox besitze (Vu+ Duo mit PLI Image). Nichts würde ich lieber tun als den Autotimer entsprechend zu nutzen. Leider kann ich die dafür notwendige OE2.0 Version nicht installieren. Ich habe sehr lange erfolglos versucht, die Tips für DB OE1.6 Benutzer zu nutzen (Daten aus dem OE2.0 ziehen und für meine Version verwenden). Dies ist (natürlich?) kläglich gescheitert, weil da Sachen verlangt sind, die auf der VU nicht existieren. Der erste Green Screen war z. B. weil "Toolkits" verlangt wurde. Die hab ich dann sogar noch "installiert", doch dann kam der nächste GS. usw.


    Leider habe ich keine Programmierkenntnisse, um das Autotimer Plugin etsprechend zu ergänzen.


    Und die Auswahl von "" brachte die Box zum Absturz, daher hatte ich die Config abgeändert.

  • In der nächsten Version solltest du "" verwenden können.
    Wegen dem AutoTimer, es sollte reichen, die letzte OE1.6 Version zu verwenden und dann die aktuelle AutoTimer.py aus dem Git.

  • Quote

    Originally posted by betonme
    Habt ihr alle Module nachinstalliert, wie im ersten Post erwähnt.


    Ansonsten postet bitte noch ein Telnet log. Danke


    hmm... gar nicht so einfach, da es nacheinem engima reboot immer funkrioniert. aber irgednwas passiert dann im laufe des betriebs, dass es dann nicht mehr geht. bis jetzt hab ich mitm log noch nie lange genug durchgehalten.
    ich probiers wenn zeit ist nochmal länger...

    DM8000 1,5 TB HDD
    DM800
    DM900 UHD
    Onkyo 807 + Teufel Motiv 10
    Sky Full HD

  • Quote

    Original von betonme


    Wegen dem AutoTimer, es sollte reichen, die letzte OE1.6 Version zu verwenden und dann die aktuelle AutoTimer.py aus dem Git.


    Das hatte ich versucht, den erstem GS gabs bei


    Code
    from Plugins.SystemPlugins.Toolkit.SimpleThread import SimpleThread


    den zweiten dann bei


    Code
    from . import config, xrange, itervalues


    Da ich ja nicht wirklich weiss was ich da genau tue, hab ich dann aufgegeben, weil ich davon ausgehe, dass da noch mehr DB-spezifische Aufrufe kommen ;(

  • Quote

    Original von flolee


    hmm... gar nicht so einfach, da es nacheinem engima reboot immer funkrioniert. aber irgednwas passiert dann im laufe des betriebs, dass es dann nicht mehr geht. bis jetzt hab ich mitm log noch nie lange genug durchgehalten.
    ich probiers wenn zeit ist nochmal länger...

    Hi, teste bitte gleich die 0.5.1 :-)


    Wenn es dann gerade nicht gehen sollte, was passiert, wenn du kurz ins Setup gehst, gleich wieder raus. Geht es danach wieder?

  • betonme
    das dicke schwarze in deinem release text vom 0.5.1 geht top :hurra: kann ich dir schon mal sagen ;)
    aber was nicht geht ist der aufruf über die AMS da kommt das verbotzeichen und nix geht mehr hier der log


    PS. aus der emc raus ist es das selbe auch das zeichen und nix geht mehr

    Files

    • E2Log.txt

      (51.65 kB, downloaded 5 times, last: )

    Edited once, last by zombi ().

  • Quote

    Original von betonme
    Ne das geht dann wirklich nicht mehr so einfach.
    Da sollen deine Image Bauer mal ran :-)


    Hab ich schon versucht, für 2 Images in 2 Foren ohne Reaktion. In beiden ist aber dein SeriesPlugin gar nicht auf dem "offiziellen" Feed und der Autotimer dümpelt so auf Stand Februar 2012 oder so vor sich hin.


    Bin ja schon froh, dass das OE1.6 IPK aus diesem Thread eigentlich so weit läuft. Mit diesem Zustand kann ich leben. Muss man doch wieder auf DB sparen :tongue:


    Danke jedenfalls für deine Hilfe. Aus Bug Meldungen zu dem Plugin werd ich mich aber auch raushalten, weil das ja auch immer an meiner Box liegen könnte, wenn da was nicht passt...

  • Quote

    Original von flolee


    hmm... gar nicht so einfach, da es nacheinem engima reboot immer funkrioniert. aber irgednwas passiert dann im laufe des betriebs, dass es dann nicht mehr geht. bis jetzt hab ich mitm log noch nie lange genug durchgehalten.
    ich probiers wenn zeit ist nochmal länger...

    Ich denke, ich hab den Fehler:
    Immer wenn das Setup geöffnet und wieder geschlossen wurde, funktionierte das Chaching nicht mehr, das führte zu "No matching Series found"

  • betonme
    die 0.5.2 geht jetzt so weit ich getestet habe richtig gut bzw. auch schneller :hurra:
    aufruf über Movielisten geht ,rename geht ,fehler mit dem record bei rename ist auch weg,aus dem cool gehts top und auch bei live tv geht es .
    bei alten serien (wie Magnum zb) wird nichts gefunden aber bei neueren serien findet er oft was,das Plugin ist eine ser schöne bereicherung danke für das Teil :thx: