PushService 0.3.0 OE2.0

  • Hi,
    Ja das stimmt.
    Da die Service Module jetzt auch dynamisch eingebunden werden, ist auch deren Konfiguration im XML File abgelegt.
    Das kannst du kurz am Rechner editieren und zurück kopieren, dann musst du nur noch den Config Screen aufrufen und es wird neu eingelesen.
    Bevor du es editierst, öffne kurz den Config Screen und füge den Smtp Service hinzu, speichern nicht vergessen, dann werden im xml die entsprechenden Platzhalter eingetragen.
    Gruss

  • Quote

    Original von betonme


    Das kannst du kurz am Rechner editieren und zurück kopieren, dann musst du nur noch den Config Screen aufrufen und es wird neu eingelesen.


    Ok, Danke, das hat soweit funktioniert, nachdem ich mal kapiert hatte das "false" zum GS führt und es besser "False" heißen muss :rolleyes:


    Was mir jetzt noch auffällt, dass die alten Settings mit Passwort usw in der "settings" Datei noch drinstehen. Ich vermute, dass ich diese Überbleibsel auch nur durch manuelles Editieren (mit entsprechend init 4 und init 3 vorher/nachher) loswerde....

  • Quote

    Original von __QT__


    Ok, Danke, das hat soweit funktioniert, nachdem ich mal kapiert hatte das "false" zum GS führt und es besser "False" heißen muss :rolleyes:


    Was mir jetzt noch auffällt, dass die alten Settings mit Passwort usw in der "settings" Datei noch drinstehen. Ich vermute, dass ich diese Überbleibsel auch nur durch manuelles Editieren (mit entsprechend init 4 und init 3 vorher/nachher) loswerde....


    Hast du zufällig noch das Log, dann bau ich noch einen Check ein.
    Update: Hat sich erledigt.


    Leider geht es wohl nicht anders, die verwaisten Einträge loszuwerden.

  • Das letzte Update ist echt super.
    Benutze den SNMP Service mit TLS ohne Probleme.


    Das einzige was ich etwas verwirrend finde, ist der gelbe Button in der PushService Configuration. Da steht "Kanäle" bei mir drauf, obwohl man damit die Services konfiguriert.


    Aber das ist nur Kosmetik - ansonsten bis jetzt alles super!

  • Hab heute meine 8k mit dem Update vom Feed (OE2) auf den neuesten Stand gebracht und jetzt kann ich das Plugin nicht mehr starten.


    Das Plugin im Plugin-Browser markiert, bewirkt ein Drücken der Ok-Taste der Fernbedienung nichts.

  • Quote

    Original von Viril
    Hab heute meine 8k mit dem Update vom Feed (OE2) auf den neuesten Stand gebracht und jetzt kann ich das Plugin nicht mehr starten.


    Das Plugin im Plugin-Browser markiert, bewirkt ein Drücken der Ok-Taste der Fernbedienung nichts.


    Teste bitte nochmal. Danke


    Quote

    Original von Florie
    Wie konfiguriere ich denn Growl?


    Ich nutze Growl for Windows 2.8, hier mal meine anonymisierten Settings:
    PushService:

    Code
    <Service enable="False" name="GNTP">
    <Option key="growlhost">IPorName</Option>
    <Option key="growlport">23053</Option>
    <Option key="timeout">3</Option>
    <Option key="password">YourPassword</Option>
    <Option key="sticky">True</Option>
    <Option key="priority">1</Option>
    </Service>


    Growl:
    Settings
    Applications: New: PushService
    Enabled True / Rest - default
    Network:
    Require password for LAN Apps: YourPassword
    Allow network notification: Yes


    Wie ist deine Firewall eingestellt?


    PS: Jemand noch eine Idee für ein PushService Icon?

  • Super, jetzt gehts, bin mit dem Host ursprünglich nicht klar gekommen...

  • Kriege beim Testen des SMTP-Versandes diesen Fehler.
    Wie kann ich Testen woran es liegt?

    Files

    • Error.png

      (182.02 kB, downloaded 333 times, last: )

    verwende aktuell OE 2.0 Exp.

  • Quote

    Original von Frallo
    Kriege beim Testen des SMTP-Versandes diesen Fehler.
    Wie kann ich Testen woran es liegt?

    Hi,
    du kannst höchstens noch mit Telnet mitloggen, aber ich glaub nicht, dass du dort mehr Informationen bekommst.
    Welchen Mail Provider und welche Einstellungen verwendest du?


    Gruß

  • Sorry, war mein Fehler.
    Der Mail-Server ist ein selbstbetriebenes Postfix in der Cloud.


    Ich hatte aus Versehen zusätzlich zu TLS noch SSL aktiviert und mein SMTP-Dienst ist nur auf TLS konfiguriert.


    Nun tut es. Sorry wegen der Umstände


    verwende aktuell OE 2.0 Exp.

  • Quote

    DeactivatedTimers: Der AutoTimer trifft auf einen Timerkonflikt und kann eine Sendung nicht aufnehmen und erstellt deswegen einen deaktivierten Timer (muss aktiviert werden). PS würde euch in dem Fall eine eMail mit dem betreffenden Timer zuschicken. Vergesst nicht folgende Option im AutoTimer Setup einzuschalten: "Add timer as disabled on conflict" ("Bei Konflikt deaktivierten Timer hinzufügen") - Remove deactivated timer(s) after successful transmission = False (On False PS will tag them as DeactivatedTimerPushed)



    Hallo. Super Plugin für Leute die immer über den Stand der Dreambox informiert sein möchten.


    Einen "feature request" zu der Deactivated Timer Funktion möchte ich aber loswerden.


    Könnte man das nicht auch erweitern das man eine Nachricht bekommt wenn der Autotimer einen Timer erfolgreich gesetzt hat? Wäre ne Super Funktion um zu erfahren das der Autotimer einen Film gefunden hat.


    Mir ist klar das man das natürlich auch als Modul einbinden könnte aber für mich nicht Programmierer leider nicht machbar.


    Grüße,
    Christian

    -->
    openwrt + minicom + screen = 24/7 Bootlog

    Edited once, last by Schnello ().

  • betonme
    wollte das plugin mal mit poedit übersetzen, würdest du bitte die paar fehler korrigieren?


    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Hi,


    Quote

    Könnte man das nicht auch erweitern das man eine Nachricht bekommt wenn der Autotimer einen Timer erfolgreich gesetzt hat? Wäre ne Super Funktion um zu erfahren das der Autotimer einen Film gefunden hat.


    das war simple.


    Das Modul von Deactivated Timers kopieren, umbennen und anpassen.


    Hab es aber nicht getestet.


    Beachte PushService läuft unabhängig vom AutoTimer, d.h. erst beim nächsten PushService Durchlauf werden die Timer gemeldet.


    Gruß


    Update:
    Bereits auf dem Feed


  • Wow danke.
    Funktioniert auf den ersten Blick perfekt.


    Danke,
    Christian

    Files

    -->
    openwrt + minicom + screen = 24/7 Bootlog