AirPlayer - iOS iPhone iPad Support

  • Hallo und erstmal vielen Dank für das Plugin! Super!!


    -> iPad Fotos funktioniert einwandfrei und ich bekomme folgenden Debug output wenn ich welche anzeigen will


    [AirPlayer] PHOTOHandler POST
    [AirPlayer] show_picture
    before: 1
    [Picload] decode picture... /hdd/pic.jpg


    -> beim iPhone4 Fotos tut sich leider gar nichts. Passiert nix aufm TV, passiert nix im Logfile :(


    Zum Einsatz kommt die Dreambox 8000 mit enigma2-plugin-extensions-airplayer_0.1.6_mipsel.ipk.


    Wenn ich irgendwie beim debugging helfen kann, sag Bescheid :)


    Danke & Gruß
    escapechen

  • Zur 0.1.6er Version:


    1. Die Apple-Trailer funktionieren, lassen sich aber nur per Fernbedienung beenden. Wenn man nämlich den Trailer auf dem iPod stoppt, wird er auf dem TV pausiert und kann nur per Fernbedienung entweder fortgesetzt oder gestoppt werden.


    2. Sollten die Apple-Events von der Apple-Seite nicht auch funktionieren? Hier zumindest gehts nicht (getestest mit dem Apple Education Event).

  • Quote

    Original von JacKzonE
    Zur 0.1.6er Version:


    1. Die Apple-Trailer funktionieren, lassen sich aber nur per Fernbedienung beenden. Wenn man nämlich den Trailer auf dem iPod stoppt, wird er auf dem TV pausiert und kann nur per Fernbedienung entweder fortgesetzt oder gestoppt werden.


    2. Sollten die Apple-Events von der Apple-Seite nicht auch funktionieren? Hier zumindest gehts nicht (getestest mit dem Apple Education Event).


    auch das Event geht bei mir!


    man wird weitergeleitet zu

    Code
    http://qthttp.apple.com.edgesuite.net/1201oihbafvpihboijhpihbasdouhbasv/ipad_w_vod_mvp.m3u8


    um die m3u8 abspielen zu können braucht man das gstreamer modul fragmented


  • das gerät wird aber angezeigt? evtl mal das iOS gerät in den Airplane Modus und wieder zurück ... evtl geht es dann?

  • kann die probleme mit den bildern bestätigen...bei mir läuft derzeit nur Video...hab heute die 0.1.6 installiert, seitdem funktionieren die Fotos weder mit iPad2 noch iPhone4s...
    das ganze mit DM500HD...


    Sonst aber Top Plugin was ich nicht mehr missen möchte. danke hellmaster.

  • Quote

    Original von surger13
    kann die probleme mit den bildern bestätigen...bei mir läuft derzeit nur Video...hab heute die 0.1.6 installiert, seitdem funktionieren die Fotos weder mit iPad2 noch iPhone4s...
    das ganze mit DM500HD...


    Sonst aber Top Plugin was ich nicht mehr missen möchte. danke hellmaster.


    Auf meinem ipad2 und iphone4s alles ok

  • Quote

    Original von JacKzonE
    Zur 0.1.6er Version:


    1. Die Apple-Trailer funktionieren, lassen sich aber nur per Fernbedienung beenden. Wenn man nämlich den Trailer auf dem iPod stoppt, wird er auf dem TV pausiert und kann nur per Fernbedienung entweder fortgesetzt oder gestoppt werden.


    2. Sollten die Apple-Events von der Apple-Seite nicht auch funktionieren? Hier zumindest gehts nicht (getestest mit dem Apple Education Event).


    Also Apple Trailer funktioniert bei mir nicht. Musikvideos funktionieren, aber Videotrailer hab ich noch nicht zum laufen bekommen.

  • Quote

    Original von Eaglefire


    Also Apple Trailer funktioniert bei mir nicht. Musikvideos funktionieren, aber Videotrailer hab ich noch nicht zum laufen bekommen.


    Ich meinte die Trailer über die Webseite die über iTunes habe ich nicht probiert vermutlich sind die aber wie fast alles aus iTunes DRM geschützt

  • Quote

    Original von hellmaster1024


    Ich meinte die Trailer über die Webseite die über iTunes habe ich nicht probiert vermutlich sind die aber wie fast alles aus iTunes DRM geschützt


    Achso, verstehe. Wäre schon super gewesen einen Film über iTunes zu leihen und dann über Airplay mit Iphone oder IPad wiedergeben zu können.

  • Quote

    Original von hellmaster1024
    auch das Event geht bei mir!


    man wird weitergeleitet zu

    Code
    http://qthttp.apple.com.edgesuite.net/1201oihbafvpihboijhpihbasdouhbasv/ipad_w_vod_mvp.m3u8


    um die m3u8 abspielen zu können braucht man das gstreamer modul fragmented


    So, ich habe das gst-plugin-fragmented nachinstalliert (/usr/lib/gstreamer-0.10/libgstfragmented.so vorhanden), aber leider weiterhin kein Bild - das Video läuft noch nicht mal an. Muss ich das Airplayer-Plugin jetzt nochmal drüberinstallieren oder mache ich jetzt noch irgendwas falsch? (ich gehe auf dem iPod über Safari auf die apple.com Seite und klicke auf das Education Event)

  • Hab meinen Fehler gefunden und nun gehen auch die Bilder wieder... :hurra:
    Der Ordner zum cachen war auf wundersame weise von meinem USB-Stick verschwunden, so dass der pfad in den Settings ins leere zeigte...hab das korrigiert und nun laufen neben den Videos auch die Fotos wieder...



    Quote

    Original von hellmaster1024


    Auf meinem ipad2 und iphone4s alles ok

  • Quote

    Original von JacKzonE


    So, ich habe das gst-plugin-fragmented nachinstalliert (/usr/lib/gstreamer-0.10/libgstfragmented.so vorhanden), aber leider weiterhin kein Bild - das Video läuft noch nicht mal an. Muss ich das Airplayer-Plugin jetzt nochmal drüberinstallieren oder mache ich jetzt noch irgendwas falsch? (ich gehe auf dem iPod über Safari auf die apple.com Seite und klicke auf das Education Event)


    Also zumindest muss e2 neu gestartet werden denke ich! es kann aber sein das noch mehr installiert werden muss ... kann ich von hier schwer einschätzen.


    wenn was fehlt oder was passiert kann man ganz gut testen indem man per telnet auf die console geht

    Code
    init 4
    killall enigma2
    gst-launch-0.10 --gst-debug-level=2 playbin2 uri=http://qthttp.app
    le.com.edgesuite.net/1201oihbafvpihboijhpihbasdouhbasv/ipad_w_vod_mvp.m3u8 user-agent=QuickTime
  • Hmm, es hat eine Zeit lang gedauert und irgendwann ging dann das Video los. Die Ausgabe war folgende:


  • ja das sieht doch schon ganz gut aus! dann müsste es auch über AirPlayer klappen! evtl geht das video nicht sofort los weil er noch buffert, sollte aber abspielen

  • Das ist aber das komische: er wartet und wartet und wartet und bricht dann nach wenigen Sekunden das Airplay ab und es wird wieder normales TV angezeigt.

  • Quote

    Original von JacKzonE
    Das ist aber das komische: er wartet und wartet und wartet und bricht dann nach wenigen Sekunden das Airplay ab und es wird wieder normales TV angezeigt.


    Versuch mal Während der wartet Play Pause am iPad und oder an der Box zu drücken

  • Das klappt leider auch nicht.


    Es scheint so zu sein, als ob meine Box nicht lange genug wartet und das Airplay abbricht. Würde das Video sofort beginnen (was aber bei der manuellen Eingabe von oben doch etwas gedauert hat), würde es auch abgespielt werden. Die Youtube-Videos z.B. werden ziemlich schnell abgespielt und hier fällt es nicht auf, wobei wenn ich nicht sofort die Playtaste am iPod drücke, wird das Airplay ebenfalls beendet.

  • Quote

    Original von hellmaster1024


    das gerät wird aber angezeigt? evtl mal das iOS gerät in den Airplane Modus und wieder zurück ... evtl geht es dann?


    Danke für Deine Antwort.
    Ja mit dem hin und herschalten hab ich ausprobiert. "Airplayer E2" default. Ich kann es auch auswählen und es bleibt ausgewählt, aber es tut sich nichts auf TV oder im log. Habe auch DiaShow etc. ausprobiert um irgendeinen Effekt zu triggern, leider ohne Erfolg. Habe auch die Sache mit dem Buffercache runterdrehen etc. ausprobiert.


    Irgendne Idee was ich noch probieren könnte ?


    Danke&Gruß,
    escapechen

  • Klink mich kurz mal wieder ein.....


    Ich werd das faule Gefühl nicht los dass das "nicht-funktionnieren" auch Boxenabhängig sein könnte.


    Bei mir klappt es auf einer 8000er. Auf der anderen 8000er, welche absolut identisch konfiguriert ist, bloss 8 Monate älter bring ich das Plugin auf Teufel komm raus nicht zum laufen.


    J ;(ke

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials