LCD4linux-Plugin - WLAN-Web / Android / Pearl / Samsung - LCD-Display an der Dream [14.06.2020]

  • Quote

    Original von joergm6
    hmm, kannst du nicht mehrere Infos in eine Textdatei schreiben, wenn die Werte untereinander oder nebeneinander stehen?
    Textinhalte werden, wie Alles, beim Bildaufbau neu gelesen, also min. 1/min und z.B. bei Programmwechsel. Außerdem erzeugt eine Änderung der 1.Textdatei einen (fast) sofortigen Refresh.


    hmm okay ich schreib das mal bisl um das ich alles in eine .txt packe!


    trotzdem danke!

  • update gemach!


    so, nach 2 tagen tests, muss ich sagen, dass bei mir alles beim alten ist ;)
    keinerlei crashes oder sonstige auffälligkeiten :)


    danke for erklärungen und support!


    gruss
    brau21

  • Hallo Joerg,


    meine Box Bottet wieder selbständig.
    Ich habe bereits beim KAlender alles Rausgenommen.
    Kann es sein das der Kalender komplett raus sollte?


    hier mal ein Auszug aus der CrashLog


    Danke fürs drüberschauen.


    [LCD4linux] Audio activ 2 AC3
    do EPG 1
    Len 1023
    [LCD4linux] E2DataTime: 0.399705886841
    [LCD4linux] Run Worker Pic 2
    FATAL: ebase.cpp:233 ASSERTION m_tid == (pid_t)-1 || m_tid == eThread::gettid() FAILED!
    PC: 75bd70f4
    00000000 00000001 00000000 6e006920
    00000573 0000061d 00000006 00000000
    0057cc1f 25252525 dadfc5b3 5f6d207c
    20646974 65203d3d 65726854 005f0000
    0000061d 00000006 00000573 00000000
    00000000 00000059 fffffffd 772f8000
    005f63c4 75bd7080 6dfff490 00000000
    75cf7970 6dffde50 77398000 75bdb8a8
    As a final action, i will try to dump a bit of code.
    I just hope that this won't crash.
    75bd70f4: 07 00 e0 10 ff ff 03 24 3b e8 03 7c 21 20

  • aus dem kurzen Stück kann garnichts erkannt werden. Zu diesem Zeitpunkt wollte L4L den Bildaufbau beginnen, ist aber soweit nicht gekommen, hat also noch nix gemacht. Wichtiger wäre, was vorher gewesen ist, ob es z.B. immer zu einem bestimmten Zeitpunkt/Ereignis passiert.
    Leider passieren diese Crashes nicht zeitlich zusammen mit dem Verursacher weshalb es auch nicht direkt möglich ist das Problem zu erkennen. Verursacher kann also auch was ganz anderes sein, E2 "merkt" das aber irgendwann. Deshalb ist es auch schwer bis unmöglich zu identifizieren. Habe also keine Idee.

  • Hi joerg,


    Sag mal, gibt's eigentlich die Möglichkeit Fortschritts Balken auch mit Farbverlauf darzustellen?
    Siehe oberen Balken im Bild ...


    Den nutze ich für die CO2 Anzeige fürs netatmo ... Wäre ja auch für die andren Balken interessant

    Files

    • image.jpg

      (130.99 kB, downloaded 523 times, last: )

    Edited once, last by fuzzi99 ().

  • Quote

    Original von fuzzi99


    Den nutze ich für die CO2 Anzeige fürs netatmo ... Wäre ja auch für die andren Balken interessant


    is ja geil, verrat mir mal bitte, wie das funzt

  • Hab mir 10 Bildchen gebastelt die ich via Skript verlinke - je nachdem wie hoch der CO2 Wert ist. Das verlinkte Bildchen wird dann nur angezeigt... Eigentlich ganz einfach. Die Stufen kann man sich ja entsprechend im Skript anpassen.


    Wenn sowas out of the lcd4linux Box funktionieren würde wäre das natürlich geil ;-)

  • Hallo Jörg und alle die sich auskennen,
    habe heute mein Xtrend neu aufgesetzt und lcd4linux liefert an meinen Samsung nichts mehr. Per webif ist lcd4 linux nicht mehr zu erreichen. Auf die vor wenigen Wochen installierte zurück(war die vom 11.4.2013). Wieder Zugriff auf webif aber kein Samsung ansteuerbar. Gibt es Probleme mit dem Samsung Displays? Bei der alten habe ich ja noch ein Vorschaubild und sehe die Pearl und dort ist ein Bild und bei dem benutzerdefinierten Bildern.
    Ich konnte im Anschluss von der aktuellen Version irgendetwas mit C_Images lesen. Ich habe die Log.TXT vom lcd mit angehangen. Villeicht naht ja Hilfe. Achso es ist ein Samsung SPF 87H den ich am Xtrend zu hängen habe.

    Files

    • L4log.txt

      (230.54 kB, downloaded 8 times, last: )

    Edited 2 times, last by meepmeep ().

  • In dem Log kannst du zumindest erkennen das L4L läuft aber die Samsung's nicht findet.


    01:00:49 1. Vendor=04e8 ProdID=2034 False
    01:00:49 1. Vendor=04e8 ProdID=2033 False
    01:00:49 Samsung Device not found


    Was passiert denn wenn du die Samsung Displays im laufenden Betrieb vom USB-Port trennst und wieder verbindest?
    Bei mir kommt dann eine Mledung auf dem Fernseher.
    kann es sein das deine USB-Treiber nicht laufen?


    und WEBIF: Ist es installiert bzw. kannst Du überhaubt per http auf die Box zugreifen?

  • meepmeep: kann dir nicht ganz folgen, Was meinst du mit C_Images?
    Hast du das Samsung neu? Hast du eine alte Konfig eingespielt oder neu gemacht? Ich frage deshalb, da das Samsung nicht gefunden wird, ob es evtl ein 87H-old (also alte Version ist). Das mal einstellen. Auch mal im Post 1 schauen, um zu ermitteln, ob das LCD bei den Devices aufgeführt ist.

  • Hallo Jörg,


    evtl. habe ich es übersehen, aber ist es möglich für die Displays eine Hintergrundfarbe in den verschiedenen Modi zu wählen?


    Wenn noch nicht, ist es DIr möglich, dass einzubauen?


    Ich sage schon mal Danke

    Leider keine Dreambox..... Support nur beschränkt möglich :) Und das wichtigste zum Schluss.... Fragen gehören ins Forum und nicht in mein Postfach ;)

  • Hallo an alle,


    das mit dem ProID wundert mich auch. Ich habe heute das Pli neu flashen müssen. Aber der Reihe nach. Ich habe die Software vor ein oder 2 Tagen aktualiesiert. So da ich noch das Display jedes mal mit der Hand anschalte(Attinity fehlt noch), habe ich Ihn gestern eingeschaltet. Siehe da, nichts mehr. Da ich sowieso in letzter Zeit viel probiert habe, also ein blankes reines Pli 3.0 rauf. So weit so gut, lcd4linux dazu. Webif ist bereits darauf. Kein raufkommen auf die Box per webif ala IPbox/lcd4linux. Webif läuft. Dachte ich, nun gut spiele ich die Version vom 11.4 ein, die funktionierte ja. Per Webif erreichbar und wenn ich keinen Samsung einstelle, sondern Pearl oder benutzerdefiniertes Bild oder so sehe ich den Monitor in der Vorschau, aber logisch, nicht auf dem Samsung. Ich habe das Gefühl das da etwas nicht stimmt. Tippe auf dem USB. Achso Jörg, bei dem einspielen der Version 3.2 kam es zu eine Meldung beim verlassen der Installation vor dem Neustart der Benutzeroberfläche, zu dieser Meldung mit dem C-image oder so. Ich nahm an, dass durch die Installation und der fehlenden Zuordnung die Fehlermeldung kam.
    Fazit:
    Version 3.2 zugriff auf webif und auf den schwarzen Bildschirm von lcd4linux
    Version 3.4 zugriff auf webif und proxyfehler auf lcd4linux.


    Ich nehme den Samsung jetzt noch einmal ab und stecke ihn an und prüfe ob da ne Meldung kommt.

  • Hallo an alle,
    Ich hatte ein mal ein funktionierendes Samsung an lcd4linux. Meine ProduktID hat sich nicht geändert, aber lcd4linux meint das.
    20:26:49 1. Vendor=04e8 ProdID=2026 False
    20:26:49 1. Vendor=04e8 ProdID=2025 False
    ist jetzt mit dem spf87H old und vorher
    17:34:18 1. Vendor=04e8 ProdID=2034 False
    17:34:18 1. Vendor=04e8 ProdID=2033 False
    mit dem spf87
    hmmmm. Ich verstehe das nicht
    wie kann ich vom Samsung die ProdID auslesen?????

  • Hallo an Alle,


    ich habe meinen Fehler gefunden habe jetzt die LCD4linux 3.2 wieder auf meinem System. Aber der Fehler lag bei der python-imaging_1.1.6-ml1_mipsel.ipk wie immer im Detail ich brauchte die python-imaging_1.1.7-r4_mips32el-nf.ipk für die E2- Version und siehe da es wurde wieder Licht auf meinem Display. Danke für die vielen Ideen Joergm6 und auch allen anderen. Jetzt kann ich den abend abschließen und ins Bett gehen.. Ahh Sicherung werde ich jetzt noch machen. Für alle Fälle....
    DANKE noch einmal und Gute Nacht von meepmeep

  • Hallo zusammen,


    ich hatte ein ähnliche Idee wie fuzzi99 und habe den Raumklima-Indikator von Netatmo nachprogrammiert.
    Idee war, eine farbige Anzeige zum Raumklima auf dem L4L zu haben.


    Leider ist die Berechnung des Raumklimas in der Netatmo-App nicht offen gelegt und so habe ich selber für die unterschiedlichen Einflußgrößen Transferfunktionen entwickelt.


    Die Ausgabe des Raumklimas lehnt sich an die Netatmo App an:
    0-24: sehr gutes Raumklima
    25-49: gutes Raumklima
    50-74: schlechtes Raumklima
    75-100: ungesundes Raumklima


    Folgende Einflußgrößen werden betrachtet:
    - Innentemperatur: hierbei wird mit HIlfe der Luftfeuchtigkeit der "Humidex" berechnet
    - CO2
    - Luftfeuchtigkeit
    - Lärm


    Ich habe im Netz nach Informationen zur Erstellung der Transferfunktionen geschaut und in den meisten Fällen sind es lineare Zusammenhänge. Nur beim Lärm habe ich eine exp. Funktion verwendet, welche im unteren Bereich 35 ... 50 flach verläuft und dann steiler wird. Hierzu gibt es auch Untersuchungen, die im Netz zu finden sind.


    Die Einzelresultate werden zu einem Gesamtklima verrechnet. Erst wählte ich den Ansatz die Einzelwerte geometrisch zu verrechnen, was aber dazuführte, daß wenn es einwenig laut ist, einwenig kalt ist und der CO2 Wert etwas erhöht ist, daß dann das Endergebnis zu hoch erscheint.
    Am Ende habe ich den Maximalwert der Einzelgrößen als Gesamtergebnis genommen.


    Das Gesamtraumklima wird dann in 11 farbige Buttons umgerechnet:
    00 = grün
    ...
    25 = grün/gelb
    ...
    50 = gelb
    ...
    75 = gelb/rot
    ...
    100 = rot


    Ich spiele gerade noch etwas an den Transferfunktionen rum und wenn das soweit paßt, frage ich mal im NetAtmo Thread an, ob cmikula das in sein Netatmo plugin mitaufnehmen will, dann müsste L4L nur noch anzeigen.


    Hier ein paar Screenshots (die viel Details um besser bewerten zu können)