LCD4linux-Plugin - WLAN-Web / Android / Pearl / Samsung - LCD-Display an der Dream [14.06.2020]

  • Daaaannnnke von der Randgruppe ;-)


    alle Varianten sehen super aus:
    Temperatur + Luftdruck + CO2 passt bei mir super


    :350:

  • hallo jörg!


    hätte da noch eine frage an dich!


    sagt dir libfreetype etwas?


    (FreeType is a freely available software library to render Fonts)
    http://www.freetype.org/


    benüzt du das auch in deinem plugin?


    würde das gerne anwenden bei meinem lcd4linux um an der fritzbox die Schrift zu ändern..


    der Samsung treiber läuft ;)

  • Quote

    Original von joergm6
    V3.3 Unterstützung für Netatmo-Randgruppe in unserer L4L-Randgruppe ;)


    .
    MatzeFro: auch eine Einstellung für dich ist enthalten


    nix für ungut, aaaaaber


    wenn ich das netatmo einstelle (2. schirm) bekomm ich beim gui neustart
    oder reboot eine grünschleife


    ich hatte das netatmoplugin, dann den skin in verdachcht.
    es ist aber def. die einstellung im l4l


    ach so, evtl. liegts ja an der solo2


    wenn ich im l4l die einstellung netatmo auf aus hab, keine probleme

  • Hallo,


    seit den 144 Updates von gestern startet Enigma neu sobald ich in ein Menü wechsle. Umschalten ist kein Problem nur bei Menüs oder BP startet die Box neu. Ich hab im Crashlog ein paar Einträge vom LCD4linux Plugin gefunden, kann da der Hund begraben liegen?

  • Ja liegt daran, werde dann mal den Crashlog direkt dort posten. Hab das LCD4linux deaktiviert und alle Updates installiert, läuft ohne Probleme.

  • Das LCD4linux macht seit den Updates vom 4.5. Probleme.
    Sobald ich ein Menü aktiviere startet Enigma neu, nur die Infobar lässt sich ohne Absturz einblenden, alles andere führt zu einem Neustart.


    Hab das Plugin jetzt mal deaktiviert und alles läuft.

  • pumian: Benutzt du Netatmo-Skin-Renderer? Im Crash ist von Netatmo/L4L nix zu sehen, nur Skin. So richtig ne Ahnung hab ich allerdings nicht. Netatmo wird unabhängig ob aktiviert oder nicht importiert und L4L hat mit dem LCD-Bild-Erzeugen noch nicht begonnen. In den Netatmo-Renderer fehlt allerdings auch jegliche Abfrage, ob überhaupt Daten vorliegen.


    Top55: Habe ich auch noch keine Idee. Ich habe mir das Update noch nicht getraut ;) . Naja nun werde ich das wohl machen müssen in der Hoffnung, ich finde den Fehler. Auf dem ersten Blick (was ich gestern nach FC2-Problem getan hatte) sehe ich keinen Fehler im Code. Naja, schauen wir mal.
    Edit: scheint mit OSD zusammen zu hängen.... weiter schauen

  • Ich hab den Übeltäter gefunden, ist das OSD. Sobald das eingeschaltet ist, geht die Box in den Neustart, ohne ist alles OK.

  • ja, ich nutzte den skin renderer,


    aber das ganze crasht auch, wenn ich diesen nicht nutzte
    wie gesagt, hatte ja auch den skin in verdacht.


    sobald ich netatmo im l4l auf aktiv hab, kommt der grüne, sobald die box was speichern möchte.
    in der settings z.b.


    ich kann dann nicht mal mehr die box runterfahren (schleife)


    hab die kiste gestern 5x neu geflasht, bis ich da draufgekommen bin.


    eigentlich hätt ich nur die l4lconfig wieder zurück kopieren müssen.


    mach dir keinen kopf, is ja nur ein randgruppen feature

  • Vielen Dank Jörg, dass du die verbleibende Zeit nun auch mit Sekundenanzeige in Media implementiert hast :hurra: :hurra:

  • ;(
    Ich muss leider aus gegeben Anlass eine Warnung aussprechen..


    L4L arbeitet intern nur mit Threads. Da E2 nicht Thread-Safe ist, darf eigentlich keine E2-Information in einem Thread abgerufen werden.
    Durch die aktuelle Änderung im E2 werden solche Fehler sofort mit einem Crash beantwortet. Threads können E2 durcheinander bringen und um alle Plugins zu finden, die es so machen, gibt es halt nun den Crash.


    L4L müsste sehr sehr viele umfangreiche Änderungen erhalten um es anzupassen. Wann und ob ich dafür, in der nächsten Zeit, die Zeit und Energie aufbringe, kann ich euch nicht sagen.


    *muss mich erstmal sammeln*


    Auch wenn es weh tut, bin ich euch diese Info schuldig.