LCD4linux-Plugin - WLAN-Web / Android / Pearl / Samsung - LCD-Display an der Dream [14.06.2020]

  • Quote

    Original von Luckky_36
    Anbei noch ein Foto vom Display was es im Moment macht.
    Das obere sind irgendwelche Klötze die von rechts nach links wandern.


    Das sieht ja irgendwie "defekt" aus. Flash doch nochmal das Display zu Original und nochmal den Hack. Brauchst du nicht zufällig was schönes von Pearl :D . Ich würde mir mal ein 2. ordern um ein LCD Defekt auszuschließen.
    Jörg

  • R4 geht auch meiner 800HD nicht, alles schwarz. R3 lief ohne Probleme

    Dreambox 800S (+ int. WD3200BEVT)
    Flash Image: iCVS + GP3
    USB Image: ---
    Speedbox! W900V FW 29.04.76
    Harmony 555
    Panasonic Plasma TH-42PX71

  • Quote

    Original von noxx
    R4 geht auch meiner 800HD nicht, alles schwarz. R3 lief ohne Probleme


    nach jedem Update muss die spezielle lcd4linux bei DM800HD wieder kopiert werden, da diese überschrieben wird.
    Jörg

  • Quote

    Original von Luckky_36
    Anbei noch ein Foto vom Display was es im Moment macht.
    Das obere sind irgendwelche Klötze die von rechts nach links wandern.



    Hatte mit dem ICVS auch Probleme, nehme mal OOZOON, dann gehts ;-)

    __________________________________________________________________


    :rot: Finger weg von HD+ :rot:

  • Also ich hab nun mal die 800hd aus dem Keller geholt und die Installation wie hier angegeben ausgeführt. Bis auf die Tatsache das ich zuerst vergessen hatte der Datei 'libgd.so.2' ebenfalls die Rechte 0755 zu geben lief das auch alles ganz gut.


    Im /tmp wurde erstellt aber das Display stand im BSOH und wollte einfach nicht die Inhalte wiedergeben. Nach der Berechtigung der 'libgd.so.2' mit '0755' hatte sich dann


    Code
    root@dm800:~# /usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/lcd4linux -Fv
    v -f /usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/dpf1.conf
    /usr/lib/enigma2/python/Plugins/Extensions/LCD4linux/lcd4linux: error while loading shared libraries: libgd.so.2: cannot open shared object file: No such file or directory


    zu



    geändert und seitdem tut das LCD auch mit der 0.4-r2 wie es soll auf der 800hd.

  • Hallo,


    ist es denn möglich das plugin auch auf ner clarke tech et9000 zu nutzen? ich hab bisher nur das von mcbain installiert was auch super funktioniert! interessieren würde mich aber das hier besprochene plugin, das bietet mehr anzeigemöglichkeiten (das mit dem wetter find ich ganz toll).

  • Heyho zusammen, habe 2 Fragen:


    1.) Ausführung als Thread/im Hintergrund----> ja/nein


    Wie ist hier der Standardwert für? habe den Wert derzeit auf "nein" und es läuft einwandfrei... ändert sich überhaupt etwas wenn ich ihn auf "ja" setze?


    2.) Wie genau tue ich updaten? :)
    einfach die neue 0.4 über telnet drüberbügeln? oder davor erst deinstallieren?


  • Zu 1) keine Ahnung :)


    Zu 2) ja einfach per Telnet normal installieren, die Box erkennts als Update und bügelts drüber


    Ich hab die 0.4 jetzt auch am laufen, stürzt aber immernoch ab... läuft ne weile und irgendwann unvorhersehbar geht nix mehr. Ich probier jetzt noch mit dem Nicelevel rum (geht da nur 0 oder 19 oder auch ein zwischenwert?),
    wenn das dann auch nicht geht muss ich wohl oder übel wieder auf 0.2 zurück :/ kann man die dann auch einfach drüber bügeln oder muss vorher alles deinstalliert und neu installiert werden?!?


    Oder kann man mal probieren die 0.4 mit dem start script der 0.2 zu testen? Nur hab ich das File von der 0.2 leider nicht da ^^

    Ich antworte mit einem entschiedenen Vielleicht!!


  • Es hat sich aber nicht grundsätzlich etwas verändert, weshalb ich nicht verstehe, wo ein Unterschied sein soll. Der lcd4linux-demon ist immer der selbe, das Plugin selbst läuft nur innerhalb E2 und macht nichts selber mit dem Display. Gut der Startscript ist verändert, aber der startet und stop doch nur und macht auch nix mit dem Demon.
    Du kannst ja den Startscript mal tauschen, musst dann aber manuell starten und stoppen, da der alte script nur 1 Demon starten kann und der Parameter (start1) vom Neuen nicht existiert. Ich hänge das alte Startscript mal an (Attribut 755 setzen nicht vergessen!)


    Eine niedrigere Version kann man nicht so einfach drüberbügeln, entweder das Downgrade erzwingen oder vorher deinstallieren.


    zu 1. Standard ist "Nein", "ja" ist noch zum experimentieren, ob es sauber im E2 läuft. Theoretisch soll "ja" E2 weniger behindern, da zum Bildgenerieren für das LCD das E2 nicht warten muss. Wenn E2 nicht abstürzt kann man auch "ja" lassen.


    freak4all : probiere es aus. :D


    Jörg

  • Hallo Jörg,


    ich muss nocheinmal das Thema umbenannter Kanal aufwärmen.


    Wenn im Favoriten Bouquet ein Kanal umbenannt wird, wird das Picon im OSD Skin weiterhin richtig zugeordnet aber lcd4linux zeigt mir dann nur den Kanalnamen und kein Picon mehr !


    Und es hat wohl nichts mit dem Settingseditor zu tun - Das Verhalten ist bei DreamboxEdit und BouquetSetEditor gleich !
    Ich habe das aktuelle ICVS und kann auch dementsprechend nur die Kanalreferenz nutzen.


    Kannst Du Dir das evt. mal anschauen bzw. verifizieren ?? Danke.

    DM 7080 HD
    . 4 x DVB-S2, HDD 1TB, SSD 64GB
    . 2 x DPF, 2 x Smargo
    . OE2.2, GP3.3, Oscam
    . Sky DE HD, HD+, Hustler HD
    . 19°E, 13°E, 9°E, 42°E - 30°W

    Edited once, last by Sprudelverduenner ().

  • ich hab mit der aktuellen Version nochmal ein wenig rumprobiert und folgende vermutung oder folgendes festgestellt:


    Wenn ich rumzappe geht das LCD eigentl...
    Schalte ich vermutlich auf einen Sender bei dem das Picon noch nicht im Cache ist (meine Vermutung), dann schaltet das LCD sofort in den normalen Bilderanzeigemodus. Bei sendern wo die Picons schon im cache sind stürzt nichts ab....
    Oder ich täusche mich und das ist nur zufall das das Umschalten in den normalen Bildermodus zufällig aufgrund von anderen Ursachen passiert.


    Kann das jemand bestätigen?


    Wenn ich mir die Urzeit der Zuletzt erstellten Picons im Picon Cache anschaue und den Sender dazu, dann stimmt das mit meiner Vermutung überein, das das crashed sobald man auf einen Sender schaltet dem sein Picon noch nicht im Cache liegt (Ich habe Picons sowie den Picon_Cache alles auf einem USB Stick)

    Ich antworte mit einem entschiedenen Vielleicht!!

    Edited 2 times, last by DigiTVglotzer ().

  • Ich bekomme die Python-Bibliothek nicht installiert:


    Installing python-imaging (1.1.6-ml1) to root...
    Collected errors:
    * ERROR: Cannot satisfy the following dependencies for python-imaging:
    * libpython2.6-1.0 (>= 2.6.7) *
    * Cannot find package python-imaging.


    Installiert ist libpython2.6-1.0 - 2.6.4-ml8.2a


    Woher bekomme ich die aktuellere Version und kann ich die einfach einspielen oder muss dann noch eine ganze Menge mehr hochgerüstet werden?


    Ich will ungern das Image updaten, das hat schon ein paar Monate auf dem Buckel, läuft aber stabil und ist an diversen Stellen händisch angefummelt (Plugins auf CF auslagern, SATA-Festplatte per Startscript in den DMA-Modus gebracht uvm.), so dass ein Update der 7025 in eine Höllenarbeit ausarten würde :-(

  • Quote

    Original von Terminator212


    Ich will ungern das Image updaten, das hat schon ein paar Monate auf dem Buckel, läuft aber stabil und ist an diversen Stellen händisch angefummelt (Plugins auf CF auslagern, SATA-Festplatte per Startscript in den DMA-Modus gebracht uvm.), so dass ein Update der 7025 in eine Höllenarbeit ausarten würde :-(


    Viel Spaß beim Neueinrichten :D .
    ...
    Das Image ist zu alt, wurde schon öfters bestätigt.
    Jörg

  • @ joergm6:


    Hast du dir mein Problem mal angesehen??


    Ich probier jetzt mal folgendes, ich wandel alle Picons selbst von Hand um und kopier sie in den Cache Ordner, wenns dann nicht mehr abstürzt würd ich sagen kommts definitv davon.
    Gebe gleich Rückmeldung hier

    Ich antworte mit einem entschiedenen Vielleicht!!

  • Quote

    Original von DigiTVglotzer
    @ joergm6:


    Hast du dir mein Problem mal angesehen??


    Ich probier jetzt mal folgendes, ich wandel alle Picons selbst von Hand um und kopier sie in den Cache Ordner, wenns dann nicht mehr abstürzt würd ich sagen kommts definitv davon.
    Gebe gleich Rückmeldung hier


    Es gibt auch Leute die arbeiten müssen, ich gehöre dazu :rolleyes: .
    Ich kann nicht wirklich daran glauben, es sei denn die 800HD hat ein I/O Problem, wenn das neue Icon gespeichert wird und gleichzeitig der lcd4linux-demon zugreift. Wenn es hängt kannst du mal die Datei /tmp/dpg.png schauen, ob die noch aktualisiert wird. Denn nur das macht das Plugin. Der lcd4linux-demon öffnet diese und stellt es dar.


    Und eine 800hd habe ich auch nicht zum probieren, diese hat offensichtlich ein Performance-Problem.
    Jörg

  • Habe mal versucht das0 Plugin auf einem sh4 Receiver (Pingulux) zum laufen zu bewegen.
    Bekomme aber die Fehlermeldung: "The Imaging C Module is not installed" Das Imaging C für Mips läuft auf dem sh4 Receiver ja nicht.
    Wo bekomme ich Imaging C für sh4?

  • Tolle Arbeit!!


    Ich habe das Ding auch vor Weihnachten bestellt gehabt. Bin dann gestern durch die Threads geflogen, hab den Hack mit Windows gemacht, an die Box gestöpselt, Plugin drauf und rennt und macht Spaß :D


    Danke!!


  • Ich habe es mal nachgestellt, hast Recht und PM.
    Jörg

  • Genial, gleich beim ersten Versucht funktioniert alles bestens :)


    Einen Wunsch hätte ich noch: um den Config-Screen in meinem Skin "Vali Ai.HD (shadow) Mod V2 für GP3" sauber skinnen zu können wäre es super, wenn man die Position des help-window festlegen könnte (dieses wird ja bei einigen Feldern automatisch angezeigt und greift aktuell auf eine Default-Position des Skins zurück, die für den Config-Screen nicht ganz passt).

    DM900 mit Merlin 4 (OE 2.5)